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Graphical Mode Examples Listed by Product

This guide includes descriptions of the following examples.

Category Example number

The Thermo-Calc collection includes binary and ternary system examples, Scheil, the Equilibrium 
Calculator, Material to Material Calculator, plus more.

"Thermo-Calc  Examples Collection" on page 1

T_01 to T_22

General Property Models Library

"Thermo-Calc General Property Models Examples Collection" on page 61 

General Models: PM_G_01 to 
PM_G_20

Add-on Modules and Material Specific Property Model Libraries (in Alphabetical Order)

"Additive Manufacturing (AM) Module Examples Collection" on page 113 AM_01 to AM_15

"Diffusion Module (DICTRA) Examples Collection" on page 233

D_01, D_02, D_03 (the Quick 
Start Guide Examples)

D_04 to D_10

"Nickel Model Library Examples Collection" on page 378
Nickel Property Models: PM_NI_
01 to PM_Ni_04

"Noble Metal Alloys Model Library Examples Collection" on page 388
Noble Metals Property 
Models: PM_Noble_01

Precipitation Module (TC-PRISMA) Examples Collection P_01 to P_16

"Process Metallurgy Module Examples Collection" on page 352 PMET_01 to PMET_08

"Steel Model Library Examples Collection" on page 393
Steel Property Models: PM_Fe_
01 to PM_Fe_12

"Titanium Model Library Examples Collection" on page 425
Titanium Property Models: PM_
Ti_01 to PM_Ti_02
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Thermo-Calc  Examples Collection

These are the Graphical Mode examples. There are separate Console Mode examples also 
available. 

In this section:

T_01: Calculating a Single-Point Equilibrium 3

T_02: Stepping in Temperature in the Fe-C System 5

T_03: Fe-C Phase Diagrams 7

T_04: Fe-Cr-C Ternary Phase Diagram  at 1000 K 9

T_05: Stable and the Metastable Fe-C Phase Diagrams 11

T_06: Serially Coupled Equilibrium Calculators 13

T_07: User-Defined Functions 15

T_08: Scheil and Equilibrium Solidification 17

T_09: Carbide Driving Force Heat Map 20

T_10: Scheil Solidification with Back Diffusion 22

T_11: Surface Tension in Cu-Zr 24

T_12: Viscosity in Cr-Ni 26

T_13: Scheil Solidification with Solute Trapping 28

T_14: Fe-Cr-Ni Transition Comparison Using the Material to Material Calculator 30

T_15: Molar Volume and Thermal Expansion Coefficients for L12-type Al3Sc and Al3Zr Compounds 33

T_16: Electrical Resistivity and Thermal Conductivity for Pure Copper 36

T_17: Al2O3-MgO Phase Diagram 40

T_18: Scheil with Delta Ferrite to Austenite Transition 42

T_19: Young's Modulus for Ti-O with Elastic Properties 44

T_20: Ternary Diagram with Clockwise Plot Axes 47
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T_21: Pourbaix Diagrams of Fe with the Aqueous Calculator 50

T_22: Aqueous pH of Solutions 56
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T_01: Calculating a Single-Point Equilibrium

This example shows the result from a single-point equilibrium calculation in the Fe-C system. It 
demonstrates the use of the Equilibrium Calculator and generates a Table Renderer in the Visualizations 
window. The number of equilibrium conditions is C+2 where C is the number of components, meaning that 
four conditions are needed in this example:

 l Temperature is 1000 K

 l Pressure is 100000 Pa

 l System size is 1 mole

 l Mass percent carbon is 0.1%

Project File Information

 l Folder: Thermo-Calc

 l File name: T_01_Single-point_equilibrium.tcu

Table Results

This example is included as a tutorial on our website and as part of the Graphical Mode 
Examples playlist on our YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 1: The displayed results of the calculation show that the BCC_A2 (ferrite) and GRAPHITE phases are stable 
for this set of equilibrium conditions.
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T_02: Stepping in Temperature in the Fe-C System

This example shows how the fractions of stable phases vary for an Fe-0.1 mass-% C alloy when the 
temperature is varied between 500 and 2000 K. It demonstrates the use of the Equilibrium Calculator. To 
allow temperature to vary, the corresponding Axis Definition checkbox is selected. 

Project File Information

 l Folder: Thermo-Calc

 l File name: T_02_Step_in_temperature_in_Fe-C.tcu

Visualizations

This example is included as a tutorial on our website and as part of the Graphical Mode 
Examples playlist on our YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

Figure 2: In this example, results are displayed graphically using a Plot Renderer activity.

Thermo-Calc Examples Collection ǀ 5 of 431

https://thermocalc.com/support/video-tutorials/
https://www.youtube.com/playlist?list=PLfv6McToaTGSzHrh3TfNF2EhoUUUqeEWd


For the Plot Renderer, there is an option to use the  Table View button to convert plots to 
table data for all calculation types and calculators. 

 If you want, you can also use a Table Renderer to generate text results instead, as shown in this example 
after adding a Table Renderer to the Equilibrium Calculator and clicking Perform.
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T_03: Fe-C Phase Diagrams

This example shows the stable Fe-C phase diagram (stable meaning that the graphite phase is entered in 
the calculation). The same diagram is calculated using the Binary Calculator activity and then using a 
System Definer and Equilibrium Calculator. 

In both cases, a Plot Renderer is used to display results. The purpose of the Binary Calculator is to simplify 
common calculations for binary systems. In the Equilibrium Calculator two Axes are defined on the Plot 
Renderer. An axis variable must be an equilibrium condition.

In the Plot Renderer settings window, click  Show more and Show less to toggle between 
viewing all or some of the available settings.

Project File  Information

 l Folder: Thermo-Calc

 l File name: T_03_Fe-C_phase_diagram.tcu

Visualizations

This example is included as a tutorial on our website and as part of the Graphical Mode 
Examples playlist on our YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 3: The plot result of the System Definer and Equilibrium Calculator.

Figure 4: The plot result of the Binary Calculator simulation.
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T_04: Fe-Cr-C Ternary Phase Diagram  at 1000 K

This example shows a ternary phase diagram in the Fe-Cr-C system at 1000 K. Similar to example "T_03: Fe-
C Phase Diagrams" on page 7, the same diagram is calculated using a Ternary Calculator and then using a 
System Definer and Equilibrium Calculator. Two Plot Renderer activities are added to create two plots.

Project File Information

 l Folder: Thermo-Calc

 l File name: T_04_Fe-Cr-C_ternary_phase_diagram.tcu

Visualizations

This example is included as a tutorial on our website and as part of the Graphical Mode 
Examples playlist on our YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

In the Plot Renderer settings window, click  Show more and Show less to toggle between 
viewing all or some of the available settings.

Try practicing with two features on the Plot Renderer Configuration window. 

 l To toggle between a triangular and a rectangular diagram, click the  Toggle Triangular/Regular 
Diagram button then click Perform to see what happens. 

 l To toggle the X and Y axis variables, click the  Switch Axes button and then click Perform.
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Figure 5: Ternary Calculator.

Figure 6: Equilibrium Calculator.
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T_05: Stable and the Metastable Fe-C Phase Diagrams

This example shows how to overlay results from two calculations in the same plot using the Equilibrium 
Calculator. 

Project File Information

 l Folder: Thermo-Calc

 l File name: T_05_Fe-C_stable_and_metastable_phase_diagram.tcu

Visualizations

This example is included as a tutorial on our website and as part of the Graphical Mode 
Examples playlist on our YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

 1. The Plot Renderer activity is first created as a successor to Equilibrium Calculator 1.

 2.  Then right-click the Plot Renderer node and select Add predecessor and the results from both 
equilibrium calculators are in the same plot. In Equilibrium Calculator 1 the stable phase diagram is 
calculated and in Equilibrium Calculator 2 the metastable phase. 

 3. The metastable diagram is obtained by deselecting checkboxes for the GRAPHITE_A9 and 
DIAMOND_A4 phases on the Metastable Phases node (System Definer 2)  → Phases and Phase 
Constitution tab.

To make it easier to work with your project, right-click any node and select Rename. In 
this example, System Definer 1 is renamed to Stable System and System Definer 2 is 
renamed to Metastable System.
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T_06: Serially Coupled Equilibrium Calculators

Sometimes there are multiple solutions for a given set of equilibrium conditions. In other cases the 
equilibrium calculation does not converge. You can then aid the final calculation by, in effect, telling the 
software where it should start the search for the equilibrium. 

This example shows how to serially couple two Equilibrium Calculator nodes together for more complex 
equilibrium conditions. For each calculation, the output is to a Table Renderer. 

Project File Information

 l Folder: Thermo-Calc

 l File name: T_06_Serial_equilibrium_calculators.tcu

Table Renderer Results

This example is included as a tutorial on our website and as part of the Graphical Mode 
Examples playlist on our YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

Equilibrium Calculator 1

In the first example, the objective is to calculate the equilibrium at 850° C where the mole fractions of the 
FCC A1 and BCC A2 phases are 0.5 each for an Fe-Cr-C steel with 10% chromium. In Equilibrium Calculator 1 
a simple set of equilibrium conditions (temperature, pressure, system size and composition) are used to 
find a carbon content where only the FCC A1 and BCC A2 phases are stable. The results from this 
preliminary calculation are displayed in  Table Renderer 1. Open the example to see the full table.
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Equilibrium Calculator 2, 3, and 4

Click each tab along the top of the Visualizations window to view the results associated to Table Renderer 
2, Table Renderer 2, and Table Renderer 2.

 l In Equilibrium Calculator 2 the carbon content equilibrium condition is replaced by the condition 
that the numbers of moles of the BCC A2 phase should be 0.5. The final result is displayed in Table 
Renderer 2. In this case, the final objective is to calculate the solidus temperature of an Fe-Cr-C 
steel with 10% Cr and 0.01% C. 

 l In Equilibrium Calculator 3 the state at 2000 K is calculated and the result is displayed in Table 
Renderer 3. 

 l In Equilibrium Calculator 4 the temperature equilibrium condition is replaced by the condition Fix 
phase / liquid / 0.0, meaning that liquid should be stable in an amount of zero moles, i.e. the solidus 
temperature. The final result is displayed in Table Renderer 4.
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T_07: User-Defined Functions

This example shows how to implement user-defined functions. A series of equilibria for an Fe-Cr-C alloy are 
calculated by varying temperature between 500 and 3000 K. In the configuration window of the 
Equilibrium Calculator under the Functions tab, two identically meaning functions are defined, fraction 
solid and f solid, the values of which are plotted against temperature in two  Plot Renderer activities. 
Functions can be entered in terms of QuantitiesQ1, Q2, Q3 and so forth, or by using the Thermo-Calc 
syntax.

Project File Information

 l Folder: Thermo-Calc

 l File name: T_07_User_defined_functions.tcu

Visualizations

This example is included as a tutorial on our website and as part of the Graphical Mode 
Examples playlist on our YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

In the Plot Renderer settings window, click  Show more and Show less to toggle between 
viewing all or some of the available settings.
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Figure 7: The result of the fraction_solid function.

Figure 8: The result of the f_solid function.
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T_08: Scheil and Equilibrium Solidification

This example shows a comparison for an Al-Si alloy solidified under full local equilibrium and under the 
Scheil assumptions, i.e. zero diffusion in the solidified material and infinitely fast diffusion in the liquid. The 
example uses the Scheil Calculator and adds a Plot Renderer and a Table Renderer. 

Project File Information

 l Folder: Thermo-Calc

 l File name: T_08_Scheil_and_equilibrium_solidification.tcu

Visualizations

This example is included as a tutorial on  our website and as part of the Scheil Solidification 
Simulations playlist on our YouTube channel. 

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

Figure 9: The plot compares the mole fraction of a solid vs temperature. 
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Figure 10: The table provides the data, which you can also export.

Saving the Table (via Table Renderer)

There are different ways to save the table from the Table Renderer Visualizations or Configuration 
windows. 

For the Plot Renderer, there is an option to use the  Table View button to convert plots to 
table data for all calculation types and calculators. 

Method 1

In the Visualizations window, right click the table and select Save As...
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Method 2

 1. In the Project window, click the Table Renderer.

 2. In the Configuration window, click the  Save table button .
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T_09: Carbide Driving Force Heat Map

This is an example of using Grid calculations to plot the driving force for a carbide as a function of two 
composition variables. With the Grid Calculation Type, a 2D grid is generated from the two calculation axes. 
After the calculation is done, an equilibrium is calculated in each grid point. A Plot Renderer connected to a 
grid calculation plots the Z-axis property for each equilibrium as a function of the two calculation axes. You 
can choose different Plot types such as Heat map, Contour, and 3D to display the results. 

In the Plot Renderer settings window, click  Show more and Show less to toggle between 
viewing all or some of the available settings.

Project File Information

 l Folder: Thermo-Calc

 l File name: T_09_Heat_map_of_carbide_driving_force.tcu

Visualizations

This example is included as a tutorial on our website and as part of the Graphical Mode 
Examples playlist on our YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 11: The results are plotted as a Heat map. Alternatively, a Contour Plot type can be selected on the Plot 
Renderer.
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T_10: Scheil Solidification with Back Diffusion

This is an example of a Scheil solidification simulation of a Al-2.1Cu-1Si alloy including back diffusion in the 
primary phase.

The example uses two of the Scheil Calculator activity nodes with different cooling rates, 10 K/s and 0.005 
K/s. The lower cooling rate produces a solidification curve that is closer to the equilibrium curve as shown 
in the plot result. Both a thermodynamic ALDEMO (aluminum demo) and mobility MALDEMO (Al-alloys 
mobility) database are used for this calculation.

Project File and License Information

 l Folder: Thermo-Calc

 l File name: T_10_Scheil_with_back_diffusion.tcu

The Scheil with back diffusion  feature is only available for systems with diffusion data, i.e. this 
model requires the use of a mobility database.

Running the example itself does not require an additional license.

Visualizations

This example is included as a tutorial on  our website and as part of the Scheil Solidification 
Simulations playlist on our YouTube channel. 

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 12: Scheil solidification. The lower cooling rate produces a solidification curve that is closer to the 
equilibrium curve .
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T_11: Surface Tension in Cu-Zr

This is an example of including surface tension in the calculations. 

Using the ALDEMO database, which is the free demonstration version of the TCS Al-based Alloy Database 
(TCAL), the surface tension of liquid metallic is plotted at 1373 K for Cu-Zr and compared to experimental 
data from [2005Kra].

Reference

[2005Kra] V. P. Krasovskyy, Y. V. Naidich, N. A. Krasovskaya, Surface tension and density of copper–
Zirconium alloys in contact with fluoride refractories, J. Mater. Sci. 40, 2367–2369 (2005).

Project File Information

 l Folder: Thermo-Calc

 l File name: T_11_Surface_tension_in_Cu-Zr.tcu

The same example is also provided in Console Mode as tcex56.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

Thermo-Calc Examples Collection ǀ 24 of 431

https://www.thermocalc.com/training/video-tutorials/
https://www.youtube.com/channel/UCLTh3apGItuaVK69mrwcpJg/featured


Figure 13: Surface tension of liquid metallic at 1373 K for Cu-Zr and compared to experimental data from 
[2005Kra].

More Information

The thermophysical properties are progressively being added to the Thermo-Calc databases starting with 
Thermo-Calc software version 2020a. 

You can learn more about the models by searching the help (press F1 when in Thermo-Calc). 

You can find information on our website about the properties that can be calculated with 
Thermo-Calc and the Add-on Modules. 
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T_12: Viscosity in Cr-Ni

This is an example of including viscosity in the calculations. 

Using the FEDEMO database, which is the free demonstration version of the TCS Steel and Fe-alloys 
Database (TCFE), the viscosity of metallic liquids is plotted at 1873 K for Cu-Ni and compared to 
experimental data from [2005Sat].

Reference

[2005Sat] Y. Sato, K. Sugisawa, D. Aoki, T. Yamamura, Viscosities of Fe–Ni, Fe–Co and Ni–Co binary melts, 
Meas. Sci. Technol. 16, 363–371 (2005).

Project File Information

 l Folder: Thermo-Calc

 l File name: T_12_Viscosity_in_Cr-Ni.tcu

The same example is also provided in Console Mode as tcex55.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 14: The viscosity of metallic liquids  at 1873 K for Cu-Ni and compared to experimental data from 
[2005Sat].

More Information

The thermophysical properties are progressively being added to the Thermo-Calc databases starting with 
Thermo-Calc software version 2020a. 

You can learn more about the models by searching the help (press F1 when in Thermo-Calc). 

You can find information on our website about the properties that can be calculated with 
Thermo-Calc and the Add-on Modules. 
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T_13: Scheil Solidification with Solute Trapping

In Graphical Mode, you use the Scheil Calculator to set up the various Scheil solidification simulations.

This example shows the use of the Scheil with solute trapping option with an Al-7.5Si-0.2Cu alloy as 
compared to a Classic Scheil calculation. The thermodynamic ALDEMO (Aluminum demo) database, 
available to all users, is selected for this calculation to simulate the effect of solute trapping in the primary 
phase. This type of simulation is useful for additive manufacturing applications.

This example shows how the alloy starts to solidify at a lower temperature compared to a classic Scheil 
simulation, an effect which increases with increasing solidification speed. The solidification speed is 
calculated from user supplied scanning speed and angle between the solid/liquid interface and the 
scanning direction.

The example uses the Aziz model, with an Interface driving force of Migration energy and a Maximum 
velocity for infinite driving force of 2000 m/s.

Read more about Scheil Solidification Simulations on our website, including how to select the 
right model for your simulation. If you are in Thermo-Calc, press F1 to search the help to learn 
about using Scheil.

Project File  Information

 l Folder: Thermo-Calc

 l File name: T_13_Scheil_with_Solute_Trapping.tcu

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 15: The effect of Scheil solidification with solute trapping of a Al-7.5Si-0.2Cu alloy compared to equilibrium 
and a Classic Scheil calculation.
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T_14: Fe-Cr-Ni Transition Comparison Using the Material to 
Material Calculator

In Graphical Mode, you use the Material to Material Calculator to perform calculations and examine how 
two materials transition from one into the other. The calculations in this example search for potential 
deleterious phases during heat treatment of alloys joined together. In this example, the calculation steps 
between a model martensitic stainless steel (Fe-17Cr-2Ni) and a model Alloy 800 composition (Fe-35Ni-
19Cr). Neither alloy is predicted to form the deleterious sigma phase at 600 °C. However sigma is predicted 
to form at a wide range of mixtures of these two materials, which could have an impact on mechanical 
properties if it forms.

The example, as defined when you open it, uses a One Axis calculation (also known as a property diagram), 
a temperature of 650 °C, to compare the volume fraction of all phases to the mass fraction of Alloy 800. 
The Fraction of the second material (Alloy 800) is set to 50% (0.5), which for a One Axis calculation is used 
as the start value. 

As with all the examples, you can adjust the settings to plot a variety of combinations of 
output to see how the Material to Material Calculator works before defining your own project. 

The plot for this calculation compares the volume fraction of all phases of Material 1 (martensitic stainless 
steel) to the mass fraction of Material 2 (Alloy 800). In the plots you can see where each phase  (FCC_A1, 
SIGMA_D8B, and BCC_A2) evolves. As you step from Material 1 to Material 2, the FCC_A1 phase starts 
forming at about 5% (0.05), SIGMA-D8B phase starts to evolve at about 19% (0.19), and the BCC_A2 
transitions from Material 1 to Material 2 where it stops forming at approximately 24% (0.24). The purpose 
of the calculation is to determine at what fraction of Alloy 800 the deleterious sigma phase forms and this 
is shown for these compositions.

Project File Information

 l Folder: Thermo-Calc

 l File name: T_14_Fe-Cr-Ni_Material_to_Material.tcu

Visualizations

This example is included as a tutorial on our website and as part of the Graphical Mode 
Examples playlist on our YouTube channel.
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Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

In the Plot Renderer settings window, click  Show more and Show less to toggle between 
viewing all or some of the available settings.

The default plot shows the volume fraction of all phases as a function of the mass fraction of the second 
material, which in this case, is Alloy 800. You can see that the martensitic stainless composition is BCC at 
this temperature, and the highly alloyed stainless is FCC. Neither material is expected to form any 
deleterious phase on its own at 650 °C.

However, mixtures of these two materials, which could arise from a graded transition joint, weld, or 
potentially a diffusion couple, show some stability for the deleterious sigma phase at this temperature. You 
can try to make small adjustments to the initial chemistry to reduce the potential for sigma phase to form.

Figure 16: This plot shows the volume fraction of phases when changing composition from the Martensitic Steel 
(First material) to the Alloy 800 (Second material). This calculation uses the Material to Material Calculator to 
examine the transition of phases for two compositions of Fe-Cr-Ni. The purpose  is to determine at what fraction 
of Alloy 800 does the deleterious sigma phase start to form. See the text for details. 
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Figure 17: The composition varies linearly when the composition is changed from the Martensitic steel to the 
Alloy 800 using the Material to Material Calculator. See the text for details. 
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T_15: Molar Volume and Thermal Expansion Coefficients 
for L12-type Al3Sc and Al3Zr Compounds

This example calculates volumetric thermal expansion coefficients of the L12-type Al3Sc and the L12-type 
Al3Zr, respectively. Both Al3Zr and Al3Sc are modeled as the same phase (named as AL3SC, since Al3Sc is 
stable while Al3Zr is metastable).

The example  uses two System Definers and Equilibrium Calculators to plot and compare the molar volume 
and thermal expansion coefficients of the Al3Sc and Al3Zr binary compounds. It uses the 
ALDEMO database, which is the free demonstration version of the TCS Al-based Alloy Database (TCAL) and 
an Experimental File Reader node to read the data from [2015Sah].

Project File Information

 l Folder: Thermo-Calc

 l File name: T_15_Molar_Volume_and_Thermal_Expansion_Coefficient.tcu

The example includes an experimental data (*.exp) file called Al3X.exp.

The same example is also provided in Console Mode as two separate examples: tcex58 and 
tcex59.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 18: Compares the molar volume of both Al3Zr and Al3Sc, which are modeled as the same phase (named as 
AL3SC, since Al3Sc is stable while Al3Zr is metastable).

Figure 19: Compares volumetric thermal expansion coefficients of the L12-type Al3Sc and the L12-type Al3Zr using 
theoretical data with quasiharmonic approximation from [2015Sah].
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Reference

[2015Sah] S. Saha, T. Z. Todorova, J. W. Zwanziger, Temperature dependent lattice misfit and coherency of 
Al3X (X=Sc, Zr, Ti and Nb) particles in an Al matrix. Acta Mater. 89, 109–115 (2015).

More Information

The thermophysical properties are progressively being added to the Thermo-Calc databases starting with 
Thermo-Calc software version 2020a. 

You can learn more about the models by searching the help (press F1 when in Thermo-Calc). 

You can find information on our website about the properties that can be calculated with 
Thermo-Calc and the Add-on Modules. 
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T_16: Electrical Resistivity and Thermal Conductivity for 
Pure Copper

This example calculates the electrical resistivity (ELRS) and thermal conductivity (THCD) of pure Cu. It 
makes a One Axis (step) calculation over a wide temperature range, covering both the FCC_A1 state and 
the liquid state. It plots thermal conductivity of the system (both FCC_A1 and liquid) and that of a single 
phase (taking FCC_A1 as an example), respectively. Also it plots electrical resistivity of the system and that 
of FCC_A1.

The example set up uses an Equilibrium Calculator combined with four Experimental File Reader nodes that 
take data from the included 1972Ho_cu_thcd.exp and 1981Ho_cu_elrs.exp files.

The example is available to all users as it uses the ALDEMO database, which is the free 
demonstration version of the TCS Al-based Alloy Database (TCAL).

Project File Information

 l Folder: Thermo-Calc

 l File name: T_16_Electrical_Resistivity_Thermal_Conductivity_Cu.tcu

 l Experimental data files included 1972Ho_cu_thcd.exp and 1981Ho_cu_elrs.exp

The same example is also provided in Console Mode as tcex60.

Visualizations

This example is included as a tutorial on our website and as part of the Graphical Mode 
Examples playlist on our YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 20: The electrical resistivity (ELRS) of pure Cu over a wide temperature range, covering both the FCC_A1 
state and the liquid state. The data was recommended by [1981Ho].

Figure 21: The electrical resistivity (ELRS) of a single phase (FCC_A1) vs. temperature. The data was recommended 
by [1981Ho].

Thermo-Calc Examples Collection ǀ 37 of 431



Figure 22: The thermal conductivity of pure Cu over a wide temperature range, covering both the FCC_A1 state 
and the liquid state. The data was recommended by [1972Ho].

Figure 23: The thermal conductivity (THCD) of a single phase (FCC_A1) vs. temperature. The data was 
recommended by [1972Ho].
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References

[1972Ho] C. Y. Ho, R. W. Powell, P. E. Liley, Thermal Conductivity of the Elements. J. Phys. Chem. Ref. Data. 
1, 279–421 (1972).

[1981Ho] C. Y. Ho, M. W. Ackerman, K. Y. Wu, T. N. Havill, R. H. Bogaard, R. A. Matula, S. G. Oh, and H. M. 
James. Electrical resistivity of ten selected binary alloy systems. CINDAS report 59, for Office of standard 
reference data National Bureau of Standards, Department of Commerce (1981).

More Information

For more advanced examples using the TCAL database, see "PM_G_10: Freeze-in Thermal 
Conductivity" on page 86 and "PM_G_11: Freeze-in Electrical Resistivity" on page 88.

The thermophysical properties are progressively being added to the Thermo-Calc databases starting with 
Thermo-Calc software version 2020a. 

You can learn more about the models by searching the help (press F1 when in Thermo-Calc). 

You can find information on our website about the properties that can be calculated with 
Thermo-Calc and the Add-on Modules. 
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T_17: Al2O3-MgO Phase Diagram
Al2O3-MgO is one of the basic systems to understand metallurgical slags and refractories. This example  
uses an Equilibrium Calculator to calculate a phase diagram of the pseudo-binary system Al2O3-MgO. It also 
demonstrates how to change components  in the System Definer. In this case,  the components AL2O3 and 
MgO are defined instead of the elements Al, Mg, and O.

In the Plot Renderer settings window, click  Show more and Show less to toggle between 
viewing all or some of the available settings.

Project File and License Information

 l Folder: Thermo-Calc

 l File name: T_17_Al2O3-MgO_phase_diagram.tcu

The TCS Metal Oxide Solutions Database (TCOX) is used in this example. A valid license for  
version 11 (TCOX11) or newer is required to run the example.  

Visualizations

This example is included as a tutorial on our website and as part of the Graphical Mode 
Examples playlist on our YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

Thermo-Calc Examples Collection ǀ 40 of 431

https://thermocalc.com/support/video-tutorials/
https://www.youtube.com/playlist?list=PLfv6McToaTGSzHrh3TfNF2EhoUUUqeEWd


Figure 24: Phase diagram of the pseudo-binary system Al2O3-MgO.

More Information

This example is also included in the TCS Metal Oxide Solutions Database (TCOX) Validation and 
Calculation Examples Collection. 

There is a similar example provided in Console Mode that uses the OXDEMO database, which is 
available to all users. See tcex17.

Go to the Metal Slag and Oxides Database page  on our website where you can access a 
Validation and Calculation Examples Collection and the Technical Information plus learn about 
its many applications  with the Process Metallurgy Module. Also explore further applications of 
Thermo-Calc to Refractory Oxides and Slags including links to resources such as examples, 
publications, and more.
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T_18: Scheil with Delta Ferrite to Austenite Transition

This is a example of a Scheil solidification simulation using an Fe-0.23C-0.19Si-0.47Mn-0.92Cr-0.09Ni-0.3Mo 
(wt%) alloy (Steel P) [2015Sch],  which is a steel that undergoes the peritectic transformation. 

The result of a Scheil Calculator with the default Classic Scheil calculation type is compared to a the result 
of a calculator where the setting Allow delta ferrite to austenite transition in steel is selected. Carbon ( C ) 
is set as a Fast diffuser in both. A comparison to experimental solidus temperature from Schaffnit et al. 
[2015Sch] shows that for this steel, using the Allow delta ferrite to austenite transition in steel option 
gives a much better agreement with experiment than the standard Classic Scheil.    

Project File and License Information

 l Folder: Thermo-Calc

 l File name: T_18_Scheil_with_Delta_Ferrite_to_Austenite_Transition.tcu

This uses the TCFE database. A license is required to run the example.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 25: Mole fraction of solid as a function of temperature comparing the liquidus and solidus from 
experimental data [2015Sch]. 

Reference

[2015Sch] P. Schaffnit, C. Stallybrass, J. Konrad, F. Stein, M. Weinberg, A Scheil–Gulliver model dedicated to 
the solidification of steel. Calphad. 48, 184–188 (2015).
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T_19: Young's Modulus for Ti-O with Elastic Properties

This is an example which shows the effect of oxygen concentration at three temperatures on  an elastic 
property, Young's modulus, for the HCP_A3 phase in a Ti-O system.

It is well established in the literature that mechanical properties of titanium and its related alloys are 
sensitive to the presence of even dilute concentrations of interstitial solutes such as carbon, hydrogen, 
nitrogen and oxygen. It is therefore important to adequately model the effects of impurities in the host 
lattice when calculating mechanical properties, such as the elastic constants and the corresponding moduli 
determined from these constants.   

Only the elastic constants are assessed, and then used to derive the elastic moduli, meaning 
the experimental data in the plot are completely standalone from the assessment process.  

In this example, three Equilibrium Calculators are used with One Axis calculations at different 
temperatures (298 K, 533 K, and 672 K) to show the Young's modulus of an HCP_A3 phase as a function of 
mole percent of O and compared to experimental data from [1957Gra; 1966Fed; 1971Hsu].

Project File and License Information

 l Folder: Thermo-Calc

 l File name: T_19_Elastic_Properties_YoungsModulus_Ti-O.tcu

The   TCS Ti/TiAl-based Alloys Database (TCTI) is used in this example. A valid license is required 
to run the example. 

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.
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Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

Figure 26:  Effect of oxygen on Young’s modulus in HCP_A3 titanium compared to experimental data [1957Gra; 
1966Fed; 1971Hsu].

References

[1957Gra] W. H. Graft, D. W. Levinson and W. Rostoker, The influence of alloying on the elastic modulus of 
titanium alloys, Trans. Am. Soc. Met. 49, 263-279 (1957).

[1966Fed] S. G. Fedofov, Titanium and Its Alloys, Publ. No. lO, I. I. Kornilov Editor, Israel Prog. Sci. Trans., 
199 (1966).

[1971Hsu] N. Hsu, H. Conrad, Ultrasonic wave velocity measurements on titanium-oxygen alloys. Scr. 
Metall. 5, 905–908 (1971).
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More Information

As of Thermo-Calc version 2025b, elastic properties are available with Thermo-Calc and the 
TCS Ti/TiAl-based Alloys Database (TCTI) (TCTI6 and newer), TCS Steel and Fe-alloys Database 
(TCFE) (TCFE14 and newer), TCS High Entropy Alloys Database (TCHEA) (TCHEA8 and newer), 
and TCS Ni-based Superalloys Database (TCNI) (TCNI13 and newer). These elastic properties 
will be added to additional databases over time. Subscribe to our newsletter to be kept up-to-
date on the latest product releases, webinars, user group meetings, applications examples, 
and more.
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T_20: Ternary Diagram with Clockwise Plot Axes

This Ternary Calculator example for a Cr-Fe-Ni system shows how to use different plot axis combinations 
on the Plot Renderer representing clockwise and counterclockwise axes. This example uses the FEDEMO 
database and is available to all users. 

A ternary phase diagram is fully defined by the elements in the corners of the diagram. See Figure 27 for 
the Cr-Fe-Ni 1000 K isothermal section when plotted as a ternary diagram. To plot this diagram in Thermo-
Calc you define the X- and Y-axes instead of the corner elements. 

Define the X- and Y- Plot Axes

The same diagram can therefore be defined with different combinations of the plot axes. In this example, 
there is Cr in the bottom left corner and Fe in the lower right corner. Then you can define the X-axis by Fe 
increasing from 0 to 100 (these numbers are entered in the Limits fields). It is also possible to define the X-
axis by decreasing Cr from 100 to 0. The main reason for defining a decreasing plot axis in Thermo-Calc is 
when comparing with experimental diagrams that can be visualized in this way.

To define a decreasing plot axis, on the Plot Renderer, click to deselect the Automatic scaling checkbox. 
Then either change the limits as described above by entering 100.0 and  0.0 in the fields, or click the Swap 
button to swap the lower (0.0) and upper (100.0) limits. 

The Flexible Mode plot type is used in this example as it allows you to individually work with 
the axes. 
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Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

Project File Information

 l Folder: Thermo-Calc

 l File name: T_20_Ternary_Cr-Fe-Ni_Clockwise_Axes.tcu

In the installed example the Plot Renderer node is renamed to Counterclockwise x:+Fe y:-Cr. As above, the 
settings are completed on the Configuration window to plot the Composition of Fe on the X-axis and Cr 
decreasing on the Y-axis. Click Perform to display the result of Figure 27. 

You can continue on the Plot Renderer to plot different combinations of axes variables in order to 
represent clockwise and counterclockwise plot axes. 

Figure 27: Counterclockwise x:+Fe y:-Cr. Increasing Mass percent Fe (X-axis). Decreasing Mass percent Cr (Y-axis).
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Then for the other plot examples, the settings on each Plot Renderer Configuration window (for renamed 
nodes Clockwise x:-Cr y:+Ni and Counterclockwise x:+Fe y:+Ni) are also changed to show the different 
combinations of plot axes.

Figure 28: Clockwise x:-Cr y:+Ni: Decreasing Mass percent Cr (X-axis). Increasing Mass percent Ni (Y-axis).

Figure 29: Counterclockwise x:+Fe y:+Ni: Increasing Mass percent Fe (X-axis). Increasing Mass percent Ni (Y-axis).
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T_21: Pourbaix Diagrams of Fe with the Aqueous 
Calculator

In Graphical Mode, you use the Aqueous Calculation template in combination with an appropriate 
database to calculate aqueous corrosion and Pourbaix diagrams. 

The free PAQ2 database is used in this example to give all users the opportunity to experiment 
with these types of calculations. No additional license is required. 

The aqueous template adds a System Definer, Aqueous Calculator, and Plot Renderer with default settings 
specialized for aqueous calculations. 

Figure 30: To add the template, click Aqueous Calculation from the My Project page in the Equilibrium group.

This example uses the aqueous template to plot Pourbaix diagrams of Fe under different conditions. The 
stability lines for H2 and O2 gas formation is calculated in a separate Aqueous Calculator (which is 
renamed) and overlaid to the Pourbaix diagrams. 

Also see the companion example, "T_22: Aqueous pH of Solutions" on page 56.

In this example the Pourbaix diagram for Fe is calculated under normal conditions and in equilibrium with 
CO2 gas. The formation of H2 and O2 gas is not considered in the calculations (GAS phase is set to 
suspended/dormant) and instead the formation lines are calculated separately and overlaid to the plot.

Since GAS is suspended from the Pourbaix calculation and we want to overlay the gas formation lines 
separately, you need to prevent H2 and O2 containing species to form in the AQUEOUS phase. This is 
handled  on the System Definer window from the Phases and Phase Constituent tab. 
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On this tab, at the top under  Phases > Name, click the AQUEOUS phase. This populates the Constitution 
details for the PAQ2 database at the bottom of the window where you next click Edit to add/remove 
species. 

A similar process is done when in equilibrium with CO2.  

In a Pourbaix calculation it is not always certain that conditions can be fulfilled (eg. some 
pH/Eh combinations CANNOT reach equilibrium under the constraints set).
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Project File Information

 l Folder: Thermo-Calc

 l File name: T_21_Aqueous_Fe-Pourbaix.tcu

When the Aqueous Calculator is added to your project using the template, this allows for 
efficient setup of advanced aqueous calculations. For optimal results, the latest version 
(TCAQ4) of the TCS Aqueous Solutions Database (TCAQ) is recommended as it is designed 
specifically for this. Although other versions (TCAQ 3.1 and older) and the free PAQ2 database 
can be used, there are limitations and additional requirements to conduct more complex 
simulations. 

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 31: The Fe Pourbaix diagram, which is a plot result sourced from two renamed Aqueous Calculators (the 
"Metal and oxide stability" and "Gas stability" nodes).

Figure 32: The Fe Pourbaix diagram in equilibrium with CO2. This is a result plot sourced from two renamed 
Aqueous Calculators (the  "Gas stability" and "Metal and oxide stability (with CO2)" nodes).
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Figure 33: Phases formed at different pH of the aqueous solution. This is a plot result from the Aqueous Calculator 
renamed to "Step in pH".

Figure 34: Ionic strength of the aqueous solution. This is a plot result from the Aqueous Calculator renamed to 
"Step in pH".
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More Information

Go to the Aqueous Solutions Databases page on our website where you can access the latest 
TCAQ Validation and Calculation Examples Collection and the Technical Information. Also 
explore further options to work with aqueous solutions and this database using the Aqueous 
Calculator.
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T_22: Aqueous pH of Solutions

In Graphical Mode, you use the Aqueous Calculator in combination with an appropriate database to 
calculate aqueous property diagrams. 

The free PAQ2 database is used in this example to give all users the opportunity to experiment 
with these types of calculations. No additional license is required. 

This example has two calculations using the Aqueous Calculation template. 

The aqueous template adds a System Definer, Aqueous Calculator, and Plot Renderer with default settings 
specialized for aqueous calculations. 

Figure 35: To add the template, click Aqueous Calculation from the My Project page in the Equilibrium group.

Also see the companion example, "T_21: Pourbaix Diagrams of Fe with the Aqueous 
Calculator" on page 50.

The first calculation shows how to calculate the pH of 1kg H2O-0.1kg NaCl solution in equilibrium with 
CO2 gas. The calculation uses the template defaults set on the System Definer (renamed in the example to 
H2O-0.1NaCl in CO2 equilibrium) and the Aqueous Calculator (renamed to Step in T).

On the Aqueous Calculator, in the Condition Definitions section, you include user-defined conditions to 
ensure there is 0.1 kg of NaCl in the solution. Setting the amount of Ze and H+1 to 0.0 also ensures there is 
a neutral solution. See the results when this is run in Figure 36 and Figure 37.
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The second calculation shows how to predict pH of a solution with 1 kg H2O with 1 mole (HCl-HNO3) 
mixture. 

This calculation shows how you can change the components for the calculation for an easier setup. 

On the System Definer (renamed to 1kgH2O-1moleHCl-HNO3 mixture) on the Components tab, you 
change the component N to NO3-1 and Cl to CL-1 and then you can construct the HCl-HNO3 mixture 
directly in combination with the H+1 component using user-defined conditions. 

Then on the Aqueous Calculator (renamed to 1kg-H2O-1moleHCl-HNO3 mixture (Calc)), with a One Axis 
step in CL-1, you can make predictions of pH for the 1 kg H2O with 1 mole HCl-HNO3 mixture and see how it 
changes with amount of HCl. See Figure 38 for the result.
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Project File Information

 l Folder: Thermo-Calc

 l File name: T_22_Aqueous_pH_of_Solutions.tcu

When the Aqueous Calculator is added to your project using the template, this allows for 
efficient setup of advanced aqueous calculations. For optimal results, the latest version 
(TCAQ4) of the TCS Aqueous Solutions Database (TCAQ) is recommended as it is designed 
specifically for this. Although other versions (TCAQ 3.1 and older) and the free PAQ2 database 
can be used, there are limitations and additional requirements to conduct more complex 
simulations. 

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 36: pH of 1kg H2O-0.1kg NaCl in equilibrium with CO2 gas in function of temperature.

Figure 37: Molality of CO2 for a aqueous solution 1kg H2O-0.1kg NaCl in equilibrium with CO2 gas.
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Figure 38: pH for a aqueous solution of 1kg-H2O-1mole HCl-HNO3 mixture.

More Information

Go to the Aqueous Solutions Databases page on our website where you can access the latest 
TCAQ Validation and Calculation Examples Collection and the Technical Information. Also 
explore further options to work with aqueous solutions and this database using the Aqueous 
Calculator.
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Thermo-Calc General Property Models Examples 
Collection

The General Models are available to all users. 

To run calculations with  the Add-on Property Model Libraries all require a valid maintenance 
license plus a license for the specific database version: Nickel Models (TCNI11 and newer and 
MOBNI5 and newer; Noble Metal Alloys Models (TCNOBL3 and newer); Steel Models (TCFE9 
and newer + MOBFE4 and newer); Titanium Models (TCTI6 and newer).

These examples use the Property Model Calculator, an activity available with Thermo-Calc. 

In this section:

PM_G_01: Phase Transition 63

PM_G_02: Coarsening and Interfacial Energy 66

PM_G_03: Driving Force and Interfacial Energy 70

PM_G_04: Yield Strength 72

PM_G_05: Yield Strength NiAlCr 76

PM_G_06: Yield Strength HEA 78

PM_G_07: Hot Crack Susceptibility 80

PM_G_08: Spinodal 82

PM_G_09: T-Zero Temperature 84

PM_G_10: Freeze-in Thermal Conductivity 86

PM_G_11: Freeze-in Electrical Resistivity 88

PM_G_12: Solidus and Liquidus Batch Calculation 90

PM_G_13: Ti Alloy Design for Additive Manufacturing 92

PM_G_14: Ti-Fe T-Zero Martensite 94

PM_G_15: Columnar to Equiaxed Transition (CET) of a NiAlCr Alloy 96
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PM_G_16:  Columnar to Equiaxed Transition of a CMSX-4 Alloy 99

PM_G_17: Columnar to Equiaxed Transition of an IN718 Alloy 103

PM_G_18: Equilibrium and Annealing Heat Treatment for ASTM A29 106

PM_G_19: Thermal Conductivity for an AM Cu-Alloy 109

PM_G_20: Scheil for an Al-1Si-1Mn-0.7Mg-0.6Fe-0.1Cu Alloy 111
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PM_G_01: Phase Transition

The example uses the Property Model Calculator and a Phase Transition Property Model to predict the 
transition temperature to the unwanted brittle sigma phase. The example shows how the temperature is 
influenced by changes to a steel alloy’s composition using the Uncertainty Calculation Type and then you 
can choose to use either a Histogram (frequency diagram) or Probability plot after choosing the Statistical 
Plot type on the Plot Renderer.

Project File Information

 l Folder: Property Models → General

 l File name: PM_G_01_Phase_Transition.tcu

Visualizations

This example is included as a Property Model tutorial on our website and as part of the 
Property Model Calculator playlist on our YouTube channel. 

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 39: A property diagram as a result of using the Equilibrium Calculator with a One Axis calculation to 
determine a good starting temperature of the SIGMA phase.

Once you set up the Property Model Calculator, but before running a Grid calculation, it is recommended 
you run a Single calculation to make sure the calculation is valid. 

 l If the subprocess worked, it displays in the Event Log. The Event Log also has the result Relaxed 
condition, referring to the variable, which in this case is temperature. 

 l If the calculation did not work, NaN (not a number) displays instead. Check your configuration set up 
and run the calculation again before moving on to the more complicated calculation.
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Figure 40: Using the Property Model Calculator with the Phase Transition Model to plot a histogram showing how 
the transition temperature of sigma varies when you vary the composition. The plot changes each time you run 
the calculation because it is taking a random sampling from the composition range set.

The X-axis is labeled the Relaxed Condition: Temperature (Phase Trans.), which you can see 
on the  Plot Renderer 1 Configuration window. The Y-axis shows the Frequency, which is the 
number of samples out of 40 where the composition transitions at each temperature. You can 
see that the transitions occur more frequently near the 600 °C starting point and less 
frequently at the edges.

Since only one variable can serve as a Relaxed condition per calculation, the quantity that is 
not relaxed has a NaN result in its corresponding result quantity. The Evaluation temperature 
result quantity inherits the unit set in the conditions while the Composition result quantity 
inherits the normalization (mole or mass) but always returns a fraction.

Thermo-Calc General Property Models Examples Collection ǀ 65 of 431



PM_G_02: Coarsening and Interfacial Energy

The example uses the Property Model Calculator and both thermodynamic (FEDEMO) and kinetic 
(MFEDEMO) demonstration steel databases. Using a Grid Calculation Type it produces these plot types: a 
Heat map, a Contour plot and an overlaid plot combining a cross plot with a contour plot (where both the 
interfacial energy and coarsening rate is shown). It also creates a diagram to show the phase fractions vs 
time and a 3D Plot type comparing the coarsening rate coefficient.

Project File Information

 l Folder: Property Models → General

 l File name: PM_G_02_Coarsening_and_Interfacial_energy.tcu

Visualizations

This example is included as a Property Model tutorial on our website and as part of the 
Property Model Calculator playlist on our YouTube channel. 

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 41: Uses a Property Model Calculator with a Grid Calculation type to plot the coarsening rate coefficient as 
a Heat map.

Figure 42: Uses a Property Model Calculator with a Grid Calculation type to plot the coarsening rate coefficient as 
a 3D plot.
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Figure 43: Uses a Property Model Calculator with a Grid Calculation type to plot the coarsening rate coefficient as 
a Contour plot. 

Figure 44: Comparing the coarsening rate coefficient and interfacial energy in overlaid plots. 
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Figure 45: A One Axis Equilibrium calculation showing the phase fractions vs T (with a Flexible Mode plot type).
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PM_G_03: Driving Force and Interfacial Energy

The example uses the Property Model Calculator and a thermodynamic demonstration steel database 
(FEDEMO). Using a Grid Calculation type it produces a Contour plot comparing the driving force and 
interfacial energy.

Project File Information

 l Folder: Property Models → General

 l File name: PM_G_03_Driving_force_and_Interfacial_energy.tcu

Visualizations

This example is included as a Property Model tutorial on our website and as part of the 
Property Model Calculator playlist on our YouTube channel. 

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

Figure 46: An overlaid Contour plot comparing the driving force and interfacial energy.
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Figure 47: A One Axis Equilibrium calculation showing the Phase fractions vs T.
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PM_G_04: Yield Strength

The example uses the Property Model Calculator and the Yield strength Property Model with a 
thermodynamic demonstration aluminum database (ALDEMO).

Using default options for the precipitation strengthening models, this example compares the Simplified 
model (general), Seidman model (Al-base) and Deschamps model (Al-base) yield strength versus 
precipitate radius to experimental data for an Al-0.3wt%Sc alloy homogenized at 648 °C for 24 hours and 
subsequently aged at 350 °C.

The Seidman model [2002Sei] considers a combination of a shearing mechanism and Orowan dislocation 
bypass mechanism. For the shearing mechanism, the increase in yield strength results from the 
contributions of ordering strengthening, coherency strengthening, and modulus mismatch strengthening.

When Seidman model (Al-base) is selected as the Precipitation strengthening model, the setting for  is a 
constant related to the coherency strengthening of precipitates, which usually varies from 2 to 3. In this 
example, the default  is 2.6 [1985Ard]. The m setting is the parameter that relates to the modulus 
mismatch strengthening and the default is set as 0.85 [1985Ard]. This model is applied in the study of 
precipitation hardening in dilute Al(Sc) alloys containing coherent Al3Sc precipitates. The model parameters 
described above can be adjusted to work for hardenable aluminum alloy calculations from the 2000 (Al–Cu 
and Al–Cu–Mg), 6000 (Al–Mg–Si), and 7000 (Al–Zn–Mg) series.

As a comparison, the Simplified model [2008Zan] only considers the general mechanisms of cutting and 
looping (Orowan mechanism) without regard to any detailed dislocation mechanisms.

When Simplified model (general) is selected as the Precipitation strengthening model, the default Critical 
radius (the critical size ) is optimized against experimental results for dilute Al-Sc. If the precipitates are 
smaller than a critical size (approximately 5–10 nm) the dislocations cut the precipitates. The strength of 
the obstacle is then proportional to the square root of the average radius. If the particles are larger than 
the critical size, , it is less costly for the dislocations to bow round the particles and the strengthening 
contribution is inversely proportional to . Since the Simplified model (general) only depends on generic 
material constants (  and ) it may be applied to any precipitation strengthened material.

The Deschamps model (Al-base) model [1998Des], is for precipitation strengthening, mainly intended for 
use with Al-base alloys. The Deschamps model includes use of Friedel or Kock's statistics for particle size 
distribution. Default parameters are used to match a dilute Al-Sc alloy with Al3Sc precipitates. As is done 
for the other precipitation strengthening models, a critical radius, describing the transition from cutting to 
looping, must be specified when you are setting up the configuration.
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Project File Information

 l Folder: Property Models → General

 l File name: PM_G_04_Yield_Strength.tcu

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

 

Figure 48: Strength vs Radius - Simplified compared to experimental data from [2002Sei].
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Figure 49: Strength vs Radius - Seidman compared to experimental data from [2002Sei].

Figure 50: Strength vs Radius - Deschamps compared to experimental data from [2002Sei].
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PM_G_05: Yield Strength NiAlCr

The example uses the Property Model Calculator and the Yield strength Property Model with a 
thermodynamic demonstration nickel database (NIDEMO).

The Reppich model is developed for calculation of precipitation strengthening in Ni-based super alloys 
consisting mainly of gamma prime (γ') precipitates in a gamma matrix. The example shows a calculation of 
the precipitation strengthening vs precipitate radius in a Ni-10at%Al-10at%Cr alloy.

This example uses the Reppich model [1982Rep] which is developed and rests on existing hardening 
models estimating the increase of the yield stress due to pairwise particle cutting and antiphase domain 
boundary (APB) formation. The effect of the anisotropy on the dislocation line tension of two-phase 
material and on the Orowan stress is taken into account. Compared to conventional APB hardening 
theories, this model can be applied to large volume fraction of precipitates in the anisotropic systems.

For the settings input of the Reppich model (Ni-base):

 l A is a numerical factor depending on the morphology of the precipitates. For spherical particles, A 
equals to 0.72.

 l w represents the elastic repulsion between the strongly paired dislocations, which can be 
determined by the experimental data [1979Hüt].

In this example, A and w are set by default to 0.7639 and 0.2919, respectively. The C factor default 
of 0 is not changed. 

Project File Information

 l Folder: Property Models → General

 l File name: PM_G_05_Yield_Strength_NiAlCr.tcu

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.
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Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

Figure 51: Reppich model plotted with results and experimental data for PE16, all data is normalized with the 
square root of the volume fraction of precipitate.

References

[1979Hüt] W. Hüther, B. Reppich, Order hardening of MgO by large precipitated volume fractions of spinel 
particles. Mater. Sci. Eng. 39, 247–259 (1979).

[1982Rep] B. Reppich, Some new aspects concerning particle hardening mechanisms in γ’ precipitating Ni-
base alloys—I. Theoretical concept. Acta Metall. 30, 87–94 (1982).

Thermo-Calc General Property Models Examples Collection ǀ 77 of 431



PM_G_06: Yield Strength HEA

The example uses the Property Model Calculator and the Yield strength Property Model with the 
thermodynamic TCS High Entropy Alloys Database (TCHEA). It is an example of solid solution strengthening, 
which is the contribution to total strength due to the elastic strains in the crystal lattice caused by alloying 
elements of a lattice parameter differing from the main constituent. The example shows the solid solution 
strengthening at 300 K and 411 K over the full solubility range for the Mo-Ta system as compared to 
experimental data  [1972Ste].

Project File and License Information

 l Folder: Property Models → General

 l File name: PM_G_06_Yield_Strength_HEA.tcu

This example requires the use of the TCS High Entropy Alloys Database (TCHEA). A license is 
required to run the example.

This example is configured to run with BCC_A2 selected and BCC_B2/BCC_B2#2 deselected in 
the System Definer → Phases and Phase Constitution tab, when using version 8 (TCHEA8) or 
higher. If the database is changed to an earlier version, this selection is reset by the software 
and you need to either manually re-apply these settings on the System Definer or reopen the 
example.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 52: The solid solution strengthening over the full solubility range for the Mo-Ta system as compared to 
experimental data [1972Ste].

Reference
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PM_G_07: Hot Crack Susceptibility

The example uses the Property Model Calculator and the Crack Susceptibility Coefficient Model to 
calculate the hot tearing tendency during solidification for an Al-Si alloy. The ALDEMO: Aluminum Demo 
Database  is used and this example is available to all users. 

The Crack Susceptibility Coefficient Property Model, available as a General model with the Property Model 
Calculator,  calculates the crack susceptibility coefficient, which describes the risk or tendency of a material 
to experience cracking or hot tearing during solidification. Cracking/hot tearing is one of the most common 
and serious defects encountered during the casting of, for example, aluminum alloys. In general, it is 
defined by the formation of a macroscopic fissure in a casting because of stress and the associated strain, 
generated during cooling, at a temperature above the non-equilibrium solidus. Crack susceptibility is also 
referred to as solidification cracking, hot cracking, hot shortness, supersolidus cracking, and shrinkage 
brittleness. The Crack Susceptibility Coefficient (CSC) is calculated using Scheil results with three different 
model options: Clyne and Davies, Kou, and Easton. 

The Model is based on the publication by Yan and Lin [2006Yan] and uses experimental data [1955Pum; 
1976Feu; 2004Bar] from this paper. 

The experimental hot cracking susceptibility of an alloy is defined as the ratio between the cracking length 
for that alloy and the maximum cracking length in the alloy system studied. Considering the uncertainties 
and difficulties in hot tearing measurements, the calculated hot tearing tendencies are in excellent 
agreement with the experimental data. The typical L-shaped curve is well reproduced in the current 
prediction. It rapidly increases at a low solute content and has a maximum at a composition of around 0.5 
wt pct Si.

Project File Information

 l Folder: Property Models → General

 l File name: PM_G_07_Hot_Crack_Susceptibility.tcu

Visualizations

This example is included as a Property Model tutorial on our website and as part of the 
Property Model Calculator playlist on our YouTube channel. 

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 53: The plot compares the predicted cracking susceptibility/composition curve for the Al-Si system with the 
experimental hot tearing tendencies [1955Pum; 1976Feu; 2004Bar].
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PM_G_08: Spinodal

The example uses the Property Model Calculator and the Spinodal Property Model to  calculate the so-
called spinodal curve for the BCC_A2 miscibility gap in the system Fe-Cr. The FEDEMO: Iron Demo 
Database  is used and this example is available to all users. 

Two Property Model Calculators are used in this example. The spinodal curve (a One Axis calculation), is 
overlaid on top of a the Fe-Cr Phase diagram calculation. As can be seen in the plot, the spinodal curve for 
BCC goes through the one-phase region for Sigma. This is because the spinodal curve for a phase is 
calculated when all other phases are suspended.

Project File Information

 l Folder: Property Models → General

 l File name: PM_G_08_Spinodal.tcu

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 54: An Fe-Cr spinodal curve for BCC goes through the one-phase region for Sigma. 
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PM_G_09: T-Zero Temperature

The example uses the Property Model Calculator and the T-Zero Temperature Property Model to  calculate 
the so-called T0 line for the two-phase field FCC_A1 and BCC_A2 in the Fe-Ni system.  The line is plotted 
together with the phase diagram for the same Fe-Ni system. The FEDEMO: Iron Demo Database  is used 
and this example is available to all users. 

The  temperature is defined as the temperature where two phases of identical chemical composition 
have the same molar Gibbs free energy. This temperature is an important quantity in the field of 
diffusionless phase transformations, e.g. martensitic transformation, since it is the upper limit where 
diffusionless phase transformations can occur.

Two Property Model Calculators are used in this example. The T0 line (a One Axis calculation) for the two-
phase field FCC_A1 and BCC_A2 is overlaid on top of a the Fe-Ni Phase diagram calculation. 

Project File Information

 l Folder: Property Models → General

 l File name: PM_G_09_T-Zero_temperature.tcu

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 55: In this plot for the Fe-Ni system, the T0 line for the FCC_A1 and BCC_A2 phases is located in the middle 
of the two-phase region. No solution for the T0 temperature exists above about 30 mass% Ni.
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PM_G_10: Freeze-in Thermal Conductivity

The example uses the Property Model Calculator and the Equilibrium with Freeze-in Temperature 
Property Model to compare the use of the model with thermal conductivity with and without grain 
boundary (GB) phase scattering being included in the calculation. 

The TCS Al-based Alloy Database (TCAL) is used to evaluate a 7075_T6 alloy (Al-1.6Cu-2.5Mg-5.6Zn-0.25Fe-
0.15Mn-0.23Cr-0.2Ti-0.2Si) mass%. The "T6" in the alloy name means that the alloy has been artificially 
peak-aged, i.e. the matrix is almost depleted. The heating is assumed to be at a typical artificial aging 
temperature of 150 °C. The temperature has then been increased for measuring of the reported values 
thermal conductivity at 400, 500, and 532 °C.

The thermal conductivity  due to grain boundary phase scattering is approximated as a scattering constant 
times the total volume fraction of the grain boundary phases. The contribution to thermal conductivity is 
assumed to be related to that to electrical resistivity, following the Wiedemann-Franz law.

The calculation set up assumes that the alloy reaches equilibrium at the peak-age temperature, i.e. that the 
amounts of phases and their composition freeze-in at 150 °C and that these do not change for the 
evaluation of thermal conductivity at the temperatures 400, 500, and 532 °C. Calculations are compared 
between accounting and ignoring contributions from grain boundary (GB) phase scattering. 

As can be seen in Figure 56, the calculation including the approximate effect of grain boundary phase 
scattering is close to the experimentally measured values. Excluding the effect of grain boundary phase 
scattering slightly overestimates the thermal conductivity. Experimental data is from [2008ASM].

Project File and License Information

 l Folder: Property Models → General

 l File name: PM_G_10_Freeze_In_Thermal_Conductivity.tcu

The  TCS Al-based Alloy Database (TCAL) is used in this example. A valid license for  version 7 
(TCAL7) or newer is required to run the example.  
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Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

Figure 56: Comparing the freeze-in temperature for the 7075_T6 alloy with and without grain boundary (GB) 
scattering included in the calculations.  

Reference
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PM_G_11: Freeze-in Electrical Resistivity

The example uses the Property Model Calculator and the Equilibrium with Freeze-in Temperature 
Property Model to compare the use of the model for electrical resistivity with and without grain boundary 
(GB) scattering being included in the calculation. 

The TCS Al-based Alloy Database (TCAL) is used to evaluate a 4032-O alloy (Al-0.9Cu-1.0Mg-0.9Ni-12.2Si) 
mass%. The "O" in the alloy name means that the Al alloy has been heat-treated at a typical temperature of 
350 °C. The measurement of electric resistivity is usually performed at room temperature.

The electrical resistivity due to grain boundary phase scattering is approximated as a scattering constant 
times the total volume fraction of the grain boundary phases.

The calculation set up assumes that the alloy reaches equilibrium at the "O" heat-treated temperature, i.e. 
that the amounts of phases and their composition freeze-in at 350 °C and that these do not change for the 
evaluation of electrical resistivity at the room temperature. Calculations are compared between accounting 
and ignoring contributions from grain boundary (GB) scattering. 

As can be seen from Figure 57, the calculated electrical resistivity at room  temperature, including grain 
boundary phase scattering, is very close to the experimentally measured value (4.3E-8) for the alloy. 
Excluding the grain boundary phase scattering somewhat underestimates the electrical resistivity for the 
alloy. Experimental data is from [1993Dav]. 

Project File and License Information

 l Folder: Property Models → General

 l File name: PM_G_11_Freeze_In_Electric_Conductivity.tcu

The  TCS Al-based Alloy Database (TCAL) is used in this example. A valid license for  version 7 
(TCAL7) or newer is required to run the example.  

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.
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Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

Figure 57: Comparing the freeze-in temperature for the 4032-O alloy with and without grain boundary (GB) 
scattering included in the calculations.  

Reference

[1993Dav] J.R. Davis, ASM Specialty Handbook: Aluminum and Aluminum Alloys, 1993, ASM International. 
Pages: 784. ISBN: 978-0-87170-496-2.
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PM_G_12: Solidus and Liquidus Batch Calculation

The example uses the Property Model Calculator and the Liquidus and Solidus Temperature Property 
Model to demonstrate the use of the Batch Calculation Type. 

The   thermodynamic demonstration steel database (FEDEMO) is used along with a randomized set of 
experimental data points that are shown on the Configuration window in a table. The data showing in this 
example is imported from a data file prepared with specific data entry requirements. 

A variety of compositions for an Fe-Cr-Mn-Ni-C alloy is used for the calculations; these compositions are 
also taken from the same data file. When the heading includes Exp, then these columns are considered 
experimental data by Thermo-Calc, where in this example it is the columns titled Exp Liq temp C and Exp 
Sol temp C. This experimental data can then be plotted  as a function of the calculated solidus/liquidus 
temperature and compared on the plot using a Cross plot, which is selected on the Plot Renderer. The 
limits are shown using the setting RMS (root mean square). 

The experimental data entered into the batch data file is unitless even though the actual 
experimental data unit is Celsius (as written in the header text). In order for the plot and 
calculations to match, Celsius is chosen as the temperature unit when defining the 
Solidus/Liquidus Property Model and all the axes manually scaled to the same limits (1360 → 
1520).  

Project File  Information

 l Folder: Property Models → General

 l File name: PM_G_12_Solidus_and_Liquidus_Batch_Calculation.tcu

Visualizations

This example is included as a Property Model tutorial on our website and as part of the 
Property Model Calculator playlist on our YouTube channel. 

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 58: A comparison of experimental liquidus and solidus data using a Cross plot with a Batch calculation. A 
root mean square (RMS) setting shows the distribution of the data points. 
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PM_G_13: Ti Alloy Design for Additive Manufacturing

This in-depth example, which is available on our website, uses the Property Model Calculator to find the 
optimal composition for a titanium-based alloy to be used for additive manufacturing applications.

Additive manufacturing provides new opportunities to fabricate complex parts. However, traditional alloys 
may not be readily printable using techniques such as laser powder bed fusion. As such, the development 
of new alloys may be necessary to fully realize the benefits of additive manufacturing technologies.

In this example, inspired by the work of Ackers et al. [2021Ack], Batch calculations within the Property 
Model Calculator are used to identify candidate titanium alloy chemistries for biomedical implant 
applications using the thermodynamic TCS Ti/TiAl-based Alloys Database (TCTI). To optimize printability 
and material weight, the liquidus temperature, solidus temperature, and density of 2000 randomized 
titanium alloy chemistries from the Ti-Nb-Zr-Sn-Ta-Fe-Mo system are calculated. An estimate of alloy cost is 
also made for each alloy. Taken together, this methodology can be used to identify compositions of interest 
and accelerate material development activities.

Figure 59: Cost estimate histogram for 2000 randomized chemistries from the Ti-Nb-Zr-Sn-Ta-Fe-Mo system.  The 
cost estimate was calculated using a user-defined function in the Property Model Calculator.
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Project File and License Information

 l Folder: Property Models → General

 l File name: PM_G_13_Ti_Alloy_Design_for_AM.tcu

A license for Thermo-Calc 2022b or newer and the   TCS Ti/TiAl-based Alloys Database (TCTI) 
version 4 (TCTI4) or newer, is required to run the example.  

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

The resulting plots and details related to setting up this example are available  to download via 
the dedicated web page. 

Reference

[2021Ack] M. A. Ackers, O. M. D. M. Messé, U. Hecht, Novel approach of alloy design and selection for 
additive manufacturing towards targeted applications. J. Alloys Compd. 866, 158965 (2021). 
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PM_G_14: Ti-Fe T-Zero Martensite

The example uses the Property Model Calculator and the T-Zero Temperature Property Model to 
demonstrate the martensitic BCC → HCP transformation for a binary Ti-Fe system. A setting is used to 
include a Gibbs energy addition to the second phase, which allows for the inclusion of an energy barrier for 
martensitic phase transformations. 

Project File and License Information

 l Folder: Property Models → General

 l File name: PM_G_14_Ti_Fe_T-Zero_Martensite.tcu

The   TCS Ti/TiAl-based Alloys Database (TCTI) is used in this example. A valid license is required 
to run the example. 

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 60: The T-Zero (barrier = 0) line is the temperature without energy addition, the solid blue line is the T-Zero 
temperature with an energy addition of 4000*w(Fe) [J/mol], that well reproduces the experimental data from 
Duwez (1952).

Reference

[1952Duw] P. Duwez, “The Martensite Transformation Temperature in Titanium Binary Alloys, Third 
Technical Report” (U.S. Atomic Energy Commission, 1952).
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PM_G_15: Columnar to Equiaxed Transition (CET) of a 
NiAlCr Alloy

This example uses the Property Model Calculator and the Columnar to Equiaxed Transition Property 
Model with nickel demo databases to  mimic the result of CMSX-4 alloy, which compares the tip radius and 
undercooling with growth velocity. 

A Ni-26Al-9Cr (at.%) alloy is used so that its calculated undercooling is close to that of a 10-component 
CMSX-4 alloy. A One Axis calculation for the FCC_L12 primary phase is done using the CET parameters 
entered on the Property Model Calculator Configuration window. 

The settings used are the same as those from the literature [2001Gäu], i.e.:

 l Number of nucleation sites: 2.0E15/m3

 l Equiaxed exponent: 3.4

 l Nucleation undercooling: 2.5 K

 l Solve for: Thermal gradient

 l Equiaxed fractions: 0.0066 0.1

Project File Information

 l Folder: Property Models → General

 l File name: PM_G_15_Ni-Al-Cr_Columnar_Equiaxed_Transition.tcu

The NIDEMO and MNIDEMO databases are used in this example and it is available to all users.

Also see these examples that use the same Property Model. However, these examples require 
licenses as they use the TCS Ni-based Superalloys Database (TCNI) and TCS Ni-alloys Mobility 
Database (MOBNI): "PM_G_16:  Columnar to Equiaxed Transition of a CMSX-4 Alloy" on 
page 99 and "PM_G_17: Columnar to Equiaxed Transition of an IN718 Alloy" on page 103.
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Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

Figure 61: Tip radius and undercooling vs growth velocity  for a Ni-26Al-9Cr alloy.
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Figure 62: CET curves for a Ni-26Al-9Cr alloy using experimental data from [2001Gäu]. Also see PM_G_16 to 
compare the results to the CMSX-4 alloy results.

Reference

[2001Gäu] M. Gäumann, C. Bezençon, P. Canalis, W. Kurz, Single-crystal laser deposition of superalloys: 
processing–microstructure maps. Acta Mater. 49, 1051–1062 (2001).
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PM_G_16:  Columnar to Equiaxed Transition of a CMSX-4 
Alloy

This example uses the Property Model Calculator and the Columnar to Equiaxed Transition Property 
Model with a CMSX-4 alloy to compare calculated CET curves to experimental data. 

A 10-component system, with a composition from Gäumann et al. [2001Gäu], is used for this simulation of 
a CMSX-4 alloy. 

 Co Cr Al Ti W Ta Re Hf Mo Ni

wt.% 9.0 6.5 5.6 1.0 6.0 6.5 3.0 0.1 0.6 Bal

at.% 9.262 7.581 12.587 1.267 1.979 2.178 0.977 0.034 0.379 Bal

Alloy composition of CMSX-4 [2001Gäu].

The results are compared with literature data (epitaxial laser metal forming) and the original model  
[1999Gäu; 2001Gäu]. 

A One Axis calculation for the FCC_L12 primary phase is done using the CET parameters entered on the 
Property Model Calculator Configuration window. 

The settings entered include:

 l Interfacial energy:    0.25 J/m2,  which gives a Gibbs-Thomson coefficient of 1.87 x 10-7 mK,  in 
agreement with the literature [2001Gäu]. 

 l Number of nucleation sites: 2.0E15/m3

 l Nucleation undercooling : 3.0 K 

 l Equiaxed exponent: 3.4

 l Solve for: Thermal gradient

 l Equiaxed fractions: 0.0066 0.1

In the calculation, the nucleation undercooling is slightly larger than originally used (2.5 K) [2001Gäu], since 
it has been found that at a low speed limit, the Property Model gives an undercooling close to 3 K. 

The original value is arbitrary and does not affect the results at a high speed range. 
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Project File and License Information

 l Folder: Property Models → General

 l File name: PM_G_16_CMSX-4_Columnar_Equiaxed_Transition.tcu

To run this example requires a license for the TCS Ni-based Superalloys Database (TCNI) 
version 12 (TCNI12) or newer and the TCS Ni-alloys Mobility Database (MOBNI) version 6 
(MOBNI6) or newer. 

Example "PM_G_15: Columnar to Equiaxed Transition (CET) of a NiAlCr Alloy" on page 96 uses 
demo databases available to everyone and mimics this alloy in its results. 

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 63: Tip radius and undercooling vs growth velocity  for a CMSX-4 alloy.

Figure 64: Calculated CET curves (solid lines) in comparison to experimental data (data points) and calculations 
(dashed lines) from the literature [2001Gäu].
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References

[1999Gäu] M. Gäumann, PhD thesis, Epitaxial laser metal forming of a single crystal superalloy, École 
polytechnique fédérale de Lausanne (EPFL) (1999).

[2001Gäu] M. Gäumann, C. Bezençon, P. Canalis, W. Kurz, Single-crystal laser deposition of superalloys: 
processing–microstructure maps. Acta Mater. 49, 1051–1062 (2001).

More Information

Also see these examples that use the same Property Model: "PM_G_15: Columnar to Equiaxed 
Transition (CET) of a NiAlCr Alloy" on page 96 and "PM_G_17: Columnar to Equiaxed Transition 
of an IN718 Alloy" on the next page.
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PM_G_17: Columnar to Equiaxed Transition of an 
IN718 Alloy

The example uses the Property Model Calculator and the Columnar to Equiaxed Transition Property 
Model to compare calculated CET curves for an IN718 alloy to experimental data. 

A One Axis calculation for the FCC_L12 primary phase is done using the CET parameters entered on the 
Property Model Calculator Configuration window. 

The settings entered include:

 l Interfacial energy:    0.5 J/m2. 
 l Number of nucleation sites: 4.0E11/m3

 l Nucleation undercooling : 4.0 K 

 l Equiaxed exponent: 3.13

 l Solve for: Thermal gradient

 l Equiaxed fractions: 0.01 0.49 0.99

The literature data from Polonsky et al. [2020Pol] are not purely experimental data, but rather combined 
with experimental equiaxed evidence and model calculations with numerical values of thermal gradients, 
growth velocity as well as tip undercooling. Polonsky et al. estimated tip undercooling based on a Scheil 
calculation, which smeared out the composition inhomogeneity at the dendrite front, hence 
underestimating the undercooling. Since both tip undercooling and nucleation site density promotes the 
formation of equiaxed crystals, an increase in undercooling in this example calculation leads to a decrease 
in nucleation site density compared to the results in [2020Pol] if one were fitting the same set of data.

Project File and License Information

 l Folder: Property Models → General

 l File name: PM_G_17_IN718_Columnar_Equiaxed_Transition.tcu

To run this example requires a license for the TCS Ni-based Superalloys Database (TCNI) 
version 12 (TCNI12) or newer and the TCS Ni-alloys Mobility Database (MOBNI) version 6 
(MOBNI6) or newer. 
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Example "PM_G_15: Columnar to Equiaxed Transition (CET) of a NiAlCr Alloy" on page 96 uses 
demo databases available to everyone. 

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

Figure 65: Tip radius and undercooling vs growth velocity  for an IN718  alloy.
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Figure 66: Calculated CET curves for IN718 in comparison with literature data [2020Pol].

Reference

[2020Pol] A. T. Polonsky, N. Raghavan, M. P. Echlin, M. M. Kirka, R. R. Dehoff, T. M. Pollock, 3D 
Characterization of the Columnar-to-Equiaxed Transition in Additively Manufactured Inconel 718, in 
Superalloys 2020 (2020), pp. 990–1002.

More Information

Also see these examples that use the same Property Model: "PM_G_15: Columnar to Equiaxed 
Transition (CET) of a NiAlCr Alloy" on page 96 and "PM_G_16:  Columnar to Equiaxed Transition 
of a CMSX-4 Alloy" on page 99.
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PM_G_18: Equilibrium and Annealing Heat Treatment for 
ASTM A29

This example uses the Property Model Calculator and the Equilibrium Property Model and calculates the 
equilibrium for the provided conditions. The calculation result from this model is the same as when you are 
using the Equilibrium Calculator with the Single Equilibrium calculation type, but this model is preferable 
when min/max or uncertainty calculations are required in case of compositional variations, which is true 
for most engineering materials.

An example for choosing annealing heat treatments for a medium carbon low alloyed AISI 4130 steel is 
shown. The alloy has the following composition, as per ASTM A29 standard:

Fe C Mn P S Si Cr Mo

Rem. 0.28-0.33 0.40-0.60 0.035 0.040 0.15-0.35 0.80-0.10 0.15-0.25

The Equilibrium Model in this example is calculated for uncertainty in chemical compositions and annealing 
temperatures (820-900 °C) to optimize for formation of austenite phase (FCC_A1). This is done to achieve a 
microstructure suitable for machining. It is seen that best probabilistic results are achieved around 860 °C, 
which agrees well with the industrially applied process.

Project File Information

 l Folder: Property Models → General

 l File name: PM_G_18_Equilibrium.tcu

This uses the latest versions of TCS Steel and Fe-alloys Database (TCFE) (TCFE14) and TCS 
Steels/Fe-Alloys Mobility Database (MOBFE) (MOBFE8). Valid licenses are required to run the 
example. Earlier versions can be used but there will be slight differences to the results.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.
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Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

Figure 67: Histogram of evaluation temperature used for equilibrium calculations. The data maintains the shape 
of a normal distribution, indicating that all sampled calculations pass the applied filter.
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Figure 68: One axis equilibrium diagram of AISI 4130 steel using the average composition per ASTM A29. The 
region where Austenite (FCC_A1#2 in this diagram) is stable ranges from ~ 740 °C to ~ 1480 °C.
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PM_G_19: Thermal Conductivity for an AM Cu-Alloy

This example uses the Property Model Calculator and the Equilibrium with Freeze-in Temperature. The 
Equilibrium with Freeze-in Temperature Model calculates equilibrium at the freeze-in temperature and 
evaluates the properties at a different temperature. This model is particularly relevant for estimating 
thermophysical properties such as thermal or electrical conductivities. The assumption in this model is that 
diffusion and phase transformations are negligible when changing from the freeze-in-temperature and, 
therefore, that the phase amounts and compositions of phases are kept at all other temperatures.

Project File Information

 l Folder: Property Models → General

 l File name: PM_G_19_Equilibrium-With-Freezein.tcu

This uses the latest version of TCS Cu-based Alloys Database (TCCU) (TCCU6). A valid license is 
required to run the example. Earlier versions can be used but there will be slight differences to 
the results.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 69: The thermal conductivity (W/m.K) as a function of temperature (°C) for an additively manufactured Cu-
alloy (GRCop-42), which was developed by NASA for application in rocket engine combustion chamber liners. The 
values are compared against literature values [2023Che] and show a good fit. 

Reference
[2023Che]  Y. Chen, C. Zeng, H. Ding, S. Emanet, P. R. Gradl, D. L. Ellis, S. Guo, Thermophysical properties of 

additively manufactured (AM) GRCop-42 and GRCop-84. Mater. Today Commun. 36, 106665 (2023).
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PM_G_20: Scheil for an Al-1Si-1Mn-0.7Mg-0.6Fe-0.1Cu 
Alloy

This example uses the Property Model Calculator and the Scheil Property Model. The Scheil Property 
Model calculates solidification under the Scheil assumption. This Property Model is essentially the same as 
the Scheil Calculator included in the software, but implementing Scheil as a Property Model allows users to 
benefit from the additional calculation types available in the Property Model Calculator, including multi-
axis Grid, Min/Max, Uncertainty, and Batch.

Project File Information

 l Folder: Property Models → General

 l File name: PM_G_20_Scheil.tcu

The TCS Al-based Alloy Database (TCAL) (TCAL9) and TCS Al-alloys Mobility Database (MOBAL) 
(MOBAL8) are used in this example. Valid licenses are required to run the example. Earlier 
versions can be used but there will be slight differences to the results.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 70: The heatmap plot considers an Al-1Si-1Mn-0.7Mg-0.6Fe-0.1Cu alloy wherein the freezing range is 
plotted with respect to changing chemical composition of Si (0.7-1.3 wt%) and Mg (0.6-1.2 wt%).
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Additive Manufacturing (AM) Module 
Examples Collection

A separate license is required to perform calculations with the Additive Manufacturing (AM) 
Module. Without a license you are in Demo Mode where you can, for example, open and view 
example set ups, run some examples, add templates and nodes to the Project window, adjust 
some Configuration settings, and preview some functionality on the Visualizations window. 

Read more about the Additive Manufacturing (AM) Module on our website including the 
details about database compatibility or to watch an introductory webinar. You can also use 
the Getting Started Guide to learn about the key features available. 

In this section:

AM_01: Transient Simulation of a Single Track 115

AM_02: Transient and Steady-state Simulations of a Single Track 121

AM_03: Steady-state Simulations 127

AM_04: Scheil Transient Steady-state 132

AM_05: Using AM Calculator Probe Data with the Diffusion Module (DICTRA) 139

AM_06a: Calibrating a Heat Source for a 316L Steel 148
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AM_11: Comparing Single Tracks Printed on Casted and LPBF Substrates 194
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AM_14: Using the Top-hat Beam Shape 221

AM_15: Electron Beam Melting in an IN718 Alloy 229
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AM_01: Transient Simulation of a Single Track

The following example is part of a series showing some of the features of the Additive Manufacturing (AM) 
Module and the AM Calculator. In this example, a single track simulation is performed using the Transient 
model of the AM Calculator.

Project File and License Information

 l Folder: Additive Manufacturing

 l File name: AM_01_Transient_DE_No_Marangoni.tcu

A separate license is required to perform calculations with the Additive Manufacturing (AM) 
Module. Without a license you are in Demo Mode where you can, for example, open and view 
example set ups, run some examples, add templates and nodes to the Project window, adjust 
some Configuration settings, and preview some functionality on the Visualizations window. 

Some examples (AM_01, AM_02, AM_03,  and AM_06b) are available to all users.  These 
examples can be run without an additional Additive Manufacturing license when you are in 
DEMO (demonstration) mode. However, the AM Module is not available with the Educational 
version of Thermo-Calc. Search the help for Available Options with the Additive Manufacturing 
(AM) Module. 

Material Properties

These properties are the same for both AM_01 and AM_02 [2021Gra].

 l Inconel 738LC: Ni-15.8 Cr-8.6 Co-2.7 W-3.3 Ti-3.6 Al-1.8 Ta-1.8 Mo-0.04 Fe-0.8 Nb-0.002 Mn-0.1 C 
Mass percent.

 l Database: TCNI12

 l The material property was pre-calculated, and stored as a built-in material library of the Additive 
Manufacturing (AM) Module.
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Model Configuration

The transient model solves for the heat equation in the entire 3D domain, including the melt pool, and is 
therefore, computationally expensive to solve. The fluid flow inside the melt pool due to the Marangoni 
effect is not included in this example. The double ellipsoidal, or the so-called Goldak heat source model, is 
used to predict melt pool size and temperature distribution during single track scanning. The parameters 
for the double ellipsoidal heat source are computed using optimization in a steady-state case for the given 
process parameters (power and scanning speed) and the melt pool size reported in the paper by Grange et 
al. [2021Gra]. The resulting parameters are shown in Figure 71.

Figure 71: Optimized heat source parameters entered on the AM Calculator for the experiment given in Grange et 
al. [2021Gra] with power = 230 W and scanning speed = 960 mm/s.

The geometry for a transient simulation, as given in the paper by Grange et al. [2021Gra], is shown in 
Figure 72. The base plate is 2 mm in length, 0.5 mm in width, and with a thickness of 0.95 mm. A layer of 
powder with a thickness of 55 μm is deposited on the solid substrate. The powder layer, however, has the 
same material properties as the solid substrate. The laser beam with a power of 230 W develops linear 
scanning with constant velocity 960 mm/s. The trajectory evolves from initial position (x, y) = (0.25, 0.25) 
mm to final position (1.75, 0.25) mm on the top surface.

Figure 72: The geometry used for the Additive Manufacturing (AM) Module examples AM_01 and AM_02.

Additive Manufacturing (AM) Module Examples Collection ǀ 116 of 431



Two probes monitor the temporal evolution of temperature at positions shown in Figure 73. The results 
can be presented by tabulated data or as 2D graph plots.

Figure 73: Probe positions for Probes P1 and P2, where P1 is placed exactly on the scanning track while P2 is 
placed at a distance of 0.04 mm from the track, as shown in a close up of the probes on the Visualizations 
window.

Visualizations

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it takes at least 30 minutes for the calculations to 
complete.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation(s).

 l Geometry: View the geometry and adjust parameters visually by changing inputs on the 
Configuration window. Add probes needed.

 l Melt pool and other dynamically changing features can also be visualized and changed.

 l Plot results: After completing the set up and performing the calculation, to view the matching name 
of the node on tab(s) in the Visualizations window, click a Plot Renderer node in the Project 
window or click the tabs individually in the Visualizations window.
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In the surface plot it shows the temperature distribution after the scanning process is completed. It is 
noted that the melt pool shape reaches a steady-state when the laser beam approaches the end of the 
scanning track. The melt pool dimensions at the end of scanning track is given in the table.

Melt Pool Dimension Size (mm)

Width 0.125

Depth 0.144

Length 1.12

If you are in the project file, click the Probe plot node in the Project window and the 3D Plot 
tab in the Visualizations window.

Figure 74: Surface plot of temperature distribution after the single track scan is completed. Probes P1 and P2 can 
also be seen on the top surface.

It is also possible to plot quantities at different cross-sections inside the domain by selecting the Slice 
checkbox on the Plot Renderer Configuration window under the 3D Plot tab. The next figure shows the 
temperature slices plotted at cross-sections orthogonal to the scanning direction.
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Figure 75: Slices of the computational domain, orthogonal to the scanning direction, showing temperature 
distribution at different cross-sections. Red tubes show the contour of the melt pool (at liquidus temperature).

Figure 76: 2D probe plot showing temperature evolution as a function of time at probes P1 and P2.
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Figure 77: 2D plot over line showing temperature in the tail of the melt pool as a function of distance plotted 
along the scanning track.

Reference

[2021Gra] D. Grange, A. Queva, G. Guillemot, M. Bellet, J.-D. Bartout, C. Colin, Effect of processing 
parameters during the laser beam melting of Inconel 738: Comparison between simulated and 
experimental melt pool shape. J. Mater. Process. Technol. 289, 116897 (2021).

Other Resources

Read more about the Additive Manufacturing (AM) Module on our website including the 
details about database compatibility or to watch an introductory webinar. You can also use 
the Getting Started Guide to learn about the key features available. 

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.
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AM_02: Transient and Steady-state Simulations of a Single 
Track

The following example is part of a series showing some of the features of the Additive Manufacturing (AM) 
Module and the AM Calculator. This example builds on the work done by Grange et al. [2021Gra] and is 
similar to example AM_01. The difference however is that in this example a single track simulation is 
performed using Transient with heat source from Steady-state model instead of the Transient model.

The Transient with heat source from Steady-state model exploits the assumption that the melt pool size 
and temperature distribution reaches a steady-state almost instantly and thus first solves for a Steady-
state case with the given process parameters. The result from the Steady-state in the form of temperature 
distribution in the melt pool is then mapped as a heat source in the transient simulation. This novel 
approach is much faster and efficient than the approach used in example AM_01 where the heat equation 
is solved in the entire 3D domain.

Project File and License Information

 l Folder: Additive Manufacturing

 l File name: AM_02_TransientSS_DE.tcu

A separate license is required to perform calculations with the Additive Manufacturing (AM) 
Module. Without a license you are in Demo Mode where you can, for example, open and view 
example set ups, run some examples, add templates and nodes to the Project window, adjust 
some Configuration settings, and preview some functionality on the Visualizations window. 

Some examples (AM_01, AM_02, AM_03,  and AM_06b) are available to all users.  These 
examples can be run without an additional Additive Manufacturing license when you are in 
DEMO (demonstration) mode. However, the AM Module is not available with the Educational 
version of Thermo-Calc. Search the help for Available Options with the Additive Manufacturing 
(AM) Module. 

Material Properties

These properties are the same for both AM_01 and AM_02 [2021Gra].
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 l Inconel 738LC: Ni-15.8 Cr-8.6 Co-2.7 W-3.3 Ti-3.6 Al-1.8 Ta-1.8 Mo-0.04 Fe-0.8 Nb-0.002 Mn-0.1 C 
Mass percent.

 l Database: TCNI12

 l The material property was pre-calculated, and stored as a built-in material library of the Additive 
Manufacturing (AM) Module.

Model Configuration

The transient model solves for the heat equation in the entire 3D domain, including the melt pool, and is 
therefore, computationally expensive to solve. The fluid flow inside the melt pool due to the Marangoni 
effect is not included in this example. The double ellipsoidal, or the so-called Goldak heat source model, is 
used to predict melt pool size and temperature distribution during single track scanning. The parameters 
for the double ellipsoidal heat source are computed using optimization in a steady-state case for the given 
process parameters (power and scanning speed) and the melt pool size reported in the paper by Grange et 
al. [2021Gra]. The resulting parameters are shown in Figure 78.

Figure 78: Optimized heat source parameters entered on the AM Calculator for the experiment given in Grange et 
al. [2021Gra] with power = 230 W and scanning speed = 960 mm/s.

The geometry for a transient simulation, as given in the paper by Grange et al. [2021Gra], is shown in 
Figure 79. The base plate is 2 mm in length, 0.5 mm in width, and with a thickness of 0.95 mm. A layer of 
powder with a thickness of 55 μm is deposited on the solid substrate. The powder layer, however, has the 
same material properties as the solid substrate. The laser beam with a power of 230 W develops linear 
scanning with constant velocity 960 mm/s. The trajectory evolves from initial position (x, y) = (0.25, 0.25) 
mm to final position (1.75, 0.25) mm on the top surface.
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Figure 79: The geometry used for the Additive Manufacturing (AM) Module examples AM_01 and AM_02.

Two probes monitor the temporal evolution of temperature at positions shown in Figure 80. The results 
can be presented by tabulated data or as 2D graph plots.

Figure 80: Probe positions for Probes P1 and P2, where P1 is placed exactly on the scanning track while P2 is 
placed at a distance of 0.04 mm from the track, as shown in a close up of the probes on the Visualizations 
window.
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Visualizations

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation(s).

 l Geometry: View the geometry and adjust parameters visually by changing inputs on the 
Configuration window.

 l Melt pool and other dynamically changing features can also be visualized and changed.

 l Plot results: After completing the set up and performing the calculation, to view the matching name 
of the node on tab(s) in the Visualizations window, click a Plot Renderer node in the Project 
window or click the tabs individually in the Visualizations window.

With the example open and after it is run, the following is a summary of what is visible on the 
Visualizationswindow.

The figure below shows the surface plot of temperature distribution after the single track scanning is 
completed. The temperature profile is qualitatively similar to the one in example AM_01, however the 
maximum temperature is slightly lower in example AM_02. This could be due to selection of a coarse mesh 
in both examples which sometimes could affect the maximum temperature.

Figure 81: Surface plot of temperature distribution after the single track scan is completed. Probes P1 and P2 can 
also be seen on the top surface.
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The melt pool dimensions for AM_02 are given in the following table, which are very similar to the melt 
pool dimensions obtained in example AM_01.

Melt Pool Dimension Size (mm)

Width 0.127

Depth 0.129

Length 1.12

A qualitative comparison between AM_01 and AM_02 can also be made by looking at probe plots. The 
probe plot for AM_02 is given in Figure 82.

Figure 82: 2D probe plot showing temperature evolution as a function of time at probes P1 and P2.

Despite the fact that maximum temperature is higher in AM_01, the temperature profile in the tail of the 
melt pool and close to the melt pool is very similar. This can also be concluded by comparing plot over lines 
for the two examples, where the plot over line for AM_02 is given in Figure 83.
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Figure 83: 2D plot over line showing temperature in the tail of the melt pool as a function of distance plotted 
along the scanning track.

Reference

[2021Gra] D. Grange, A. Queva, G. Guillemot, M. Bellet, J.-D. Bartout, C. Colin, Effect of processing 
parameters during the laser beam melting of Inconel 738: Comparison between simulated and 
experimental melt pool shape. J. Mater. Process. Technol. 289, 116897 (2021).

Other Resources

Read more about the Additive Manufacturing (AM) Module on our website including the 
details about database compatibility or to watch an introductory webinar. You can also use 
the Getting Started Guide to learn about the key features available. 

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.
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AM_03: Steady-state Simulations

The following example is part of a series showing some of the features of the Additive Manufacturing (AM) 
Module and the AM Calculator.

In this example steady-state simulations are performed for IN625 with different conditions i.e.

 i. without fluid flow in the melt pool,

 ii. with fluid flow in the melt pool due to Marangoni effect, and

 iii. using separate material properties for powder and fluid flow in the melt pool due to Marangoni 
effect.

and then the results are compared to demonstrate the effects of fluid flow and separate material 
properties for the powder on the temperature distribution as well as on the shape of the melt pool.

For the first two simulations, the same material properties are used for both powder and solid 
substrate.

In steady-state simulations it is assumed that the heat source (laser beam) moves with a 
uniform speed relative to the base plate. In this case, the model is solved by modifying 
governing equations to a reference frame attached to a moving heat source. Furthermore, in 
steady-state mode you can make use of symmetry along the width of the geometry and solve 
for only half of the domain.

Project File and License Information

 l Folder: Additive Manufacturing

 l File name: AM_03_Steady.tcu
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A separate license is required to perform calculations with the Additive Manufacturing (AM) 
Module. Without a license you are in Demo Mode where you can, for example, open and view 
example set ups, run some examples, add templates and nodes to the Project window, adjust 
some Configuration settings, and preview some functionality on the Visualizations window. 

Some examples (AM_01, AM_02, AM_03,  and AM_06b) are available to all users.  These 
examples can be run without an additional Additive Manufacturing license when you are in 
DEMO (demonstration) mode. However, the AM Module is not available with the Educational 
version of Thermo-Calc. Search the help for Available Options with the Additive Manufacturing 
(AM) Module. 

Visualizations

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation(s).

 l Geometry: View the geometry and adjust parameters visually by changing inputs on the 
Configuration window.

 l Melt pool and other dynamically changing features can also be visualized and changed.

 l Plot results: After completing the set up and performing the calculation, to view the matching name 
of the node on tab(s) in the Visualizations window, click a Plot Renderer node in the Project 
window or click the tabs individually in the Visualizations window.
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Results Discussion

Figure 84: A comparison of the melt pool depth for different simulation conditions; (top) without fluid flow, 
(middle) with fluid flow in the melt pool and (bottom) with both fluid flow and different material properties for 
the powder layer. Isocontours show the boundaries of (inner) melt pool and (outer) mushy zone.

The table shows a comparison of the melt pool dimensions for different simulation conditions.

Simulation Set Up
Melt Pool Dimensions (mm)

Width Depth Length

Without fluid flow 0.115 0.111 0.736

With fluid flow 0.147 0.111 0.869

Separate powder material properties 0.194 0.111 1.064

Figure 84 shows the effect of fluid flow on temperature distribution and size of the melt pool for the given 
process parameters. A quantitative comparison is also given in the table. It can be seen that with the 
addition of fluid flow due to gradient in surface tension (Marangoni effect), the melt pool tends to increase 
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its dimensions in all three directions. This is because the negative gradient in surface tension with respect 
to the temperature creates an outward flow on the surface of the melt pool which consequently increases 
the width and length of the melt pool, as shown in Figure 85.

Figure 85: Vectors showing flow field in the melt pool due to gradient in surface tension. The colors of the vectors 
represent the magnitude of the velocity. Surface colormap shows the temperature distribution.

Figure 86: Surface colormap of temperature dependent thermal conductivity showing different values in powder 
and liquid/solid and (right) the corresponding temperature distribution.

Using separate material properties for powder has a significant effect on both the temperature distribution 
and the size of the melt pool. This is because a lower thermal diffusivity in the powder makes the 
temperature to diffuse more towards the length of the melt pool hence causing a significant increase in the 
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length of the melt pool (shown in Figure 86) as compared to the first two cases. There is also an obvious 
increase in the width of the melt pool while the depth of the melt pool is almost the same as with the fluid 
flow. Furthermore, the maximum temperature is also highest in the case with separate material properties.

Figure 87: Temperature distribution along the top surface of the melt pool from the heat source position toward 
the tail. The plot compares three conditions: no fluid flow (solid blue line), fluid flow only (dashed green line), and 
combined powder and fluid flow (dash-dotted red line).

Other Resources

Read more about the Additive Manufacturing (AM) Module on our website including the 
details about database compatibility or to watch an introductory webinar. You can also use 
the Getting Started Guide to learn about the key features available. 

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.
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AM_04: Scheil Transient Steady-state

In this example, three different simulations are performed: Steady-state, Transient Single track, and 
Transient Multilayer. Both Transient Single track and Transient Multilayer use Transient with heat source 
from Steady-state model to compute time-dependent temperature distribution in the given geometry. The 
primary difference between this example and the previous examples (AM_01 to AM_03) is that, in this 
case, the material properties data is retrieved from the Scheil Calculator whereas in the previous examples 
the material properties are taken from the preinstalled material library. Furthermore, this example 
simulates scanning of two layers of powder where the second layer is spread on the top of the first layer 
when scanning of the first layer is completed.

Project File and License Information

 l Folder: Additive Manufacturing

 l File name: AM_04_Scheil_TransientSS.tcu

Material chosen for this example is Ti-6Al-4V. To run this example requires both version 
TCTI5.0 and newer of the TCS Ti/TiAl-based Alloys Database (TCTI) in addition to a license for 
the Additive Manufacturing (AM) Module. Some portions of this example are also covered in 
the Getting Started Guide on our website.

Visualizations

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it takes at least 30 minutes for the calculations to 
complete.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation(s).
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 l Geometry: View the geometry and adjust parameters visually by changing inputs on the 
Configuration window.

 l Melt pool and other dynamically changing features can also be visualized and changed.

 l Plot results: After completing the set up and performing the calculation, to view the matching name 
of the node on tab(s) in the Visualizations window, click a Plot Renderer node in the Project 
window or click the tabs individually in the Visualizations window.

Steady-state

The Steady-state calculator of this example computes temperature distribution in a steady state for the 
power of 100 W and scanning speed of 600 mm/s. The beam radius in this example is taken as 100 μm. For 
the geometry, the steady-state model only needs the height of the solid substrate as the input, which is 
taken as 2.0 mm. The solid substrate is covered with a powder layer of thickness 55 μm. This example also 
takes into account the effect of fluid flow due to Marangoni forces inside the melt pool.

Figure 88: Geometry definition for Transient Multilayer. The scanning strategy shows the scanning pattern on the 
top most layer.
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Figure 89: Temperature distribution around the melt pool and mushy zone for the Steady-state case. Velocity 
vectors representing the fluid flow inside the melt pool can also be seen.

Transient Single Track

Figure 90: 3D Surface colormap showing temperature distribution at the end of single track transient simulation. 
The velocity vectors around the heat source show the direction of fluid flow in the melt pool.
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Figure 91: 2D Plot showing temperature as a function of time from Probe 1 (orange) and Probe 2 (blue) after the 
single track scan is completed.

Transient Multilayer

Figure 92: Temperature distribution on the top surface of the workpiece during scanning of the first layer.
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Figure 93: Temperature distribution on the top surface of the workpiece during scanning of the second layer.

Figure 94: 2D Plot showing temperature as a function of time from Probe 1 after scanning the first layer.
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Figure 95: 2D Plot showing temperature as a function of time from Probe 2 after scanning the second layer.

Figure 96: 2D Plot Over Line showing temperature profiles plotted along the lines, parallel to the width of the 
geometry placed on the top of the first layer (P1) and the second layer (P2).

Other Resources

Read more about the Additive Manufacturing (AM) Module on our website including the 
details about database compatibility or to watch an introductory webinar. You can also use 
the Getting Started Guide to learn about the key features available. 
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Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.
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AM_05: Using AM Calculator Probe Data with the Diffusion 
Module (DICTRA)

The microstructure of a hot-work tool steel additively manufactured using laser powder-bed fusion (L-PBF) 
is studied in detail by microstructure characterization and computational thermodynamics and kinetics by 
C.-Y. Chou et al. [2021Cho].

This example demonstrates the application of adding probes to an AM Calculator and then using this data 
via the Thermal Profile that is set up on a connected Diffusion Calculator. The example also uses a Scheil 
Calculator to collect some materials data that is then further used with the AM Calculator prior to using the 
probe data generated by the AM Calculator.

Project File and License Information

 l Folder: Additive Manufacturing

 l File name: AM_05_AM_Probe_to_Diffusion.tcu

A separate license is required to perform calculations with the Additive Manufacturing (AM) 
Module. This example also requires a license for the Diffusion Module (DICTRA), plus 
additional database licenses for the TCS Steel and Fe-alloys Database (TCFE) (TCFE13 and 
newer), and the TCS Steels/Fe-Alloys Mobility Database (MOBFE) (MOBFE8 and newer).

Background

According to the thermodynamics of this steel, δ-ferrite is the solid phase stable at the highest 
temperature and would be the first solid phase to form during solidification from a thermodynamic point of 
view, see Figure 97.
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Figure 97: Equilibrium property diagram calculated in Thermo-Calc of the tool steel showing δ-ferrite would be 
the first solid phase to form during solidification according to equilibrium.

However, the high solidification and cooling rates during the L-PBF process lead to suppression of δ-ferrite 
and instead solidification of an austenite phase directly containing a cellular substructure where the 
alloying elements have segregated to the inter-cellular regions.

The microsegregation can be predicted by reducing the complex solidification behavior to a diffusion 
problem in one dimension enabling comparisons with the measured segregation profiles quantified at a 
nanometer scale.

Configuration and Calculation Set Up

For all calculations, the simplified composition Fe-0.35C-4.93Cr-0.45Mn-2.24Mo-0.25Si-0.54V (mass%) was 
used with δ-ferrite suspended on the System Definer.

The Additive Manufacturing template was used to first add the System Definer, Scheil Calculator, AM 
Calculator, and Plot Renderer to the Project window tree. Additionally, a Diffusion Calculator was added 
as a successor to the AM Calculator in order to automatically import the time-temperature profile from the 
AM simulation into the diffusion simulation. See Figure 98 (or refer to the example if you have it open) to 
see the layout.
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Figure 98: Project tree of the example containing activities from the default Additive Manufacturing template 
with additional Diffusion Calculator and Experimental File Reader nodes added, where the segregation profiles 
datasets are pulled from the Experimental File Reader.

On the AM Calculator Configuration window, the calculation type Transient with heat source from 
Steady-state is selected with a single track scan pattern and a Geometry of 2 mm x 1 mm x 4 mm (height x 
width x length). The Base plate temperature is set to 200 °C.
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Additional settings are then made on the Configuration window as follows.

The Double ellipsoidal volume heat source was previously assessed as a function of linear energy density 
for a similar material and directly applied to the experimental conditions of a volumetric energy density of 
80 J/mm3. The laser Power is entered at 260 W, Scanning speed at 900 mm/s, and powder Layer thickness 
30 μm. Below is a snapshot of the settings.

A probe was then added in the center of the scan track at a distance of 1.3 mm from the edge. The Probe 
Positions can either be entered directly on the Configuration window or click the Pick coordinate button 
and then click on the geometry in the Visualizations window to directly choose the probe point (or points if 
there is more than one probe added).
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Figure 99: Close up of the probe point added to the geometry for the single track AM simulation.

Figure 100: The full geometry set up for the single track AM simulation with a probe point added to the middle of 
the scan. Open the example to better see the set up and to try working within the window.
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Diffusion Calculations

For the Diffusion Module (DICTRA) solidification calculations using the Diffusion Calculator, only the liquid 
to austenite (FCC) transformation was simulated. On the Diffusion Calculator Configuration window, a 
Region of 140 nm with liquid and FCC allowed to form at the right boundary is set.

In the Thermal Profile section, the time temperature from the probe was selected between a Start time of 
5.0E-4 and Simulation time of 8.5.0E-4 s in order to only simulate the solidification, which can be viewed 
on the Visualizations window as in Figure 101. Note that the probes need to be added and then run in the 
AM Calculator to make this data available in for this part of the calculation.
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Figure 101: Time temperature profile of the probe in the AM simulation. The green curve show the part of the 
profile used during the diffusion simulation with the Diffusion Calculator.

The calculated segregation profiles are finally compared with the STEM-EDS line scans as shown in Figure 
102.

Figure 102: The simulated segregation profile with overlaid experimental STEM-EDS line scans from C.-Y. Chou et 
al. [2021Cho].
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Visualizations

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it can take over three hours to complete the 
calculations. 

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation(s). This example highlights some of these capabilities:

 l Probes: Probes are added to the AM Calculator during the set up either by entering coordinates or 
directly adding these to the geometry. See Figure 99 and Figure 100 for example.

 l Thermal Profile: The Diffusion Calculator Thermal Profile settings automatically include the probe 
data and you can visualize to help you continue the simulation. See Figure 101.

 l Plot results: After completing the set up and performing the calculation, to view the matching name 
of the node on tab(s) in the Visualizations window, click a Plot Renderer node in the Project 
window or click the tabs individually in the Visualizations window. See Figure 102.

Reference

[2021Cho] C.-Y. Chou, N. H. Pettersson, A. Durga, F. Zhang, C. Oikonomou, A. Borgenstam, J. Odqvist, G. 
Lindwall, Influence of solidification structure on austenite to martensite transformation in additively 
manufactured hot-work tool steels. Acta Mater. 215, 117044 (2021).

Other Resources

Read more about the Additive Manufacturing (AM) Module on our website including the 
details about database compatibility or to watch an introductory webinar. You can also use 
the Getting Started Guide to learn about the key features available. 
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Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.
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AM_06a: Calibrating a Heat Source for a 316L Steel

This example demonstrates the calibration of the heat source using the Gaussian as well as Double 
ellipsoidal heat sources. In this example, experimental data is taken from Hu. et al. [2019Hu] where the 
authors performed single-track experiments using the selective laser melting (SLM) process on 316L 
stainless steel for varying processing conditions. The power ranges from 50 W to 100 W while the scanning 
speed varies from 400 mm/s to 2800 mm/s. The data imported from [2019Hu], consisting of 21 
experimental points, is saved in the project file.

Also see the companion example, "AM_06b: Using the Calibrated Heat Source for a 316L Steel" 
on page 154.

Project File and License Information

 l Folder: Additive Manufacturing

 l File name: AM_06a_Calibrate_Heat_Sources_316L.tcu

An Additive Manufacturing Module license is needed to run AM_06a.

Some examples (AM_01, AM_02, AM_03,  and AM_06b) are available to all users.  These 
examples can be run without an additional Additive Manufacturing license when you are in 
DEMO (demonstration) mode. However, the AM Module is not available with the Educational 
version of Thermo-Calc. Search the help for Available Options with the Additive Manufacturing 
(AM) Module. 

Material Properties

 l SS316L: Fe-17.0Cr-12.0Ni-2.5Mo-0.03C Mass percent

 l Database: TCFE13

 l The material properties are precalculated, and stored as a built-in material library with the Additive 
Manufacturing (AM) Module.
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AM Calculator Configuration Settings

The AM_06a example contains two AM Calculators, which are renamed to AM Calibration Gaussian and 
AM Calibration Double Ellipsoidal.

 l AM Calibration Gaussian uses a Gaussian Heat Source with the keyhole model.

 l AM Calibration Double Ellipsoidal uses a Double ellipsoidal Heat Source. 

 l The heat source parameters for both heat sources are calibrated for the given experimental data.

 l For both AM Calculators, the Base plate temperature and the Ambient temperature use a value of 
353 K and the Layer thickness is 10 μm. The rest of the Configuration settings keep the original 
defaults.

For AM Calibration Gaussian, all of the 21 experimental points that are imported to the Experiment Data 
table are selected to be used in the calibration. This is because, for the Gaussian heat source with the 
keyhole model, one wants to obtain a single constant value for beam radius as well as absorptivity to 
correctly predict the melt pool size for a range of power and scanning speed. It is also in order to obtain the 
best possible value it is good to include as many experiments as you can to calibrate the heat source 
parameters.

For this AM Calculator, other settings include:

 l Constant (calibrated), which means the absorptivity is not a function of temperature or angle, and a 
constant value is calibrated for each experiment. 

 l The Beam radius is set to Calibrated, which means that both beam radius and absorptivity are 
calibrated.

 l Calibrate for is set to Width and depth, which means that the experimental values for both width 
and depth are used for calibration.

For AM Calibration Double Ellipsoidal, only five (5) experiment points are selected to perform the 
calibration. Two experiments are selected from the lower energy density, two from the higher energy 
density, and then one experiment is selected in the middle region of the two extremes.

Visualizations

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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When you run (Perform) this example, it can take about an hour to complete the calculations. 

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation(s).

Calibrated Functions

For AM Calibration Gaussian, a comparison of the melt pool dimensions from the experiments and 
calibration simulation is shown in Figure 103.

Figure 103: A comparison of melt pool dimension for Gaussian heat source calibration. The "Not used" points 
shown in the legend are because a checkbox is not selected in the 'Use' column for row 10 on the Plot Renderer 
Configuration window. 

The resulting calibrated heat source parameters for AM Calibration Gaussian, are shown in Figure 104.
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Figure 104: Calibrated heat source parameters for Gaussian heat source calibration.

In order to obtain the expressions for Absorptivity and Beam radius, one of the experiments (Experiment # 
10) is not included. This is because Experiment # 10 is an outlier and you can see that the values for Exp 
width and Exp depth (hollow square) then the Sim width and Sim depth (hollow circle) are excluded in 
Figure 103. 

For both Absorptivity and Beam radius the Constant function of P/v is chosen to be saved as a calibrated 
heat source. Absorptivity of the material at the printing conditions is usually unknown in these experiments 
which is why it is regarded as a fitting parameter. Beam radius, on the other hand, is most often known, 
but does not match the definition of beam radius in the Gaussian heat source model used in the 
simulation, which is why a different value is obtained as compared to the one used in the experiment.
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Figure 105: A comparison of melt pool dimension for double ellipsoidal heat source calibration.

Figure 106: Calibrated heat source parameters for double ellipsoidal heat source calibration.

While selecting the functions for heat source parameters for double ellipsoidal, it was seen that ar, af, and 
b remained almost unchanged for all the experiments. Therefore the Constant function of P/v for ar, af, 
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and b is used. For Absorptivity, a Linear function of P/v gave the best R2 value while for c a Cubic function 
of P/v gave the best R2 value. One of the experiments (experiment # 21) was excluded (i.e. the checkbox is 
deselected) to get a suitable curve for all functions.

Reference

[2019Hu] Z. Hu, B. Nagarajan, X. Song, R. Huang, W. Zhai, J. Wei, Formation of SS316L Single Tracks in Micro 
Selective Laser Melting: Surface, Geometry, and Defects. Adv. Mater. Sci. Eng. 2019, Article ID 9451406, 
1–9 (2019).

Other Resources

Read more about the Additive Manufacturing (AM) Module on our website including the 
details about database compatibility or to watch an introductory webinar. You can also use 
the Getting Started Guide to learn about the key features available. 

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.
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AM_06b: Using the Calibrated Heat Source for a 316L Steel

This example demonstrates the use of the two calibrated heat sources that are saved in the example AM_
06a. One heat source is of the Gaussian type while the other heat source is Double ellipsoidal. For both 
heat sources, expressions are saved as a function of energy density (P/v) for all heat source parameters as 
well as the absorptivity. The example consists of four AM Calculators, two of which use a Gaussian heat 
source while the other two use a Double ellipsoidal heat source, and where the processing conditions for 
all four AM Calculators are taken from Hu et al [2019Hu].

"AM_06a: Calibrating a Heat Source for a 316L Steel" on page 148

Project File and License Information

 l Folder: Additive Manufacturing

 l File name: AM_06b_Use_Calibrated_Heat_Sources_316L.tcu

Other than an Additive Manufacturing (AM) Module license, this example does not require an 
additional license to run it, although its companion example, AM_06a, does.

Material Properties

 l SS316L: Fe-17.0Cr-12.0Ni-2.5Mo-0.03C Mass percent

 l Database: TCFE13

 l The material properties are precalculated, and stored as a built-in material library with the Additive 
Manufacturing (AM) Module.

Configuration and Calculation Set Up

There are four AM Calculators where all the calculators use the Steady-state simulation type and the Single 
point Calculation Type. The purpose of this example is to use the saved heat sources from AM_06a and 
then validate the results by comparing the melt pool size from the simulations with the experimental melt 
pool dimensions as given in Hu et. al [2019Hu].

The saved heat sources are selected from the Heat Source list on the AM Calculator, where a subsection 
called Users heat sources includes all previously saved heat sources. In the example, two calculators use 
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the Gaussian - 316L - beam d 15um user-defined heat source, and two use the Double ellipsoidal - 316L - 
beam d 15um user-defined heat source. The Base plate temperature and Ambient temperature is set to 
353 K, while the Layer thickness is set to 10 μm.

Visualizations

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it takes a few minutes for the calculations to complete.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation(s).

For this example, it is best to open and run this simulation to be able to view all the different 
plots and outputs to various tabs on both the various Configuration windows as well as the 
Visualizations window.

Gaussian Heat Source and Keyhole Model

The different processing conditions are selected to simulate both the conduction mode as well as the 
keyhole mode. For Gaussian - 316L - beam d 15 um heat source, with P = 100 W and scanning speed = 
2800 mm/s, the dominant mode of heat transfer is conduction, which is why a shallow melt pool is 
obtained. The results from the simulations are fairly close to the ones from the experiments, as can be seen 
in Table 1.

With P = 80 W and scanning speed = 400 mm/s, a keyhole mode is observed in the experiments. This is also 
predicted from the simulations as can be seen in Figure 107.

A comparison of the melt pool depth from the simulations and the experiments for the latter case shows 
that the calibrated Gaussian heat source with the keyhole model predicts the melt pool depth with 
reasonable accuracy. However, it underpredicts the melt pool width. This is because fluid flow due to 
Marangoni forces is not included in these simulations, which probably causes the melt pool to widen in the 
experiments.
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Calculator 
Name

Power 
[W]

Scanning 
Speed 
[mm/s]

Melt Pool Width Melt Pool Depth

Simulation 
[μm]

Experiment 
[μm]

Simulation 
[μm]

Experiment 
[μm]

AM use 
calibrated 
Gaussian P100 
u2800

100 2800 53.30 47.82 12.93 14.36

AM use 
calibrated 
Gaussian P80 
u400

80 400 93.25 105 102.71 106.57

Table 1: A comparison of the melt pool dimensions from the simulations and experiments using the calibrated 
Gaussian heat source.

Figure 107: Steady-state temperature distribution around the melt pool for SS316L with P = 80 W and scanning 
speed = 400 mm/s using the calibrated Gaussian heat source with the keyhole model. A keyhole can also be seen 
formed just below the location of the heat source.

Double Ellipsoidal Heat Source

For the Double ellipsoidal - 316L - beam d 15 um heat source, two different processing conditions are 
selected to simulate both the conduction mode as well as the keyhole mode. For both processing 
conditions, the prediction of the melt pool size from the simulations is in fairly good agreement with the 
results from the experiments as can be seen in Table 2.

The temperature distribution using the calibrated double ellipsoidal heat source with P = 80 W and 
scanning speed = 400 mm/s is shown in Figure 108.
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Calculator 
Name

Power 
[W]

Scanning 
Speed 
[mm/s]

Melt Pool Width Melt Pool Depth

Simulation 
[μm]

Experiment 
[μm]

Simulation 
[μm]

Experiment 
[μm]

AM use 
calibrated DE 
P80 u1200

100 1200 65.07 64.34 31.63 29.68

AM use 
calibrated DE 
P80 u400

80 400 103.65 105 112.29 106.57

Table 2: A comparison of the melt pool dimensions from the simulations and experiments using the calibrated 
double ellipsoidal heat source.

Figure 108: Steady-state temperature distribution around the melt pool for SS316L with P = 80 W and scanning 
speed = 400 mm/s using the calibrated double ellipsoidal heat source.

Reference

[2019Hu] Z. Hu, B. Nagarajan, X. Song, R. Huang, W. Zhai, J. Wei, Formation of SS316L Single Tracks in Micro 
Selective Laser Melting: Surface, Geometry, and Defects. Adv. Mater. Sci. Eng. 2019, Article ID 9451406, 
1–9 (2019).
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Other Resources

Read more about the Additive Manufacturing (AM) Module on our website including the 
details about database compatibility or to watch an introductory webinar. You can also use 
the Getting Started Guide to learn about the key features available. 

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.
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AM_07: Batch Calculations for an IN718 Alloy

This example shows the use of the AM Calculator with a Steady-state mode and Batch Calculation Type 
where it compares calculated and measured melt pool dimensions. The experimental data are from the 
2022 NIST AM-Bench Test Series [2022NIST] where single track experiments were performed on a IN718 
bare plate at different power and scan speeds.

The use of different Plot types in this example include a Parity plot, 3D plot showing the keyhole, and 
Printability map.

This example is part of a set using a Steady-state simulation with a Gaussian heat source, plus 
the Keyhole model including Fluid flow. These examples collectively show the use of Batch 
and Grid calculation types plus various plot types such as Printability maps, Parity plots, and 
Melt pool vs energy density. The examples are  numbered AM_07 to AM_09b.  

Project File and License Information

 l Folder: Additive Manufacturing

 l File name: AM_07_Batch_IN718.tcu

This example requires an Additive Manufacturing (AM) Module license.

Some examples (AM_01, AM_02, AM_03,  and AM_06b) are available to all users.  These 
examples can be run without an additional Additive Manufacturing license when you are in 
DEMO (demonstration) mode. However, the AM Module is not available with the Educational 
version of Thermo-Calc. Search the help for Available Options with the Additive Manufacturing 
(AM) Module. 

Configuration and Calculation Set Up

Below highlights the main settings for this example.

The Steady-state simulation is selected and the Fluid flow including Marangoni effect checkbox is 
selected. 
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The Heat Source is set to Gaussian and uses the Keyhole model. The printers in the experiments had a 
beam diameter of 67 μm so the Gaussian Beam radius is set to 33.5 μm. The Absorptivity is set to 30.0 %.

The IN718 material is selected from the Material Properties library. The material properties are 
precalculated and stored as a built-in material Library.

The Batch Calculation Type is used to set up all the conditions from the multiple experiments in a single 
calculation. The experimental Power and scan Speed as well as the measured melt pool Width and Depth 
were collected in a CSV file and read into the software. This data is then saved in the project file. 
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In the Batch Experiment Data table you can see that the power ranges between 245 W to 285 W and the 
scan speed ranges between 800 mm/s to 1200 mm/s.

Visualizations

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it takes at least 30 minutes for the calculations to 
complete.

There is a wide variety of information shown both in the Visualizations and Plot Renderer 
Configuration windows that can be viewed during configuration and after performing the 
calculation(s). Not all views, such as the Geometry or previews, nor all additional output (i.e. 
plots) are shown in this section and it is recommended that you open and run the example to 
review all available options and results. 
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Parity Plot

Figure 109: Parity plot comparing experimental versus calculated melt pool width and depth for all the 
experiments. The experiments are single tracks on bare plate IN718 with varied power and scan speed.  The Root 
Mean Square (RMS) error can also be shown as a dashed line.  

Figure 110: Alternatively, lines for user-defined Absolute or Relative in % error can be shown instead by selecting 
these options on the Configuration window.
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3D Plot with Surface Colormap

 

Figure 111: 3D plot showing a keyhole for the second simulation that uses power 285 W and scan speed 1200 
mm/s. 
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Figure 112: Selecting the Batch experiment number to display in the Visualizations window for the 3D plot shown 
in Figure 111.

Reference

[2022NIST] National Institute of Standards and Technology (NIST), Additive Manufacturing Benchmark Test 
Series (AM-Bench) (2022), (available at https://www.nist.gov/ambench). 

Other Resources

Read more about the Additive Manufacturing (AM) Module on our website including the 
details about database compatibility or to watch an introductory webinar. You can also use 
the Getting Started Guide to learn about the key features available. 

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.
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AM_08a: Grid Calculation for a Ti64 Alloy

This example shows the use of the AM Calculator with a Steady-state mode and Grid Calculation Type 
where it compares the calculated and measured printability map. Printability maps are also known as 
process maps. The experiments are from Dilip et. al [2017Dil] where they performed single track 
experiments with the alloy Ti64 at different power and scan speeds. They also printed cubes and 
performed measurements of the porosity amounts for each experimental condition.

The use of different Plot types in this example include a Printability map and a 3D plot with surface 
colormap.

This example is part of a set using a Steady-state simulation with a Gaussian heat source, plus 
the Keyhole model including Fluid flow. These examples collectively show the use of Batch 
and Grid calculation types plus various plot types such as Printability maps, Parity plots, and 
Melt pool vs energy density. The examples are  numbered AM_07 to AM_09b.  

Project File and License Information

 l Folder: Additive Manufacturing

 l File name: AM_08a_Printability_Map_Ti64.tcu

This example requires an Additive Manufacturing (AM) Module license.

Configuration and Calculation Set Up

Below highlights some of the settings for this example to compare with experimental data of Ti64.

 This example builds on the previous one (AM_07) and it is recommended to review this and 
to open the example file to locate and follow along for the settings described here and found 
on the Configuration window. 

The Steady-state calculation  includes Fluid flow. 
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The Heat Source is set to Gaussian and uses the Keyhole model.  The printers in the experiments had a 
beam diameter of 100 μm so the Gaussian Beam radius is set to 50 μm. The Absorptivity is set to 
Calculated. 

The Ti6Al4V from project file material is selected from the Material Properties library. The material 
properties are precalculated and stored as a built-in material Library.

The Grid Calculation Type is used to cover all the conditions from the experiments in a single calculation. 
The Power ranges between 50-200 W and the Scanning speed ranges between 500-1200 mm/s.
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Visualizations

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it can take around two hours to complete the 
calculations. 

There is a wide variety of information shown both in the Visualizations and Plot Renderer 
Configuration windows that can be viewed during configuration and after performing the 
calculation(s). Not all views, such as the Geometry or previews, nor all additional output (i.e. 
plots) are shown in this section and it is recommended that you open and run the example to 
review all available options and results. 

Plot Renderer Configuration Window

The combined results from the Grid calculation can be viewed under the matching Grid tab on the Plot 
Renderer Configuration window where it is set to use the Printability map plot type. In this example, the 
Plot Renderer node is renamed to Printability map in the Project window.
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The experimental value of 30 μm powder thickness (Layer thickness) and  100 μm for the Hatch distance 
seems to be too big to produce dense builds according to this lack of fusion criteria. Full density can then in 
principle only be achieved by melting the regions between tracks by shifting the layers printed on top so 
the full depth of the melt pool covers unmelted regions.
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Printability Map and 3D Plot

There is a video tutorial about the Printability Map on our website and on our YouTube 
channel. It is also included in the Additive Manufacturing Module YouTube playlist.

 

Figure 113: The calculated printability map for Ti64 showing the regions for keyholing porosity (upper left) and 
lack of fusion porosity to the lower right. The labels show the measured amount of porosity. Labels in red show 
regions with severe amounts of porosity and labels in black/green show regions with little or no defects. 
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Figure 114: 3D plot showing a keyhole for the simulation that uses power 200 W and scan speed 1200 mm/s.

Reference

[2017Dil] J. J. S. Dilip, S. Zhang, C. Teng, K. Zeng, C. Robinson, D. Pal, B. Stucker, Influence of processing 
parameters on the evolution of melt pool, porosity, and microstructures in Ti-6Al-4V alloy parts 
fabricated by selective laser melting. Prog. Addit. Manuf. 2, 157–167 (2017). 

Other Resources

Read more about the Additive Manufacturing (AM) Module on our website including the 
details about database compatibility or to watch an introductory webinar. You can also use 
the Getting Started Guide to learn about the key features available. 
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AM_08b: Batch Calculations for a Ti64 Alloy

This example shows the use of the AM Calculator with a Steady-state mode and Batch Calculation Type 
where it compares the calculated and measured melt pool dimensions. The experiments are from Dilip et. 
al [2017Dil] where they performed single track experiments with the alloy Ti64 at different power and scan 
speeds. 

The use of different Plot types in this example include a Parity plot, Melt pool vs energy density, 3D plot 
showing the keyhole, and Printability map.

This example is part of a set using a Steady-state simulation with a Gaussian heat source, plus 
the Keyhole model including Fluid flow. These examples collectively show the use of Batch 
and Grid calculation types plus various plot types such as Printability maps, Parity plots, and 
Melt pool vs energy density. The examples are  numbered AM_07 to AM_09b.  

Project File and License Information

 l Folder: Additive Manufacturing

 l File name: AM_08b_Batch_Ti64.tcu

This example requires an Additive Manufacturing (AM) Module license.

Configuration and Calculation Set Up

Below highlights some of the settings for this example. This example builds on the previous 
ones (AM_07 and AM_08a) and it is recommended to review these and to open the example 
file to locate and follow along for the settings described here and found on the Configuration 
window. 

The Steady-state calculation is configured with the Gaussian Heat Source with the Keyhole model and 
includes Fluid flow. The printers had a beam diameter of 100 μm so the Gaussian Beam radius is set to 50 
μm. The Absorptivity is set to 27 %.

The Ti6Al4V material is selected from the Material Properties library. The material properties are 
precalculated and stored as a built-in material Library.
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The Batch Calculation Type is used to set up all the conditions from the experiments in a single calculation. 
The experimental Power and scan Speed as well as the measured melt pool Width and Depth were 
collected in a CSV file and read into the software. This data is then saved in the project file. 

In the Batch Experiment Data table (see  Visualizing the Batch Calculation Experimental Data) you can see 
that the power ranges between 50-195 W and the scan speed ranges between 500-1200 mm/s.

Visualizations

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it takes at least 30 minutes for the calculations to 
complete.

There is a wide variety of information shown both in the Visualizations and Plot Renderer 
Configuration windows that can be viewed during configuration and after performing the 
calculation(s). Not all views, such as the Geometry or previews, nor all additional output (i.e. 
plots) are shown in this section and it is recommended that you open and run the example to 
review all available options and results. 

 Visualizing the Batch Calculation Experimental Data

During the set up of a calculation, the Batch Experiment Data is imported  into the AM Calculator 
Configuration window, where you can review the data and choose to include or exclude data points by 
selecting and deselecting the checkboxes as needed in the Use column  (see Figure 115). At the same time, 
you can observe the change as this is updated in the Visualizations window (see Figure 116). Data can also 
be entered directly into the table. 
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Figure 115: The experimental data used for the Batch calculation for the single track experiments of Ti64 is 
imported to the AM Calculator table where you can review the data points and include or exclude as needed 
using the checkboxes. 

Figure 116: The visualization of the experimental melt pool dimensions are shown as a function of the energy 
density P/v. You can adjust the selected points in the Batch Experiment Data table and watch the updates 
dynamically in this window. 
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Parity, Melt Pool, and 3D Plot

Figure 117: Parity plot comparing experimental versus calculated melt pool width and depth for all the Batch 
calculations. The experiments are single tracks with Ti64 with varied power and scan speed.

Additive Manufacturing (AM) Module Examples Collection ǀ 174 of 431



Figure 118: Plot comparing experimental versus calculated melt pool dimensions for all the Batch calculations. 
The experiments are single tracks with Ti64 with varied power and scan speed. The melt pool width and depth are 
shown on the Y-axis and the energy density (P/v) on the X-axis.

Figure 119: 3D plot showing a keyhole for the 15th simulation that uses power 195 W and scan speed 1000 mm/s. 
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Reference

[2017Dil] J. J. S. Dilip, S. Zhang, C. Teng, K. Zeng, C. Robinson, D. Pal, B. Stucker, Influence of processing 
parameters on the evolution of melt pool, porosity, and microstructures in Ti-6Al-4V alloy parts 
fabricated by selective laser melting. Prog. Addit. Manuf. 2, 157–167 (2017). 

Other Resources

Read more about the Additive Manufacturing (AM) Module on our website including the 
details about database compatibility or to watch an introductory webinar. You can also use 
the Getting Started Guide to learn about the key features available. 

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.
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AM_09a: Grid Calculation for an SS316L Alloy

This example shows the use of the AM Calculator with a Steady-state mode and Grid Calculation Type 
where it compares the calculated and measured printability map. Printability maps are also known as 
process maps.  The experiments are from Hu et. al [2019Hu] where they performed single track 
experiments with the alloy SS316L at different power and scan speeds.

The use of different Plot types in this example include a Printability map and a 3D plot with surface 
colormap.

This example is part of a set using a Steady-state simulation with a Gaussian heat source, plus 
the Keyhole model including Fluid flow. These examples collectively show the use of Batch 
and Grid calculation types plus various plot types such as Printability maps, Parity plots, and 
Melt pool vs energy density. The examples are  numbered AM_07 to AM_09b.  

Project File and License Information

 l Folder: Additive Manufacturing

 l File name: AM_09a_Printability_Map_316L.tcu

This example requires an Additive Manufacturing (AM) Module license.

Configuration and Calculation Set Up

Below highlights some of the settings for this example. This example builds on the previous 
ones (AM_07, AM_08a, and AM_08b) and it is recommended to review these and to open the 
example file to locate and follow along for the settings described here and found on the 
Configuration window. 

The Steady-state calculation is configured with the Gaussian Heat Source with the Keyhole model and 
includes Fluid flow. 

The Gaussian Beam radius is set to 22 μm. The Absorptivity is set to 30 % and in the Scanning Strategy 
section, the powder Layer thickness is set to 10 μm. 
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The SS316L material is selected from the Material Properties library. The material properties are 
precalculated and stored as a built-in material Library.

The Grid Calculation Type is used to cover all the conditions from the experiments in a single calculation. 
The Power ranges between 40-100 W and the Scanning speed ranges between 400-3000 mm/s.

Visualizations

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it can take around two hours to complete the 
calculations. 

There is a wide variety of information shown both in the Visualizations and Plot Renderer 
Configuration windows that can be viewed during configuration and after performing the 
calculation(s). Not all views, such as the Geometry or previews, nor all additional output (i.e. 
plots) are shown in this section and it is recommended that you open and run the example to 
review all available options and results. 

Plot Renderer Configuration Window

The combined results from the Grid calculation can be viewed under the matching Grid tab on the Plot 
Renderer Configuration window where it is configured to use the Printability map plot type. In this 
example, the Plot Renderer node is renamed to Printability map in the Project window.
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Next each Function is defined and limits were adjusted to match the experimental regions of keyholing and 
lack of fusion porosity. 

 l  The keyholing limit (Keyholing: Wk/Dk) is kept at default 1.0. 

 l The Lack of fusion: D/t is increased from default of 1.0 to 1.3. 

 l The experiments were only single-track and the lack of fusion at half of the hatch distance (Lack of 
fusion hatch: Dh/t) is kept at default 1.0 and only included together with the Hatch distance of 35 
μm for demonstration purposes.
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Figure 120: The settings for the printability map with the Function limits defined for keyholing, lack of fusion, and 
lack of fusion at half of the hatch distance (as described in the text).

Printability Map and 3D Plot

There is a video tutorial about the Printability Map on our website and on our YouTube 
channel. It is also included in the Additive Manufacturing Module YouTube playlist.
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Figure 121: Printability map for 316L showing regions of keyholing and lack-of-fusion. Experimental information 
from Hu et. al. [2019Hu] overlaid as coloured labels showing  keyhole porosity (K), conduction mode with lack-of-
fusion porosity (C). Green labels showing experiments without defects for conduction mode (C) and keyhole mode 
(K).

Figure 122: 3D plot showing a keyhole for the simulation that uses power 100 W and scan speed 400 mm/s.

Reference

[2019Hu] Z. Hu, B. Nagarajan, X. Song, R. Huang, W. Zhai, J. Wei, Formation of SS316L Single Tracks in Micro 
Selective Laser Melting: Surface, Geometry, and Defects. Adv. Mater. Sci. Eng. 2019, 1–9 (2019).
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Other Resources

Read more about the Additive Manufacturing (AM) Module on our website including the 
details about database compatibility or to watch an introductory webinar. You can also use 
the Getting Started Guide to learn about the key features available. 
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AM_09b: Batch Calculations for an SS316L Alloy

This example shows the use of the AM Calculator with a Steady-state mode and Batch  Calculation Type 
where it compares the calculated and measured melt pool dimensions. The experiments are from Hu et. al 
2019 where they performed single track experiments with the alloy SS316L at different power and scan 
speeds.

The use of different Plot types in this example include a Parity plot, Melt pool vs energy density, 3D plot 
showing the keyhole, and Printability map.

This example is part of a set using a Steady-state simulation with a Gaussian heat source, plus 
the Keyhole model including Fluid flow. These examples collectively show the use of Batch 
and Grid calculation types plus various plot types such as Printability maps, Parity plots, and 
Melt pool vs energy density. The examples are  numbered AM_07 to AM_09b.  

Project File and License Information

 l Folder: Additive Manufacturing

 l File name: AM_09b_Batch_316L.tcu

This example requires an Additive Manufacturing (AM) Module license.

Configuration and Calculation Set Up

Below highlights some of the settings for this example. This example builds on the previous 
ones (AM_07, AM_08a, AM_08b, and AM_09a) and it is recommended to review these and to 
open the example file to locate and follow along for the settings described here and found on 
the Configuration window. 

The Steady-state calculation is configured with the Gaussian Heat Source with the Keyhole model and 
includes Fluid flow. 

The Gaussian Beam radius is set to 22 μm. The Absorptivity is set to 30 % and in the Scanning Strategy 
section, the powder Layer thickness is set to 10 μm. 
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The SS316L material is selected from the Material Properties library.The material properties are 
precalculated and stored as a built-in material Library.

The Batch Calculation Type is used to set up all the conditions from the experiments in a single calculation. 
The experimental Power and scan Speed as well as the measured melt pool Width and Depth were 
collected in a CSV file and read into the software. This data is then saved in the project file. 

In the Batch Experiment Data table the power ranges between 50-100 W and the scan speed ranges 
between 400-2800 mm/s.

Visualizations

There is a video tutorial about the Printability Map on our website and on our YouTube 
channel. It is also included in the Additive Manufacturing Module YouTube playlist.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it can take about an hour to complete the calculations. 

There is a wide variety of information shown both in the Visualizations and Plot Renderer 
Configuration windows that can be viewed during configuration and after performing the 
calculation(s). Not all views, such as the Geometry or previews, nor all additional output (i.e. 
plots) are shown in this section and it is recommended that you open and run the example to 
review all available options and results. 

Visualizing the Batch Calculation Experimental Data

During the set up of this calculation, the Batch Experiment Data is imported into the AM Calculator 
Configuration window, where you can review the data and choose to include or exclude data points by 
selecting and deselecting the checkboxes as needed in the Use column. At the same time, you can observe 
the change as this is updated in the Visualizations window.
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Figure 123:  The experimental data used for the Batch calculation for the single track experiments of SS316L is 
imported to the AM Calculator table where you can review the data points and include or exclude as needed 
using the checkboxes. 

Figure 124: The visualization of the experimental melt pool dimensions are shown as a function of the energy 
density P/v. You can adjust the selected points in the Batch Experiment Data table and watch the updates 
dynamically in this window. 
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Parity, Melt Pool, and 3D Plot

Figure 125: Parity plot comparing experimental versus calculated melt pool width and depth for all the Batch 
calculations. The experiments are single tracks with SS316L with varied power and scan speed.

Figure 126: 3D plot showing a keyhole for the 12th simulation that uses power 60 W and scan speed 800 mm/s. 
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Figure 127: Plot comparing experimental versus calculated melt pool dimensions for all the Batch calculations. 
The experiments are single tracks with SS316L with varied power and scan speed. The melt pool width and depth 
are shown on the Y-axis and the energy density (P/v) on the X-axis.

Figure 128: For the plot, you can choose what to include on the plot, to show width and/or depth by selecting the 
relevant checkboxes on the Configuration window. 

Reference

[2019Hu] Z. Hu, B. Nagarajan, X. Song, R. Huang, W. Zhai, J. Wei, Formation of SS316L Single Tracks in Micro 
Selective Laser Melting: Surface, Geometry, and Defects. Adv. Mater. Sci. Eng. 2019, 1–9 (2019).
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Other Resources

Read more about the Additive Manufacturing (AM) Module on our website including the 
details about database compatibility or to watch an introductory webinar. You can also use 
the Getting Started Guide to learn about the key features available. 
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AM_10: CET Transition in an IN718 Alloy

The example uses a Scheil Calculator, AM Calculator, and the Property Model Calculator with the 
Columnar to Equiaxed Transition Property Model to compare calculated CET curves for an IN718 alloy 
(from example PM_G_17) with the solidification conditions of the melt pool in the AM simulation. 

For more background about this Property Model, search the Help or the main Thermo-Calc 
documentation set for About the Columnar to Equiaxed Transition (CET) model.

This example is similar to, and based on, example PM_G_17: Columnar to Equiaxed Transition 
of an IN718 Alloy. This is available from the Property Models → General folder.

A Scheil with solute trapping calculation is done first on the Scheil Calculator to generate thermophysical 
properties data to the AM Calculator. A steady-state AM simulation is done to predict the solidification 
conditions in the melt pool, the solidification rates, and thermal gradients.

Then using the Property Model Calculator with the Columnar to Equiaxed Transition (CET) model, the 
calculated CET curves for an IN718 alloy are fed into the AM + CET node (the renamed Plot Renderer), 
where together the data from the AM and Property Model calculations are combined and overlaid on one 
plot. 

The literature data from Polonsky et al. [2020Pol] are not purely experimental data, but rather combined 
with experimental equiaxed evidence and model calculations with numerical values of thermal gradients, 
growth velocity as well as tip undercooling. Polonsky et al. estimated tip undercooling based on a Scheil 
calculation, which smeared out the composition inhomogeneity at the dendrite front, hence 
underestimating the undercooling. Since both tip undercooling and nucleation site density promotes the 
formation of equiaxed crystals, an increase in undercooling in this example calculation leads to a decrease 
in nucleation site density compared to the results in [2020Pol] if one were fitting the same set of data.

Project File and License Information

 l Folder: Additive Manufacturing

 l File name: AM_10_Columnar_to_Equiaxed_Transition_IN718.tcu
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A separate license is required to perform calculations with the Additive Manufacturing (AM) 
Module. This example also requires additional database licenses for the  TCS Ni-based 
Superalloys Database (TCNI) (TCNI12 and newer), and the  TCS Ni-alloys Mobility Database 
(MOBNI) (MOBNI6 and newer).

Configuration and Calculation Set Up

On the Scheil Calculator (renamed to Scheil with solute trapping) , the Scheil with solute trapping is used 
with these specific settings:

 l Trans-interface diffusivity: Same for all elements

 l Prefactor: 5.0E-9

 l Maximum velocity for infinite driving force: 2000 m/s

 l Model: Aziz 

 l Interface driving force: Driving energy 

For the AM Calculator (renamed to AM Steady-state), the Steady-state calculation is configured as a 
Gaussian Heat Source with the Keyhole model and includes Fluid flow. It also uses a Single Point 
calculation with the Calculated Absorptivity. 

On the Property Model Calculator (renamed to Columnar to Equiaxed Transition) a One Axis calculation for 
the FCC_L12 primary phase is done using the CET parameters entered on the Configuration window. 

The settings on the Property Model Calculator include:

 l Interfacial energy:    0.5 J/m2. 
 l Number of nucleation sites: 4.0E11/m3

 l Nucleation undercooling : 4.0 K 

 l Equiaxed exponent: 3.13

 l Solve for: Thermal gradient

 l Equiaxed fractions: 0.01 0.49 0.99

 l Solidification rate: log10(v)

Additive Manufacturing (AM) Module Examples Collection ǀ 190 of 431



Visualizations

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

There is a wide variety of information shown both in the Visualizations and Plot Renderer 
Configuration windows that can be viewed during configuration and after performing the 
calculation(s). Not all views, such as the Geometry or previews, nor all additional output (i.e. 
plots) are shown in this section and it is recommended that you open and run the example to 
review all available options and results. 

The thermal gradients and solidification rate can be visualized in 2D or 3D. Figure 129 shows the thermal 
gradient along the melt pool boundary in a 3D plot. Only the data corresponding to solidification conditions 
are shown. The thermal gradients corresponding to melting conditions are filtered out and only the tail part 
of the meltpool are shown.

Figure 129: The 3D Plot for the 3D Thermal Gradient Plot Renderer.

Both the thermal gradients and solidification rates from the melt pool can be visualized at the same time in 
a 2D scatter plot when the Plot Renderer tab Thermal Gradient vs Solidification Rate is selected.
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Figure 130: The solidification rate vs thermal gradient is shown on the AM Thermal Gradient & Solidification Rate 
Plot Renderer. 

Figure 131 is an example of a plot where the results from both the AM simulation and the CET model for 
the IN718 thermal gradient vs solidification rate are overlaid on the same plot. The blue, red, and green 
lines show the increasing equiaxed fraction from the CET Property Model and the points show the 
solidification conditions at the melt pool calculated with the Additive Manufacturing (AM) Module. When 
the results are overlaid like this, you can see that nearly all the points (those below the purple line) exist in 
a fully columnar region.

Additive Manufacturing (AM) Module Examples Collection ǀ 192 of 431



Figure 131: The solidification rate vs the thermal gradient overlaying both plots from the AM Calculator and 
Property Model Calculator (via the AM + CET Plot Renderer). 

Reference

[2020Pol] A. T. Polonsky, N. Raghavan, M. P. Echlin, M. M. Kirka, R. R. Dehoff, T. M. Pollock, 3D 
Characterization of the Columnar-to-Equiaxed Transition in Additively Manufactured Inconel 718, in 
Superalloys 2020 (2020), pp. 990–1002.

Other Resources

Read more about the Additive Manufacturing (AM) Module on our website including the 
details about database compatibility or to watch an introductory webinar. You can also use 
the Getting Started Guide to learn about the key features available. 

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.
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AM_11: Comparing Single Tracks Printed on Casted and 
LPBF Substrates

Bogdonova et al. [2024Bog] performed single track experiments with the alloy Al10SiMg. The study 
compared the printing of single tracks on two types of substrates—one fabricated with traditional casting 
and the other with laser powder bed fusion (LPBF).

Project File and License Information

 l Folder: Additive Manufacturing

 l File name: AM_11_Batch_Al10SiMg.tcu

A separate license is required to perform calculations with the Additive Manufacturing (AM) 
Module. This example also requires an additional database license for the   TCS Al-based Alloy 
Database (TCAL) (TCAL9 and newer).

Background

It is well known that the thermal conductivity of the alloy Al10SiMg is drastically reduced in the as-printed 
condition when fabricated by LPBF compared to conventionally manufactured counterparts [2022Gha].

Thermal conductivity in Thermo-Calc is modeled as a temperature- and composition-dependent property 
per phase, and the conductivity of the alloy is taken as an average over the stable phases. The composition 
of the primary phase can change greatly depending on the fabrication method where the LPBF method 
results in rapid solidification and solute trapping of solute alloy elements.

Thermal conductivity can generally be reduced by different scattering phenomena (pores, defects, phase 
interfaces) within the microstructure and can therefore be lower than the calculated conductivity averaged 
over the phases. 

The electrical resistivity due to phase interface scattering is evaluated as the scattering constant times sum 
of the interaction between the volume fraction of all the phases. The default value for the phase interface 
scattering constant is found to be 4.0e-8 Ωm for aluminum alloys. The contribution to thermal conductivity 
is assumed to be related to that of electrical resistivity, following the Wiedemann-Franz law.
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 The rapid solidification during LPBF generally results in a much finer microstructure compared to 
traditional casting. LPBF fabricated Al10SiMg solidifies with a cellular primary FCC structure and a eutectic 
structure between the cells [2021Lef]. An increased interface scattering constant more than 4.0E-8 can be 
argued given the much finer structure that has a large number of phase interfaces.

In this example the effect on material properties and melt pool dimensions is compared when printing 
single tracks on the two types of substrates. The material properties for the traditionally cast alloy is 
calculated using regular Scheil and the default interface scattering constant of 4.0E-8. The material 
properties for the LBPF fabricated alloy is calculated using Scheil with solute trapping and the effect of 
increasing the interface scattering is shown.

Visualizations

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

There is a wide variety of information shown both in the Visualizations and Plot Renderer 
Configuration windows that can be viewed during configuration and after performing the 
calculation(s). Not all views, such as the Geometry or previews, nor all additional output (i.e. 
plots) are shown in this section and it is recommended that you open and run the example to 
review all available options and results. 

When you run (Perform) this example, it can take around two hours to complete the 
calculations. 

Material Properties for the As-cast Substrate Material

The TCS Al-based Alloy Database (TCAL) is selected on the System Definer (renamed to Scheil As-cast). The 
as-cast Al10SiMg alloy has the composition of Al-10.8Si-0.3Mg-0.1Cu-0.1Fe.

The Scheil Calculator (renamed to Scheil As-cast) is configured with default settings for AM with an 
evaluation of thermophysical properties from 5000 K down to room temperature. The Calculation type is 
set to Classic Scheil.
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Material Properties for the LPBF Printed Substrate Material

The TCS Al-based Alloy Database (TCAL) is selected in the System Definer (renamed to Scheil printed). The 
LPBF Al10SiMg alloy has almost the same composition (Al-10.8Si-0.3Mg-0.1Cu-0.2Fe) with only a small 
difference in Fe content.

The Scheil Calculator (renamed to Scheil Solute-Trapping) is configured with the default settings for AM 
with an evaluation of thermophysical properties from 5000 K down to room temperature. The Calculation 
type is set to Scheil with solute trapping.

Comparing Material Properties Between the Substrates

Two plots overlay results from the two Scheil Calculators in Figure 132. The Plot Renderer, renamed to Si in 
primary FCC, shows the Si content in the primary FCC phase. The classic Scheil calculation gives less than 
1.5 at% Si. The solute trapping simulation results in twice the Si content with about 3 at% Si in the primary 
FCC phase. Atom probe experiments for a LPBF printed Al10SiMg alloy measured 3.08 at% Si in the FCC cell 
structure for the as-printed condition [2021Lef]. 

Figure 132: Silicon content in the primary FCC phase comparing regular (classic) Scheil with Scheil and solute 
trapping. The solute trapping almost doubles the Si content in the primary FCC phase.

Figure 133 is another overlaid plot that takes the results from two Scheil Calculator predecessors    to show 
how the thermal conductivity varies with temperature. The conductivity for the as-cast substrate (blue 
line), that uses classic Scheil and the default setting for the phase interface scattering constant (C = 4.0E-
8), naturally gives the highest thermal conductivity. The red line shows the reduction in conductivity due to 
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solute trapping and the increased Si content in the primary phase. The green line shows further reduction 
in thermal conductivity due to the increased interface scattering when the scattering constant was 
increased  (C = 1.0E-7).

Figure 133: Thermal conductivity for as-cast substrate and printed substrate. Blue line shows conductivity for as-
cast structure using the default setting for the interface scattering constant (C = 4.0E-8). The red line shows the 
reduced conductivity due to the solute trapping. Finally, the green line shows further reduction in thermal 
conductivity due to increased interface scattering where C = 1.0E-7.

Batch AM Steady-State Simulations

Two AM Calculators are next set up. These are renamed to As-cast Batch and AM Batch. These AM batch 
steady-state simulations are configured with similar settings, except for the interface scattering and the 
measured experimental melt pool dimensions that are different for the as-cast and LPBF fabricated 
substrates. The interface scattering settings are found on the Material Properties tab for both 
AM Calculators: 

 l The as-cast substrate uses the default interface scattering (C = 4.0E-8).

 l The LPBF as-printed substrate uses the increased value for interface scattering (C = 1.0E-7). 

The shared settings in the AM Calculator configuration (on the Conditions tab) are: 
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 l Uses Fluid flow including Marongoni effect and the keyhole model. 

 l Absorptivity is selected as Calculated and the with prefactor is set to 1.8 times the calculated value 
in order to match the experimental melt pool dimensions. 

The need to use a large prefactor is probably related to surface oxides and that the 
calculated absorptivity is for an oxide free liquid surface. The stable oxide Al2O3 often 
forms at the surfaces of Al-alloys where it remains in solid form to above 2000 °C and 
evaporates well above 3000 °C.

Figure 134: The settings window for an AM steady-state simulation for the As-cast Batch calculator. Fluid flow 
and Gaussian heat source with keyhole model are enabled, plus it uses a calculated absorptivity with a prefactor 
set to 1.8.

To reduce total calculation time, for each AM Calculator only 5 of the 12 experiments are 
selected on the Plot Renderer (click Show Table to see the details). However, the example still 
takes about two hours to perform.
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Figure 135: The temperature- and incident angle-dependent absorptivity. Red curve shows the absorptivity as a 
function of incident angle at the liquidus temperature, the blue curve shows the corresponding absorptivity at the 
evaporation temperature.

Turbulent Flow - Large Eddy Simulations

Al-alloys have in general lower viscosity compared to other metallic alloys (e.g. Ti-, Fe- or Ni-based alloys). 
The low viscosity in combination with high fluid flow rates can result in turbulent flows. This happens in this 
example for the simulations at the higher energy densities. The turbulent flow model implemented in the 
AM simulation is based on Large Eddy Simulations (LES) where the large-scale motions are represented 
directly and smaller-scale motions are modeled. A larger Smagorinsky constant filters more small-scale 
motions to be modeled. The example increases the Smagorinsky constant to 0.5. The simulations with the 
highest energy densities will otherwise fail to converge with the default value of 0.18.

Figure 136: On the Options tab for the AM Steady-State simulation (As-cast Batch) with an increased Smagorinsky 
constant to handle the high turbulent flows.
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The following parity plot examples compare the experimental versus calculated melt pool dimensions. In 
general a good trend can be seen for both the simulations with the as-cast and LPBF fabricated substrates. 
The experimental melt pools are in general deeper than the simulated with an increasing error with 
increasing depth of the melt pool.

Figure 137: 3D plot of melt pool for as-cast substrate  where P = 325 W and scanning speed = 600 mm/s.
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Figure 138: Parity plot for as-cast substrate when 5/12 experiments are calculated.

Figure 139: Parity plot for as-cast substrate when all 12 experiments are calculated.
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Figure 140: Parity plot for LPBF printed substrate when 5/12 experiments are calculated.

Figure 141: Parity plot for LPBF printed substrate when all 12 experiments are calculated.
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Figure 142: 3D plot of melt pool for LPBF printed substrate where P = 325 W and scanning speed = 1200 mm/s.
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Other Resources

Read more about the Additive Manufacturing (AM) Module on our website including the 
details about database compatibility or to watch an introductory webinar. You can also use 
the Getting Started Guide to learn about the key features available. 
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Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.
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AM_12: Using AM Calculator Probe Data with the 
Precipitation Module (TC-PRISMA)

This example demonstrates the coupling of the AM Calculator with the Precipitation Calculator via probe 
data from an AM simulation. Both a thermodynamic and mobility database is needed for the precipitation 
calculation, so the AM Material Library cannot be used. Instead, a Scheil Calculator is used to calculate the 
material properties used in the AM simulation.

The example simulates the incipient melting and re-precipitation of gamma prime in CMSX-4 during 
Selective Electron Beam Melting (SEBM) during a single pass of the beam. The SEBM process is simulated 
using an Electron Beam heat source. A transient with heat source from Steady-state simulation of a single 
track is simulated, with a cooling time of 150 s. The bed and ambient temperature is elevated to 950 °C. 
The process parameters are taken from Ramsperger et al. [2016aRam].

Project File and License Information

 l Folder: Additive Manufacturing

 l File name: AM_12_AM_Probe_to_Precipitation.tcu

A separate license is required to perform calculations with the Additive Manufacturing (AM) 
Module. This example also requires a license for the Precipitation Module (TC-PRISMA), plus 
additional database licenses for the TCS Ni-based Superalloys Database (TCNI) (TCNI13 and 
newer is recommended for best results), and the TCS Ni-alloys Mobility Database (MOBNI) 
(MOBNI6 and newer).

Background

Ramsperger and Körner [2016bRam] demonstrated that it is possible to print single crystal CMSX-4 
components using SLBM with an elevated bed temperature. The main challenge encountered is fracture 
during printing. The formation of gamma prime may incur a drop in ductility that contributes to fracture. 
Understanding the precipitation kinetics of gamma prime during 3D printing is important with regards to 
identifying optimum process parameters, and determining how best to heat treat the final component.

Wahlmann et al. [2019Wah] studied gamma prime kinetics in emulated SLBM thermal conditions, indirectly 
measuring the size of the gamma prime using X-ray diffraction during repeated nucleation and dissolution 
thermal cycles imitating the thermal history of an SLBM build. Figure 143 shows the calibration of the 
Precipitation Calculator to capture the measured kinetics.
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Figure 143: A comparison of the indirectly measured gamma prime size evolution during thermal heat treatment 
emulated an SLBM process with predictions from the Precipitation Calculator using the Thermo-Calc Ni-based 
superalloys databases (TCNI12 and MOBNI6) [2019Wah].

This AM Calculator to Precipitation Calculator example uses the calibrated parameters for gamma prime 
kinetics shown in Figure 143. The Precipitation Calculator includes the possibility for incipient melting of 
the gamma prime, which is predicted to occur during the first pass of the electron beam. Incipient melting 
describes the phenomena where solid-state precipitates are heated rapidly to a high temperature beyond 
their solvus temperature. The precipitates reach a temperature where they melt before the parent matrix 
phase. The Precipitation Calculator removes the gamma prime dispersion upon melting.

Configuration and Calculation Set Up

The Additive Manufacturing template was used to first add the System Definer, Scheil Calculator, AM 
Calculator, and Plot Renderer to the Project window tree. Additionally, a Precipitation Calculator was 
added as a successor to the AM Calculator in order to automatically import the time-temperature profile 
from the AM simulation into the precipitation simulation.

Open the example to see the Project tree layout and review the settings for each activity. It is 
useful to click around in the interface to understand where the settings are located and 
configured. This section highlights the relevant settings for this example.
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System Definer

On the System Definer, the nickel-based superalloy CSMX-4 composition was approximated by Ni-9.8Co-
6.4Ta-6.5Cr-6.4W-5.7Al-2.8Re-0.97Ti-0.62Mo-0.086Hf, (mass%). The thermodynamic (TCNI) and mobility 
(MOBNI) nickel-based superalloy databases were selected, with the phase DIS_FCC_A1 included.

You can include or exclude phases from the Phases and Phase Constitution tab on the System 
Definer.

AM Calculator

On the AM Calculator Configuration window, the calculation type Transient with heat source from 
Steady-state is selected with a single track scan pattern and Geometry of 5 mm x 5 mm x 5 mm (height x 
width x length). The Base plate temperature and Ambient temperature is set to 950 ℃  with a gas 
pressure of 1 Pa.

Additional settings are then made on the Configuration window as follows.

 l In the Heat Source section, Electron Beam is selected with a Power of 1110 W, a Calculated 
Absorptivity, an Acceleration voltage of 60 kV, and a Beam radius of 250 μm. The keyhole model 
checkbox is selected.

 l In the Scanning Strategy section, the Scanning speed is 2000 mm/s and the Layer thickness is 50 
μm. A Cooling time of 150 s is included.

 l In the Top Boundary Conditions section, the Evaporation checkbox is selected to include this in the 
model.

 l In the Probe Positions section, a single probe is added to the center of the top surface of the 
component, below the powder layer. See the Geometry tab as shown in Figure 144.
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Figure 144: The full geometry set up for the single track AM simulation with a probe point added to the middle of 
the scan. Open the example to better see the set up and try working in the Visualizations window.

Precipitation Calculator

The following highlights the relevant settings to make on the Configuration window for this example.

On the Options tab:

 l Both the Preprocess equilibrium data and Include incipient melting checkboxes are selected.

On the Conditions tab, under Matrix Phase:

 l DIS_FCC_A1 is selected.

Also see "Selecting the Disordered Phase as a Matrix Phase" in the Precipitation Module 
User Guide, or search for this in the help.

 l Click Show Details, then for Mobility adjustment > Prefactor, keep Same for all elements and 
enter 6.0 for the Prefactor.

On the Conditions tab, under Precipitate Phase:

 l FCC_L12#2 is selected.

 l Nucleation sites = Bulk

 l Interfacial energy = 0.035 J/m2
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 l Click Show Details, then:
 l Phase energy addition = -55.0 J/mol

 l Select the Preexisting size distribution checkbox.

 l Click Edit Particle Size Distribution, and note the Compositions entered.

In the Preexisting Particle Size Distribution window you can also adjust other settings.  In this 
case, the size distribution is approximated by a Weibull distribution function with a mean 
radius of 200 nm, an Alpha of 2.0, and a fraction offset of 0.5 Search for "Particle Size 
Distribution (PSD)" in the Precipitation Module User Guide, or in the help.

On the Conditions tab, under Calculation Type: 

 l Temperature unit = Kelvin

 l Start time = 0.0

 l Simulation time = 150.01 Seconds

 l Probes: Probe1

 l Condense time-temperature data = None
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Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation(s).

Figure 145 and Figure 146 show the predicted evolution of the precipitate dispersion including the change 
in mean radius and volume fraction, respectively. The second Y axis in both figures shows the temperature. 
The initial gamma prime size distribution describes the gamma prime that has formed during the 
production of the AM powder. It is too large to dissolve during the rapid heating as the electron beam 
heats the component, and melts before the matrix. The gamma prime re-precipitates upon resolidification 
and cooling below the gamma prime solvus, and coarsens whilst held at elevated temperature. The 
incipient melting of the initial size distribution is clearly evident.

Figure 145: The mean radius and temperature as a function of temperature, with the mean radius on the left axis, 
and the temperature on the right axis.
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Figure 146: The volume fraction and temperature as a function of temperature, with the volume fraction on the 
left axis, and the temperature on the right axis. 

The gamma prime distribution just prior to incipient melting is observed at 0.004 s. It has not dissolved 
significantly during the rapid heating as the electron beam passes. At 1 s the material has solidified and 
cooled to a temperature where gamma prime has nucleated and grown. The size distribution at the end of 
the simulation is shown at 150.1 s. Figure 147 shows the size distributions at these times during the single 
track AM simulation.
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Figure 147: The size distributions of gamma prime at key points during the simulation. 
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Other Resources

Read more about the Additive Manufacturing (AM) Module on our website including the 
details about database compatibility or to watch an introductory webinar. You can also use 
the Getting Started Guide to learn about the key features available. 
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AM_13: Using the Core-ring Beam Shape

This Steady-state example demonstrates the use of Core-ring Heat Source model available in the AM 
Module with Batch calculations. 

The heat source parameters for the Core-ring heat source, as well as the processing parameters (power 
and speed), are taken from Holla et al. [2024Hol]. The example also compares the predicted melt pool 
dimensions with the experimental data from this paper. 

For TC-Python users,  there is an example using Core-ring: pyex_AM_09_CoreRing_
BeamShape.py. 

There is a companion example in Graphical Mode using Top-hat: "AM_14: Using the Top-hat 
Beam Shape" on page 221. 

Project File and License Information

 l Folder: Additive Manufacturing

 l File name: AM_13_CoreRing_BeamShape.tcu

This example requires an Additive Manufacturing (AM) Module license.

Background

In a core-ring heat source, the energy is distributed between the central core and the surrounding ring, 
allowing for more precise control of heat input and a more uniform temperature distribution, reducing the 
risk of unstable keyhole formation [2023Bi]. Furthermore, a wider melt pool with the Core-ring beam 
shape as compared to a Gaussian profile allows enlargement of the hatch distances and together with the 
possibility of using higher scanning speeds, results in faster printing process and increased productivity 
[2021Grü]. 

The inclusion of a Core-ring heat source model in the AM Module, together with the keyhole model, allows 
you to predict the temperature evolution and melt pool shape along with the transition from conduction 
mode to keyhole mode for a Core-ring heat source. The experimental data taken from the literature 
[2024Hol] demonstrates the use of a Core-ring heat source for single track experiments on stainless steel 
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316L bare plates. A wide range of process parameters (power = 200 W – 900 W and scanning speed = 200 
mm/s – 800 mm/s) also shows different cases for both conduction as well as the keyhole mode, which are 
correctly predicted in this example by the simulation results.

Material Properties

 l SS316L: Fe-17.0Cr-12.0Ni-2.5Mo-0.03C Mass percent

 l Database: TCFE13 and with interface scattering = 1e-07.

 l The material properties are precalculated, and stored as a built-in material library with the Additive 
Manufacturing (AM) Module.

AM Calculator Configuration Settings

This example contains one AM Calculator, which is renamed to Core-ring_20/80. On the Configuration 
window, Conditions tab, this Steady-state calculation is configured with the Core-ring Heat Source with the 
Keyhole model and includes Fluid flow.  

The Custom Mode is used in order to set all the heat source parameters as given in Table 2 of  [2024Hol]. 
Individual settings are entered to match: 

 l Beam radius-Core: 47.6 μm

 l Beam radius-Ring: 25.29 μm

 l Ring radius: 68.4 μm 

The Amount of power in the ring is set to 80%, which is equivalent to 20/80 beam shape in [2024Hol].

The Absorptivity is set to Calculated with a prefactor of 1.2. It uses the keyhole model where  the Beam 
quality factor M2 is kept as 1.0.

The Batch Calculation Type is used to set up all the conditions from the experiments in a single calculation. 
In the Batch Experiment Data section, the experimental Power and scan Speed as well as the measured 
melt pool Width (Exp width) and Depth (Exp. depth) were collected in a CSV file and imported into the 
software. This data is then saved in the project file.

In the Batch Experiment Data table, the Power ranges between 200  W to 900 W, and the scan Speed 
ranges between 200 mm/s to 800 mm/s.

Visualizations

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
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Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it takes a few minutes for the calculations to complete.

Parity Plot

This specific Parity plot is shown by clicking the Parity Plot node in the Project window. Then you can see 
on the Visualizations window it is in the tab of the same name. The settings are located on the 
Configuration window on the Batch tab.

The plot compares experimental and calculated melt pool width and depth for all experiments. The 
experiments are single tracks on bare plate SS316L with varied power and scan speed using a Core-ring 
heat source. 

Figure 148: Parity plot comparing experimental and calculated melt pool width and depth for all the experiments 
when using a Core-ring heat source. The Root Mean Square (RMS) error can also be seen as a dashed line.

3D Plots

The specific 3D Plot that is highlighted in this section is shown by clicking the 3D Plot node in the Project 
window. Then on the Visualizations window on the tab of the same name, you can use various toolbar 
buttons  to navigate and experiment with the views, for example:
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 Zoom to Heat Source position

In Figure 149, and using a combination of the Plot Renderer Configuration window settings on the 3D Plot 
tab and the Visualizations window, different zoom levels and adjusting the Glyph scale factor setting helps 
to clearly show the melt pool and velocity vectors. 

Further, the plot on the left is displayed by choosing the applicable Batch experiments results from the list 
(P=200 W, V=500 mm/s) and this set of experiments undergoes melting in conduction mode. Then the plot 
on the right is displayed by choosing the applicable Batch experiments results (P=600 W, V=200 mm/s) and 
that one forms a keyhole. 
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Figure 149: A comparison of the melt pools for two different processing conditions: Red and blue isocontours 
show liquidus and solidus temperatures, respectively. See the text for details.

In Figure 150 you can click the  Set View button plus  Mirror Geometry button to obtain this top 
view of a Surface colormap. 

In general, you can play around with the 3D Plot Configuration window settings. For example, for the right-
hand side figure, you can view the Flow velocity field with different Display types such as an Arrow 
(shown). 

 

Figure 150: Top view (XY) of the surface colormap showing (left) temperature distribution due to the 20/80 Core-
ring beam shape, and (right) velocity field caused by the distinctive temperature profile, resulting in widening of 
the melt pool. P=200 W, V=500 mm/s. Red and blue isocontours show liquidus and solidus temperatures, 
respectively.
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In Figure 151, this cross-section compares the melt pool shape and size for Batch experiment 1 (P=200 W, 
V=500 mm/s) to the experimental results as shown in Figure 9 in the paper by  [2024Hol]. 

 

Figure 151: A cross-section comparing melt pool shape and size for P=200 W, V=500 mm/s from (left) simulation 
and (right) experiments [2024Hol-Fig9]. Red and blue isocontours in the simulation result show liquidus and 
solidus temperatures, respectively. 

In Figure 152, the formation of the meltpool is shown on the left and compared to a cross-section that is 
taken from Batch experiment 3 (P=600 W, V=200 mm/s) to show the formation of a keyhole and the 
maximum melt pool size, where you can also see the widening of the melt pool due to fluid flow. Compare 
this to Figure 153, which are the experimental results as shown in Figure 9 in the paper by  [2024Hol]. 

 

Figure 152: Cross-sections at different locations along the scanning direction showing (left) formation of keyhole 
and (right) maximum melt pool dimensions for P=600 W, V=200 mm/s. See the text for more. 
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Figure 153: Cross-section showing the experimental melt track for the same processing conditions shown in 
Figure 152. From [2024Hol-Fig9].

Other Resources

Read more about the Additive Manufacturing (AM) Module on our website including the 
details about database compatibility or to watch an introductory webinar. You can also use 
the Getting Started Guide to learn about the key features available. 

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.
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AM_14: Using the Top-hat Beam Shape

This Steady-state example demonstrates the use of Top-hat Heat Source model in the AM Module with 
Batch calculations. 

The processing parameters (power and speed) and other processing conditions such as the layer thickness 
are taken from Sow et al. [2020Sow]. The example also compares the predicted melt pool dimensions with 
the experimental data.

For TC-Python users, there is an example using Top-hat: pyex_AM_10_TopHat_BeamShape.py.

There is a companion example in Graphical Mode using Core-ring: "AM_13: Using the Core-ring 
Beam Shape" on page 213. 

Project File and License Information

 l Folder: Additive Manufacturing

 l File name: AM_14_TopHat_BeamShape.tcu

This example requires an Additive Manufacturing (AM) Module license.

Background

The primary benefit of the Top-hat heat source beam shape, in comparison to the Gaussian beam shape, is 
uniform energy distribution across the beam spot, leading to even heating of the material surface. With 
lower peak intensity as compared to the Gaussian beam, a Top-hat beam also allows the use of larger 
beam size that not only increases productivity but also reduces vapor-induced instabilities [2020Sow]. The 
inclusion of Top-hat heat source model in the AM Module, together with the keyhole model, allows you to 
predict the temperature evolution and melt pool shape along with the transition from conduction mode to 
keyhole mode for a Top-hat heat source. The example uses experimental data taken from the literature  
[2020Sow] and demonstrates the use of Top-hat heat source with a rather large beam size for single track 
experiments on an IN625 alloy.

Additive Manufacturing (AM) Module Examples Collection ǀ 221 of 431



Material Properties

 l IN625: Ni-21.5Cr-5.0Fe-0.5Si-0.5Mn-9.0Mo-0.4Ti-1.0Co-1.8Nb-1.8Ta-0.4Al Mass percent

 l Database: TCNI12 and with solute trapping and interface scattering = 1e-07.

 l The material properties are precalculated, and stored as a built-in material library with the Additive 
Manufacturing (AM) Module.

AM Calculator Configuration Settings

This example contains one AM Calculator, which is renamed to Top-hat. On the Configuration window, 
Conditions tab, this Steady-state calculation is configured with the Top-hat Heat Source with the Keyhole 
model.

Fluid flow is not used in this example (the Fluid flow including Marangoni effect checkbox is 
not selected). Although fluid flow plays a crucial role in determining the shape and size of the 
melt pool, in this case it was found that it overestimates the melt pool width for most cases 
when fluid flow is included.

In the Geometry section, the Height of the base plate is set to 3.0 mm and in the Scanning Strategy section 
the Layer thickness is changed to 50.0 μm.

In the Heat Source section, the Beam radius is set to 450 μm. 

In the [2020Sow] paper, it is mentioned that the beam diameter for the top-hat distribution is 
500 μm. However, in Figure 2 of this paper, where intensity is plotted against the distance for 
the top-hat beam, the actual diameter looks much larger than that. In order to match the 
intensity distribution, the beam radius is therefore set to 450 μm. 

Also in the Heat Source section, the Absorptivity is set to Calculated with a prefactor of 1.0 and in the 
keyhole model, Beam quality factor M2 is kept as 1.0.

The Batch Calculation Type is used to set up all the conditions from the experiments in a single calculation. 
In the Batch Experiment Data section, the experimental Power and scan Speed as well as the measured 
melt pool Width (Exp width) and Depth (Exp. depth) were collected in a CSV file and imported into the 
software. This data is then saved in the project file.

Data with the error bars is also read and stored in the project file, that is later used to plot error bars 
together with the experimental values of melt pool width and depth.
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In the Batch Experiment Data table, the Power is always 1000 W and the scan Speed ranges between 25 
mm/s to 500 mm/s.

Visualizations

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it takes a few minutes for the calculations to complete.

Parity Plot

This specific Parity plot is shown by clicking the Parity Plot node in the Project window. Then you can see 
on the Visualizations window it is in the tab of the same name. The settings are located on the 
Configuration window on the Batch tab.

The plot compares experimental and calculated melt pool width and depth. It can be seen that the 
calculated melt pool width shows a fairly good agreement with the measured values. A mixed trend is 
however, seen for the melt pool depth. For lower energy densities, the calculated and measured melt pool 
depth matches quite well, however it starts to deviate once the melting appears to happen in the keyhole 
mode in the experiments, while it is still in the conduction mode in the calculations. For the last three 
points, where the calculations also predict a keyhole mode, the melt pool depth matches quite well with 
the measured value, except for the very last point where it is somehow overpredicted. The difference in 
depth could be attributed to the uncertainty in the actual beam size of the top-hat beam.
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Figure 154: Parity plot comparing experimental and calculated melt pool width and depth for all the experiments. 
The experiments are single tracks on IN625 with constant power and varied scan speed using the Top-hat heat 
source. The Root Mean Square (RMS) error can also be seen as a dashed line.

Melt Pool Dimensions

This Melt Pool vs Energy Density plot is shown by clicking the Melt Pool Dimensions node in the Project 
window. Then you can see on the Visualizations window it is in the tab of the same name. The settings are 
located on the Configuration window on the Batch tab.

The plot shows a comparison of the experimental and calculated melt pool width and depth, where the 
error bars are also plotted with the measured data. Rather large error bars, especially for the higher energy 
density cases, show that the overall trend for the calculated values of melt pool width and depth is in good 
agreement with the measured values. Some improvements are however needed for the low energy density 
cases where a huge deviation is found between the calculated and measured values.
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Figure 155: A comparison of the experimental and calculated melt pool width and depth for all the experiments. 
The error bars on the experimental data are also shown.
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3D Plots

 

  

Figure 156: A comparison of the temperature distribution for three different processing conditions: (top-
left) P=1000 W, V=25 mm/s, (top-right) P=1000 W, V=50 mm/s, both of which form keyhole during melting and 
(bottom-left) P=1000 W, V=250 mm/s that undergoes melting in conduction mode.

For the comparisons in Figure 157, all cross-sections are taken where the melt pools attain maximum width 
and depth. Red and blue isocontours show liquidus and solidus temperatures, respectively.
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Figure 157: Cross-sections comparing melt pool shape and size for (top-left) P=1000 W, V=25 mm/s, (top-right) 
P=1000 W, V=50 mm/s and (bottom-left) P=1000 W, V=250 mm/s. 

Other Resources

Read more about the Additive Manufacturing (AM) Module on our website including the 
details about database compatibility or to watch an introductory webinar. You can also use 
the Getting Started Guide to learn about the key features available. 
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Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Reference

[2020Sow] M. C. Sow, T. De Terris, O. Castelnau, Z. Hamouche, F. Coste, R. Fabbro, P. Peyre, Influence of 
beam diameter on Laser Powder Bed Fusion (L-PBF) process. Addit. Manuf. 36, 101532 (2020).
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AM_15: Electron Beam Melting in an IN718 Alloy

This steady-state example demonstrates the use of Electron Beam Heat Source for Batch calculations.

The experimental data as well as the process conditions are taken from [2019Din]. The steady-state 
calculations represent single bead experiments where electron beam was used to scan an IN718 base plate 
at 1025 °C. The example also compares the predicted melt pool dimensions with the experimental data 
from this paper.

For TC-Python users, there is a comparable  example: pyex_AM_12_Electron_Beam_Melting_
IN718.py.

Project File and License Information

 l Folder: Additive Manufacturing

 l File name: AM_15_Electron_Beam_Melting_IN718.tcu

This example requires an Additive Manufacturing (AM) Module license.

Background

In an Electron Beam melting (EBM) process, a high energy electron beam is used to selectively melt the 
powder layer inside a vacuum chamber. In the Additive Manufacturing (AM) Module, the energy 
distribution from the electron beam is approximated using a Gaussian profile. In the paper [2019Din], 
authors performed a series of single bead experiments on the IN718 base plate (Case B in the paper) using 
an A2X EBM system (Arcam AB). The process was performed under a controlled vacuum.

Material Properties

 l IN718: Ni-0.05C-0.14Mn-0.08Si-18.27Cr-0.57Al-2.9Mo-5.15Nb-0.01Ta-1.04Ti-0.79Co-19.18Fe-
0.04Cu Mass percent

 l Database: TCNI12 and with interface scattering = 1e-07. The material properties are precalculated, 
and stored as a built-in material library with the Additive Manufacturing (AM) Module.
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AM Calculator Configuration Settings

This example contains one AM Calculator, which is renamed to Electron Beam Melting. On the 
Configuration window, Conditions tab, this Steady-state calculation is configured with the Electron Beam 
Heat Source with the Keyhole model and includes Fluid flow.

The Gas pressure is set to 0.2 Pascal. The Base plate temperature as well as the Ambient temperature are 
set to 1025 °C. The Height of the base plate is set to 3.0 mm.

The Absorptivity of the Electron Beam heat source is set to be Calculated with a prefactor of 1.0. The 
Acceleration voltage  of the beam, as mentioned in the paper, is set 60.0 kV.

The Beam radius of the electron beam is not mentioned in the experimental setup of the paper. We have 
set the Beam radius to 125.0 μm, which is also the minimum beam radius of the A2X EBM system. The 
Convective heat transfer coefficient is set to 0.0 W/m2 to eliminate any heat loss due to convection in the 
vacuum chamber.

Experimental data for the Batch calculation is taken from Case B in the paper (single bead experiments on a 
bare metal plate). Data for low scanning speed i.e. < 300 mm/s is not included in the example.

Visualizations

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

Parity Plot

This specific Parity plot is shown by clicking the Parity Plot node in the Project window. Then you can see 
on the Visualizations window it is in the tab of the same name. The settings are located on the 
Configuration window on the Batch tab.
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The plot compares experimental and calculated melt pool width and depth for all experiments. The 
experiments are single bead experiments on bare plate IN718 with varied power and scan speed using an 
Electron Beam heat source.

Figure 158: Parity plot comparing experimental and calculated melt pool width and depth for all the experiments 
when using an Electron Beam heat source. The Root Mean Square (RMS) error can also be seen as a dashed line.
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3D Plots

 

Figure 159: A comparison of the keyhole profile for two different processing conditions (left) P=600 W, v=1000 
mm/s, and (right) P=1000 W, v=300 mm/s.

Other Resources

Read more about the Additive Manufacturing (AM) Module on our website including the 
details about database compatibility or to watch an introductory webinar. You can also use 
the Getting Started Guide to learn about the key features available. 

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Reference

[2019Din] X. Ding, Y. Koizumi, D. Wei, and A. Chiba, “Effect of process parameters on melt pool geometry 
and microstructure development for electron beam melting of IN718: A systematic single bead analysis 
study,” Addit. Manuf., vol. 26, pp. 215–226, Mar. 2019.
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Diffusion Module (DICTRA) Examples Collection

These are the Graphical Mode examples. There are separate Console Mode examples also 
available. 

Examples using up to three elements are available to all users. The other examples require a 
Diffusion Module (DICTRA) license to calculate and plot results. 

The Role of Diffusion in Materials: A Tutorial is available for download on our website. It is 
intended for engineers interested in using the Diffusion Module (DICTRA), as well as students 
learning about the role of diffusion in materials. It is designed to be useful at many levels, 
from undergraduate studies to someone with a PhD and experience in a related field.

These examples use the Diffusion Calculator. All examples use demonstration database packages included 
with your installation no matter what licenses you have.

In this section:

D_01: Homogenization of a Binary Fe-Ni Alloy 234

D_02: Ferrite(bcc)/Austenite(fcc) Transformation in a Binary Fe-C Alloy 237

D_03: Evolution of an Fe-Cr-Ni Diffusion Couple 240

D_04: Fe-C Moving Boundary - Austenite to Ferrite 243

D_05: γ/α/γ Diffusion Couple of Fe-Ni-Cr alloys 248

D_06: Diffusion Through a Tube Wall 254

D_07: Multiphase Carburization of an Alloy 258

D_08: Microsegregation During Solidification 262

D_09: Ni Post Weld Heat Treatment 265

D_10: Iron (Fe) Homogenization in Scheil 269
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D_01: Homogenization of a Binary Fe-Ni Alloy

The single phase example simulates the diffusion of Fe and Ni at a temperature of 1400 K in a planar 
domain. At this temperature the material is fully austenitic, i.e. the only phase present is the so-called fcc 
(face centered cubic) phase. Initially, there is a linear variation in Ni going from 10 mass-% on the left-hand 
side to 50 mass-% on the right-hand side. 

Project File Information

 l Folder: Diffusion Module - DICTRA

 l File name: D_01_Diffusion_Single_Phase.tcu

This example is part of the Diffusion Module (DICTRA) Quick Start Guide available to all users. A 
version of the example is also available for Console Mode.

Visualizations

This example is included as a Diffusion Module (DICTRA) tutorial on our website and as part of 
the  playlist on our YouTube channel. 

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.

 l Composition Profiles and Thermal Profile: When setting up a calculator on a Configuration window 
you can preview the profile and adjust settings as needed. When you click a calculator node in the 
Project window, the matching name of the node is on the tab(s) displayed in the Visualizations 
window. 

 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.
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Figure 160: During set up of the calculation, you can preview the Composition Profile (shown) or Thermal Profile. 
Click the tab(s) in the Visualizations window to switch between these previews and adjust settings on the 
Diffusion Calculator Configuration window. For an Isothermal Thermal Profile this shows the constant 
temperature as entered. 
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Figure 161: After performing the calculation, you can view the  result on the Composition of Ni vs Distance tab, 
which shows the initial and final Ni profile. In this example, the Plot Renderer is renamed and this matches the 
tab name in the Visualizations window.
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D_02: Ferrite(bcc)/Austenite(fcc) Transformation in a 
Binary Fe-C Alloy

The moving phase boundary example  simulates the growth of ferrite (bcc) into austenite (fcc). The 
austenite is assumed to be initially homogeneous with the composition Fe-0.15 mass-% C. The 
transformation temperature is 1050 K. The initial thickness of the austenite is 2 mm and an initially very 
thin ferrite (1 nm) is also present at the start of the simulation. 

Project File Information

 l Folder: Diffusion Module - DICTRA

 l File name: D_02_Diffusion_Moving_Boundary.tcu

This example is part of the Diffusion Module (DICTRA)  Quick Start Guide available to all users. 
A version of the example is also available for Console Mode.

Visualizations

This example is included as a Diffusion Module (DICTRA) tutorial on our website and as part of 
the  playlist on our YouTube channel. 

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.

 l Composition Profiles and Thermal Profile: When setting up a calculator on a Configuration window 
you can preview the profile and adjust settings as needed. When you click a calculator node in the 
Project window, the matching name of the node is on the tab(s) displayed in the Visualizations 
window. 

 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.
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Figure 162: During set up of the calculation, you can preview the Composition Profile (shown) or Thermal Profile. 
Click the tab(s) in the Visualizations window to switch between these previews and adjust settings on the 
Diffusion Calculator Configuration window. For an Isothermal Thermal Profile this shows the constant 
temperature as entered. 
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Figure 163: After performing the calculation, you can view the result on the Position of interface vs time tab. In 
this example, the Plot Renderer is renamed and this matches the tab name in the Visualizations window. 

Figure 164: After performing the calculation, you can view the result on the Composition profile C tab. In this 
example, the Plot Renderer is renamed and this matches the tab name in the Visualizations window.
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D_03: Evolution of an Fe-Cr-Ni Diffusion Couple

The multiphase example simulates the evolution of an Fe-Cr-Ni diffusion couple during a 100 hour heat 
treatment at  1100° C (1373.15 K). Both end members of the diffusion couple are duplex ferrite plus 
austenite, but the majority phase is ferrite on the left-hand side and austenite on the right. 

With this type of simulation it is assumed that the material is fully equilibrated at each grid point, i.e. the 
local phase fractions, phase compositions and so forth are obtained from an equilibrium calculation with 
the local overall composition as a condition. 

More details about the homogenization model for multiphase simulations can be found in Larsson and 
Engström [2006Lar]   and Larsson and Höglund [2009Lar]. Experimental data is from Engström [1995Eng]. 

Project File Information

 l Folder: Diffusion Module - DICTRA

 l File name: D_03_Diffusion_Multiphase.tcu

This example is part of the Diffusion Module (DICTRA)  Quick Start Guide available to all users. 
A version of the example is also available for Console Mode.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.

 l Composition Profiles and Thermal Profile: When setting up a calculator on a Configuration window 
you can preview the profile and adjust settings as needed. When you click a calculator node in the 
Project window, the matching name of the node is on the tab(s) displayed in the Visualizations 
window. 
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 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.

Figure 165: During set up of the calculation, you can preview the Composition Profile (shown) or Thermal Profile. 
Click the tab(s) in the Visualizations window to switch between these previews and adjust settings on the 
Diffusion Calculator Configuration window. For an Isothermal Thermal Profile this shows the constant 
temperature as entered. 
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Figure 166: After performing the calculation, you can view the  result on the Phase fraction of FCC tab. In this 
example, the Plot Renderer is renamed and this matches the tab name in the Visualizations window.

References
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D_04: Fe-C Moving Boundary - Austenite to Ferrite

This example simulates the austenite to ferrite transformation in a Fe-0.01 mass% C steel during 
continuous cooling. The simulation starts at a temperature where only austenite is stable, ferrite nucleates 
and grows into the austenite during cooling in the two phase region. Plots of thermal and carbon 
composition profiles are generated.

Project File Information

 l Folder: Diffusion Module - DICTRA

 l File name: D_04_Diffusion_Fe-C_Moving_Boundary_Austenite_to_Ferrite.tcu

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.

 l Composition Profiles and Thermal Profile: When setting up a calculator on a Configuration window 
you can preview the profile and adjust settings as needed. When you click a calculator node in the 
Project window, the matching name of the node is on the tab(s) displayed in the Visualizations 
window. 

 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.
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Figure 167: During set up of the calculation, preview the Composition Profile. Click the tab in the Visualizations 
window to switch between these previews and adjust settings on the Diffusion Calculator Configuration window. 
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Figure 168: During set up of the calculation,  preview the non-isothermal Thermal Profile. Click the tab in the 
Visualizations window to switch between these previews and adjust settings on the Diffusion Calculator 
Configuration window. Also see the plot result comparing the thermal profile for the two regions.
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Figure 169: After performing the calculation,  view the result on the Thermal profile tab. In this example, the Plot 
Renderer is renamed and this matches the tab name in the Visualizations window. Note that this Thermal Profile 
is slightly different than what you can preview during set up.
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Figure 170: After performing the calculation, view the  result on the Carbon composition profile tab. In this 
example, the Plot Renderer is renamed and this matches the tab name in the Visualizations window.
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D_05: γ/α/γ Diffusion Couple of Fe-Ni-Cr alloys

This example demonstrates the evolution of a ternary Fe-Cr-Ni diffusion couple. A thin slice of ferrite (α 
phase) (38%Cr,0%Ni) is clamped between two thicker slices of austenite (γ phase) (27%Cr, 20%Ni). The 
assembly is subsequently heat treated at 1373 K. 

This set up corresponds to diffusion couple in Kajihara et al. [1993aKaj] and Kajihara and Kikuchi 
[1993bKaj].

Project File Information

 l Folder: Diffusion Module - DICTRA

 l File name: D_05_Diffusion_Fe_Ni_Cr_Moving_Boundary_Diffusion_Couple.tcu

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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When you run (Perform) this example, it takes a few minutes for the calculations to complete.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.

 l Composition Profiles and Thermal Profile: When setting up a calculator on a Configuration window 
you can preview the profile and adjust settings as needed. When you click a calculator node in the 
Project window, the matching name of the node is on the tab(s) displayed in the Visualizations 
window. 

 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.

Figure 171: In this example, all Plot Renderer nodes are renamed and each match a tab name in the Visualizations 
window. Use the left and right arrows in the Visualizations window to move through the tabs and the down arrow 
to choose by name when a tab is not visible. 
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Figure 172: During set up of the calculation, preview the Composition Profile (shown) or Thermal Profile. Click the 
tab(s) in the Visualizations window to switch between these previews and adjust settings on the Diffusion 
Calculator Configuration window. For an Isothermal Thermal Profile this shows the constant temperature as 
entered. 

Figure 173: After performing the calculation, view the  result on the  Interface position tab. 
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Figure 174: After performing the calculation,  view the result on the Concentration profiles at 3600 s tab.

Figure 175: After performing the calculation,  view the result on the Concentration profiles at 36 000 s tab. 
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Figure 176: After performing the calculation,  view the  on the Concentration profiles at 360 000 s tab. 

Figure 177: After performing the calculation,  view the  result on the Concentration profiles at 3 600 000 s tab. 
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Figure 178: After performing the calculation,  view the  result on the Diffusion paths tab. 
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D_06: Diffusion Through a Tube Wall

This is a simple example of diffusion through a tube wall. The tube material is an Fe-0.06Mn-0.05C alloy. 
Two plots comparing distance to the U-fraction of manganese and composition of carbon are generated to 
visualize the austenite region. A cylindrical geometry is used with mixed zero flux and activity boundary 
conditions. 

On the inside wall a carbon activity of 0.9 is maintained whereas on the outside the carbon activity is very 
low. This example demonstrates the use of boundary conditions, advanced plotting and tables. 

Project File Information

 l Folder: Diffusion Module - DICTRA

 l File name: D_06_Diffusion_Carburization_Tube.tcu

This example is based on Console Mode exab6. When in Console Mode, you can open the 
example from Thermo-Calc  (File → Examples Files → Diffusion Module). 

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.

 l Composition Profiles and Thermal Profile: When setting up a calculator on a Configuration window 
you can preview the profile and adjust settings as needed. When you click a calculator node in the 
Project window, the matching name of the node is on the tab(s) displayed in the Visualizations 
window. 
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 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.

Figure 179: During set up of the calculation, you can preview the Composition Profile (shown) or Thermal Profile. 
Click the tab(s) in the Visualizations window to switch between these previews and adjust settings on the 
Diffusion Calculator Configuration window. For an Isothermal Thermal Profile this shows the constant 
temperature as entered. 
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Figure 180: After performing the calculation, you can view the  result on the Composition of C vs Distance tab. In 
this example, the Plot Renderer is renamed and this matches the tab name in the Visualizations window.

Figure 181: After performing the calculation, you can view the result on the U-fraction of Mn vs Distance tab. In 
this example, the Plot Renderer is renamed and this matches the tab name in the Visualizations window.
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Figure 182: After performing the calculation, you can view the result on the Table Composition C vs Distance tab. 
In this example, the Table Renderer is renamed and this matches the tab name in the Visualizations window.
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D_07: Multiphase Carburization of an Alloy

This example is based on Engström et al. [1994Eng] and is about carburization of a Ni-25Cr-0.0001C alloy. In 
this case the M7C3 and M3C2 carbides are entered as spheroid phases in an FCC_A1 matrix. It is similar to 
Graphical Mode example D_06 except the default simulation condition is automatically set to use the 
homogenization model. 

The isothermal calculation is run for 1000 hours at a temperature of 1123 K using the mixed zero flux and 
activity left boundary condition. Results are plotted using two Plot Renderers and a Table Renderer.

Project File Information

 l Folder: Diffusion Module - DICTRA

 l File name: D_07_Diffusion_Carburization_Multiphase.tcu

This example is based on Console Mode exd1b. When in Console Mode, you can open the 
example from Thermo-Calc  (File → Examples Files → Diffusion Module). 

Visualizations

This example is included as a Diffusion Module (DICTRA) tutorial on our website and as part of 
the  playlist on our YouTube channel. 

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it takes a few minutes for the calculations to complete.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.

 l Composition Profiles and Thermal Profile: When setting up a calculator on a Configuration window 
you can preview the profile and adjust settings as needed. When you click a calculator node in the 
Project window, the matching name of the node is on the tab(s) displayed in the Visualizations 
window. 
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 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.

Figure 183: During set up of the calculation, you can preview the Composition Profile (shown) or Thermal Profile. 
Click the tab(s) in the Visualizations window to switch between these previews and adjust settings on the 
Diffusion Calculator Configuration window. For an Isothermal Thermal Profile this shows the constant 
temperature as entered. 
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Figure 184: After performing the calculation, you can view the  result on the Phase fraction vs distance tab. In this 
example, the Plot Renderer is renamed and this matches the tab name in the Visualizations window. 

Figure 185: After performing the calculation, you can view the  result on the Table of Composition profiles tab. In 
this example, the Table Renderer is renamed and this matches the tab name in the Visualizations window.
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Figure 186: After performing the calculation, you can view the result on the Composition of C vs distance tab. In 
this example, the Plot Renderer is renamed and this matches the tab name in the Visualizations window.
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D_08: Microsegregation During Solidification

This application example, which is available on our website, shows how Thermo-Calc together with the 
Diffusion Module (DICTRA) can be used to investigate and predict microsegregation  (solute redistribution) 
during solidification. 

The example is based on a real case where the elemental distribution of a continuously cast steel was 
measured revealing the concentration of the elements Si, Mn, and P as sketched in Figure 1. The profile 
results from the well-known segregation across secondary dendrite arms. The interesting point is that the 
elements Si and Mn show the expected positive segregation (higher concentrations) in the interdendritic 
regions. The peak of the P content, on the other hand, is shifted compared to Si and Mn, and, in fact, shows 
negative segregation in the interdendritic region. This is unexpected and counterintuitive.

The calculations are based on ones performed in the frame of a research project funded by the European 
Union called VESPISM – Virtual Experiments to Solve Problems in Metallurgy – conducted from 2001 to 
2004. 

Project File and License Information

 l Folder: Diffusion Module - DICTRA

 l File name: D_08_Diffusion_Microsegregation_During_Solidification.tcu

Running this calculation requires licenses for the Add-on Diffusion Module (DICTRA) plus the 
steels thermodynamic database (TCFE) and mobility database (MOBFE). For best results, 
TCFE14 and MOBFE8.1 and newer (as of 2025a) are recommended.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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When you run (Perform) this example, it takes a few minutes for the calculations to complete.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.

 l Composition Profiles and Thermal Profile: When setting up a calculator on a Configuration window 
you can preview the profile and adjust settings as needed. When you click a calculator node in the 
Project window, the matching name of the node is on the tab(s) displayed in the Visualizations 
window. 

 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.

 

Figure 187: During set up of the calculation, you can preview the Composition Profile. Click the tab in the 
Visualizations window to switch between these previews and adjust settings on the Diffusion Calculator 
Configuration window. 
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The other resulting plots and details related to setting up this example are available to 
download via the dedicated web page.  
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D_09: Ni Post Weld Heat Treatment

In this example, a Ni-based alloy (Ni-Al-Co-Cr-Mo-Ti) post weld heat treatment analysis is completed. It 
shows how to import an initial composition profile from a file into the Diffusion Calculator. Then the 
calculation is run and plotted to show the composition of Al vs distance compared to experimental data 
from [2017She]. Such simulations can be used to design the heat treatment such that the desired 
homogenization of the weld is achieved. The initial composition profile needs to be determined by suitable 
experimental techniques, for example microprobe.

This example highlights the dual purpose of the Visualizations window where you can enter or import 
Composition profiles via the Diffusion Calculator Configuration window as well as being able to view and 
analyze results via the Plot Renderer after a calculation runs. 

Project File Information

 l Folder: Diffusion Module - DICTRA

 l File name: D_09 Ni_Post_Weld_Heat_Treatment_From_File.tcu

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

On the Diffusion Calculator, when defining its setup, the Composition profiles are imported using the Table 
input option. A prepared file, in this case a csv file, is set up with the correct data columns, which then are 
included on the Configuration window. After import the Composition Profiles are further able to be seen 
via the Visualizations window, at which point adjustments can be made as needed.  In this isothermal 
example, you can also see that the constant temperature of the Thermal Profile is  previewed.

Diffusion Module (DICTRA) Examples Collection ǀ 265 of 431

https://www.thermocalc.com/training/video-tutorials/
https://www.youtube.com/channel/UCLTh3apGItuaVK69mrwcpJg/featured


Figure 188: The Diffusion Calculator Configuration window showing the composition profile data, which is then 
compiled and displayed on the Visualizations window.

Figure 189: The Visualizations window displays details from both the Diffusion Calculator node (renamed to Post-
weld heat treatment) via the Composition Profile and Thermal Profile tabs as well as the Plot Renderer node 
(renamed to Composition of Al vs Distance).
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Figure 190: The Composition Profiles as shown in the Visualizations window after data is prepared and then 
imported into the Diffusion Calculator Configuration window.

An Experimental File Reader node is used to supply experimental data from [2017She] to the Plot 
Renderer to validate the composition of, for example, Al vs distance on the Plot Renderer. The plot shows 
the content of Al along the cross-section of the weld, both before and after the post weld heat treatment. 
There is good agreement between the diffusion simulation and the data measured in the literature.
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Figure 191: Plot results showing the mole fraction of Al before and after the heat treatment as a function of 
distance for a Ni-based alloy compared to experimental data [2017She].

Other plots can be added to investigate further details of the simulations, such as phase fractions or 
compositions.
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D_10: Iron (Fe) Homogenization in Scheil

This example models the homogenization of a cast Ni-Cr steel and compares predictions with the 
experimental data collated by Fuchs and Roósz [1975Fuc]. The conditions studied have a dendritic half 
spacing of 200 µm and are heat treated to temperatures of 1120 °C and 1235 °C. The data has been un-
normalized to allow comparison using wt.% composition values.

The composition of the steel is 0.4C, 0.65Mn, 0.35Si, 0.015S, 0.01P, 1.9Ni, 0.95Cr, and 0.3 Mo (wt.%). The 
diffusion of Cr and Ni are modeled using a simplified chemistry of 0.4C, 0.65Mn, 1.9Ni, and 0.95Cr.

Project File and License Information

 l Folder: Diffusion Module - DICTRA

 l File name: D_10_Fe _Homogenization_from_Scheil.tcu

The Diffusion Module (DICTRA) Console Mode example exa7 is available to show the use of 
Scheil segregation profiles in Console Mode.

The FEDEMO thermodynamic and MFEDEMO mobility databases are used with this example. 
Users with a Diffusion Module (DICTRA) license can run the example. Other users can read the 
documentation as a DEMO license only allows the use of up to three components.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.
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 l Composition Profiles and Thermal Profile: When setting up a calculator on a Configuration window 
you can preview the profile and adjust settings as needed. When you click a calculator node in the 
Project window, the matching name of the node is on the tab(s) displayed in the Visualizations 
window. 

 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.

Figure 192: The predicted chemical segregation using the Scheil calculation, with a dendritic half spacing of 200 
µm. This is the Composition Profile that is set up on the Diffusion Calculator and then previewed in the 
Visualizations window. 
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Figure 193: The solidification behavior predicted from the Scheil calculation compared with the equilibrium solid 
fraction.

Figure 194: A comparison of the predicted and measured maximum Cr across the dendrites during 
homogenization at 1120 °C.
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Figure 195: A comparison of the predicted and measured maximum Ni across the dendrites during 
homogenization at 1120  °C.

Figure 196: A comparison of the predicted and measured maximum Cr across the dendrites during 
homogenization at 1235 °C.
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Figure 197: A comparison of the predicted and measured maximum Ni across the dendrites during 
homogenization at 1235 °C.
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Precipitation Module (TC-PRISMA) Examples Collection

Examples that use up to three elements are available to all users. Other examples require a 
Precipitation Module (TC-PRISMA) license to calculate and plot results. 

When an example uses a demonstration (demo) database package, this is included with your 
installation. 

Unless specified in tables for each example, all the numerical parameters are assumed default 
values.

In this section:

P_01: Isothermal Precipitation of Al3Sc 276

P_02: Stable and Metastable Carbides - Isothermal 281

P_03: Stable and Metastable Carbides - TTT Diagram 285

P_04: Precipitation of Iron Carbon Cementite 289

P_05: Precipitation of γ’ in Ni Superalloys - Isothermal 292

P_06: Precipitation of γ’ in Ni Superalloys - Non-isothermal 297

P_07: Continuous Cooling Transformation (CCT) Diagram of Ni-Al-Cr γ-γ’ 305

P_08: Precipitation of Cu-Ti CU4TI with Assumptions of Sphere and Needle Morphologies 308

P_09: Precipitation of Al-Sc AL3SC with Assumption of Sphere and Cuboid Morphologies 314

P_10: Initial Particle Size Distribution of Fe-Cr-C 320

P_11: Interfacial Energy Function 327

P_12: Comparing Growth Rate Models for an Al-Zr System 330

P_13: Paraequilibrium Precipitation of Cementite Fe-C-Cr 334
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P_14: Grain Growth and the Zener Pinning Effect 337

P_15: Smooth Transition from Paraequilibrium to Ortho-equilibrium 341

P_16 Isothermal Coarsening and  a 3D to 2D Stereological Conversion 346
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P_01: Isothermal Precipitation of Al3Sc
This example simulates the kinetics of precipitation of Al3Sc from an FCC_A1 solution phase. The simulation 
results can be compared with experimental data collected from Marquis and Seidman [2001Mar] and 
Novotny and Ardell [2001Nov].

This example also includes a plot using the Yield strength Property Model. This demonstrates how you can 
use the results from a Precipitation Module (TC-PRISMA) simulation as input to the Yield Strength Model, 
i.e. the calculated precipitate radius/radii for each time step is used to calculate the precipitation 
strengthening, and similarly, the matrix composition for each time step is used to calculate the solid 
solution strengthening when this is selected in the Configuration on the Plot Renderer. The experimental 
data for the Yield Strength Model is from Seidman et al. [2002Sei]. In this example, the Precipitation 
strengthening model used is Seidman model (Al-base). This is selected on the Plot Renderer configuration 
panel that is connected to the Property Model.

Project File and Step-By Step Instructions

 l Folder: Precipitation Module - TC-PRISMA

 l File name: P_01_Precipitation_Al-Sc_AL3SC.tcus

Example Settings

System (System Definer)

Database package
Demo: Aluminum-based alloys 
(ALDEMO, MALDEMO)

Elements Al, Sc

Conditions (Precipitation Calculator)

Composition Al-0.18Sc Mole percent

Matrix phase FCC_A1

Precipitate phase AL3SC

Precipitate Phase Data Parameters (Precipitation Calculator)

Nucleation sites Bulk
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Interfacial energy Calculated

Calculation Type (Precipitation Calculator)

Calculation type Isothermal

Temperature 350° C

Simulation time 1.0E7 seconds

Experimental File Reader 1 and 2  

There are two Experimental File Reader nodes used. One for the mean radius plot and 
one to demonstrate the Yield Strength Property Model.

 

Visualizations

This example is included as a Precipitation Module (TC-PRISMA) tutorial on our website and as 
part of the  playlist on our YouTube channel. 

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.

 l Thermal Profile: When setting up a calculator on a Configuration window for Isothermal or Non-
isothermal Calculation Types, you can preview the profile and adjust settings as needed. When you 
click a calculator node in the Project window, the matching name of the node is on the tab(s) 
displayed in the Visualizations window. 

For TTT Diagram and CCT Diagram calculations there is nothing shown for the 
Precipitation Calculator tab in the Visualizations window as there is no Thermal Profile 
to be defined.
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 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.

Figure 198: During set up of the calculation,  preview the  Thermal Profile. Click the tab in the Visualizations 
window to  preview it. For an Isothermal Thermal Profile this shows the constant temperature as entered. 
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Figure 199: After performing the calculation, you can view the  result on the applicable tab. This plot shows the 
mean radius of the AL3SC precipitate as a function of time.
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Figure 200: After performing the calculation, you can view the  result on the applicable tab. This plot shows the 
total yield strength of the AL3SC precipitate as a function of time compared to experimental data from Siedmen 
et al. [2002Sei]. The model captures the over-tempering behavior from excessive coarsening of the strengthening 
precipitates.
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P_02: Stable and Metastable Carbides - Isothermal

This example simulates the kinetics of precipitation of both stable and metastable carbides from ferrite 
phase. It demonstrates that metastable carbides (cementite, M7C3) may first emerge and then disappear 
and the stable phase (M23C6) prevails. 

This example uses the Equilibrium Calculator  and a one axis calculation to determine how the phases 
change with temperature. We are interested in the carbide precipitation at 1053 K where only the carbide 
M23C6 is stable according to the equilibrium calculation. The Precipitation Calculator is used to do an 
isothermal calculation of the three phases (cementite, M23C6, and M7C3) where cementite and M7C3 are 
metastable phases. 

Project File Information

 l Folder: Precipitation Module - TC-PRISMA

 l File name: P_02_Precipitation_Fe-C-Cr_Cementite-M7C3-M23C6.tcu

Example Settings

System (System Definer)

Database package Demo: Steels and Fe-alloys (FEDEMO,MFEDEMO)

Elements Fe, C, Cr

Conditions (Precipitation Calculator)

Composition Fe-0.1C-12Cr Mass percent

Matrix phase BCC_A2

Precipitate phases Cementite, M23C6 and M7C3

Matrix Phase Data Parameters (Precipitation Calculator)

Grain size (click Show Details to display this setting) 1.0E-4 m

Precipitate Phase Data Parameters (Precipitation Calculator)

Nucleation sites Grain boundaries
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Interfacial energy Cementite 0.167 J/m2, M23C6 0.252 J/m2, M7C3 0.282 J/m2

Calculation Type (Precipitation Calculator)

Calculation type Isothermal

Temperature 1053 K

Simulation time 400 000 seconds

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.

 l Thermal Profile: When setting up a calculator on a Configuration window for Isothermal or Non-
isothermal Calculation Types, you can preview the profile and adjust settings as needed. When you 
click a calculator node in the Project window, the matching name of the node is on the tab(s) 
displayed in the Visualizations window. 

For TTT Diagram and CCT Diagram calculations there is nothing shown for the 
Precipitation Calculator tab in the Visualizations window as there is no Thermal Profile 
to be defined.

 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.
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For this Isothermal example, its Thermal Profile is also displayed in the Visualizations window 
showing the constant temperature entered for this calculation type. The tab names match the 
node names in the Project window.

Figure 201: After performing the calculation, you can view the  result on the applicable tab. This shows the 
equilibrium property diagram for the Fe-C-Cr alloy, highlighting what phases are predicted to be at equilibrium 
for a range of temperatures. The calculation shows that at 1053 K, M23C6 is the stable carbide.
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Figure 202: After performing the calculation, you can view the  result on the applicable tab. This shows the 
evolution of the volume fraction of cementite, M7C3, and M23C6 during an isothermal heat treatment of an Fe-C-
Cr alloy at 1073 K. The cementite and M7C3 are metastable at this temperature, however their nucleation 
kinetics are faster than the stable phase, allowing them to form and then dissolve when the next more 
thermodynamically stable phase nucleates.
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P_03: Stable and Metastable Carbides - TTT Diagram

In this example, the kinetics of precipitation of both stable and metastable carbides is calculated from the 
ferrite phase. It demonstrates that metastable carbides may first emerge and then disappear and the 
stable phase prevails.

This example uses the Equilibrium Calculator  and a one axis calculation type to determine how the phases 
change with temperature. Using this result,  the Precipitation Calculator is used to do a TTT (Time-
Temperature-Transformation) diagram calculation of the three phases (cementite, M23C6 and M7C3) at 
the grain boundaries.

For a TTT diagram calculation, select TTT diagram in Calculation Type, then enter Min, Max, and Step of 
Temperature, as well as Max annealing time. In Stop criterion, choose Volume fraction of phase and 
enter the value. 

Project File Information

 l Folder: Precipitation Module - TC-PRISMA

 l File name: P_03_Precipitation_Fe-C-Cr_TTT_Cementite-M7C3-M23C6.tcu

Example Settings

System (System Definer)

Database package Demo: Steels and Fe-alloys (FEDEMO and MFEDEMO)

Elements Fe, C, Cr

Conditions (Precipitation Calculator)

Composition Fe-0.1C-12Cr Mass percent

Matrix phase BCC_A2
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Precipitate phases Cementite, M23C6 and M7C3

Matrix Phase Data Parameters (Precipitation Calculator)

Grain size  (click Show Details to display this setting) 1.0E-4 m

Precipitate Phase Data Parameters

Nucleation sites Grain boundaries

Interfacial energy Cementite 0.167 J/m2, M23C6 0.252 J/m2, M7C3 0.282 J/m2

Calculation Type (Precipitation Calculator)

Calculation type TTT diagram

Temperature 500° to 800° C with 25° C steps

Max. annealing time 1.0E8 seconds

Stop criteria Volume fraction of phase is set to 0.0001

Options > Numerical Parameters

No. of grid points over one order of magnitude in radius 150

Max no. of grid points over one order of magnitude in radius 200

Min no. of grid points over one order of magnitude in radius 100

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.
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 l Thermal Profile: When setting up a calculator on a Configuration window for Isothermal or Non-
isothermal Calculation Types, you can preview the profile and adjust settings as needed. When you 
click a calculator node in the Project window, the matching name of the node is on the tab(s) 
displayed in the Visualizations window. 

For TTT Diagram and CCT Diagram calculations there is nothing shown for the 
Precipitation Calculator tab in the Visualizations window as there is no Thermal Profile 
to be defined.

 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.

Figure 203: After performing the calculation, you can view the result on the applicable tab. Here the results from 
the equilibrium calculator are shown, which assesses the stability of phases across the temperature range of 
interest.
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Figure 204: After performing the calculation, you can view the  result on the applicable tab.This shows results 
from a TTT (Temperature-Transformation) simulation using the Precipitation Calculator to examine the sequence 
of phase transitions considering the formation of cementite, M7C3, and M23C6 carbide phases. The previous 
Equilibrium Calculator reveals the temperatures where the cementite and M7C3 are metastable.

Precipitation Module (TC-PRISMA) Examples Collection ǀ 288 of 431



P_04: Precipitation of Iron Carbon Cementite

This example is based on  [1949Wer] and simulates the kinetics of precipitation of carbides from a BCC Fe 
solution phase. This isothermal calculation example uses the Precipitation Calculator plus two Experimental 
File Reader activities to plot the volume fraction  of the  cementite phase.

Project File  Information

 l Folder: Precipitation Module - TC-PRISMA

 l File name: P_04_Precipitation_Fe-C_Cemetite.tcu

Example Settings

System (System Definer)

Database package Demo: Steels and Fe-alloys (FEDEMO and MFEDEMO) 

Elements Fe, C

Conditions (Precipitation Calculator)

Composition Fe-0.016C mass percent

Matrix phase BCC_A2

Precipitate phase Cementite

Matrix Phase Data Parameters (Precipitation Calculator)

Grain aspect ratio   (click Show Details to display this setting) 1.0

Dislocation density    (click Show Details to display this setting) 1.5e11m-3

Precipitate Phase Parameters (Precipitation Calculator)

Nucleation sites Dislocations

Interfacial energy 0.24 J/m2
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Growth rate model (click Show Details) Advanced 

Calculation Type (Precipitation Calculator)

Calculation type Isothermal

Temperature 102° C

Simulation time 600 000 seconds

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it takes a few minutes for the calculations to complete.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.

 l Thermal Profile: When setting up a calculator on a Configuration window for Isothermal or Non-
isothermal Calculation Types, you can preview the profile and adjust settings as needed. When you 
click a calculator node in the Project window, the matching name of the node is on the tab(s) 
displayed in the Visualizations window. 

For TTT Diagram and CCT Diagram calculations there is nothing shown for the 
Precipitation Calculator tab in the Visualizations window as there is no Thermal Profile 
to be defined.

Precipitation Module (TC-PRISMA) Examples Collection ǀ 290 of 431

https://www.thermocalc.com/training/video-tutorials/
https://www.youtube.com/channel/UCLTh3apGItuaVK69mrwcpJg/featured


 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.

For this Isothermal example, its Thermal Profile is also displayed in the Visualizations window 
showing the constant temperature entered for this calculation type. The tab names match the 
node names in the Project window.

Figure 205: After performing the calculation, you can view the  result on the applicable tab. The result compares 
the predicted evolution of the volume fraction of cementite with the measurements of [1949Wer]. 

Reference

[1949Wer] C. A. Wert, Precipitation from Solid Solutions of C and N in α-Iron. J. Appl. Phys. 20, 943 (1949).
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P_05: Precipitation of γ’ in Ni Superalloys - Isothermal

This example simulates the kinetics of precipitation of gamma prime (γ’) phase from gamma (γ) phase. The 
simulation results can be compared with experimental data collected from Sudbrack et al. [2008Sud]. 

This example uses three Experimental File Reader activities with the Precipitation Calculator. It does an 
isothermal calculation to plot the volume fraction, mean radius, and number density of the  cementite 
phase.

DIS_FCC_A1 needs to be selected on the System Definer. 

Project File Information

 l Folder: Precipitation Module - TC-PRISMA

 l File name: P_05_Precipitation_Ni-Al-Cr_Isothermal_Gamma-Gamma_prime.tcu

Example Settings

System (System Definer)

Database package Demo: Nickel-based Super Alloys (NIDEMO and MNIDEMO)

Elements Ni, Al Cr

Conditions (Precipitation Calculator)

Composition Ni-9.8Al-8.3Cr Mole percent

Matrix phase DIS-FCC_A1 

Precipitate phase FCC_L12#2

Precipitate Phase Data Parameters (Precipitation Calculator)

Nucleation sites Bulk

Precipitation Module (TC-PRISMA) Examples Collection ǀ 292 of 431



Interfacial energy  0.012 J/m2

Calculation Type (Precipitation Calculator)

Calculation type Isothermal

Temperature 800° C

Simulation time 1 000 000 seconds

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.

 l Thermal Profile: When setting up a calculator on a Configuration window for Isothermal or Non-
isothermal Calculation Types, you can preview the profile and adjust settings as needed. When you 
click a calculator node in the Project window, the matching name of the node is on the tab(s) 
displayed in the Visualizations window. 

For TTT Diagram and CCT Diagram calculations there is nothing shown for the 
Precipitation Calculator tab in the Visualizations window as there is no Thermal Profile 
to be defined.

 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.
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For this Isothermal example, its Thermal Profile is also displayed in the Visualizations window 
showing the constant temperature entered for this calculation type. The tab names match the 
node names in the Project window.

Figure 206: After performing the calculation, you can view the result on the applicable tab. This plot compares the 
predicted evolution of the volume fraction of gamma prime with the measurements of [2008Sud]. 
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Figure 207: After performing the calculation, you can view the  result on the applicable tab. This plot compares the 
predicted evolution of the number density of gamma prime with the measurements of [2008Sud].

Figure 208: After performing the calculation, you can view the  result on the applicable tab. This plot compares the 
predicted evolution of the mean particle radius of gamma prime with the measurements of [2008Sud].
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Reference

[2008Sud] C. K. Sudbrack, T. D. Ziebell, R. D. Noebe, D. N. Seidman, Effects of a tungsten addition on the 
morphological evolution, spatial correlations and temporal evolution of a model Ni–Al–Cr superalloy. 
Acta Mater. 56, 448–463 (2008).
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P_06: Precipitation of γ’ in Ni Superalloys - Non-isothermal

This example simulates the kinetics of precipitation of gamma prime (γ’) phase from gamma (γ) phase in Ni-
8Al-8Cr and Ni-10Al-10Cr at.% alloys during continuous cooling from a super-solvus temperature. The 
simulation results can be compared with experimental results from Rojhirunsakool et al. [2013Roj].

DIS_FCC_A1 needs to be selected on the System Definer for both the thermodynamic and 
mobility databases. 

Project File Information

 l Folder: Precipitation Module - TC-PRISMA

 l File name: P_06_Precipitation_Ni-Al-Cr_Non-isothermal_Gamma-Gamma_prime.tcu

Example Settings

System (System Definer)

Database package Demo: Nickel-based Super Alloys (NIDEMO and MNIDEMO)

Elements Ni, Al, Cr

Conditions (Precipitation Calculator)

Composition (Ni-8Al-8Cr) Ni-8Al-8Cr Mole percent

Composition (Ni-10Al-10Cr) Ni-10Al-10Cr Mole percent

Matrix phase DIS_FCC_A1 
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Precipitate phase FCC_L12#2

Matrix Phase Data Parameters (Precipitation Calculator)

Mobility adjustment > Prefactor (click Show Details to 
display this setting)

Keep the default, Same for all elements, then enter 5.0 for 
the Prefactor.

Precipitate Phase Data Parameters (Precipitation Calculator)

Nucleation sites Bulk

Interfacial energy 0.023 J/m2

Calculation Type (Precipitation Calculator)

Calculation type Non-isothermal

Temperature unit Celsius

Time unit Seconds

Temperature

1150 - 380 °C

Simulation time (Ni-8Al-8Cr) 3300 s

Simulation time (Ni-10Al-10Cr) 3300 s

Multimodal PSD (Plot Renderer)

Separate multimodal PSD checkbox is selected for 8Al-8Cr 
for both the Mean radius and PSD plots.

 l Mean Radius and PSD plots: The Inflection 
neighbors and Smoothing interactions defaults are 
kept.

 l Mean Radius plot: The Points are set to 15.

Separate multimodal PSD checkbox is selected for 10Al-10Cr 
for both the Mean radius and PSD plots.

 l Mean Radius and PSD plots: The Inflection 
neighbors and Smoothing interactions defaults are 
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kept.

 l Mean Radius plot: The Points are set to 50.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it takes a few minutes for the calculations to complete.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.

 l Thermal Profile: When setting up a calculator on a Configuration window for Isothermal or Non-
isothermal Calculation Types, you can preview the profile and adjust settings as needed. When you 
click a calculator node in the Project window, the matching name of the node is on the tab(s) 
displayed in the Visualizations window. 

For TTT Diagram and CCT Diagram calculations there is nothing shown for the 
Precipitation Calculator tab in the Visualizations window as there is no Thermal Profile 
to be defined.

 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.
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 In this example, all nodes are renamed in the Project window, and this matches each of the 
tab names in the Visualizations window.

Figure 209: During set up of the calculation, you can preview the non-isothermal Thermal Profile(s). Click the tab 
in the Visualizations window to adjust settings on the Precipitation Calculator Configuration window. In this case 
the heat treatment is a continuous cooling curve, however any thermal profile can be modeled using the Non-
isothermal Calculation Type.
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Figure 210: These results show the predicted evolution of the mean radius of gamma prime populations 
nucleating during the quench for the Ni-8Al-8Cr alloy. Note that the tertiary particles (second particle population) 
are very small, and this dispersion would appear monomodal without TEM characterization.
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Figure 211: These results show the predicted evolution of the mean radius of gamma prime populations 
nucleating during the quench for the Ni-10Al-10Cr alloy. In this case three distinct particle populations are 
simulated to form, agreeing with [2013Roj].
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Figure 212: These results show the predicted size distributions of precipitates at different times during the quench 
of the for the Ni-8Al-8Cr alloy. The individual particle populations are distinguished using the “Separate 
multimodal PSD” option showing a bimodal distribution with very small nano-meter sized tertiary particles.
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Figure 213: These results show the predicted size distributions of precipitates at different times during the quench 
for the Ni-10Al-10Cr alloy. The individual particle populations are distinguished using the “Separate multimodal 
PSD” option showing the formation of a tri-modal dispersion.

Reference

[2013Roj] T. Rojhirunsakool, S. Meher, J. Y. Hwang, S. Nag, J. Tiley, R. Banerjee, Influence of composition on 
monomodal versus multimodal γ′ precipitation in Ni–Al–Cr alloys. J. Mater. Sci. 48, 825–831 (2013).
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P_07: Continuous Cooling Transformation (CCT) Diagram 
of Ni-Al-Cr γ-γ’

This example shows you how to simulate a CCT (Continuous Cooling Transformation) diagram for gamma 
prime (γ’) precipitation in a Ni-Cr-Al alloy using the Precipitation Calculator. A CCT calculation maintains the 
same cooling rate the entire time.

The system is a Ni-10Al-10Cr γ - γ’ alloy and it is calculated and plotted with superimposition of the cooling 
rate values.

Project File and Step-By Step Instructions

 l Folder: Precipitation Module - TC-PRISMA

 l File name: P_07_Precipitation_Ni-Al-Cr_CCT_Gamma-Gamma_prime.tcu

Example Settings

System (System Definer)

Database package Demo: Nickel-based Super Alloys (NIDEMO and MNIDEMO)

Elements Ni, Al, Cr

Conditions (Precipitation Calculator)

Composition Ni-10Al-10Cr Mole percent 

Matrix phase DIS_FCC_A1

Precipitate phase FCC_L12#2

Precipitate Phase Data Parameters (Precipitation Calculator)

Nucleation sites Bulk

Interfacial energy 0.023 J/m2

Calculation Type (Precipitation Calculator)

Calculation type CCT Diagram

Temperature Min to Max 500 to 1200 Kelvin
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Cooling rate(s) .01 .1 1 10 100 K/s

Stop criteria Volume fraction of phase 1.0E-4

Visualizations

This example is included as a Precipitation Module (TC-PRISMA) tutorial on our website and as 
part of the  playlist on our YouTube channel. 

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it takes a few minutes for the calculations to complete.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.

 l Thermal Profile: When setting up a calculator on a Configuration window for Isothermal or Non-
isothermal Calculation Types, you can preview the profile and adjust settings as needed. When you 
click a calculator node in the Project window, the matching name of the node is on the tab(s) 
displayed in the Visualizations window. 

For TTT Diagram and CCT Diagram calculations there is nothing shown for the 
Precipitation Calculator tab in the Visualizations window as there is no Thermal Profile 
to be defined.

 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.

Precipitation Module (TC-PRISMA) Examples Collection ǀ 306 of 431

https://thermocalc.com/support/video-tutorials/precipitation-module-tc-prisma-examples/
https://www.youtube.com/playlist?list=PLfv6McToaTGSpqvuLoY3b_UV-8xpgLUkJ


Figure 214: In this plot, the blue horizontal line shows the time it takes for γ’ to transform at each of the cooling 
rates according to the stop criteria, which is set as 1e-4 volume fraction. The cooling rates are represented by the 
multicoloured curved lines.

If you hover your mouse over the intersection of the blue line and any of the vertical lines, a yellow box 
shows the approximate time it takes for γ’ to transform according to the stop criteria, which is a volume 
fraction of 1e-4, followed by the approximate temperature. 

Figure 215: An example of the table shown in the Visualizations window, which shows the same information as in 
the plot - for each cooling rate the temperature and the time it takes for γ’ to transform according to the stop 
criteria, which is a volume fraction of 1e-4.
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P_08: Precipitation of Cu-Ti CU4TI with Assumptions of 
Sphere and Needle Morphologies

In this isothermal calculation example, the precipitation of Cu4Ti phase in a Cu-Ti binary alloy is calculated. 
To make a comparison, two separate simulations are performed, one assuming spherical morphology 
without elastic strain energy, and the other assuming needle morphology whose shape, determined by 
competition between interfacial energy and elastic strain energy, is changed during the simulation. The 
transformation strain is obtained from Borchers [1999Bor]. The results are compared with experiment 
results from Kampmann et al. [1987Kam]. 

Project File Information

 l Folder: Precipitation Module - TC-PRISMA

 l File name: P_08_Precipitation_Cu-Ti_CU4TI1_Sphere_Needle.tcu

Example Settings

 To ensure that the settings are done on the correct Precipitation Calculators, the Sphere and 
Needle nodes are renamed from Precipitation Calculator to match their morphology. The 
morphology is set in the Precipitate Phase section when you click Show Details.
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System (System Definer)

Database package Demo: Copper-based alloys (CUDEMO and MCUDEMO)

Elements Cu, Ti

Sphere and Needle Conditions (Precipitation Calculator)

Composition Cu-1.9Ti Mole percent

Matrix phase FCC_L12

Precipitate phase CU4TI1

Matrix Phase Data Parameters (Precipitation Calculator)

Mobility adjustment > Prefactor 
(click Show Details to display this 
setting)

Keep the default, Same for all elements, then enter 100 for the Prefactor.

Precipitate Phase Data Parameters (Precipitation Calculator)

Nucleation sites Bulk

Interfacial energy The default 

Morphology  (click Show Details to 
display this setting)

For the Sphere node (renamed from Precipitation Calculator), keep the default. 

For the Needle node (renamed from Precipitation Calculator), Needle is selected. 

Transformation strain (click Show 
Details to display this setting)

For the Sphere node (renamed from Precipitation Calculator), keep the default. 

For the Needlenode (renamed from Precipitation Calculator), User defined is 
selected. In this example, the following settings are defined:

 l ε11 and ε22 are set to 0.022

 l ε33 is set to 0.003 

Calculation Type  (Precipitation Calculator)

Calculation type Isothermal

Temperature 350° C
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Simulation time 10,000 seconds

Datasets (Experimental File Reader)

Borchers Mean radius vs Time and 
Borchers Number density vs Time

Data sets included with this example and imported to two Experimental File Readers. 
These data sets are used for the Mean Radius and Number Density plots, 
respectively.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it takes a few minutes for the calculations to complete.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.

 l Thermal Profile: When setting up a calculator on a Configuration window for Isothermal or Non-
isothermal Calculation Types, you can preview the profile and adjust settings as needed. When you 
click a calculator node in the Project window, the matching name of the node is on the tab(s) 
displayed in the Visualizations window. 

For TTT Diagram and CCT Diagram calculations there is nothing shown for the 
Precipitation Calculator tab in the Visualizations window as there is no Thermal Profile 
to be defined.
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 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.

 In this example, all nodes are renamed in the Project window, and this matches each of the 
tab names in the Visualizations window.

For this Isothermal example, its Thermal Profile is also displayed in the Visualizations window 
showing the constant temperature entered for this calculation type. The tab names match the 
node names in the Project window.

Figure 216: The predicted evolution of the morphology of needle shaped precipitates, showing how the mean 
aspect ratio changes during the isothermal heat treatment.
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Figure 217: The results compare the predicted evolution of the mean size of precipitates with the experimental 
data from [1987Kam], comparing the spherical and needle shaped approximations of the precipitate morphology. 
Note how the needle shape approximation is closer to the experimental data.

Figure 218: These results show both the predicted final particle size distribution from the needle shape simulation 
and the predicted relationship between the length of the precipitate and the needle aspect ratio.
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Figure 219: This shows the approximates the size of the needle shaped precipitates as a sphere of equivalent 
volume, and compares the experimental results of [1987Kam] with those obtained from a spherical and needle 
shaped approximation.
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P_09: Precipitation of Al-Sc AL3SC with Assumption of 
Sphere and Cuboid Morphologies

In this isothermal calculation example, the precipitation of Al3Sc phase from FCC_A1 matrix phase in an Al-
Sc binary alloy is simulated. To make a comparison, two separate calculations are performed, one assuming 
spherical morphology without elastic strain energy, and the other assuming cuboid morphology whose 
shape is determined by competition between interfacial energy and elastic strain energy. The simulation 
results are compared with experimental data collected from Marquis and Seidman [2001Mar] and Novotny 
and Ardell  [2001Nov]. In addition, mean cubic factor and cubic factor distribution are also plotted for 
cuboid shape to illustrate the spherical-cuboidal transition during precipitation. 

Project File and Step-By Step Instructions

 l Folder: Precipitation Module - TC-PRISMA

 l File name: P_09_Precipitation_Al-Sc_AL3SC_Sphere_Cuboid.tcu

Example Settings

 To ensure that the settings are done on the correct Precipitation Calculators, the Sphere and 
Cuboid nodes are renamed from Precipitation Calculator to match their morphology. The 
morphology is set in the Precipitate Phase section when you click Show Details. See P_08 for 
an example of this.

System (System Definer)

Database package Demo: Aluminum-based alloys (ALDEMO, MALDEMO)

Elements Al, Sc

Sphere and Cuboid Conditions (Precipitation Calculator)

Composition Al-0.18Sc Mole percent

Matrix phase FCC_A1

Precipitation Module (TC-PRISMA) Examples Collection ǀ 314 of 431



Precipitate phase AL3SC

Matrix Phase Data Parameters (Precipitation Calculator)

Elastic properties   (click 
Show Details to display 
this setting)

For the Sphere node (renamed from Precipitation Calculator), the default, Disregard is kept.

For the Cuboid node (renamed from Precipitation Calculator), choose Cubic. Then enter the 
elastic constants accordingly. Default elastic constants are given based on the major element of 
the alloy system. In this example that is 

 l c11 is 108.2 GPa

 l c12 is 61.3 GPa

 l c44 is 28.5 GPa

Precipitate Phase Data Parameters (Precipitation Calculator)

Nucleation sites Bulk

Interfacial energy The default 

Morphology  (click Show 
Details to display this 
setting)

For the Sphere node (renamed from Precipitation Calculator), keep the default. 

For the Cuboid node (renamed from Precipitation Calculator), Cuboid is selected. 

Transformation strain 
(click Show Details to 
display this setting)

For the Sphere node (renamed from Precipitation Calculator), keep the default. 

For the Cuboid node (renamed from Precipitation Calculator), Calculate from molar volume is 
selected  to obtain a purely dilatational strain. 

Calculation Type  (Precipitation Calculator)

Calculation type Isothermal

Temperature 350° C

Simulation time 1.0E9 seconds

Datasets (Experimental File Reader)

Dataset 1 and Dataset 2
Data sets included with this example and imported to one Experimental File Reader. It is used 
for the Mean Radius plot.
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Visualizations

This example is included as a Precipitation Module (TC-PRISMA) tutorial on our website and as 
part of the  playlist on our YouTube channel. 

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.

 l Thermal Profile: When setting up a calculator on a Configuration window for Isothermal or Non-
isothermal Calculation Types, you can preview the profile and adjust settings as needed. When you 
click a calculator node in the Project window, the matching name of the node is on the tab(s) 
displayed in the Visualizations window. 

For TTT Diagram and CCT Diagram calculations there is nothing shown for the 
Precipitation Calculator tab in the Visualizations window as there is no Thermal Profile 
to be defined.

 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.

 In this example, all nodes are renamed in the Project window, and this matches each of the 
tab names in the Visualizations window.

For this Isothermal example, its Thermal Profile is also displayed in the Visualizations window 
showing the constant temperature entered for this calculation type. The tab names match the 
node names in the Project window.
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Figure 220: This shows the predicted evolution of the mean size of precipitates with the experimental data from 
[2001Mar, 2001Nov], comparing the spherical and cuboidal shaped approximations of the precipitate 
morphology. Although there is not significant difference in the results, capturing the correct geometry of the 
precipitate is important in subsequent calculations of precipitate spacing used in property calculations.
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Figure 221: These results compare the predicted size distributions after heat treatment considering the spherical 
and cuboidal approximations of the precipitate morphology.

Figure 222: These results compare the predicted evolution of the mean particle radius and mean aspect ratio 
from using the cuboidal approximation of the precipitate morphology. In this case, the radius of a sphere of 
equivalent volume to the cuboidal precipitate is shown.
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Figure 223: These results show the predicted size distribution of the precipitates obtained from the cuboidal 
approximation of the precipitate morphology. Also shown is the calculated size dependent cubic factor of the 
cuboids associated with this dispersion.
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P_10: Initial Particle Size Distribution of Fe-Cr-C

This example demonstrates the effect of initial particle size distribution (PSD) of the precipitate phases on 
the overall precipitation kinetics. It uses two Precipitation Calculators to simulate and compare carbide 
precipitations from a ferritic BCC_A2 matrix in a Fe-0.1C-12Cr alloy. Three carbides, CEMENTITE, M23C7, 
and M7C3 are included in the calculations simulating a complex precipitation sequence with stable and 
meta-stable precipitate phases. The results show a large difference in predicted behaviour, with meta-
stable precipitates dissolving earlier as a result of the stable precipitates existing in the initial condition.

This example also shows the different ways to create the initial size distribution.

 l Generate 3D PSD from distribution function: CEMENTITE's PSD is approximated from an LSW 
distribution.

 l From File: M23C6's PSD is loaded from a file.

 l Approximate the 3D PSD from experimental data: M7C3's PSD is approximated from 1D 
experimental data descriptive of halved linear intercepts. 

Project File Information

 l Folder: Precipitation Module - TC-PRISMA

 l File name: P_10_Precipitation_Initial_PSD_FeCrC.tcu

There are also two *.csv files available for you to use as a template for when you are importing data from a 
file. 

 l Input data for M23C6: P_10_Precipitation_Initial_PSD_FeCrC_psd_3D_M23C6.csv

 l Input data for M7C3: P_10_Precipitation_Initial_PSD_FeCrC_psd_1D_M7C3.csv

Preexisting Particle Size Distribution

The Preexisting Particle Size Distribution window shown in Figure 224 is a graphical representation of the 
radius versus corresponding number densities, with fields available to enter the initial precipitate 
composition and volume fraction. An editable table is also provided for the particle size distribution.

Cementite
The amount of Fe and Cr must be defined for Cementite for this alloy. Fe is set to the dependent 
component, and 72 mass percent of Cr is set. The option Generate 3D PSD from distribution function is 
chosen to create the PSD for Cementite. The initial volume fraction of 0.001 % is assumed. An LSW 
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distribution is selected with a mean radius of 1E-8m.

Figure 224: An LSW distribution with a mean radius of 1E-8m is used.

M23C6
The amount of Fe and Cr must be defined for M23C6 for this alloy. Fe is set to the dependent component, 
and 70 mass percent of Cr is set. The From File option is used to create the PSD. 

The file loaded for M23C6 is available from the Example files → Precipitation Module - TC-
PRISMA folder and is named P_10_Precipitation_Initial_PSD_FeCrC_psd_3D_M23C6.csv.

 You can import data from a spreadsheet or text file (.xls, .xlsx, .csv, or .txt formats are acceptable). The 
initial volume fraction of 0.15 % is assumed.
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M7C3
The amount of Fe and Cr must be defined for M7C3 for this alloy. Fe is set to the dependent component, 
and 83 mass percent of Cr is set. The Approximate the 3D PSD from experimental data option is used to 
create the PSD.

In this example, the linear intercept method is used to measure the size distribution of M7C3 from 
micrographs descriptive of sectioning the dispersion. A size distribution of halved linear intercepts is 
created and is available as a file you can use as a template. 

The file loaded for M7C3 is available from the Example files → Precipitation Module - TC-
PRISMA folder and is named  P_10_Precipitation_Initial_PSD_FeCrC_psd_1D_M7C3.csv.

The Dimensionality of the exp. data is set to 1D. The experimental data is loaded by importing the above 
named *.csv file. An LSW Distribution is used.  When you click Generate, it calibrates the chosen 
distribution and stereology description to the experimental data. The initial volume fraction of 0.15 % is 
assumed.
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Example Settings

System (System Definer)

Database package Demo: Steels and Fe-alloys (FEDEMO and MFEDEMO)

Elements Fe, C, Cr

Conditions (Precipitation Calculator)

Composition Fe-0.1C-12Cr Mass percent

Matrix phase
BCC_A2

All other defaults are kept.
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Precipitate phases CEMENTITE, M23C6 and M7C3

Precipitate Phase Data Parameters (Precipitation Calculator)

Nucleation sites
Grain boundaries (all calculations): Calculated from the matrix settings with a wetting angle 
of 90°

Interfacial energy

User-defined function f(r,T) (all calculations):

 l CEMENTITE: 0.167 J/m2

 l M23C6 0.252 J/m2

 l M7C3 0.282 J/m2

Preexisting size distribution 
(click Show Details to 
display this setting)

For the Precipitation Calculator including particle size distribution (PSD), and for all 
precipitate phases, this checkbox is selected.

For each precipitate phase (CEMENTITE, M23C6 and M7C3), click Edit Particle Size 
Distribution to make changes to the parameters. A window opens with a graphical 
representation of the radius vs number density.

Input type

 l Generate 3D PSD from distribution function - CEMENTITE uses this option in the 
example

 l From File - M23C6 uses this option in the example

 l Approximate the 3D PSD from experimental data - M7C3 uses this option in the 
example.

Calculation Type (Precipitation Calculator)

Calculation type Isothermal

Temperature 1053 K

Simulation time 400 000 seconds

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.
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Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.

 l Thermal Profile: When setting up a calculator on a Configuration window for Isothermal or Non-
isothermal Calculation Types, you can preview the profile and adjust settings as needed. When you 
click a calculator node in the Project window, the matching name of the node is on the tab(s) 
displayed in the Visualizations window. 

For TTT Diagram and CCT Diagram calculations there is nothing shown for the 
Precipitation Calculator tab in the Visualizations window as there is no Thermal Profile 
to be defined.

 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.

For this Isothermal example, its Thermal Profile is also displayed in the Visualizations window 
showing the constant temperature entered for this calculation type. The tab names match the 
node names in the Project window.
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Figure 225: These results show the predicted volume fraction of cementite, M23C6, and M7C3 during an 
isothermal aging with an initial particle size distribution of each precipitate phase. The predicted kinetics are 
sensitive to the initial size, volume fraction, and composition of these precipitates.

Figure 226: The predicted volume fraction of cementite, M23C6, and M7C3 during an isothermal aging with no 
precipitates in solution in the initial condition.
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P_11: Interfacial Energy Function

In some cases, interfacial energy may be a function of temperature and/or particle radius. This example 
uses four Precipitation Calculators at four temperature points in 30 K increments: 673 K, 703 K, 733 K, and 
763 K. It is an isothermal calculation to examine the mean radius of an Al-0.12Sc system. It uses an FCC_A1 
matrix phase and AL3SC precipitate phase with bulk nucleation sites and user-defined interfacial energy 
function. The user defined interfacial energy function uses an error function to set a smooth transition of 
the interfacial energy from 0.065  J/m2 to 0.085   J/m2 for particle radii below and above 1e-8m and 5e-8m, 
respectively.

A dataset based on Iwamura and Miura [2004Iwa]  data is compared with the calculated results.

Project File Information

 l Folder: Precipitation Module - TC-PRISMA

 l File name: P_11_Interfacial_energy_function.tcu

Example Settings

System (System Definer)

Database package Demo: Aluminum-based Alloys (ALDEMO, MALDEMO)

Elements Al, Sc

Conditions (Precipitation Calculator)

Composition Al-0.12Sc Mole percent

Matrix phase
FCC_A1

All other defaults are kept.

Precipitate phase

AL3SC

Nucleation sites (all calculations): Bulk (6.025E28 m-3)

Interfacial energy (all calculations): User-defined function f(r,T): 0.075+0.011*erf((r-3e-8)/1e-8 
J/m2)

Calculation Type  (Precipitation Calculator)

Calculation type Isothermal (all calculations)
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Temperature Four temperature points in 30 K increments: 673 K, 703 K, 733 K, and 763 K.

Simulation time 1 000 000 seconds (all calculations)

Datasets (Experimental File Reader)

Wamura 2004 (Dataset 
1)

Data set included with this example and imported to one Experimental File Reader. 

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it takes a few minutes for the calculations to complete.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.

 l Thermal Profile: When setting up a calculator on a Configuration window for Isothermal or Non-
isothermal Calculation Types, you can preview the profile and adjust settings as needed. When you 
click a calculator node in the Project window, the matching name of the node is on the tab(s) 
displayed in the Visualizations window. 

For TTT Diagram and CCT Diagram calculations there is nothing shown for the 
Precipitation Calculator tab in the Visualizations window as there is no Thermal Profile 
to be defined.
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 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.

For this Isothermal example, its Thermal Profile is also displayed in the Visualizations window 
showing the constant temperature entered for this calculation type. The tab names match the 
node names in the Project window.

Figure 227: The results of an isothermal calculation to examine the mean radius of an Al-0.12Sc system with 
experimental data from [2004Iwa]. 
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P_12: Comparing Growth Rate Models for an Al-Zr System

This example compares the Simplified, General, and Advanced growth rate models for an Al-Zr system. The 
resulting plot compares the mean radius of the spheres for each AL3ZR_D023 precipitate phase calculated 
for each type of growth rate model. 

All models treat a spherical particle (precipitate) of stoichiometric composition or with negligible atomic 
diffusivity. Local equilibrium at the precipitate-matrix interface is assumed. 

When you use the Advanced model,  the velocity of a moving phase interface and the operating tie-line are 
solved together from flux-balance equations. This model can treat both high supersaturation and cross 
diffusion rigorously. It can also capture the transition between NPLE (non-partitioning local equilibrium) 
and PLE (partitioning local equilibrium) without any ad hoc treatment.

The Simplified model is based on the quasi-steady state diffusion approximation, and estimates solute 
partitioning  with matrix composition and nuclei composition instead of time-consuming stepwise tie-line 
calculations. It also neglects cross diffusion for simplicity. 

The General model  can be considered the same theoretical approximation as, but an improvement over,  
the Simplified model, with cross-diffusion terms taken into account, as well as adjustment of Gibbs-
Thomson effect and effective diffusivity implemented. A dataset based on Knipling et al. [2008Kni]   data is 
compared with the calculated results.

Project File Information

 l Folder: Precipitation Module - TC-PRISMA

 l File name: P_12_Precipitation_Al-Zr_GrowthRateModel_comparison.tcu

Example Settings

System (System Definer)

Database package Demo: Aluminum-based Alloys (ALDEMO, MALDEMO)

Elements Al, Zr

Conditions (Precipitation Calculator)

Composition Al-0.2Zr Mole percent

Matrix phase FCC_A1
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All other defaults are kept.

Precipitate phase

AL3ZR_D023

Click Show Details to select the Growth rate model (Simplified, Advanced and General). All other 
defaults are kept.

Calculation Type  (Precipitation Calculator)

Calculation type Isothermal

Temperature 425 Celsius

Simulation time 400 hours

Datasets (Experimental File Reader)

2008 Knipling Data set included with this example and imported to one Experimental File Reader.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it takes a few minutes for the calculations to complete.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.

 l Thermal Profile: When setting up a calculator on a Configuration window for Isothermal or Non-
isothermal Calculation Types, you can preview the profile and adjust settings as needed. When you 
click a calculator node in the Project window, the matching name of the node is on the tab(s) 
displayed in the Visualizations window. 
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For TTT Diagram and CCT Diagram calculations there is nothing shown for the 
Precipitation Calculator tab in the Visualizations window as there is no Thermal Profile 
to be defined.

 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.

For this Isothermal example, its Thermal Profile is also displayed in the Visualizations window 
showing the constant temperature entered for this calculation type. The tab names match the 
node names in the Project window.

Figure 228: This shows the impact of the available growth rate settings options and compares the mean radius 
measurements of [2008Kni] with results obtained from the simplified, general, and advanced growth rate models. 
The experimental data includes measurements taken from different dendrites.
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[2008Kni] K. E. Knipling, D. C. Dunand, D. N. Seidman, Precipitation evolution in Al–Zr and Al–Zr–Ti alloys 
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P_13: Paraequilibrium Precipitation of Cementite Fe-C-Cr

In this example, the precipitation of cementite during tempering of a Fe-Cr-C steel is simulated considering 
two interface conditions: one is the usual ortho-equilibrium condition; the other is the para-equilibrium 
condition. The simulation results are compared with the experimental data from Sakuma et al. [1980Sak]. 

This example demonstrates that the early stage of the cementite precipitation can only be accounted for by 
a simulation applying the para-equilibrium condition, under which the precipitation kinetics are controlled 
by the diffusion of C. The comparison also shows a later stage gradual transition from the para-equilibrium 
condition to the ortho-equilibrium condition, and if the tempering time is long enough the diffusion of Cr 
has a dominating effect on the coarsening of cementite. 

Project File Information

 l Folder: Precipitation Module - TC-PRISMA

 l File name: P_13_Precipitation_Fe-C-Cr_Paraequilibrium_Precipitation_of_Cementite.tcu

Example Settings

System (System Definer)

Database package Demo: Steels and Fe-alloys (FEDEMO, MFEDEMO)

Elements Fe, Cr, C

Conditions (Precipitation Calculator)

Composition Fe-0.95Cr-1.065C Mass percent

Matrix phase
BCC_A2

All other defaults are kept.

Precipitate phase

CEMENTITE_D011

Click Show Details to select the Growth rate model (Simplified (OE) and Para-eq) (PE). All other 
defaults are kept.

Calculation Type  (Precipitation Calculator)

Calculation type Isothermal

Temperature 773 Kelvin
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Simulation time 20 hours for the paraequilibrium model and 600 hours for the simplified model.

Datasets (Experimental File Reader)

1980 Sakuma Data set included with this example and imported to one Experimental File Reader.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it can take over two hours to complete the calculations. 

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.

 l Thermal Profile: When setting up a calculator on a Configuration window for Isothermal or Non-
isothermal Calculation Types, you can preview the profile and adjust settings as needed. When you 
click a calculator node in the Project window, the matching name of the node is on the tab(s) 
displayed in the Visualizations window. 

For TTT Diagram and CCT Diagram calculations there is nothing shown for the 
Precipitation Calculator tab in the Visualizations window as there is no Thermal Profile 
to be defined.

 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.
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For this Isothermal example, its Thermal Profile is also displayed in the Visualizations window 
showing the constant temperature entered for this calculation type. The tab names match the 
node names in the Project window.

Figure 229: These results compare the predicted and measured evolution of the mean radius of cementite with 
the experimental data from [1980Sak] to simulation predictions obtained from the ortho-equilibrium (OE), and 
para-equilibrium (PE) approximations of the precipitate composition. The precipitate growth kinetics exhibited by 
cementite can be rationalized by the transition from PE to OE.

Reference

[1980Sak] T. Sakuma, N. Watanabe, T. Nishizawa, The Effect of Alloying Element on the Coarsening 
Behavior of Cementite Particles in Ferrite. Trans. Japan Inst. Met. 21, 159–168 (1980).
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P_14: Grain Growth and the Zener Pinning Effect

This example demonstrates the simulation of normal grain growth and the pinning effect [1948Smi; 
1998Man] of precipitated second-phase particles on the grain boundary motion.

To investigate the grain growth and Zener pinning effect, an Fe-0.2C (wt.%) binary alloy, with a BCC_A2 
matrix phase and CEMENTITE precipitate phase, is simulated and uses the demonstration steel databases, 
FEDEMO and MFEDEMO. These databases are available to all users (i.e. you do not need a license for the 
Precipitation Module (TC-PRISMA)) and contain the necessary thermodynamic and kinetic data needed for 
the calculation.

Project File Information

 l Folder: Precipitation Module - TC-PRISMA

 l File name: P_14_Precipitation_Fe-C-Ferrite-Grain_Growth_with_Zener_Pinning.tcu

Example Settings

System (System Definer)

Database 
package

Demo: Steels and Fe-alloys (FEDEMO and MFEDEMO)

Elements Fe, C

Conditions (Precipitation Calculator)

Composition Fe-0.2C Mass percent

Matrix phase

BCC_A2

 l Grain boundary energy (J/m2): 0.5
 l Grain boundary mobility: Prefactor(m4/Js): 2 x 10-15

 l Click to Edit grain size distribution. Then Initial grain size distribution: Hillert distribution with 
average radius of 3.2 x 10-6 m

 l Mobility adjustment: Same for all elements. Prefactor 0.08.
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Precipitate phase
CEMENTITE

 l Zener pinning parameters:  Cutoff size (m): 8.0 x 10-7

Calculation Type  (Precipitation Calculator)

Calculation type Isothermal

Temperature 722 °C

Simulation time 35 hours

Datasets (Experimental File Reader)

[1975Hel] Data sets included with this example and imported to two Experimental File Readers.

Visualizations

This example is included as a Precipitation Module (TC-PRISMA) tutorial on our website and as 
part of the  playlist on our YouTube channel. 

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.

 l Thermal Profile: When setting up a calculator on a Configuration window for Isothermal or Non-
isothermal Calculation Types, you can preview the profile and adjust settings as needed. When you 
click a calculator node in the Project window, the matching name of the node is on the tab(s) 
displayed in the Visualizations window. 

For TTT Diagram and CCT Diagram calculations there is nothing shown for the 
Precipitation Calculator tab in the Visualizations window as there is no Thermal Profile 
to be defined.
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 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.

For this Isothermal example, its Thermal Profile is also displayed in the Visualizations window 
showing the constant temperature entered for this calculation type. The tab names match the 
node names in the Project window.

The calculated equilibrium volume fraction of CEMENTITE at 722 °C (0.02786), using FEDEMO, matches that 
(0.02787) of a Fe-0.2C-0.004S-0.0004O-0.001N-0.001Al (wt.%) multicomponent commercial alloy, 
calculated using the latest version of the TCS Steel and Fe-alloys Database (TCFE), an alloy that was studied 
by Hellman and Hillert [1975Hel]. The mobility adjustment assures the precipitation kinetics of CEMENTITE 
phase in Fe-C system matches that of experimental data [1975Hel] of the commercial counterpart (and 
shown in Figure 230)

Figure 230: The evolution of the mean radius of cementite comparing the experimental data from [1975Hel] with 
the Precipitation Calculator results.

The grain boundary energy was chosen to be a reasonable value of 0.5 J/m2. There is a large discrepancy, in 
several orders of magnitude, among experimental data regarding the grain boundary mobility. In the 
present calculation, a value of 2x10-15 m4/Js was chosen.
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Figure 231: The evolution of the mean grain radius of ferrite comparing the experimental data from [1975Hel] 
with predictions made with and without Zener pinning from an evolving dispersion of cementite precipitates.
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P_15: Smooth Transition from Paraequilibrium to Ortho-
equilibrium

In this example, the precipitation of cementite during tempering of an Fe-Mn-C steel is simulated 
considering three interface conditions:  the usual ortho-equilibrium (OE) condition; paraequilibrium (PE) 
condition; and  a smooth transition from paraequilibrium  to ortho-equilibrium condition (PE-OE). The 
simulation results are compared with the experimental data from Miyamoto et al. [2007Miy].

The Precipitation Calculator nodes are renamed in the example to match the abbreviations for 
the three interface conditions considered: OE, PE, and PE-OE. Also see the video to learn how 
to create this example.

This example demonstrates that the early stage of the cementite precipitation follows a PE condition, 
under which the precipitation kinetics is controlled by the diffusion of C. At a later stage, gradual transition 
from PE condition to OE condition occurs, and if the tempering time is long enough the diffusion of Mn has 
a dominating effect on the coarsening of cementite. While a Simplified model follows the OE condition and 
a Para-eq model follows PE condition, the PE Automatic model enables the smooth transition from PE 
condition at early stage to OE condition at a late stage.

The example uses the demonstration steel databases, FEDEMO and MFEDEMO. These databases are 
available to all users (i.e. you do not need a license for the Precipitation Module (TC-PRISMA)) and contain 
the necessary thermodynamic and kinetic data needed for the calculation.

Project File Information

 l Folder: Precipitation Module - TC-PRISMA

 l File name: P_15_Precipitation_Fe-C-Mn_PE-OE_Precipitation_of_Cementite.tcu

Example Settings

System (System Definer)

Database 
package

Demo: Steels and Fe-alloys (FEDEMO and MFEDEMO)
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Elements Fe, Mn, C

Conditions (Precipitation Calculator)

Composition Fe-1.96Mn-0.61C mass percent

Matrix phase

BCC_A2

Click Show Details:

 l Grain size: Average radius 1.0E-7m

 l Grain aspect ratio: 100.0

 l Mobility adjustment: Keep the default, Same for all elements, then enter 0.008 for the 
Prefactor, and -7e4 J/mol for the Activation energy.

All other defaults are kept.

Precipitate 
phase

CEMENTITE_D011

Click Show Details to select the Growth rate model (Simplified, Para-eq, and PE Automatic). All other 
defaults are kept.

Calculation Type  (Precipitation Calculator)

Calculation type Isothermal

Temperature 923.15 Kelvin

Simulation time 1E6 seconds for Simplified and PE Automatic models, and 5 seconds for Para-eq model

Datasets (Experimental File Reader)

Mean Radius Exp Data set including experimental mean radius of cementite

Mn 
Concentration

Data set including experimental Mn composition in cementite

Visualizations

This example is included as a Precipitation Module (TC-PRISMA) tutorial on our website and as 
part of the  playlist on our YouTube channel. 

Precipitation Module (TC-PRISMA) Examples Collection ǀ 342 of 431

https://thermocalc.com/support/video-tutorials/precipitation-module-tc-prisma-examples/
https://www.youtube.com/playlist?list=PLfv6McToaTGSpqvuLoY3b_UV-8xpgLUkJ


Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it takes a few minutes for the calculations to complete.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.

 l Thermal Profile: When setting up a calculator on a Configuration window for Isothermal or Non-
isothermal Calculation Types, you can preview the profile and adjust settings as needed. When you 
click a calculator node in the Project window, the matching name of the node is on the tab(s) 
displayed in the Visualizations window. 

For TTT Diagram and CCT Diagram calculations there is nothing shown for the 
Precipitation Calculator tab in the Visualizations window as there is no Thermal Profile 
to be defined.

 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.

For this Isothermal example, its Thermal Profile is also displayed in the Visualizations window 
showing the constant temperature entered for this calculation type. The tab names match the 
node names in the Project window.
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Figure 232:  A comparison between the measurements of mean cementite radius from [2007Miy] with the 
simplified (OE), para-eq (PE), and PE Automatic (PE-OE) growth models. The PE-OE model is needed to capture 
the nucleation, growth, and coarsening behavior of cementite.

Precipitation Module (TC-PRISMA) Examples Collection ǀ 344 of 431



Figure 233:  A comparison of the evolution of the cementite Mn composition during isothermal aging at 923.15 K 
between the experimental data from [2007Miy] with model predictions obtained from the simplified (OE) growth 
model, the para-eq (PE) growth model, and the PE Automatic (PE-OE) growth model. The PE-OE model captures 
the behavior shown in the experimental data, where the Mn composition transitions from the initial ferrite 
composition towards the equilibrium cementite composition.

Reference

[2007Miy] G. Miyamoto, J. Oh, K. Hono, T. Furuhara, T. Maki, Effect of partitioning of Mn and Si on the 
growth kinetics of cementite in tempered Fe–0.6 mass% C martensite. Acta Mater. 55, 5027–5038 
(2007).
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P_16 Isothermal Coarsening and  a 3D to 2D Stereological 
Conversion  

This example demonstrates the use of the 3D → 2D stereological conversion functionality to compare 
Precipitation Module (TC-PRISMA) predictions with experimental data obtained from Scanning Electron 
Micrographs (SEM). 

The 3D → 2D setting is available on a Plot or Table Renderer that is a successor to the 
Precipitation Calculator, and when certain axis variables are selected for a spherical 
morphology.  

The isothermal coarsening kinetics of γ' precipitates in a Ni-Al-Cr alloy is modeled. The experimental data is 
from [2008Sud], which investigates isothermal coarsening kinetics at a temperature of 873 K for up to 264 
h. 

It is assumed that there are no precipitates in solution at the beginning of the isothermal heat treatment.

Project File Information

 l Folder: Precipitation Module - TC-PRISMA

 l File name: P_16_Precipitation_Ni-Al-Cr_Stereology.tcu

Example Settings

The example also includes an Equilibrium Calculator and Table Renderer to first  confirm the 
stability of the precipitate phase for this system (FCC_L12#2), then determine particle 
composition at 1073 K, and this information is used with the Precipitation Calculator set up.

System (System Definer)

Database 
package

Demo: Nickel-based superalloys (NIDEMO and MNIDEMO)
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Elements Ni, Al, Cr

Conditions (Precipitation Calculator)

Composition Ni-10l-8.5Cr Mole percent

Matrix Phase

DIS_FCC_A1

 l Click Show Details and for the Mobility adjustment enter 0.5 for the 
Prefactor.

 l All other defaults are kept.

Precipitate 
Phase

FCC_L12#2

Click Show Details and adjust the default settings as indicated: 

 l Interfacial energy: Select User-defined and enter 0.01 J/m2. 

Calculation Type  (Precipitation Calculator)

Calculation 
Type

Isothermal

Temperature 1073 Kelvin

Simulation time 300 h

Datasets (Experimental File Reader)

2008 Sudbrack 
et al

Data sets are included with this example and are imported using the Experimental 
File Reader activity. There are 2D size distributions comparing results after a total 
of 16 h aging, 64 h aging, and 264 h of aging, and a comparison of the  
experimental and predicted 2D mean radius versus time. 

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.
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Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

There is a variety of information shown in the Visualizations window that can be viewed during 
configuration and after performing the calculation.

 l Thermal Profile: When setting up a calculator on a Configuration window for Isothermal or Non-
isothermal Calculation Types, you can preview the profile and adjust settings as needed. When you 
click a calculator node in the Project window, the matching name of the node is on the tab(s) 
displayed in the Visualizations window. 

For TTT Diagram and CCT Diagram calculations there is nothing shown for the 
Precipitation Calculator tab in the Visualizations window as there is no Thermal Profile 
to be defined.

 l Plot or Table results: After completing the set up and performing the calculation, to view the 
matching name of the node on tab(s) in the Visualizations window, either click a Plot Renderer or 
Table Renderer node in the Project window or click the tabs individually in the Visualizations 
window.

For this Isothermal example, its Thermal Profile is also displayed in the Visualizations window 
showing the constant temperature entered for this calculation type. The tab names match the 
node names in the Project window.
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Figure 234:  A comparison of the evolution of the mean 2D precipitate radius measurements of [2008Sud] with 
model predictions.

Figure 235: A comparison of the predicted and measured 2D size distribution after 4 h of aging.
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Figure 236: A comparison of the predicted and measured 2D size distribution after 16 h of aging.

Figure 237: A comparison of the predicted and measured 2D size distribution after 64 h of aging.
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Figure 238: A comparison of the predicted and measured 2D size distribution after 264 h of aging.

Reference

[2008Sud] C. K. Sudbrack, T. D. Ziebell, R. D. Noebe, D. N. Seidman, Effects of a tungsten addition on the 
morphological evolution, spatial correlations and temporal evolution of a model Ni–Al–Cr superalloy. 
Acta Mater. 56, 448–463 (2008).
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Process Metallurgy Module Examples Collection

The Process Metallurgy Module requires both a valid Maintenance and Support Subscription 
(M&SS) and a license for the TCS Metal Oxide Solutions Database (TCOX8 or newer). 

All users can test the Process Metallurgy Module with the included OXDEMO database, which 
is limited to these elements: Al, C, Ca, Fe, O, S, and Si. For more information about this and 
other products visit our website.

In this section:

PMET_01: Basic Oxygen Furnace (BOF) 353

PMET_02: Desulphurization in a Ladle Furnace (LF) 355

PMET_03: Argon Oxygen Decarburization (AOD) 357

PMET_04: Basic Oxygen Furnace (BOF) Kinetics 364

PMET_05: Lab Scale Ladle Furnace (LF) Kinetics 366

PMET_06: Ladle Furnace (LF) Kinetics 371

PMET_07: Vacuum Oxygen Decarburization Kinetics 374

PMET_08: Steel Deoxidation on Tapping 376
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PMET_01: Basic Oxygen Furnace (BOF)

The example uses the Process Metallurgy Calculator to demonstrate a simplified steelmaking process in a 
Basic Oxygen Furnace (BOF). 

This application example in its various forms is available on our website. There are two application 
examples (one equilibrium, one kinetic) showing how the Process Metallurgy Module can be used to 
calculate the BOF process. 

This basic example uses equilibrium calculations to gain a general understanding of your BOF process and 
help you determine optimal operation conditions and predict and optimize costs of raw materials and 
recycling. The other set of examples gives detailed instructions on how to simulate the kinetics of the 
BOF process using the kinetic process simulation (see "PMET_04: Basic Oxygen Furnace (BOF) Kinetics" on 
page 364).

Project File and License Information

 l Folder: Process Metallurgy 

 l File name: PMET_01_Basic_Oxygen_Furnace.tcu

Choose a, b, or c versions of the example based on your license.

 l PMET_01a_Basic_Oxygen_Furnace is included in a regular Thermo-Calc installation as well as the 
free Educational version of Thermo-Calc. This is a highly simplified example and uses the OXDEMO 
database, and only considers the elements Fe, C, and O.

 l PMET_01b_Basic_Oxygen_Furnace is also a simplified calculation but uses the OXDEMO database. 
It requires a full license of Thermo-Calc 2021b and newer.

 l PMET_01c_Basic_Oxygen_Furnace requires the TCOX11 database and newer and a full license of 
Thermo-Calc 2021b and newer. 

Visualizations

This example is included as a Process Metallurgy tutorial on our website and as part of the 
playlist our YouTube channel.
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The resulting plots and details related to setting up this example are available to download via 
the dedicated web page. 
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PMET_02: Desulphurization in a Ladle Furnace (LF)

The example, which is also available on our website, uses the Process Metallurgy Calculator to 
demonstrate the use of a Ladle Furnace (LF) with the Process Metallurgy Module. 

The ladle furnace (LF) fulfils many purposes in the steelmaking process. Desulphurization, which we will 
focus on in this example, is merely one of them.

Desulphurization is usually performed by transferring S that is dissolved in the liquid metal to a CaO-rich 
slag phase. For this process to be successful, two conditions need to be fulfilled:

 1. The slag must be fully liquid (liquid fraction > 0.9). This is required for kinetic reasons. The slag 
phase must be fluid so that it can emulsify with the liquid steel and form a large surface area where 
the reaction between steel and slag can take place.

 2. The slag must take up a large amount of S from the liquid steel (have a “high sulphur capacity”) so 
that a significant amount of sulphur will move from the liquid steel to the slag phase.

The example demonstrates how the Process Metallurgy Module in Thermo-Calc can be used to explore 
these two conditions for an equilibrium between liquid steel and slag in a ladle furnace, trying to find good 
slag compositions. We also investigate why excessive slag carry-over from the BOF or EAF is detrimental for 
desulphurization in the LF and who how slag conditioning with CaC2 as fluxing agent can recover the 
desulphurizing ability of the slag.

Project File and License Information

 l Folder: Process Metallurgy  

 l File names: PMET_02a_Ladle_Furnace.tcu or PMET_02b_Desulphurization_in_Ladle_
Furnace.tcu. 

Choose a or b versions of the example  based on your license

 l PMET_02a_Ladle_Furnace.tcu can be run with OXDEMO database but requires the full license for 
Thermo-Calc 2021b and newer.

 l PMET_02b_Desulphurization_in_Ladle_Furnace.tcu requires the TCOX11 database and a full 
license for Thermo-Calc 2021b and newer.
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Visualizations

This example is included as a Process Metallurgy tutorial on our website and as part of the 
playlist our YouTube channel.

The resulting plots and details related to setting up this example are available  to download via 
the dedicated web page. 
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PMET_03: Argon Oxygen Decarburization (AOD)

 The Argon Oxygen Decarburization (AOD) process is a converter process applied in stainless steel making. 
In this process the oxidation of chromium in the steel melt needs to be prevented while carbon is oxidized. 
This is achieved by reducing the oxygen partial pressure by having a high Ar-content in the blowing gas. It is 
a highly exothermic process that requires adiabatic modeling. In this example the conversion of carbon-rich 
steel scrap is modeled together with additions of Ferronickel and Ferrochrome to a stainless steel. The 
example uses the Process Metallurgy Calculator. 

Visit the website Application Examples → Process Metallurgy page for more background 
information as well as more in depth analyses of this and other examples. Also visit the 
Process Metallurgy Module page to access resources such as training videos, presentations, 
publications, webinars, and much more. 

Project File and License Information

 l Folder: Process Metallurgy  

 l File name: PMET_03_Argon_Oxygen_Decarburization.tcu

This example requires a license to run the simulation. It works with TCS Metal Oxide Solutions 
Database (TCOX) versions 8 and newer. 

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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When you run (Perform) this example, it takes a few minutes for the calculations to complete.

Background Description

The AOD-process is characterized by an initially high O2-content of the blowing gas, which is gradually 
replaced by Ar. The maximum temperature of the process is typically around 1720 °C. A grid plot of an 
adiabatic calculation is well suited to model the required simultaneous change of amount of gas and its 
composition during this process. The black line in the plot above indicates a possible process control path 
that finally leads to suitable alloy composition close to a X5CrNi 18-10 stainless steel.

In principle, this plot could be used to control the blowing gas flow in a plant process. However, note that 
the simulation only considers a global gas phase, i.e. additional gas is added but never removed. This 
means that the given gas phase composition is an average one and not identical to the composition of the 
gas flowing in at each point in time. Additionally there is a certain impact on the resulting equilibria from 
the fact that all gas remains in the system and is not removed. 
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Slag Basicity

Figure 239: The Slag Basicity plot shows the basicity of the slag (which is a measure for the sulphur capacity of 
the slag). The process achieves a final basicity of 1.74 which is typical for an AOD-process. The black line in the 
plot indicates a possible process control path that finally leads to suitable alloy composition close to a X5CrNi 18-
10 stainless steel.
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S Content in Steel

Figure 240: In the S Content in Steel plot, the sulphur content in the steel melt is slightly reduced during the 
process from 0.056% in the initial steel scrap to finally ca. 0.035%. The black line in the plot indicates a possible 
process control path that finally leads to suitable alloy composition close to a X5CrNi 18-10 stainless steel.
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Cr Content in Slag

Figure 241: In the Cr Content in Slag plot, the Cr2O3-content in the slag reaches at the end of the process ca. 26 
wt-%. This is typical for the AOD-process and requires an additional Cr-recovery step after the conversion to 
reduce the loss of chromium.  The black line in the plot indicates a possible process control path that finally leads 
to suitable alloy composition close to a X5CrNi 18-10 stainless steel.
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Amount of Slag

Figure 242: In the Amount of Slag plot, you can see that the process generates about 15 tons of slag in the total. 
The black line in the plot indicates a possible process control path that finally leads to suitable alloy composition 
close to a X5CrNi 18-10 stainless steel.
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Liquid Slag Fraction

Figure 243: In the Liquid Slag Fraction plot, you can see that towards the end of the process the slag is calculated 
to be mostly liquid. The black line in the plot indicates a possible process control path that finally leads to suitable 
alloy composition close to a X5CrNi 18-10 stainless steel.
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PMET_04: Basic Oxygen Furnace (BOF) Kinetics

The example uses the Process Metallurgy Calculator to simulate the kinetics of the Basic Oxygen Furnace 
(BOF) process. This application example in its various forms is available on our website.

Metallurgical processes such as the BOF process rarely reach equilibrium. Therefore, a model description 
must include kinetics if meaningful results are to be obtained. In recent years, a simple but powerful model 
termed the Effective Equilibrium Reaction Zone (EERZ) model has been developed and widely applied to 
simulate various metallurgical processes.

This example shows you how to set up a kinetic simulation of the BOF process in the Process Metallurgy 
Module and includes a description of the EERZ model. For information about the equilibrium examples, see 
"PMET_01: Basic Oxygen Furnace (BOF)" on page 353.

Project File Information

 l Folder: Process Metallurgy

Choose a, b, or c versions of the example based on your license. 

 l PMET_04a_Basic_Oxygen_Furnace_Kinetics is included in a regular Thermo-Calc installation as well 
as the free Educational version of Thermo-Calc.  This  only considers the elements Fe, C, and O.

 l PMET_04b_Basic_Oxygen_Furnace_Kinetics needs a full license of Thermo-Calc 2021b or newer, 
but uses the free OXDEMO database. It considers the elements Fe, C, O, Ca, Al, Si, and S.

 l PMET_04c_Basic_Oxygen_Furnace_Kinetics requires both a full license of Thermo-Calc 2021b or 
newer and a license for the TCOX11 database and newer. This simulation corresponds pretty much 
to a real BOF process with the elements Fe, Mn, C, O, Ca, Al, Mg, Si, S, and P considered.  

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.
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Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

The resulting plots and details related to setting up this example are available  to download via 
the dedicated web page. 
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PMET_05: Lab Scale Ladle Furnace (LF) Kinetics

Using the Process Metallurgy Calculator and the Process simulation branch, this example is based on the 
publication by Piva et al [2017Piv] where a lab scale sample of pure iron is first deoxidized with Si-Mn and 
then a synthetic top slag is added to the steel. Generally, by using the project file and the information 
below, you can get an idea about how to set up a ladle furnace simulation using the Process Metallurgy 
Module.

Visit the website Application Examples → Process Metallurgy page for more background 
information as well as more in depth analyses of this and other examples. Also visit the 
Process Metallurgy Module page to access resources such as training videos, presentations, 
publications, webinars, and much more. 

Project File and License Information

 l Folder: Process Metallurgy  

 l File name: PMET_05_Lab_Scale_Ladle_Furnace_Kinetics.tcu 

This example is best run with the TCS Metal Oxide Solutions Database (TCOX) version 13 or 
newer and a full license of Thermo-Calc 2024a or newer. Running the example with earlier 
versions of the database is possible but the results are not consistent with the referenced 
paper.

Visualizations

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it takes a few minutes for the calculations to complete.
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About the Plot Results

Many different aspects of the reactions taking place in the LF can be plotted and analyzed. After you run 
the project file and obtain the plots, you can experiment by adjusting the settings on each Plot Renderer to 
see what happens in each case. There is more analysis about this and other examples available at the links 
to our website.

For an example of a more realistic industry scale, see "PMET_06: Ladle Furnace (LF) Kinetics" 
on page 371.

Setting Up the LF Process Simulation

In the paper by Piva et al. [2017], it is experimentally investigated how the steel and inclusion composition 
changes in function of time as the Si-Mn killed steel reacts with the slag. This experiment can serve as a 
model for the production of SiMn killed steel with subsequent top-slag deoxidation.

Figure 244: Diagram of the experiment performed by Piva et al. [2017]. The sequence as described in the text is: 
(1) liquid Fe with dissolved oxygen; (2) FeMn and SiMn added to deoxidize Fe; (3) top slag added after 360s; and 
(4) gradual reaction between steel, slag and inclusions.

According to the publication the following reaction sequence is expected as shown in the diagram:

 1. In the initial state the steel contains 400 ppm of dissolved oxygen.

 2. The deoxidizing agents are added. They dissolve and react with the oxygen in the steel forming 
oxide inclusions, thereby reducing the amount of dissolved oxygen ("killing" the steel). The kinetics 
are fast, and it can be assumed that the reaction proceeds to thermodynamic equilibrium. 

 3. On adding the slag (360 s after step 2, killing the steel) the liquid steel starts reacting with the slag. 

 4. According to the authors the most important reaction that takes place is the dissolution of Al out of 
the slag and its transferal into the liquid steel, where it reacts with the inclusions and changes their 
chemistry. Flotation of the inclusions is assumed to be negligible, due to the small size of the 
crucible and lack of stirring. 
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In this example only the last reaction is simulated after adding the slag. The kinetic 
parameters, compositions of all materials and process schedule are all taken from the 
publication.

Results and Experimental Analysis

The plots below compare the Al content in the liquid steel with the experimentally determined amount. 
The bottom plot shows how the Al2O3 from the slag phase is gradually reduced to metallic Al that dissolves 
in the liquid steel. 

In this example, only part of the Al in the liquid steel is dissolved as metallic Al. With the 
Process Metallurgy Module, it is possible to plot both dissolved Al and also total Al.  

In the steel industry this fraction of Al in the liquid steel is often termed dissolved Al. The rest of the Al 
reacts with the oxygen in the liquid steel and forms oxide inclusions. The amount of dissolved Al plus the Al  
bound up in oxide inclusions is often termed total Al. The difference between total Al minus dissolved Al is 
an important measure for the steel cleanness. 

Total Al is what was measured by Piva et al. [2017] and their experimental data are compared to the 
calculated values below.
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Figure 245: Total Al in the steel compared with experimental data (blue/top curve). Additionally the amount of 
dissolved Al is plotted (red/bottom curve), this is done by selecting “Composition of phase group” and “Liquid 
metal”. Note that the red/bottom curve is not available with the example. 

Immediately after killing the steel with SiMn and FeMn, the liquid steel contains liquid Si-Mn-oxide 
inclusions only. As the liquid steel picks up Al from the slag phase in function of time, the inclusions get 
richer and richer in Al. This experimentally verified change in inclusion chemistry is well reproduced by this 
simulation.

In the experiment, only the average composition of all inclusions could be measured; the type 
of inclusion (liquid / solid) was not determined.

Figure 246: Calculated composition of non-metallic inclusions in function of processing time compared to 
experimental data [2017Piv].

With this simulation it is also possible to calculate the amount and type of inclusions present in the liquid 
steel. At the beginning of the process all the inclusions are liquid oxides, that gradually get richer in Al2O3 
as the steel picks up Al from the slag.  After 20 minutes processing time, the first solid corundum (Al2O3) 
inclusions start appearing. After 25 minutes almost no liquid inclusions remain. 
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Figure 247: Amount of inclusions in the liquid steel in function of processing time. The total amount of inclusions 
(red line) and liquid oxide inclusions (blue line) are plotted. Up to about 20 min all inclusions are liquid oxide type, 
then they are replaced by solid corundum (Al2O3) inclusions. Experimental data from [2017Piv].

Reference

[2017Piv] Piva, S. P. T., Kumar, D. & Pistorius, P. C. "Modeling Manganese Silicate Inclusion Composition 
Changes during Ladle Treatment Using FactSage Macros," Metall. Mater. Trans. B 48, 37–45 (2017).
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PMET_06: Ladle Furnace (LF) Kinetics

This in-depth example, which is also showcased on our website, uses the Process Metallurgy Calculator to 
show how to set up a full kinetic simulation of steel refining in a ladle furnace using the Process Metallurgy 
Module in Thermo-Calc. The Process Metallurgy Module uses the Effective Equilibrium Reaction Zone 
model (EERZ) to simulate the kinetics of the process. In this example, a full kinetic simulation of the LF 
refining process  is set up using the Process Metallurgy Module. 

For a simpler process  that describes a lab-scale ladle furnace process, see "PMET_05: Lab Scale 
Ladle Furnace (LF) Kinetics" on page 366.

Background Overview

After steelmaking, which is mostly performed in a basic oxygen furnace (BOF) or electric arc furnace (EAF), 
the steel is usually tapped into a ladle where certain additions are made (deoxidation agents, slag formers, 
certain alloying elements) and then transferred to the ladle furnace (LF). The LF fulfils many purposes in the 
steel refining process, the most important being:

 l Temperature control / heating by an electrical arc.

 l Mixing by Ar or N2 bubbling through porous plugs in the bottom of the ladle to achieve 
homogeneous temperature and composition throughout the ladle.

 l Removal of unwanted non-metallic phases / inclusions such as corundum (Al2O3), liquid oxide 
inclusions, spinel, on so on, by flotation, aided by Ar or N2 bubbling.

 l Modification / engineering of non-metallic inclusions so that they are not detrimental for the 
downstream processing and/or the final product.

 l Removal of unwanted volatile elements such as Pb, Zn, Sn, and so on. Due to their high vapor 
pressure, these elements are enriched in the rising Ar or N2 bubbles. After the gas escapes out of 
the ladle and cools, they condense, forming copious amounts of dust.

 l Removal of unwanted elements such as sulphur by liquid steel / slag reactions.

 l Lowering of the dissolved gas content. In the LF this is mainly achieved through chemical reactions. 
For direct removal of dissolved gas, vacuum degassing (VD) is usually required.

 l Alloying and trimming of the steel to achieve the exact alloy composition required by the 
specification of the steel that is to be produced.

The reactions taking place in a LF are a complex interplay between equilibrium thermodynamics that define 
the direction of chemical reactions, and kinetics that define how fast the equilibrium state is approached.
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 Project File and License Information

 l Folder: Process Metallurgy  

 l File name: PMET_06_Ladle_Furnace_Kinetics.tcu

This example requires the database TCOX10 or newer, a full license of Thermo-Calc 2020b or 
newer, plus a license for the Process Metallurgy Module.

Visualizations

This example is included as a Process Metallurgy tutorial on our website and as part of the 
playlist our YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

The resulting plots and details related to setting up this example are available  to download via 
the dedicated web page. 
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The nodes in the Project window for this example. The Process Metallurgy Calculator is renamed to EERZ model. If 
you click this node the Configuration window opens, which is where all the settings for the process simulation are 
located. This advanced example also uses three Experimental Data Reader nodes to read the experimental data 
that is included in the simulation results. After setting up the system and accessing the experimental data, you 
then add Plot Renderers to the calculator to generate the output in the Visualizations window. 
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PMET_07: Vacuum Oxygen Decarburization Kinetics

The vacuum oxygen decarburization (VOD) process is used to lower the carbon content in a stainless steel 
without compromising on the Cr yield.

This application example, which is available on our website  and uses the Process Metallurgy Calculator, 
shows how the Process Metallurgy Module in Thermo-Calc can be used to simulate the Vacuum Oxygen 
Decarburization (VOD) process for a stainless steel.

In this example, based on data of a real vacuum oxygen decarburization (VOD) process published by Ding et 
al. [2000Din], we show how to set up the VOD process in Thermo-Calc’s Process Metallurgy Module. Use of 
the following features in the Process Metallurgy Module are highlighted in this example:

 l Change of pressure as a function of time during the process

 l Change of reaction kinetics as a function of time during the process

 l Selection of zone where degassing is allowed

Project File and License Information

 l Folder: Process Metallurgy  

 l File name: PMET_07_Vacuum_Oxygen_Decarburization_Kinetics.tcu

This example requires a license for Thermo-Calc 2024a or newer, the database TCOX13 or 
newer, and a license for the Process Metallurgy Module.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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The resulting plots and details related to setting up this example are available  to download via 
the dedicated web page. 

Reference

[2000Din] R. Ding, B. Blanpain, P. T. Jones, P. Wollants, Modeling of the vacuum oxygen decarburization 
refining process. Metall. Mater. Trans. B. 31, 197–206 (2000).
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PMET_08: Steel Deoxidation on Tapping

This application example, which is available on our website and uses the Process Metallurgy Calculator, 
shows a few of the ways the Process Metallurgy Module in Thermo-Calc can be used to investigate steel 
deoxidation (killing) on tapping.

About Deoxidation or “Killing” of Steel

Deoxidation of steel, also known as killing of steel, occurs toward the end of the steelmaking process, but 
before desulphurization. After primary steelmaking, for example in a basic oxygen furnace (BOF) or electric 
arc furnace (EAF), the liquid steel contains a large amount of dissolved oxygen [O] (400 to over 1000 ppm.) 
(see "PMET_04: Basic Oxygen Furnace (BOF) Kinetics" on page 364).  

This oxygen must be removed from the liquid steel for several reasons, including:

 l Desulphurization is not effective with high oxygen content in the steel 

 l Continuous casting of un-killed steel is not possible and will result in “boiling” of the steel in the 
mould and massive porosity.

The two most widely applied methods of deoxidizing or killing the steel are adding Al to the steel (Al-killed 
steel) and adding Si to the steel (Si-killed steel). In this example we look at how the Process Metallurgy 
Module in Thermo-Calc can be used to investigate these two widely applied methods of deoxidizing or 
killing the steel.

The two most widely applied methods of deoxidizing or killing the steel are adding Al (Al-killed steel) to the 
steel and adding Si (Si-killed steel) to the steel. These elements readily react with oxygen to form oxides 
that precipitate within the liquid steel. This does not reduce the total amount of oxygen in the liquid steel; 
it simply transforms the dissolved oxygen into an oxide precipitate. This oxide precipitate then needs to be 
removed from the steel by flotation during secondary metallurgy in the ladle furnace (LF).

This, however, can result in the formation of damaging inclusions that cause problems during further 
processing, so we go on to look at two simple and very common processes that are used to transform the 
solid SiO2 and Al2O3 inclusions into liquid oxides so that they are less damaging.

Project File and License Information

 l Folder: Process Metallurgy  

 l File name: PMET_08_Steel_Deoxidation_on_Tapping.tcu
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Choose a or b versions of the example based  on your license.

 l PMET_08a_Steel_Deoxidation_on_Tapping.tcu is included in a regular Thermo-Calc installation as 
well as the free Educational version of Thermo-Calc. It is a simplified version that uses the OXDEMO 
database.

 l PMET_08b_Steel_Deoxidation_on_Tapping.tcu requires a full license of Thermo-Calc version 
2021b or newer and database TCOX11 or newer.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

The resulting plots and details related to setting up this example are available  to download via 
the dedicated web page. 
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Nickel Model Library Examples Collection

The General Models  are available to all users. To run calculations with the Nickel Models (as 
part of the Nickel Model Library) requires a valid maintenance license plus licenses for both 
the TCNI (version 11 and newer) and MOBNI (version 5 and newer) databases. 

These examples use the Property Model Calculator, an activity available with Thermo-Calc plus the 
available Property Models in the Nickel Model Library. 

In this section:

PM_Ni_01: Lattice Parameter of γ/γ' 379

PM_Ni_02: Antiphase Boundary Energy of γ' 381

PM_Ni_03: Critical Temperatures of Alloy 718 383

PM_Ni_04: Strain Age Cracking (SAC) 385
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PM_Ni_01: Lattice Parameter of γ/γ'

The example uses the Property Model Calculator with the Equilibrium with Freeze-in Temperature - Ni 
Model.

The lattice parameters are measured experimentally for γ/γ' in a Ni0.6Mo0.92Ta12.5Al1.83Ti10.5Cr3.3W 
alloy.

The thermodynamically stable equilibrium will not be reached for this alloy during the experimental heat 
treatment; only the phases γ and γ' are noticed in the experiment. The γ/γ' microstructure is in this 
calculation example assumed to freeze-in at 1000 °C where the phase compositions do not change during 
cooling to room temperature.

Some of the key settings to note in this example: 

 l The Subset of phases is selected as Gamma and gamma-prime only to match the experimental 
observations. 

 l The Freeze-in temperature is set to 1000 °C. 

 l A One Axis calculation is used where the evaluation temperatures are within a range of 20 °C to 
1000 °C.

Project File and License Information

 l Folder: Property Models → Nickel

 l File name: PM_Ni_01_Lattice_Parameter_of_Gamma_Gamma_Prime.tcu

To run calculations with the Nickel Models requires a valid maintenance license plus licenses 
for both the TCNI (version 11 and newer) and MOBNI (version 5 and newer) databases. For 
some Property Models, additional recommendations for the database version to use is 
indicated in its description. Also see our website to learn more about the Nickel Model Library.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.
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Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

Figure 248: The lattice parameters for γ and γ' are plotted against experimental data from [1985Nat].

Reference

[1985Nat] M. V. Nathal, R. A. Mackay, R. G. Garlick, Temperature dependence of γ-γ’ lattice mismatch in 
Nickel-base superalloys. Mater. Sci. Eng. 75, 195–205 (1985).
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PM_Ni_02: Antiphase Boundary Energy of γ'

The example uses the Property Model Calculator with the Antiphase Boundary Energy - Ni Model.

This example shows a calculation of the antiphase boundary energy for an Al75Ni alloy at room 
temperature with increasing amounts of Ti. The plot shows the (111) APB energy in Ni3Al1−xTix over the 
whole compositional range together with first-principle calculations from Chandran and Sondhi [2011Cha] 
and Vamsi and Karthikeyani [2012Vam] evaluated at 0 K. The trend with increasing 111 APBE with an 
increasing amount of Ti is predicted by all calculations but the absolute values between the first principle 
calculations are quite different.

Some of the key settings to note in this example: 

 l γ' is the only stable phase for these compositions. FCC_L12 is therefore selected as the only phase  in 
the System Definer.

 l The Freeze-in temperature and evaluation temperature are both set at 20 °C with the Subset of 
phases for All phases. 

 l A One Axis calculation is used with Mole percent Ti between 0 and 25 in 20 steps.

 l The plotting quantity APBE for 111 plane (1/2) is then compared with the first principle 
calculations.

Project File and License Information

 l Folder: Property Models → Nickel

 l File name: PM_Ni_02_Antiphase_Boundary_Energy_of_Gamma_Prime.tcu

To run calculations with the Nickel Models requires a valid maintenance license plus licenses 
for both the TCNI (version 11 and newer) and MOBNI (version 5 and newer) databases. For 
some Property Models, additional recommendations for the database version to use is 
indicated in its description. Also see our website to learn more about the Nickel Model Library.
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Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

Figure 249: Composition of Ti (mole %) compared to antiphase boundary surface energy for 111 plane and 
experimental data from [2011Cha; 2012Vam].

References

[2011Cha] M. Chandran, S. K. Sondhi, First-principle calculation of APB energy in Ni-based binary and 
ternary alloys. Model. Simul. Mater. Sci. Eng. 19, 025008 (2011).

[2012Vam] K. V. Vamsi, S. Karthikeyan, Effect of Off-Stoichiometry and Ternary Additions on Planar Fault 
Energies in Ni3Al, in Superalloys 2012 (John Wiley & Sons, Inc., Hoboken, NJ, USA, 2012; pp. 521–530.
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PM_Ni_03: Critical Temperatures of Alloy 718

The example uses the Property Model Calculator with the Solvus for Ordered Phase-Ni Model.

In this example, the respective solvus temperatures of the Delta and Gamma double-prime phases are 
calculated.

For the Delta phase, the Subset of phases is set to All phases but the result varies very little with the 
selected subset (provided that the Delta phase is included). For the Gamma double-prime phase, which is a 
metastable phase, it is necessary to use the Typical Ni-base superalloy phase subset.

The resulting solvus temperatures are compared with experimental data from [2010Fra].

Project File and License Information

 l Folder: Property Models → Nickel

 l File name: PM_Ni_03_Critical_Temperatures_Alloy_718.tcu

To run calculations with the Nickel Models requires a valid maintenance license plus licenses 
for both the TCNI (version 11 and newer) and MOBNI (version 5 and newer) databases. For 
some Property Models, additional recommendations for the database version to use is 
indicated in its description. Also see our website to learn more about the Nickel Model Library.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 250: Solvus temperatures for NI3TA_D0A (Delta) and BCT_D022 (Gamma double-prime) compared to 
experimental data [2010Fra].

Reference

[2010Fra] R. B. Frank, C. G. Roberts, J. Zhang,  Effect of Nickel Content on Delta Solvus Temperature and 
Mechanical Properties of Alloy 718, in 7th International Symposium on Superalloy 718 and Derivatives 
(2010) (TMS (The Minerals, Metals & Materials Society), 2010, pp. 725–736.
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PM_Ni_04: Strain Age Cracking (SAC)

The example uses the Property Model Calculator with the Strain-Age Cracking - Ni Model.

Welding or additive manufacturing (AM) of Ni-base alloys has so far been strongly limited by various 
cracking issues during processing or post-processing. Strain-age cracking (SAC) occurs when the 
combination of thermal stresses and coherency stresses between the γ matrix and γ’ precipitates exceed 
the local strength of the alloy structure. Thermal residual stresses originate from the initial processing 
(welding or AM), while coherency stresses form during post-processing heat treatments, when γ’ re-
precipitates in the matrix. Coherency stresses may be tensile or compressive depending on the sign of the 
lattice misfit. 

Furthermore, coherency stresses scale with the fraction of γ’, making conventional high-γ’ alloys virtually 
impossible to weld or shape via AM. At the same time, high-γ’ fraction alloys offer attractive properties, 
such as high strength at high service temperatures. In order for such alloys to be processable, it is 
necessary to reduce the cracking tendency.  

Thermal stresses are very difficult to alleviate, as this requires heating, which in turn triggers re-
precipitation of γ’. Therefore, an alternative strategy may be to target the coherency stresses, which are 
determined by the respective lattice parameters of the matrix and precipitate. Such a strategy was adopted 
by Zhou et al. [2020Zho], where they optimized the composition of the Ni-base alloy to fulfill the above 
criteria, i.e., high fraction of γ’ and no strain-age cracking tendency.  

In this example, the experimental alloys from [2020Zho] are analyzed based on the Strain-Age Cracking - Ni 
Property Model  to compare the tendency for cracking using an SAC risk factor. 

Project File and License Information

 l Folder: Property Models → Nickel

 l File name: PM_Ni_04_Strain_Age_Cracking.tcu

To run calculations with the Nickel Models requires a valid maintenance license plus licenses 
for both the TCNI (version 11 and newer) and MOBNI (version 5 and newer) databases. For 
some Property Models, additional recommendations for the database version to use is 
indicated in its description. Also see our website to learn more about the Nickel Model Library.
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This example uses TCNI12, but in general can be run with version 11 (TCNI11) and newer 
databases. 

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

Performing the calculation for the two experimental alloys, along with the CM247LC benchmark alloy and 
using the temperature interval setting produces a set of relevant output results as shown in a table (Figure 
251) and Parallel coordinates plot (Figure 252). CM247LC is considered to be very difficult to weld, which is 
evidenced by the very high value of the SAC risk factor. Comparatively, the two experimental alloys, ExpAM 
and ExpAMmod, show values very close to zero. Low or negative values of the SAC risk factor can be 
interpreted as low or no risk for strain-age cracking.

Conventionally, the weldability of a given Ni-base alloy has been assessed based on the Ti and Al contents, 
which correlate with the fraction of γ’. However, such an approach neglects the fact that it is the coherency 
stresses that cause cracking, and these are also dependent on the lattice misfit. By tailoring an alloy to have 
low misfit, in relation to the γ’ fraction and in the relevant temperature range, it is possible to design a 
high-γ’ fraction alloy with very low risk for SAC, as shown in [2020Zho]. The SAC model used here captures 
all of these effects and can be used as a design tool for the purpose of eliminating this cracking tendency.
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Figure 251: There are a two ways to view the data in table format. In this example, there is a Table Renderer node 
added to the Project window that lists the data points in the Visualizations window. 

You can also access the same information via the Plot Renderer Configuration window by 
clicking the Table View button followed by clicking Perform. This converts the Parallel 
coordinates plot type to the same table of information.

Figure 252:  Parallel plot of the resulting SAC risk factor along with experimental and calculated solvus of γ’ for 
the three alloys compared in [2020Zho].

Reference

[2020Zho] N. Zhou, A. D. Dicus, S. A. J. Forsik, T. Wang, G. A. Colombo, M. E. Epler, Development of a New 
Alumina-Forming Crack-Resistant High-γ′ Fraction Ni-Base Superalloy for Additive Manufacturing, in 
Superalloys 2020, pp. 1046–1054.
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Noble Metal Alloys Model Library Examples 
Collection

These examples use the Property Model Calculator, an activity available with Thermo-Calc plus 
the available Property Models in the Noble Metal Alloys Model Library. 

The General Models  are available to all users. To run calculations with the Noble 
Metal Alloys Models (as part of the Noble Metal Alloys Model Library) requires a 
valid maintenance license plus a license for the TCNOBL (version 3 and 
newer) database. 

In this section:

PM_Noble_01: Color Prediction 389
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PM_Noble_01: Color Prediction

The Optical Properties - Noble Property Model, available with the Property Model Calculator 
and the Noble Metal Alloys Model Library, is used to simulate the color, reflection, and 
transmission of light, based on modeling the alloy microstructure and the resulting optical 
properties. This model is currently applicable for the Au-Al-Ag-Cu-Pt system.

This example uses the Property Model Calculator with the Optical Properties - Noble Property 
Model. 

The example demonstrates three use cases for simulating color in the Ag-Au-Cu alloy system (1) 
screening the color of the alloy system (2) designing a green-gold alloy by adjusting Ag content, 
and (3) visualizing the impact of alloy thickness and light incident angle on color. 

Project File and License Information

 l Folder: Property Models → Noble Metals

 l File name: PM_Noble_01_Color_Prediction.tcu

To run calculations with the Noble Metal Alloys Models (as part of the Noble 
Metal Alloys Model Library) requires a valid maintenance license plus a license for 
the TCNOBL (version 3 and newer) database. 

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access 
in a variety of ways. When in Thermo-Calc, from the menu select Help → Video 
Tutorials, or from the main My Project window, click Video Tutorials. Alternately,  
you can go to the website or our YouTube channel.

Open the example project file  to review the node setup on the Project window and the 
associated settings on the Configuration window for each node. For some types of projects, 
you can also adjust settings on the Plot Renderer Configuration window to preview results 
before performing the simulation. Click Perform Tree to generate plots and tables to see the 
results on the Visualizations window.

https://www.thermocalc.com/training/video-tutorials/
https://www.youtube.com/channel/UCLTh3apGItuaVK69mrwcpJg/featured
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When you run (Perform) this example, it takes a few minutes for the calculations 
to complete.

Screening the Color of the Ag-Au-Cu Alloy System

 l The entire composition space was screened with a 2 wt.% step size.

 l Alloys were annealed at 873.15 K to reach equilibrium phases and compositions for 
accurate color prediction.

 l The standard illuminant is D65 noon daylight, with a 2 ̊standard observer. The material 
is assumed to be opaque with a thickness of 10,000 nm.

 l Some color predictions near the 20–40 wt.% Cu region require model accuracy 
improvements.

Figure 253: Color prediction for Ag-Au-Cu alloy.
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Designing a Green Gold Alloy by Adjusting Ag Content in Au-10Cu-xAg 
Alloys

 l ΔE calculation box was chosen to enable the measurement of color differences.

 l Target color in Lab color space is [95, -13, 25], representing a light green shade.

Figure 254: Change of color difference (ΔE) between the targeting light green gold and the simulated 
alloy when changing Ag content.

Visualizing the Impact of Alloy Thickness and Light Incident Angle on Color

 l Intercritical annealing was not selected, as pure gold is in the FCC phase and does not 
require equilibrium calculations.

 l As material thickness increases, the color of gold tends to approach the bulk gold color 
observed in macroscopic samples.
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Figure 255: Color of pure gold varies with different light incident angles and material thicknesses.



Steel Model Library Examples Collection

The General Models  are available to all users. To run calculations with  the Steel Models (as 
part of the Steel Model Library) requires a valid maintenance license plus licenses for both the 
TCFE (version 9 and newer) and MOBFE (version 4 and newer) databases. 

These examples use the Property Model Calculator, an activity available with Thermo-Calc plus Property 
Models in the Steel Model Library. 

In this section:

PM_Fe_01: Fe-Cr-C Martensite with Intercritical Annealing 394

PM_Fe_02: Fe-Mn Martensite Morphologies 397

PM_Fe_03: Fe-C-Mn Pearlite 399

PM_Fe_04: Critical Temperatures 402

PM_Fe_05: Fe-C-Mn-Si-Ni-Cr-Mo Bainite 405

PM_Fe_06: TTT Diagram for Fe-C-Mn-Si-Cr-V 407

PM_Fe_07: Hardenability Design of Steel 409

PM_Fe_08: CCT Diagram for Fe-C-Mn-Si-Cr-V 411

PM_Fe_09: Fe-C-Ni Ferrite 413

PM_Fe_10: Martensitic Steel Strength 416

PM_Fe_11: Steel Design Using the Parallel Coordinates Plot 420

PM_Fe_12: Flow Stress 15-5PH Steel 423
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PM_Fe_01: Fe-Cr-C Martensite with Intercritical Annealing

The example uses the Property Model Calculator with the Martensite Fractions and Martensite 
Temperatures Models to  calculate martensite fractions and martensite temperatures [martensite start 
(Ms) and 90% transformation temperature (M90)]. 

The alloy is first intercritically annealed and then quenched. Austenite composition is determined by an 
equilibrium calculation at the annealing temperature. Martensite fraction is calculated as a function of 
temperature which the alloy is quenched to. The example also shows how Cr content in the alloy influences 
Ms and M90 after intercritical annealing.

Project File and License Information

 l Folder: Property Models → Steel

 l File name: PM_Fe_01_Fe-Cr-C_martensite_intercritical_annealing.tcu

To run calculations with the Steel Models requires a valid maintenance license plus licenses 
for both the TCFE (version 9 and newer) and MOBFE (version 4 and newer) databases. Also see 
our website to learn more about the Steel Model Library and other related examples.

Visualizations

This example is included as a Property Model tutorial on our website and as part of the 
Property Model Calculator playlist on our YouTube channel. 

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 256: The transformation curves plot showing Fe-Cr-C martensite with intercritical annealing.

Figure 257: Comparing Martensite start (Ms) to Martensite finish (Mf).
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Reference

[1949Har] W. J. Harris, M. Cohen, Stabilization Of The Austenite-Martensite Transformation. Trans. AIME. 
180, 447–470 (1949).
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PM_Fe_02: Fe-Mn Martensite Morphologies

The example uses the Property Model Calculator with the Martensite Temperatures Property Model to 
calculate the Ms temperatures of different types of martensites: lath, plate, and ε (HCP), compared with 
experimental ε Ms values taken from several sources.

Project File and License Information

 l Folder: Property Models → Steel

 l File name: PM_Fe_02_Fe-Mn_Martensite_Morphologies.tcu

To run calculations with the Steel Models requires a valid maintenance license plus licenses 
for both the TCFE (version 9 and newer) and MOBFE (version 4 and newer) databases. Also see 
our website to learn more about the Steel Model Library and other related examples.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 258: A diagram showing all the Ms temperatures of different types of martensite morphologies (lath, plate 
and epsilon (HCP) compared with experimental epsilon Ms values.
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PM_Fe_03: Fe-C-Mn Pearlite

The example uses the Property Model Calculator and with the Pearlite Property Model and shows how to 
calculate pearlite growth rate, lamellar spacing, and times of start (2% transformation) and finish (98% 
transformation) as functions of isothermal heat treating temperature in an Fe-0.69C-1.80Mn alloy (mass 
%). With maximize growth rate set as the criterion, the model gives maximal growth rate and minimal 
lamellar spacing. With optimal pearlite as the pearlite mode, the model optimizes partitioning of 
substitutional alloying element(s) (Mn in this example) according to the criterion, which realizes a smooth 
transition between ortho-pearlite at high temperature and para-pearlite at low temperature.

Project File and License Information

 l Folder: Property Models → Steel

 l File name: PM_Fe_03_Fe-C-Mn_Pearlite.tcu

To run calculations with the Steel Models requires a valid maintenance license plus licenses 
for both the TCFE (version 9 and newer) and MOBFE (version 4 and newer) databases. Also see 
our website to learn more about the Steel Model Library and other related examples.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 259: Growth rate as a function of temperature.

Figure 260: Lamellar spacing as a function of temperature.
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Figure 261: The TTT (time-temperature-transformation) diagram showing times of start (2% transformation) and 
finish (98% transformation) as functions of isothermal heat treating temperature in an Fe-0.69C-1.80Mn alloy 
(mass %).

Reference

[1974Raz] N. Razik, G. Lorimer, N. Ridlley, An investigation of manganese partitioning during the austenite-
pearlite transformation using analytical electron microscopy. Acta Metall. 22, 1249–1258 (1974).

Steel Model Library Examples Collection ǀ 401 of 431



PM_Fe_04: Critical Temperatures

The example uses the Property Model Calculator and the Critical Transformation Temperatures Model to 
calculate the distribution of the typical phase transition temperatures for a low alloy steel (Fe-0.3Cr-1.0Mn-
0.3Mn-0.18C) when the composition is varied within the specification for the alloy. 

In the set up of the example, the Critical Transformation Temperatures model is used with a Property 
Model Calculator Uncertainty calculation to plot a histogram showing the distribution of A1- and A3-
temperatures (Figure 262). As a comparison,  an Equilibrium Calculator, One Axis calculation results in a 
property diagram showing the phase transitions for the nominal composition (Figure 263). 

The phase transition temperatures are defined as:

 l Liquidus: First austenite or ferrite transformation from the liquid

 l Solidus: Liquid fully transformed to solid

 l A0: Magnetic transition temperature (Curie temperature) of cementite. The cementite is 
paramagnetic above A0 and ferromagnetic below

 l A1: Austenite (FCC_A1) transforms to ferrite (BCC_A2) + carbide (cementite or graphite or M23C6)

 l A2: Magnetic transition temperature (Curie temperature) of ferrite (BCC_A2). Paramagnetic above 
A2 and ferromagnetic below

 l A3: Austenite (FCC_A1) transforms to ferrite (BCC_A2)

Project File  and License Information

 l Folder: Property Models → Steel

 l File name: PM_Fe_04_Critical_Temperatures.tcu

The FEDEMO: Iron Demo Database  is used and this example is available to all 
users. However, in general a license is required to run the Steel Models.
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Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

Figure 262: The distribution of the A1 and A3 phase transition temperatures for a low alloyed steel (Fe-0.3Cr-
1.0Mn-0.3Mn-0.18C) when the composition is varied within the specification. This plot uses the Critical 
Transformation Temperatures model with the Property Model Calculator.
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Figure 263: This plot uses an Equilibrium Calculator to show an alternate visualization of the phase transitions in 
a property diagram for the nominal composition. 
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PM_Fe_05: Fe-C-Mn-Si-Ni-Cr-Mo Bainite

The example uses the Property Model Calculator and the Bainite Steel Model to calculate a Time-
Temperature-Transformation (TTT) diagram for an Fe-0.97C-0.72Mn-0.32Si-1.54Ni-0.8Cr-0.26Mo alloy. The 
result is compared to experimental results from [1948Jaf]. Other elements with low amount in the 
experimental alloy are omitted for the calculation.

Considered elements: Fe, C, Mn, Si, Cr, Ni, and Mo. Other elements in the system are 
neglected for bainite by mass percent.

A Property Model Calculator is used with a One Axis calculation and the TTT mode selected on the Plot 
Renderer to plot the TTT diagram.

Project File and License Information

 l Folder: Property Models → Steel

 l File name: PM_Fe_05_Fe-C-Mn-Si-Ni-Cr-Mo_Bainite.tcu

To run calculations with the Steel Models requires a valid maintenance license plus licenses 
for both the TCFE (version 9 and newer) and MOBFE (version 4 and newer) databases. Also see 
our website to learn more about the Steel Model Library and other related examples.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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When you run (Perform) this example, it takes a few minutes for the calculations to complete.

Figure 264: The bainite TTT diagram for an  Fe-0.97C-0.72Mn-0.32Si-1.54Ni-0.8Cr-0.26Mo alloy.

Reference

[1948Jaf]  L. D. Jaffe, Anisothermal formation of bainite and proeutectoid constituents in steels, Trans. 
AIME, vol. 176, pp. 343–383 (1948).
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PM_Fe_06: TTT Diagram for Fe-C-Mn-Si-Cr-V

The example uses the Property Model Calculator and the TTT Diagram Property Model to calculate a  Time-
Temperature-Transformation (TTT) diagram for an Fe-C-Mn-Si-Cr-V alloy (Steel 42CrV6). The calculation is 
compared to an experimental TTT diagram for the same steel (with some other impurities) from data in 
[1958Wev].  

A One Axis Calculation Type is selected on the Property Model Calculator and then the TTT Mode selected 
on the Plot Renderer as the Plot type in order to plot the final TTT diagram.

A second plot also shows the calculated terminal fractions of ferrite, pearlite, and bainite.

Project File and License Information

 l Folder: Property Models → Steel

 l File name: PM_Fe_06_Fe-C-Mn-Si-Cr-V_TTT.tcu

To run calculations with the Steel Models requires a valid maintenance license plus licenses 
for both the TCFE (version 9 and newer) and MOBFE (version 4 and newer) databases. Also see 
our website to learn more about the Steel Model Library and other related examples.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it takes several hours to complete the calculations. 
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Figure 265: The TTT diagram for an  Fe-C-Mn-Si-Cr-V alloy comparing the calculation with experimental data from 
[1958Wev].

Figure 266: The terminal fractions quantities for bainite, ferrite, and pearlite are plotted against the cooling rate 
for the Fe-C-Mn-Si-Cr-V alloy.

Reference

[1958Wev] F. Wever, A. Rose, Atlas zur Wärmebehandlung der Stähle: 1954/56/58 (Verlag Stahleisen, 
Düsseldorf, 1958), p. II-112.
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PM_Fe_07: Hardenability Design of Steel

This application example, which is available on our website, shows how the Steel Model Library in Thermo-
Calc can be used to find the optimal compositions for an Fe-Mn-C steel to achieve high hardenability for 
the purpose of strength.

Hardenability of steel is an important aspect of steel design because it affects the ability of the steel to 
develop optimum strength and toughness. Hardenability refers to the ability of steel to form martensite on 
quenching. It is a measure of the capacity of a steel to be hardened in depth when quenched from its 
austenitizing temperature, meaning that the steel forms martensite not only at the surface of the steel, but 
throughout the interior. This is usually a prerequisite for the subsequent tempering treatment for an 
optimal combination of strength and toughness. Insufficient hardenability can make the tempering 
treatment ineffective and lead to low uniformity of mechanical properties in a steel component. The two 
most important factors that influence hardenability of steel are grain size and composition, and in this 
example, we will investigate composition.

Project File and License Information

 l Folder: Property Models → Steel

 l File name: PM_Fe_07_Hardenability_Design_of_Steel.tcu

Although this example uses the FEDEMO and MFEDEMO databases, running the calculation 
requires a license for Thermo-Calc 2022b or newer and for the Steel Model Library.

Visualizations

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it takes several hours to complete the calculations. 
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The resulting plots and details related to setting up this example are available  to download via 
the dedicated web page. 
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PM_Fe_08: CCT Diagram for Fe-C-Mn-Si-Cr-V

The example uses the Property Model Calculator and the CCT Diagram Property Model to calculate a 
Continuous-Cooling-Transformation (CCT) diagram for an Fe-C-Mn-Si-Cr-V alloy (Steel 42CrV6). The 
calculation is compared to an experimental CCT diagram for the same steel (with some other impurities) 
from data in [1958Wev]. 

A One Axis Calculation Type is selected on the Property Model Calculator and then the CCT Mode selected 
as the Plot type on the Plot Renderer in order to plot the final CCT diagram.

A second plot also shows the calculated terminal fractions of ferrite, pearlite, bainite, and martensite.

Project File and License Information

 l Folder: Property Models → Steel

 l File name: PM_Fe_08_Fe-C-Mn-Si-Cr-V_CCT.tcu

To run calculations with the Steel Models requires a valid maintenance license plus licenses 
for both the TCFE (version 9 and newer) and MOBFE (version 4 and newer) databases. Also see 
our website to learn more about the Steel Model Library and other related examples.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it takes several hours to complete the calculations. 
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Figure 267: The CCT diagram for an  Fe-C-Mn-Si-Cr-V alloy comparing the calculation with experimental data from 
[1958Wev].

 

Figure 268: The terminal fractions quantities for bainite, ferrite, martensite, and pearlite are plotted against the 
cooling rate for the Fe-C-Mn-Si-Cr-V alloy.

Reference

[1958Wev] F. Wever, A. Rose, Atlas zur Wärmebehandlung der Stähle: 1954/56/58 (Verlag Stahleisen, 
Düsseldorf, 1958), p. II-112.
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PM_Fe_09: Fe-C-Ni Ferrite

The example uses the Property Model Calculator and the Ferrite Property Model to calculate the ferrite 
fraction parabolic rate constant and ferrite start time for an Fe-0.12C-3.28Ni alloy.

Two growth modes—Orthoequilibrum (OE) and Paraequilibrium (PE)—are used with a One Axis calculation 
type to compare the ferrite molar fraction and to determine the ferrite start time for each growth mode.

The experimental data for the ferrite start is taken from [1966Aar]. For the parabolic rate constant 
experimental data is from [1981Bra].

Project File and License Information

 l Folder: Property Models → Steel

 l File name: PM_Fe_09_Fe-C-Ni_Ferrite.tcu

To run calculations with the Steel Models requires a valid maintenance license plus licenses 
for both the TCFE (version 9 and newer) and MOBFE (version 4 and newer) databases. Also see 
our website to learn more about the Steel Model Library and other related examples.

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it takes a few minutes for the calculations to complete.
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Figure 269: Ferrite fraction at the end of the transformation, under orthoequilibrium (OE) or paraequilibrium (PE).

Figure 270: Parabolic rate constant. Experimental data is from [1981Bra].
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Figure 271: Ferrite start time. This plot also uses the TTT mode. Experimental data from [1966Aar].

References

[1966Aar] H. I. Aaronson, H. A. Domian, Partition of alloying elements between austenite and proeutectoid 
ferrite or bainite. AIME MET SOC TRANS. 236, 781–796 (1966).

[1981Bra] J. R. Bradley, H. I. Aaronson, Growth kinetics of grain boundary ferrite allotriomorphs in Fe-C-X 
alloys. Metall. Trans. A. 12, 1729–1741 (1981).

Steel Model Library Examples Collection ǀ 415 of 431



PM_Fe_10: Martensitic Steel Strength

The Martensitic Steel Strength Property Model, available with the Property Model Calculator and the Steel 
Model Library, predicts the general flow stress properties of martensitic steels, such as hardness, stress at 
arbitrary strain, yield strength, ultimate tensile strength, Young's modulus, etc.

The Model evaluates the following in consecutive steps:

 l Martensite fraction based on composition, annealing temperature, and quench temperature

 l Hardness of the as-quenched microstructure

 l Effect of tempering on microstructure and hardness

 l Young's modulus based on the composition of the matrix phase and contributions from precipitates

 l Strain hardening response (flow stress) based on the final hardness after tempering

In this example, data for AISI4068 from [1956Gra] are compared to calculations using the Martensitic Steel 
Strength model. In the set up, one System Definer and two Experimental File Reader activities are used 
along with four Property Model Calculators. The Martensitic Steel Strength Property Model is used in all 
cases with One Axis calculations to produce two plots that compare the tempering temperature and time 
to the total hardness of tempered steels. 

Project File and License Information

 l Folder: Property Models → Steel

 l File name: PM_Fe_10_Martensitic_Steel_Strength.tcu

To run calculations with the Steel Models requires a valid maintenance license plus licenses 
for both the TCFE (version 9 and newer) and MOBFE (version 4 and newer) databases. Also see 
our website to learn more about the Steel Model Library and other related examples.

This example uses TCFE13. Earlier versions of this database can be used although there may 
be slight differences in the results. 
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Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

For some Windows-based systems, performing the full calculation from the top My Project 
node can result in out of memory issues due to the number of calculators. If this happens, 
perform individual calculations for each Property Model Calculator (e.g. right-click the node 
and select Perform Now). This produces the full plots that are output to the Visualizations 
window.

When you run (Perform) this example, it takes a few minutes for the calculations to complete.
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Figure 272: Total hardness of the tempered steel versus tempering time, for two tempering temperatures, 
compared to data from [1956Gra].

Figure 273: Total hardness of the tempered steel versus tempering temperature, for two tempering times, 
compared to handbook data from [1956Gra].
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PM_Fe_11: Steel Design Using the Parallel Coordinates Plot

The example uses the Property Model Calculator and three Property Models to plot a property diagram 
and a Parallel coordinates plot for chemistries centered around an Fe1.5Cr2.0Ni0.31C1.0Mn alloy. The Ni, 
Cr, and C chemistries are varied to understand their influence on some key properties. This can be used to 
optimize a material chemistry to meet specific design criteria.

A One Axis calculation using the Equilibrium Calculator produces a property diagram to show the 
equilibrium fractions of the alloy.

A second calculation uses a Grid calculation with the Property Model Calculator and the Driving Force, 
Martensite Temperatures, and Martensitic Steel Strength models to demonstrate the use of the Parallel 
coordinates plot type. The driving force model in this example calculates the driving force for Cementite to 
form at 500 °C (tempering temperature). The driving force gives a good idea of how fine a dispersion of 
carbides could form. Higher driving force means a finer distribution.

When using a parallel coordinates plot type, you can interpret multidimensional data to compare how 
different parameters affect each other. In this example this includes the composition of Ni, Cr, and C (each 
in mass percent), the Driving force per mole, the Total hardness of the tempered steel, and the Ms 
temperature.

Project File and License Information

 l Folder: Property Models → Steels

 l File name: PM_Fe_11_Steel_Design_Using_Parallel_Plot.tcu

To run calculations with the Steel Models requires a valid maintenance license plus licenses 
for both the TCFE (version 9 and newer) and MOBFE (version 4 and newer) databases. Also see 
our website to learn more about the Steel Model Library and other related examples.

This example uses TCFE13. Earlier versions of this database can be used although there may 
be slight differences in the results. 
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Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it takes a few minutes for the calculations to complete.

Figure 274: A Property Diagram to observe the change in volume fraction of all phases as the temperature 
increases. 
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Figure 275: A parallel coordinates plot with multidimensional data comparing the Ni, Cr, and C compositions, the 
Driving force per mole, the Total hardness of the tempered steel, and the Ms temperature. 

Tips to Interpret the Plot Data

 l When most lines between two parallel axes are somewhat parallel to each other, there is a positive 
relationship between these two dimensions.

 l When lines cross in a kind of superposition of X-shapes, that is a negative relationship.

 l When lines cross randomly it means that there is no particular relationship.
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PM_Fe_12: Flow Stress 15-5PH Steel

The example uses the Property Model Calculator and the Martensitic Steel Strength model to calculate 
the flow stress curves for a 15-5PH steel alloy, with samples tempered for 2, 5, and 50 hours. The example 
shows the use of flow stress with this Property Model.

An Experimental File Reader is used with data from Croné et al. [2022Cro]. Three Property Model 
Calculators are used with a Flow stress mode of σ vs ϵ and a One Axis calculation is used.

The Tempering time is set for each Property Model Calculator to 2 h, 5 h, and 50 h (the settings themselves 
are entered in seconds).

Project File and License Information

 l Folder: Property Models → Steels

 l File name: PM_Fe_12_Flow_Stress_15-5PH_Steel.tcu

To run calculations with the Steel Models requires a valid maintenance license plus licenses 
for both the TCFE (version 9 and newer) and MOBFE (version 4 and newer) databases. Also see 
our website to learn more about the Steel Model Library and other related examples.

This example uses TCFE14. Earlier versions of this database can be used although there may 
be slight differences in the results. 

Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.
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Figure 276: The calculation plots the True strain [%] to the True stress [MPa] as flow stress curves and compares it 
to experimental data taken from [2022Cro].
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Titanium Model Library Examples Collection

The General Models  are available to all users. To run calculations with the Titanium Models 
(as part of the Titanium Model Library) requires a valid maintenance license plus a license for 
the TCTI (version 6 and newer) database. 

These examples use the Property Model Calculator, an activity available with Thermo-Calc plus the 
available Property Models in the Titanium Model Library. 

In this section:

PM_Ti_01: Martensite Temperatures for Ti-Zr 426

PM_Ti_02: Alloy Strength for Ti-O 429
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PM_Ti_01: Martensite Temperatures for Ti-Zr

The Martensite Temperatures - Ti Property Model, available with the Property Model Calculator and the 
Titanium Model Library, calculates the martensite start temperature (Ms) and T-Zero temperatures for Ti-
base alloys.

Choose between HCP ( , , or ) and B19_PRIME or B19_ORTHO as the Martensite phase:

 l The HCP phase is the common choice for alloys such as Ti-6Al-4V and other structural alloys.

The various forms of alpha martensite ( , , or ) are not explicitly distinguished and 
are therefore collectively described by HCP_A3 in terms of thermodynamic properties.

 l The B19_PRIME and B19_ORTHO options are intended for TiNi-based shape-memory alloys. 

 l The B19_ORTHO is useful for TiNiCu-based shape-memory alloys.

This example uses the Martensite Temperatures - Ti Property Model with a simple Ti-Zr system to show 
the use of this model. A One Axis calculation is used to plot the Ms and T-Zero temperatures as a function 
of mole fraction of Zr with experimental data from [1952Du, 1965McM, and 1970Hua]. 

Project File and License Information

 l Folder: Property Models → Titanium

 l File name: PM_Ti_01_Martensite_Temperatures_Ti-Zr.tcu

To run calculations with the Titanium Models requires a valid maintenance license plus a 
license for the TCTI (version 6 and newer) database. For some Property Models, additional 
recommendations for the database version to use is indicated in its description. Also see our 
website to learn more about the Titanium Model Library.
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Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it takes a few minutes for the calculations to complete.

Figure 277: Ms and T-Zero temperatures as a function of mole fraction of Zr with experimental data from 
[1952Du, 1965McM, and 1970Hua]. 
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PM_Ti_02: Alloy Strength for Ti-O

The Alloy Strength - Ti Property Model, available with the Property Model Calculator and the Titanium 
Model Library, calculates the strength and hardness for Ti-base alloys.

The various forms of alpha martensite ( , , or ) are not explicitly distinguished and are 
therefore collectively described by HCP_A3 in terms of thermodynamic properties.

This example uses the Alloy Strength - Ti Property Model to determine the total hardness of a  Ti-0.04Fe-
0.03C-0.005N-0.01O alloy.

A One Axis calculation is done using the latest version of the TCTI database to compare the total hardness 
vs oxygen content (in mole %). Two Experimental File Readers provide the data from [1950Fin] and 
[1973Oka] for comparison with the calculated values.  

As is clearly illustrated in this example, the effect of typical impurity elements on the strength and hardness 
of Ti is very large. It is therefore important to keep in mind that the impurity elements and their respective 
contents should be included in the calculation, either explicitly, as is done in this example, or by selecting 
an appropriate base grade with a pre-defined impurity content for the calculation. 

Project File and License Information

 l Folder: Property Models → Titanium

 l File name: PM_Ti_02_Alloy_Strength_Ti-O.tcu

To run calculations with the Titanium Models requires a valid maintenance license plus a 
license for the TCTI (version 6 and newer) database. For some Property Models, additional 
recommendations for the database version to use is indicated in its description. Also see our 
website to learn more about the Titanium Model Library.
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Visualizations

Many of our Graphical Mode examples have video tutorials, which you can access in a variety 
of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or from the 
main My Project window, click Video Tutorials. Alternately,  you can go to the website or our 
YouTube channel.

Open the example project file  to review the node setup on the Project window and the associated settings 
on the Configuration window for each node. For some types of projects, you can also adjust settings on the 
Plot Renderer Configuration window to preview results before performing the simulation. Click Perform 
Tree to generate plots and tables to see the results on the Visualizations window.

When you run (Perform) this example, it takes a few minutes for the calculations to complete.

Figure 278:  The total hardness vs O (in mole %) is shown with data from [1950Fin] and [1973Oka].
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