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Thermo-Calc 2017a 
Highlights 

 Thermo-Calc: Several new and improved features are implemented for the Property Model 
Calculator including a new liquidus and solidus temperature model and being able to create your 
own property models. 

 Diffusion Module (DICTRA): This add-on module is now available in Graphical Mode. In both 
Graphical and Console Mode, speed improvements for moving boundary simulations can result in a 
30% performance gain. 

 Precipitation Module (TC-PRISMA): You can now have up to 20 elements and 10 phases included in 
a simulation.  

 New mobility database: TCS Solder Alloy Solutions Mobility Database (MOBSLD1).  

11 updated databases including  

 The Steels/Fe-Alloys Database (TCFE9) has extensive updates including the addition of cerium (Ce) 
and the significant improvement for high-Al and high-Mn low density steels (LDS). A compatible 
MOBFE4 is also developed with the addition of Ce and binaries and ternaries related to LDS. The 
description of liquid is completely new in MOBFE4.  

 The Metal Oxide Solutions Database (TCOX7) has six new elements (F, S, Nb Cu, La, and Gd). 
 The High Entropy Alloys Database (TCHEA2) has five new elements (C, N, Re, Ru, Si) and all the 

binary and over 443 ternary systems assessed. 

Thermo-Calc 

New Property Model Calculator Features  
In Graphical Mode, you can now add a Table Renderer to the Property Model Calculator. There is also a 
predefined liquidus and solidus property model available. Also see Build Your Own Property Models. 
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Contour Plot Improvements  
Contour plots are easier to read with improved labelling that makes the labels the same colour as 
the plot lines and follows the same angle. You can also define how many decimal digits to include 
and whether these are in decimal or scientific format or automatically done. These settings are for 
contour plots and you also define these globally from Tools → Options → Plotting. 

An example of a Plot Renderer in Graphical Mode 
where this is defined. 

 
 
 

In this liquidus solidus model contour plot, the labels are the same colour as the plot lines 
and on the same angle. 
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Build Your Own Property Models 
The Property Model Calculator in Thermo-Calc Graphical Mode has predefined models available for 
immediate use and new models are being added on a regular basis. The Property Model 
Development Framework enables you to create custom property models that can be included with 
the Property Model Calculator and ultimately used for your simulations. 

When you use the Property Model Development Framework, it extends the software to enable you 
to create property models. The models are written in the easy-to-learn programming language 
Python and the Framework provides seamless integration into Thermo-Calc. This includes access to 
thermodynamic and kinetic calculation routines as well as to the Thermo-Calc plotting system. 

The Framework is based on Jython, which is a Python implementation running in the Java Virtual 
Machine. All Python libraries that are compatible to the Jython distribution can be used within the 
model (but not libraries based on native C-code). 

Model development is possible without any additional installation by using a text editor (for example 
Notepad++). However, it is recommended you use a Python Integrated Development Environment 
(IDE), which provides you with advanced features such as debugging and auto-completion. 

 The Property Model Development Framework Guide is available as a PDF and includes two 
simple examples to help get you started. From Thermo-Calc, go to Help → Online Help and from the 
Thermo-Calc menu navigate to the PDF by clicking Thermo-Calc and choosing it from the menu. You 
can also just enter a search term. The PDF is also available on our website. 
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General Bug Fixes  

• Fixed a bug where the Console Mode prompt would not sometimes load/initiate when Thermo-
Calc is opened. Note. If you experience this in previous versions, opening a new Console window 
will initiate the prompt. 

• Fixed a bug for the global plot properties in the Tools → Options menu. The Reset to original 
settings now works for all properties. This is for both Console Mode and Graphical Mode. 

• For the Table Renderer (Graphical Mode), fixed the number formatting for Swedish and German 
localized translations. 

• Fixed an issue occurring with property grid calculations for the Equilibrium Calculator and 
Property Model Calculator in Graphical Mode. In previous versions, the composition grid points 
were able to calculate a total mass percent larger than 100%, which would slow calculations. The 
behaviour is also fixed for the Property Model Calculator where negative compositions were 
allowed for Min/Max calculations. 

• Fixed an issue for the Binary and Ternary Calculators in Graphical Mode where assigning a phase 
as DORMANT still included it in the output. 

• Fixed a bug in Graphical Mode for the System Definer related to the Check/uncheck all box. 
Phase lists in the successor nodes (e.g. the calculators or the Plot Renderer) are now updated 
correctly when this check box is selected or deselected. 

• Fixed a bug in Graphical Mode for the System Definer related to charged vacancies. When 
charged vacancies were selected on the Species tab you could click Perform in error because 
these were not classified as special elements.  

Diffusion Module (DICTRA) 
The Diffusion Module, also known as DICTRA, is an add-on module to the core Thermo-Calc software 
and is now available in Graphical Mode. This makes it easier than ever to make diffusion simulations 
using the Graphical Mode interface. Four examples and a Quick Start Guide are included to help 
begin working in the module immediately. Even if you do not have a license you can try the new 
Diffusion Module using the DEMO mode. Kinetic quantities, e.g. mobilities and chemical diffusion 
coefficients, can now also be tabulated and plotted in both Graphical mode and in Console Mode. 

Diffusion Calculator 
The Diffusion Calculator is the all-in-one diffusion activity feature. Just like the other calculators in 
Thermo-Calc, you can add a Plot Renderer to the node.  

 For details and links about this feature, go to Help → Online Help and search for Diffusion 
Calculator. 

Diffusion Simulation Template 
A new Diffusion Simulation template is available on the 
dashboard. Click it to add a System Definer, Diffusion 
Calculator and Plot Renderer to your Project.  
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Test Drive the Diffusion Calculator in Demo Mode  
The Diffusion Module and three examples are available to all Thermo-Calc users but only for 
simulations with two elements. If you do not have a license for the Diffusion Module then you are in 
Demonstration Mode (Demo Mode) when using the Diffusion Calculator or the Diffusion Simulation 
template. 

 For more information go to Help → Online Help and search for diffusion demo mode. 

Diffusion Calculator Examples 
The Diffusion Module has four examples that use the new Diffusion Calculator. Graphical Mode 
examples 19, 20 and 22 are available to everyone, and 19-21 are the basis for the Quick Start Guide. 
The other example requires a Diffusion Module (DICTRA) license to calculate and plot results. All the 
examples use demonstration databases, which are included with every installation. 

The new set of examples are installed in the same folder as the other Graphical Mode examples. You 
can find these in your default directory (which is based on user-type and platform). As of this release 
you can open the examples folder from the main menu: File → Open Examples or Help → Open 
Examples. The Quick Start Guide is also available from the main menu: Help → Open Manuals. 

Diffusion Module: Graphical and Console Mode Comparison 
Below are some of the main differences between the available features or simulation types in 
Graphical Mode (GM) and Console Mode (CM). There are also other differences not listed in the 
table such as slight differences between terminology and the file formats, for example. 

For the Graphical Mode version of the Diffusion Module, additional functionality is scheduled for 
future versions of Thermo-Calc. Key: green means it is available in that mode. 

Features GM CM 

Plots  Yes Yes 

Planar, cylindrical and spherical geometries Yes Yes 

Homogenization Yes Yes 

Homogenization functions1 Yes Yes 

Tables  Yes 

Setting boundary conditions  Yes 

Importing Scheil segregation profiles  Yes 

Data optimization (PARROT)   Yes 

 

  

                                                           
1 The varieties with excluded phases are only available in Console Mode. 
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Simulation Types GM CM 

Simulations in one region with one or multiple phases Yes Yes 

Moving boundary simulations Yes Yes 

Isothermal and non-isothermal simulations Yes Yes 

Coarsening, Carburizing of high-temperature alloys2 Nitriding and 
Nitrocarburization, Paraequilibrium, Thermomigration, Grain boundary 
models, Pearlite models, Cell calculations  

 Yes 

Speed Improvement for Moving Boundary Problems 
In both Console Mode and Graphical Mode, and when simulating moving boundary problems in 
multicomponent systems, a scheme has been implemented to better predict the chemical potential 
or activities used to determine the operating tie-line in the diffusional equilibrium at the calculated 
time-step. The performance gain obtained from this can be up to 30% depending on the calculation. 

Precipitation Module (TC-PRISMA) 

Improvements and Bug Fixes 
• Doubled the number of elements (components) that can be included in a simulation. You can now 

have up to 20 elements and 10 phases.  
• Fixed an issue related to inconsistent results when you entered different units for the grain size.  
• Phases are now listed in alphabetical order when you are selecting them from the list on the 

Precipitation Calculator.  
• Backward compatibility for some project files when using the Precipitation Module: There can be an 

issue with backward compatibility when opening graphical mode project files (.tcu) including 
calculated results created in an earlier version of Thermo-Calc. If you experience difficulties, a 
suggested fix is to save the project without results (in the older version) and then open the file in 
2017a, perform the tree and save the results in 2017a. This issue is specific to Precipitation Module 
projects created in versions 2016a or 2016b and is related to improvements to the calculation 
engine. 

• Fixed an issue where plotted data points continued to be present even after deleting/removing the 
source experimental file reader. 

                                                           
2 This is because it is not yet possible to set boundary conditions in Graphical Mode. 
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Databases 

New TCS Solder Alloy Solutions Mobility Database (MOBSLD1) 
MOBSLD1 is a kinetic database containing mobility data for solder alloys. It is suitable for simulation 
of diffusion controlled phenomena using the add-on Diffusion Module (DICTRA), and/or Precipitation 
Module (TC-PRISMA). MOBSLD1 is compatible and recommended for use in combination with the 
TCSLD thermodynamic database.  

• 21 elements: Ag, Al, Au, Bi, Ca, Cd, Co, Cu, Ga, Ge, In, Mg, Mn, Ni, Pb, Pd, Pt, Sb, Si, Sn, Zn 
• 9 phases: LIQUID, FCC_A1, BCT_A5, DIAMOND_A4, HCP_ZN, RHOMBOHEDRAL_A7, CU3SN, 

CU6SN5_HT_NIAS, AG3SN_L60_CU3TI 
• 49 binary systems (17 for LIQUID, 31 for FCC_A1, 1 for DIAMOND_A4) 
• 22 ternary systems (6 for LIQUID, 16 for FCC_A1) 
• 2 quaternary systems (FCC_A1) 

TCS Steels/Fe-Alloys Database (TCFE9) 

Major updates from TCFE8 to TCFE9 

The TCFE9 database is significantly improved compared to the previous TCFE8 version. There are 
extensive updates including the addition of cerium (Ce) and the significant improvement for high-Al 
and high-Mn low density steels (LDS). A compatible MOBFE4 is also developed with the addition of 
Ce and binaries and ternaries related to LDS. In total, 32 new binary and 35 new ternary systems are 
added to the database. In addition, more than 50 binary and 39 ternary, and many quaternary, 
systems are either completely updated or partially modified to improve the robustness and 
predictability of the database. There are several major updates and these are detailed in a 
supplementary PDF as well as included in the extended information sheet, available on our website. 

 A detailed overview of the TCFE9 update is included with examples at the end of this PDF. 

New Element: Cerium (Ce) is added with 19 Ce-X binary systems (X=Al, B, C, Ca, Co, Cr, Cu, Fe, Mg, 
Mn, Mo, Ni, O, S, Si, V, Y, Zn, Zr). 

Sulphides 

• Updates to the thermodynamics of Ca-Fe-Mn-Mg-S and its lower order systems. 
• Cu-sulfides added for some applications such as electrical steels. 
• The Cr solubility in MnS is estimated based on the experimental data. 

Phosphates: Several phosphorus containing ternary iron-based systems, Fe-X-P (X=Al, Cr, Mn, Mo, 
Nb, Ni, Ti, Si) are included. 

Borides: Thermodynamic description of many boron containing systems are revised  including iron 
containing ternary systems, Fe-X-B (X=C, Cr, Co, Mo, Mn, Nb, Ni, Si, Ti, V, W, Zr), and also some other 
ternary systems such as B-Cr-Mo, B-Cr-Ni, B-Ni-Si and the quaternary B-Cr-Fe-Mo system. 

Laves Phase: Vanadium (V) is added in the Laves phase and the solubility of many elements are 
revised. The Laves phase is modified in Fe-Nb, Cu-Mo, Cu-Nb, Cu-W, Mo-Si, Nb-Si, Cu-Fe-Mo, Cr-Fe-
Mo, Cr-Si-Nb, Fe-Mn-Mo, and Fe-Mo-Si systems. 
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Copper Containing Systems: The thermodynamic properties of Cu contacting systems is improved by 
adding several new descriptions including Ca-Cu, Cu-Nb, Cu-W, Al-Cu-Fe, Al-Cu-Mn, Al-Cu-Ni, Cr-Cu-
Mo, Cr-Cu-W, Cu-Fe-Mn, Cu-Fe-Mo and Cu-Mn-Ni systems. 

Nb and V Systems: Several Nb and V systems are either newly added (such as Mn-Nb and Fe-Mn-Nb 
systems) or updated (including C-Nb, Fe-Nb, Fe-V, Nb-V, C-Cr-Nb, and Fe-Nb-V. 

Peritectic Reaction and Continuous Casting: High temperature equilibria, and specifically the 
peritectic reaction, is of significant importance in continuous casting practice. The database is 
improved by using data from recent thermodynamic assessments and systematic DSC measurements 
in C-Fe-Mn-Si and Al-C-Fe-Mn-Si systems. 

Martensitic Transformation: The thermodynamic descriptions of the Fe-C and Fe-Mn-C systems are 
modified to give a reasonable driving force for the γ→ε diffusionless transformation. 

Low-Density Steels 

• The Al-C-Cr-Fe-Mn-Ni and its subsystems are updated with the latest assessments and 
experimental info.  

• The Kappa phase is described with a regular CEF model and extended with Mn.  
• Manganese phases CBCC_A12 and CUB_A13 are added. 

Ordered Phases 

• The ordered phases B2_BCC and L12_FCC are extended to contain the same elements as the 
corresponding disordered parts (BCC_A2 and FCC_A1). However, the ordering parameters are 
only assessed in the systems where the ordering is of significant importance. These phases are 
rejected by default and can be restored manually if required. 

• The B2_BCC phase is revised in Al-Co, Al-Cr, Al-Ni, Co-Fe, Cr-Ni and Al-Cr-Ni, Al-Fe-Mn, Al-Fe-Ni, 
Al-Mn-Ni, Al-Co-Ni, and Co-Cr-Ni systems.  

• The L12_FCC phase is revised in Al-Cu, Cu-Fe, Cu-Ni, Cr-Ni, Cr-Fe, and Al-Cr-Ni, Al-Fe-Ni, Al-Mn-Ni, 
Cr-Fe-Ni, Al-Co-Ni, and Co-Cr-Ni systems. 

TCS Steels/Fe-Alloys Mobility Database (MOBFE4) 

Major updates from MOBFE3 to MOBFE4 

Ce has been added in MOBFE4. The self-diffusion and impurity diffusion data related to Ce were 
included in the BCC_A2, FCC_A1, HCP_A3 and LIQUID phases. Mobility data for several Mn-
containing binary and ternary systems was also added. Diffusion data for the LIQUID phase has also 
been assessed for systems where experimental data is available; otherwise the modified Sutherland 
equation was used for estimation. Therefore, the description of the LIQUID phase has been entirely 
updated in this version of the database, from a constant value (1·10-9 [m/s2]) to temperature 
dependent ones. In addition to pure element data, complete and critical assessments for the LIQUID 
phase in 11 binary systems are implemented. 
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TCS Metal Oxide Solutions Database (TCOX7) 

Major updates from TCOX6 to TCOX7 

• Addition of 6 new elements: Cu, F, S, Gd, La and Nb. 
 Cu: Added all binary and a few ternary metallic systems. Added Cu-O and Cu-S. Assessed 

Al2O3-Cu-O, CaO-Cu-O, Cu-Cr-O, Cu-Fe-O, Cu-O-La2O3, Cu-O-MgO, Cu-Mn-O, Cu-Nb-O, Cu-Ni-
O, Cu-Si-O, Cu-Y-O, Al2O3-Cu-O-SiO2, CaO-Cu-Fe-O, CaO-Cu-O-SiO2, Cu-Fe-O-SiO2, Cu-O-MgO-
SiO2, Cu-Cr-S, Cu-Fe-S, Cu-Mg-S, Cu-Mn-S, Cu-Ni-S, Cu-O-S, Cu-Fe-O-S. 

 F: Added liquid and solid AlF3, CaF2, CrF2, CrF3, CuF, CuF2, FeF2, FeF3, GdF3, LaF3, MgF2, MnF2, 
NbF2, NbF5, NiF2, SiF4, YF3, ZrF4. Assessed Ca-CaF2, CaF2-CaO, GdF3-Gd2O3, MgF2-MgO, AlF3-
CaF2, AlF3-MgF2, AlF3-ZrF4, CaF2-FeF2, CaF2-GdF3, CaF2-LaF3, CaF2-MgF2, MgF2-GdF3, MgF2-LaF3, 
MgF2-YF3, AlF3-Al2O3-CaF2-CaO, CaF2-CaO-MgF2-MgO, CaF2-Cr2O3, CaF2-CaO-FeO-Fe2O3-FeF2, 
CaF2-SiO2-CaO-SiF4, Al2O3-CaF2-MgO, Al2O3-CaF2-SiO2, MgF2-MgO-SiO2. Estimated CaF2-CaS, 
CaF2-CaSO4, AlF3-SiO2. 

 S: Assessed or added from literature: Al-S, Ca-S, Cr-S, Cu-S, Fe-S, Mg-S, Mn-S, Ni-S, Si-S, Y-S, 
Al-Fe-S, Ca-Fe-S, Ca-Mg-S, Ca-Mn-S, Cr-Fe-S, Cu-Cr-S, Cu-Fe-S, Cu-Mg-S, Cu-Mn-S, Cu-Ni-S, Fe-
Mg-S, Fe-Mn-S, Fe-Ni-S, Mg-Mn-S, Al-O-S, Ca-O-S, Cu-O-S, Fe-O-S, Mg-O-S, Mn-O-S, Si-O-S, 
CuS-SiO2, FeS-SiO2, MnS-SiO2, Al2O3-CaO-CaS, Al2O3-MgO-MgS, Al2O3-MnO-MnS, CaO-SiO2-
CaS, MgS-SiO2, Al2O3-CaO-CaS-MnO-MnS, Cu-Fe-O-S, CaF2-CaS. Estimated Gd-S, La-S, CaF2-
CaS, CaF2-CaSO4. 

 Gd: Added all binary metallic systems except Gd-La. Added Gd-O and estimated Gd-S. 
Assessed Al2O3-Gd2O3, CaO-Gd2O3, Cr2O3-Gd2O3, Fe2O3-Gd2O3, Gd2O3-MgO, Gd2O3-NiO, 
Gd2O3-SiO2, Gd2O3-ZrO2, Al2O3-Gd2O3-ZrO2, CaO-Gd2O3-SiO2, Gd2O3-SiO2-ZrO2. 

 La: Added all binary metallic systems except Gd-La, La-Nb and La-Si. Added La-O and 
estimated La-S. Assessed Al2O3-La2O3, CaO-La2O3, Cr2O3-La2O3, Cu-O-La2O3, Fe-O-La2O3, La2O3-
Mn-O, La2O3-Nb2O5, La2O3-NiO, La2O3-SiO2, La2O3-ZrO2, Al2O3-La2O3-Y2O3, Al2O3-La2O3-ZrO2. 

 Nb: Added all binary metallic systems except La-Nb. Assessed Nb-O. Assessed Al2O3-Nb2O5, 
CaO-Nb2O5, Cr2O3-Nb2O5, CuO-Nb2O5, Fe-Nb-O, La2O3-Nb2O5, MgO-Nb2O5, MnO-Nb2O5, 
Nb2O5-NiO, Nb2O5-SiO2, CaO-Nb2O5-SiO2. 

• The following systems are assessed for version 7: Al2O3-CaO-Cr2O3, SiO2-Fe-Mn-O, CaO-FeO-
MnO, Al2O3-Fe-Mn-O, SiO2-Al2O3-Fe-Mn-O. 

• Estimated these systems for version 7: CaO-Mn-O-Y2O3, Fe-O-NiO-SiO2. 
• Added assessment of Mg-Mn-O and Cr2O3-MgO-SiO2 from the literature. 
• Reassessed these systems for version 7: CaO-SiO2-ZrO2, CaO-SiO2-Y2O3, Al2O3-CaO-SiO2-Y2O3. 
• Modelled Fe2O3 solubility in MULLITE. 
• Modelled ZrO2 solubility in APATITE. 
• Modelled Y2O3 solubility in ZIRCON. 
• Merged CF (CaO.Fe2O3), β-CaCr2O4 and CaY2O4 to one phase: CaV2O4. 

TCS High Entropy Alloys Database (TCHEA2) 

Major updates from TCHEA1 to TCHEA2 

• Added 5 new elements (C, N, Re, Ru, Si) and 100 phases. 
• Assessed most of new binary systems that contain one or two of these 5 new elements in the 20-

element framework of this database. 
• Assessed 200 additional ternary systems relevant to the 5 new elements. 
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• The application of TCHEA2 extends from BCC and FCC HEAs to HCP HEA as well. 
• Revised some subsystems based on the validation against updated experimental information. 

This includes the phase stability of solid solutions such as BCC and FCC and intermetallic phases 
such as sigma and laves in some ternary and quaternary systems. 

TCS Cu-based Alloys Database (TCCU2) 

Major updates from TCCU1 to TCCU2 

Volume data, including molar volume and thermal expansion, for most of the solution phases and 
intermetallic phases are added in TCCU2. This allows for the calculations of volume fraction of 
phases, density, thermal expansion and lattice parameters etc. 

Two elements, Mo and O, are added in TCCU2. The thermodynamic assessments of the Ag-P, Al-O, 
Co-Cr, Co-Nb, Cr-Mo, Cr-Nb, Cu-Mo, Cu-O, Fe-Mo and Mo-Ni binary systems are implemented. The 
following ternary systems have also been assessed: Ag-P-Sn, Al-Cu-O, Co-Cu-Nb, Co-Cr-Cu, Cr-Cu-Nb, 
Cr-Cu-Mo, Cu-Fe-Mo and Cu-Mo-Ni. Additionally, the Cu-P, Co-Pb, P-Zn and Cu-P-Sn descriptions are 
updated. 

TCS Cu-based Alloys Mobility Database (MOBCU2) 
Two elements, Mo and O, are added in MOBCU2. The self-diffusion and related impurity diffusion 
data for Mo and O were included in both FCC_A1 and LIQUID phases. The complete and critical 
assessments for LIQUID Ag-Sn, Al-Ni, Al-Zn, Cu-Sn, Fe-Mn, Fe-Si and Pb-Sn binary systems are 
implemented. The description for LIQUID Ag-Cu has been updated. 

TCS Ni-based Superalloys Database (TCNI8.1) 
The major change in 8.1 is an update of several Y-systems. The solubility of Y in gamma phase has 
been increased by changing Al-Y, Co-Y, Cr-Y, Cu-Y, Fe-Y, Nb-Y, Ni-Y, Pt-Y, Re-Y and Ru-Y systems. 

Al-Ni-Y and Nb-Ni-Y have also been added to the database. In Al-Ni-Y the solubility of Al in Ni5Y 
(called NI5ZR in TCNI8) and the addition of several ternary phases are the most significant 
improvements. For Nb-Ni-Y the liquid description is also greatly improved and TCNI8 now correctly 
predicts the liquid miscibility that occurs in this system.   

TCS Solder Alloy Solutions Database (TCSLD3.2) 

• Ca is added together with some Ca-related systems: Al-Ca, Ca-Sn, Ca-Pb, Ca-Pb-Sn  
• Added the Mg-Sn and Mg-Pb binary systems. 
• Added the Bi-Cu-Sb ternary system. 
• Updated the Ag-Au-Cu system. 

TCS Fe-containing Slag Database (SLAG4.1) 
New constituents corresponding to NaF, CrF2, CrFe3 and TiF4 in the SLAG phase have been assessed 
and added to this subversion so that the melting of the flourides can be correctly calculated. 
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IRSN Mephista Nuclear Fuels Database (MEPH15_1) 

Major Updates from Mephista-11 to Mephista-15 

The description of some binary systems are improved: 

• C-Pu: improved modelling of the liquidus. 
• C-U: C3U2(S) made unstable at low temperature. 
• O-Pu: melting temperature of O2Pu1(S) increased and the improved modelling of LIQUID. 

The description of the following ternary systems are re-assessed by taking into account the previous 
improvements: 

• Ce-O-Pu: revised modelling of CeO2-PuO2 and Ce2O3-PuO2. 
• Fe-O-Pu: revised modelling of FeO-PuO2 and Fe2O3-PuO2. 
• La-O-Pu: revised modelling of La2O3-PuO2. 
• Mo-O -Pu: revised modelling of MoO3-PuO2. 
• O-Pu -Si: revised modelling of SiO2-PuO2. 
• O-Pu-Sr: revised modelling of SrO-PuO2. 
• O-Pu-Zr:  revised modelling of PuO2-ZrO2. 
• C-O-Pu: revised modelling of the full system. 

The description of some ternary systems are improved: 

• O-Pu-U: improved modelling of PuO2-UO2; improved modelling of the FCC_C1 miscibility gap. 
• Ba-O-Pu: improved modelling of BaO-PuO2. 
• Ba-Mo-O: improved modelling of Ba1Mo1O4 (G). 
• C-Pu-U: improved modelling of the full system. 

IRSN NUCLEA- Nuclear Alloys-Oxides Database (NUCL15_4) 

Major Updates from NUCLEA-10 to NUCLEA-15 

The description of some binary systems are improved: 

• Ag-Al: improved limits of the FCC_A1+HCP_A3 biphasic domain. 
• Ag-B: added LIQUID miscibility gap. 
• Al-In: improved limits of the LIQUID miscibility gap. 
• Al-Zr: added Al3Zr4(S) and improved modelling of the stoichiometric condensed phases. 
• B-C: BETA_B decomposition changed to peritectic. 
• C-U: C3U2(S) made unstable at low temperature. 
• Cr-La: improved modelling of LIQUID. 
• Cr-O: improved modelling of LIQUID. 
• In−Zr: added In1Zr1(S), In2Zr1(S), In1Zr2(S); In3Zr1(S) decomposition changed to peritectic. 
• La -Ni: added La5Ni19(S). 

The description of some ternary systems are improved: 

• Al-O-Fe: Al2FeO4 decomposition changed to peritectic in AlO1.5-FeO; SPINEL domain extended in 
AlO1.5-FeO1.5. 

• Ca-Cr-O: added assessment of CaO-CrO-Cr2O3 for oxygen partial pressures ranging from 
equilibrium with metallic chromium to PO2 = 10−3 atm. 
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• Cr-O-Si: added assessment of CrO-Cr2O3-SiO2 for oxygen partial pressures ranging from 
equilibrium with metallic chromium to PO2 = 0.21 atm. 

• Ni-O-Si: improved limits of the LIQUID miscibility gap in NiO-SiO2; improved modelling of 
Ni2O4Si1(S). 

The description of some quaternary systems are improved: 

• Al-Ca–Fe-O: added assessments of Al2O3-CaO-Fe2O3 and Al2O3-CaO-FeO. 
• Al-Fe-O-Si: added assessments of Al2O3-Fe2O3-SiO2 and Al2O3-FeO-SiO2. 
• Ca-Cr-O-Si: improved assessment of CaO-CrO-Cr2O3 for reducing conditions and for oxidising 

conditions at low CaO-content; added Ca3Cr2O12Si3 (Uvarovite), Ca5Cr5O50Si20 (Gillespite). 

Documentation and Examples 

Manuals and Examples Folders 
Once your Thermo-Calc software is installed you can open the Examples and PDF documentation 
(Manuals) from the main menu: 

To open the PDF documentation, select Help → Open 
Manuals Folder. Note for Linux openSUSE users: This link is 
not functional. To access the folder, navigate to the 
default location based on your installation type. 

To open the Examples based on whether you are in 
Console Mode or Graphical Mode, select File → Open 
Examples or Help → Open Examples.  

Materials Folder 
When you are working with the System Definer you can open the default Materials folder included 
with your installation. At the bottom of the window under Material, click Load material to navigate 
to a material file. 
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New and Updated Training Videos 
• A new video about the 2017a release highlights some of the new features detailed in these release 

notes. 
• To accompany the release of the Diffusion Module in Graphical Mode, Example 19: Single-Phase 

Diffusion Simulation is also available as a tutorial to complement the Graphical Mode Quick Start 
Guide, which uses this same example. Additional training videos will be available shortly. 

• Example 6 - Serially Coupled Equilibrium Calculators was updated to address a bug. 

Stay tuned for additional video tutorials which are available on our website (go to 
http://www.thermocalc.com/training/video-tutorials/) or you can see these on our YouTube channel  

Installation Disk Space Requirement 
Due to precompiled databases added to the Thermo-Calc installation, 2 GB of disk space is 
recommended for the 2017a installation. 

Platform Roadmap 
For information about platforms being phased out visit http://www.thermocalc.com/products-
services/software/system-requirements/platformroadmap/. 

 

https://www.youtube.com/watch?v=hLZQybYehMQ
http://www.thermocalc.com/training/video-tutorials/
https://www.youtube.com/channel/UCLTh3apGItuaVK69mrwcpJg
http://www.thermocalc.com/products-services/software/system-requirements/platformroadmap/
http://www.thermocalc.com/products-services/software/system-requirements/platformroadmap/
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Thermo-Calc 2017a: Major Updates to the TCFE9 Steel and Fe-alloys 
Database 
The TCS Steel and Fe-alloys Database, referred to as TCFE9, is a thermodynamic database for different 
kinds of steels and Fe-based alloys, such as stainless steels, high-speed steels, tool steels, high-strength 
low alloy (HSLA) steels, cast irons, corrosion-resistant high strength steels, low-density steels, and also 
cemented carbides.  

The database is developed and validated for simulation of the solidification process, the relative stability 
of matrix phases (austenite and ferrite), precipitation of secondary phases such as sulfides, borides, 
oxides, phosphides, carbides, nitrides, carbonitrides, and also intermetallic phases such as the sigma and 
laves phases. 

The TCFE9 database is significantly improved compared to the previous TCFE8 version, with 32 new 
binary and 35 new ternary systems added to the database. In addition, more than 50 binary and 39 
ternary, and many quaternary, systems are either completely updated or partially modified to improve 
the robustness and predictability of the database. The included systems are listed in Table 2, Table 3, 
and Table 4. 

The major improvements to the TCFE9 database are as follows.  

A New Element: Cerium (Ce) 
Cerium (Ce) is added with 19 Ce-X binary systems (X=Al, B, C, Ca, Co, Cr, Cu, Fe, Mg, Mn, Mo, Ni, O, S, Si, 
V, Y, Zn, Zr). Two examples are shown in Figure 1. 

  

Figure 1. Phase diagram of a) Ce-Fe [1] and b) C-Ce [2] systems. 

Sulfides 
The formation of sulfides in steels can be detrimental or beneficial. In either case it is important to 
understand and control the formation of sulfides. In the TCFE9 database the thermodynamics of Ca-Fe-
Mn-Mg-S and its lower order systems are updated after the work by Dilner [3] (Figure 2). The Cr 
solubility in MnS is estimated based on the experimental data. Cu-sulfides are also added for some 
applications such as electrical steels. 
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Figure 2. a) The solubility lines in the FeS-MnS-MgS system in the temperature interval 873-1273 K. b) 
The CaS-MgS-MnS isothermal sections plotted at 1073-1273 K together with experimental information as 
cited in [3] . 

Phosphates 
Recently a series of new experimental data and thermodynamic assessments regarding the phosphorus 
containing systems became available[4]–[6]. Thereafter, several phosphorus containing ternary iron-
based systems, Fe-X-P (X=Al, Cr, Mn, Mo, Nb, Ni, Ti, Si) are included in the TCFE9 database. 

  

Figure 3. a) The vertical section of the Fe-Ni-P system at 5 wt.% Ni, together with experimental data as 
cited in [5]. b) Calculated vertical section of the Fe-Mn-P system at mass ratio W(Fe):W(Mn)=9:1, 
together with experimental data as cited in [6]. 
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Borides 
Thermodynamic description of many boron containing systems are revised  including iron containing 
ternary systems, Fe-X-B (X=C, Cr, Co, Mo, Mn, Nb, Ni, Si, Ti, V, W, Zr), and also some other ternary 
systems such as B-Cr-Mo, B-Cr-Ni, B-Ni-Si and the quaternary B-Cr-Fe-Mo system. 

  

Figure 4. a) A calculated isothermal section diagram of the Fe–Nb–B system at 1073 K, compared with 
the experimental phase fields [7]. B) Calculated Fe-Si-B isopleth at X(B)=0.10 with DSC data [8]. 

Laves Phase 
In the TCFE9 database, vanadium (V) is added in the Laves phase and the solubility of many elements are 
revised. The Laves phase is modified in Fe-Nb, Cu-Mo, Cu-Nb, Cu-W, Mo-Si, Nb-Si, Cu-Fe-Mo, Cr-Fe-Mo, 
Cr-Si-Nb, Fe-Mn-Mo, and Fe-Mo-Si systems. This description shows satisfying accuracy of the predictions 
compared to experimental information [11-12]. 

  

Figure 5. Amount of different phases as a function of temperature in two commercial steels a) 316L [9] b) 
P91 [10]. 
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Cu Containing Systems 
The thermodynamic properties of Cu contacting systems is improved by adding several new descriptions 
including Ca-Cu, Cu-Nb, Cu-W, Al-Cu-Fe, Al-Cu-Mn, Al-Cu-Ni, Cr-Cu-Mo, Cr-Cu-W, Cu-Fe-Mn (Figure 6a), 
Cu-Fe-Mo (Figure 6b) and Cu-Mn-Ni systems. 

  

Figure 6. a) Calculated vertical sections of the a) Cu-Fe-Mn system at 20 wt.% Cu [11]. b) Cu-Fe-Mo 
system at 5 wt.% Mo along with the experimental data [12]. 

Nb and V Systems 
Niobium (Nb) and vanadium (V) are common alloying elements in different types of steels with high 
affinity to form carbides and nitrides. In the TCFE9 database several Nb and V systems are either newly 
added (such as Mn-Nb and Fe-Mn-Nb (Figure 7a) systems) or updated (including C-Nb, Fe-Nb, Fe-V, Nb-
V, C-Cr-Nb, and Fe-Nb-V (Figure 7b)).  

  

Figure 7. Isothermal sections of a) Fe-Mn-Nb [13] and b) Fe-Nb-V [14] systems at 1573 K. 
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Peritectic Reaction and Continuous Casting 
High temperature equilibria, and specifically the peritectic reaction, is of significant importance in 
continuous casting practice. The TCFE9 database is improved by using data from recent thermodynamic 
assessments [15] and systematic DSC measurements in C-Fe-Mn-Si and Al-C-Fe-Mn-Si systems. 

   

Figure 8. a) Calculated isoplethal section of a) Fe-2.12Mn-0.77Al-0.54Si-xC b) Fe-2.75Mn-1.11Si-0.097Al-
0.014Ti-0.02Nb-xC 

Low-Density Steels 
Reducing the weight of engineering structures saves both material and energy, and also leads to greater 
fuel efficiency and reduces emissions in automobiles.  

The Al-C-Cr-Fe-Mn-Ni systems is the core of low density steels and allows studies to replace costly Ni 
and Cr in stainless steels by cheaper Mn and Al. In the TCFE9 database the Al-C-Cr-Fe-Mn-Ni and its 
subsystems are updated with the latest assessments and experimental info. The Kappa phase is 
described with a regular CEF model and extended with Mn. Manganese phases CBCC_A12 and CUB_A13 
are also added. 

  

Figure 9. a) The volume fraction change of each phase with the temperature for Fe-10Mn-10Al-0.7C low-
density steel [16]. b) The calculated vertical section of C-Fe-Mn involving the liquid phase at 20 wt.% Mn 
[17].  
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Ordered Phases 
The ordered phases B2_BCC and L12_FCC are described based on the order/disorder partitioning model 
as described by Lukas et al. [18]. In the TCFE9 database the ordered phases B2_BCC and L12_FCC are 
extended to contain the same elements as the corresponding disordered parts (BCC_A2 and FCC_A1). 
However, the ordering parameters are only assessed in the systems where the ordering is of significant 
importance. These phases are rejected by default and can be restored manually if required. 

In the TCFE9 database the B2_BCC phase is revised in Al-Co, Al-Cr, Al-Ni, Co-Fe, Cr-Ni and Al-Cr-Ni, Al-Fe-
Mn (Figure 10a), Al-Fe-Ni (Figure 10b), Al-Mn-Ni, Al-Co-Ni, and Co-Cr-Ni systems.  

In addition to the B2_BCC phase, the L12_FCC phase is revised in Al-Cu, Cu-Fe, Cu-Ni, Cr-Ni, Cr-Fe, and 
Al-Cr-Ni, Al-Fe-Ni (Figure 10b), Al-Mn-Ni, Cr-Fe-Ni, Al-Co-Ni, and Co-Cr-Ni systems. 

  

Figure 10. Isothermal section of a) Al-Fe-Mn and b) Al-Fe-Ni at 900 °C compared with the experimental 
data. 

Recently Kim et al. [19] showed that a B2-type brittle but hard intermetallic compound can be 
effectively used as a strengthening second phase in high-aluminum low-density steel. Table 1 shows the 
result of a calculation with the TCFE9 database compared with the experimental observations of Kim et 
al. [19]. 

Table 1. Partitioning of alloying elements between B2 precipitate and austenite matrix in during 
annealing of cold rolled Fe-10Al-15Mn-0.8C-5Ni (at.%). Calculation with the TCFE9 database vs. 
experimental data [19]. 

 
FCC_A1 composition (at.%) B2_BCC composition (at.%) 

Element Calculated Experiment [19] Calculated Experiment [19] 

Fe 65.6 68 53.7 57 
Al 15.1 13 25.5 22.6 
Mn 16.8 16.6 10.2 9.4 
Ni 1.9 2.4 10.1 11.0 
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Martensitic Transformation 
The TCFE9 database has been successfully used for thermodynamically-based prediction of the lath and 
plate martensite start temperature [20]. The Ms temperature prediction depends on the available 
driving force which should be equal to the barrier for Martensite formation. In the TCFE9 database 
particular attention is paid to the epsilon (ε) martensite transformation, and the thermodynamic 
descriptions of the Fe-C and Fe-Mn-C systems are modified to give a reasonable driving force for the 
γ→ε diffusionless transformation. As a result, the database can be used with a user defined property 
model, similar to [20], to predict the (ε) martensite Ms temperature (Figure 11).  

  

Figure 11. Epsilon martensite start temperature a) Fe-Mn, b) Fe-17at.% Mn-xC 
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Assessed Binary Systems 

Table 2. The 254 binary systems including 32 newly added (⬛) and 50 updated (⬛) in TCFE9 database. 

 Al B C Ca Ce Co Cr Cu Fe Mg Mn Mo N Nb Ni O P S Si Ta Ti V W Y Zn Zr 

Al Al                          
B  B                         
C   C                        
Ca    Ca                       
Ce     Ce                      
Co      Co                     
Cr       Cr                    
Cu        Cu                   
Fe         Fe                  
Mg          Mg                 
Mn           Mn                
Mo            Mo               
N             N              
Nb              Nb             
Ni               Ni            
O                O           
P                 P          
S                  S         
Si                   Si        
Ta                    Ta       
Ti                     Ti      
V                      V     
W                       W    
Y                        Y   
Zn                         Zn  
Zr                          Zr 
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Assessed Ternary Systems 

Table 3. The 255 ternary systems including 35 newly added (⬛) and 39 updated (⬛) in the TCFE9 
database. 

Al-C-Fe Al-Ni-Zr C-Co-Zn C-Mo-Zr Co-Fe-N Cr-Mo-Ni Fe-Mn-Ni Fe-Si-Ti 

Al-C-Mn Al-O-Si C-Cr-Fe C-N-Nb Co-Fe-W Cr-Mo-Si Fe-Mn-O Fe-Si-W 

Al-Ca-Fe Al-O-Ti C-Cr-Mn C-N-Ti Co-Nb-Si Cr-N-Nb Fe-Mn-P Fe-Si-Zr 

Al-Ca-O Al-O-Y C-Cr-Mo C-N-Zr Co-Ni-W Cr-N-Ni Fe-Mn-S Fe-Ti-Zr 

Al-Ca-Si Al-Ti-V C-Cr-N C-Nb-Ti Co-Si-Ti Cr-N-Ti Fe-Mn-Si Mg-Mn-O 

Al-Co-Fe B-C-Fe C-Cr-Nb C-Nb-V Co-Si-W Cr-N-V Fe-Mn-V Mg-Mn-S 

Al-Co-Ni B-Co-Fe C-Cr-Ni C-Nb-W Co-Ti-Zr Cr-N-W Fe-Mo-N Mg-Ni-O 

Al-Co-Zr B-Cr-Fe C-Cr-Si C-Ni-W Co-W-Zr Cr-Nb-Ni Fe-Mo-Ni Mg-O-Si 

Al-Cr-Fe B-Cr-Mn C-Cr-Ta C-Si-Ti Cr-Cu-Fe Cr-Nb-Si Fe-Mo-P Mn-Mo-Ni 

Al-Cr-Ni B-Cr-Mo C-Cr-V C-Ta-W Cr-Cu-Mo Cr-Ni-O Fe-Mo-Si Mn-Mo-Si 

Al-Cr-O B-Cr-Ni C-Cr-W C-Ti-V Cr-Cu-Ni Cr-Ni-Si Fe-Mo-V Mn-Ni-O 

Al-Cr-Zn B-Fe-Mn C-Cr-Zr C-Ti-W Cr-Cu-W Cr-Ni-W Fe-Mo-W Mn-Ni-Si 

Al-Cu-Fe B-Fe-Mo C-Cu-Fe C-Ti-Zr Cr-Fe-Mn Cr-Ni-Zr Fe-N-Nb Mn-O-S 

Al-Cu-Mn B-Fe-Nb C-Fe-Mn C-V-W Cr-Fe-Mo Cr-O-Ti Fe-N-Ni Mn-O-Si 

Al-Cu-Ni B-Fe-Ni C-Fe-Mo C-V-Zr Cr-Fe-N Cr-O-Y Fe-N-Ti Mn-O-Y 

Al-Fe-Mn B-Fe-Si C-Fe-N C-W-Zr Cr-Fe-Nb Cr-Si-Ti Fe-N-V Mn-Si-Zn 

Al-Fe-N B-Fe-Ti C-Fe-Nb Ca-Cr-O Cr-Fe-Ni Cr-Si-W Fe-N-W Mo-N-Ni 

Al-Fe-Ni B-Fe-V C-Fe-Ni Ca-Cr-S Cr-Fe-O Cu-Fe-Mn Fe-Nb-O Mo-N-V 

Al-Fe-O B-Fe-W C-Fe-O Ca-Fe-O Cr-Fe-P Cu-Fe-Mo Fe-Nb-P Mo-Ni-Si 

Al-Fe-P B-Fe-Zr C-Fe-P Ca-Fe-S Cr-Fe-S Cu-FeN Fe-Nb-Si N-Nb-Ti 

Al-Fe-Si B-Mo-Ni C-Fe-Si Ca-Mg-O Cr-Fe-Si Cu-Fe-Ni Fe-Nb-V N-Nb-V 

Al-Fe-Ti B-Mo-Ti C-Fe-Ti Ca-Mg-S Cr-Fe-V Cu-Fe-P Fe-Nb-Zr N-Ti-V 

Al-Fe-Zn B-Ni-Si C-Fe-V Ca-Mn-O Cr-Fe-W Cu-Fe-S Fe-Ni-O N-V-W 
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Al-Mg-O B-Ni-Ti C-Fe-W Ca-Mn-S Cr-Fe-Zn Cu-Fe-Si Fe-Ni-P Ni-O-Si 

Al-Mg-Si B-Ni-Zr C-Mn-Si Ca-Ni-O Cr-Mg-O Cu-Mn-Ni Fe-Ni-Si Ni-O-Ti 

Al-Mg-Zn B-Ti-Zr C-Mn-V Ca-O-Si Cr-Mn-Mo Cu-Mn-S Fe-Ni-W Ni-O-Y 

Al-Mn-Ni C-Co-Cr C-Mo-N Ce-O-S Cr-Mn-N Cu-O-Y Fe-O-S Ni-Si-Ti 

Al-Mn-O C-Co-Fe C-Mo-Nb Co-Cr-Fe Cr-Mn-Ni Fe-Mg-O Fe-O-Si Ni-Si-W 

Al-Nb-Ni C-Co-Nb C-Mo-Ta Co-Cr-Ni Cr-Mn-O Fe-Mg-S Fe-O-Y Ni-Si-Zr 

Al-Nb-Ti C-Co-Ni C-Mo-Ti Co-Cr-W Cr-Mn-S Fe-Mn-Mo Fe-P-Si O-Si-Y 

Al-Ni-O C-Co-Ti C-Mo-V Co-Cu-Fe Cr-Mn-Si Fe-Mn-N Fe-P-Ti O-Y-Zr 

Al-Ni-Ti C-Co-W C-Mo-W Co-Fe-Mo Cr-Mo-N Fe-Mn-Nb Fe-S-Ti 
 

Assessed Quaternary Systems 

Table 4. The 77 quaternary systems including 2 newly added (⬛) and 9 updated (⬛) in the TCFE9 
database. 

Al-C-Fe-Mn Al-Fe-Mn-O C-Co-Fe-Ni C-Cr-Mo-V C-Fe-N-Ni Ca-Fe-O-Si Cr-Mg-Ni-O 

Al-Ca-Mg-O Al-Fe-Ni-O C-Co-Fe-W C-Cr-Mn-V C-Fe-Nb-W Ca-Mg-O-Si Cr-Mn-Ni-O 

Al-Ca-O-Si Al-Fe-O-Y C-Co-Nb-W C-Cr-Mn-W C-Fe-Ni-W Cr-Fe-Mg-O Cr-Mo-N-Nb 

Al-Cr-Fe-Ni Al-Mg-Mn-O C-Co-Ni-W C-Cr-Mo-V C-Fe-Si-W Cr-Fe-Mn-N Fe-Mg-Mn-O 

Al-Cr-Fe-O Al-Mg-Ni-O C-Co-V-W C-Cr-V-W C-Fe-V-W Cr-Fe-Mn-O Fe-Mg-Ni-O 

Al-Cr-Fe-Zn Al-Mg-O-Si C-Cr-Fe-Mn C-Fe-Mn-Nb C-Mo-N-Ni Cr-Fe-Mo-N Fe-Mg-O-Si 

Al-Cr-Mg-O Al-Mn-Ni-O C-Cr-Fe-Mo C-Fe-Mn-Si C-N-Nb-Ti Cr-Fe-N-Nb Fe-Mn-Nb-N 

Al-Cr-Mn-O Al-Mn-O-S C-Cr-Fe-N C-Fe-Mo-Nb C-N-Nb-V Cr-Fe-N-V Fe-Mn-Ni-O 

Al-Cr-Ni-O Al-O-Si-Y C-Cr-Fe-Ni C-Fe-Mo-Si C-N-Ti-V Cr-Fe-Ni-O Mg-Mn-Ni-O 

Al-Cr-O-Y C-Co-Cr-W C-Cr-Fe-V C-Fe-Mo-V Ca-Fe-Mg-S Cr-Fe-O-Y Mn-O-Y-Zr 

Al-Fe-Mg-O C-Co-Fe-Mo C-Cr-Fe-W C-Fe-Mo-W Ca-Fe-Mn-S Cr-Mg-Mn-O B-Cr-Fe-Mo 
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