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Graphical Mode Examples
This guide includes descriptions of the following examples.

Category Example number

Thermo-Calc Graphical Mode Examples Collection includes binary and ternary system examples, 
Scheil, the Equilibrium Calculator, Material to Material Calculator, plus more T_01 to T_16

Thermo-Calc General Property Model Examples Collection: General Models Library General Models: PM_G_01 
to PM_G_13

Steel Model Library Examples Collection Steel Models: PM_Fe_01 to 
PM_Fe_09

Nickel Model Library Examples Collection Nickel Models: PM_NI_01 to 
PM_Ni_02

Process Metallurgy Module Examples Collection PMET_01 to PMET_08

Diffusion Module (DICTRA) Graphical Mode Examples
D_01, D_02, D_03 (the Quick 
Start Guide Examples)

D_04 to D_08

Precipitation Module (TC-PRISMA) Graphical Mode Examples P_01 to P_14
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Thermo-Calc Graphical Mode Examples Collection
In this section:

T_01: Calculating a Single-Point Equilibrium 2

T_02: Stepping in Temperature in the Fe-C System 4

T_03: Fe-C Phase Diagrams 6

T_04: Fe-Cr-C Ternary Phase Diagram  at 1000 K 8

T_05: Stable and the Metastable Fe-C Phase Diagrams 10

T_06: Serially Coupled Equilibrium Calculators 12

T_07: User-Defined Functions 15

T_08: Scheil and Equilibrium Solidification 17

T_09: Carbide Driving Force Heat Map 20

T_10: Scheil Solidification with Back Diffusion 21

T_11: Surface Tension in Cu-Zr 23

T_12: Viscosity in Cr-Ni 25

T_13: Scheil Solidification with Solute Trapping 27

T_14: Fe-Cr-Ni Transition Comparison Using the Material to Material Calculator 29

T_15: Molar Volume and Thermal Expansion Coefficients for L12-type Al3Sc and Al3Zr Compounds 32

T_16: Electrical Resistivity and Thermal Conductivity for Pure Copper 35
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T_01: Calculating a Single-Point Equilibrium
This example shows the result from a single-point equilibrium calculation in the Fe-C system. It 
demonstrates the use of the Equilibrium Calculator and generates a Table Renderer in the Results 
window. The number of equilibrium conditions is C+2 where C is the number of components, meaning 
that four conditions are needed in this example:

 l Temperature is 1000 K
 l Pressure is 100000 Pa
 l System size is 1 mole
 l Mass percent carbon is 0.1%

This example is included as a tutorial on our website and as part of the Graphical Mode 
Examples playlist on our YouTube channel.

Project File Information
 l Folder: Thermo-Calc
 l File name: T_01_Single-point_equilibrium.tcu
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Figure 1: The displayed results of the calculation show that the BCC_A2 (ferrite) and GRAPHITE phases are 
stable for this set of equilibrium conditions.
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T_02: Stepping in Temperature in the Fe-C System
This example shows how the fractions of stable phases vary for an Fe-0.1 mass-% C alloy when the 
temperature is varied between 500 and 2000 K. It demonstrates the use of the Equilibrium Calculator. 
To allow temperature to vary, the corresponding Axis Definition check box is selected. 

This example is included as a tutorial on our website and as part of the Graphical Mode 
Examples playlist on our YouTube channel.

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Thermo-Calc
 l File name: T_02_Step_in_temperature_in_Fe-C.tcu

Figure 2: In this example, results are displayed graphically using a Plot Renderer activity.

For the Plot Renderer, there is an option to use the Table View  button to convert plots 
to table data for all calculation types and calculators. 
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If you want, you can also use a Table Renderer to generate text results instead, as shown in this example 
after adding a Table Renderer to the Equilibrium Calculator and clicking Perform.
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T_03: Fe-C Phase Diagrams
This example shows the stable Fe-C phase diagram (stable meaning that the graphite phase is entered in 
the calculation). The same diagram is calculated using the Binary Calculator activity and then using a 
System Definer and Equilibrium Calculator. 

In both cases, a Plot Renderer is used to display results. The purpose of the Binary Calculator is to 
simplify common calculations for binary systems. In the Equilibrium Calculator two axes are defined: 
Mass percent C and Temperature. An axis variable must also be an equilibrium condition.

This example is included as a tutorial on our website and as part of the Graphical Mode 
Examples playlist on our YouTube channel.

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File  Information
 l Folder: Thermo-Calc
 l File name: T_03_Fe-C_phase_diagram.tcu

Figure 3: The plot result of the System Definer and Equilibrium Calculator.
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Figure 4: The plot result of the Binary Calculator simulation.
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T_04: Fe-Cr-C Ternary Phase Diagram  at 1000 K
This example shows a ternary phase diagram in the Fe-Cr-C system at 1000 K. Similar to example T_03: 
Fe-C Phase Diagrams, the same diagram is calculated using a Ternary Calculator and then using a System 
Definer and Equilibrium Calculator. Two Plot Renderer activities are added to create two plots.

This example is included as a tutorial on our website and as part of the Graphical Mode 
Examples playlist on our YouTube channel.

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Thermo-Calc
 l File name: T_04_Fe-Cr-C_ternary_phase_diagram.tcu

Try practicing with two features on the Plot Renderer Configuration window. To toggle between a 
triangular and a rectangular diagram, click the Show Triangular button then click Perform to see what 
happens. To toggle the X and Y axis variables, click the Switch Axes button and then click Perform.

Figure 5: Ternary Calculator 
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Figure 6: Equilibrium Calculator
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T_05: Stable and the Metastable Fe-C Phase Diagrams
This example shows how to overlay results from two calculations in the same plot using the Equilibrium 
Calculator. 

This example is included as a tutorial on our website and as part of the Graphical Mode 
Examples playlist on our YouTube channel.

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Thermo-Calc
 l File name: T_05_Fe-C_stable_and_metastable_phase_diagram.tcu

 1. The Plot Renderer activity is first created as a successor to Equilibrium Calculator 1.

 2. Then right-click the Plot Renderer node and select Add predecessor and the results from both 
equilibrium calculators are in the same plot. In Equilibrium Calculator 1 the stable phase 
diagram is calculated and in Equilibrium Calculator 2 the metastable phase. 

 3. The metastable diagram is obtained by deselecting the graphite phase on System Definer2  → 
Phases and phase constitution tab.
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T_06: Serially Coupled Equilibrium Calculators
Sometimes there are multiple solutions for a given set of equilibrium conditions. In other cases the 
equilibrium calculation does not converge. You can then aid the final calculation by, in effect, telling the 
software where it should start the search for the equilibrium. 

This example shows how to serially couple two Equilibrium Calculator nodes together for more complex 
equilibrium conditions. For each calculation, the output is to a Table Renderer. 

This example is included as a tutorial on our website and as part of the Graphical Mode 
Examples playlist on our YouTube channel.

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Thermo-Calc
 l File name: T_06_Serial_equilibrium_calculators.tcu

Table Renderer Results

Equilibrium Calculator 1

In the first example, the objective is to calculate the equilibrium at 850° C where the mole fractions of 
the FCC A1 and BCC A2 phases are 0.5 each for an Fe-Cr-C steel with 10% chromium. In Equilibrium 
Calculator 1 a simple set of equilibrium conditions (temperature, pressure, system size and composition) 
are used to find a carbon content where only the FCC A1 and BCC A2 phases are stable. The results from 
this preliminary calculation are displayed in  Table Renderer 1.
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Equilibrium Calculator 2, 3, and 4

Click each tab along the top of the Results window to view the results associated to Table Renderer 2, 
Table Renderer 2, and Table Renderer 2.

 l In Equilibrium Calculator 2 the carbon content equilibrium condition is replaced by the condition 
that the numbers of moles of the BCC A2 phase should be 0.5. The final result is displayed in 
Table Renderer 2. In this case, the final objective is to calculate the solidus temperature of an Fe-
Cr-C steel with 10% Cr and 0.01% C. 

 l In Equilibrium Calculator 3 the state at 2000 K is calculated and the result is displayed in Table 
Renderer 3. 
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 l In Equilibrium Calculator 4 the temperature equilibrium condition is replaced by the condition 
Fix phase / liquid / 0.0, meaning that liquid should be stable in an amount of zero moles, i.e. the 
solidus temperature. The final result is displayed in Table Renderer 4.
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T_07: User-Defined Functions
This example shows how to implement user-defined functions. A series of equilibria for an Fe-Cr-C alloy 
are calculated by varying temperature between 500 and 3000 K. In the configuration window of the 
Equilibrium Calculator under the Functions tab, two identically meaning functions are defined, fraction 
solid and f solid, the values of which are plotted against temperature in two  Plot Renderer activities. 
Functions can be entered in terms of QuantitiesQ1, Q2, Q3 and so forth, or by using the Thermo-Calc 
syntax.

This example is included as a tutorial on our website and as part of the Graphical Mode 
Examples playlist on our YouTube channel.

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Thermo-Calc
 l File name: T_07_User_defined_functions.tcu
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Figure 7: The result of the fraction_solid function.

Figure 8: The result of the f_solid function.
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T_08: Scheil and Equilibrium Solidification
This example shows a comparison for an Al-Si alloy solidified under full local equilibrium and under the 
Scheil assumptions, i.e. zero diffusion in the solidified material and infinitely fast diffusion in the liquid. 
The example uses the Scheil Calculator and adds a Plot and Table Renderer. 

This example is included as a tutorial on  our website and as part of the Scheil Solidification 
Simulations playlist on our YouTube channel. 

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Thermo-Calc
 l File name: T_08_Scheil_and_equilibrium_solidification.tcu

Figure 9: The plot compares the mole fraction of a solid vs temperature. 
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Figure 10: The table provides the data, which you can also export.

To Save the Table (via Table Renderer)
There are different ways to save the table from the Table Renderer Results or Configuration windows. 

For the Plot Renderer, there is an option to use the Table View  button to convert plots 
to table data for all calculation types and calculators. 

Method 1

In the Results window, right click the table and select  Save As...
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Method 2
 1. In the Project window, click the Table Renderer.

 2. In the Configuration window, click Save table.
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T_09: Carbide Driving Force Heat Map
This is an example of using Grid calculations to plot the driving force for a carbide as a function of two 
composition variables. With the Grid calculation type, a 2D grid is generated from the two calculation 
axes. After the calculation is done, an equilibrium is calculated in each grid point. A Plot Renderer 
connected to a grid calculation plots the z-axis property for each equilibrium as a function of the two 
calculation axes. 

This example is included as a tutorial on our website and as part of the Graphical Mode 
Examples playlist on our YouTube channel.

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Thermo-Calc
 l File name: T_09_Heat_map_of_carbide_driving_force.tcu

Figure 11: The results are plotted as a heat map. Alternatively, a contour plot type can be selected on the Plot 
Renderer.
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T_10: Scheil Solidification with Back Diffusion
This is an example of a Scheil solidification simulation of a Al-2.1Cu-1Si alloy including back diffusion in 
the primary phase.

The example uses two of the Scheil Calculator activity nodes with different cooling rates, 10 K/s and 
0.005 K/s. The lower cooling rate produces a solidification curve that is closer to the equilibrium curve 
as shown in the plot result. Both a thermodynamic ALDEMO (aluminum demo) and mobility MALDEMO 
(Al-alloys mobility) database are used for this calculation.

The Scheil with back diffusion  feature is only available for systems with diffusion data, i.e. 
this model requires the use of a mobility database.

This example is included as a tutorial on  our website and as part of the Scheil Solidification 
Simulations playlist on our YouTube channel. 

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Thermo-Calc
 l File name: T_10_Scheil_with_back_diffusion.tcu. 

Running the example itself does not require an additional license.
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Figure 12: Scheil solidification. The lower cooling rate produces a solidification curve that is closer to the 
equilibrium curve .
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T_11: Surface Tension in Cu-Zr
This is an example of including surface tension in the calculations. 

Using the ALDEMO database, which is the free demonstration version of the TCS Al-based Alloy 
Database (TCAL), the surface tension of liquid metallic is plotted at 1373 K for Cu-Zr and compared to 
experimental data from [2005Kra].

Reference

[2005Kra] V. P. Krasovskyy, Y. V. Naidich, N. A. Krasovskaya, "Surface tension and density of copper–
Zirconium alloys in contact with fluoride refractories," J. Mater. Sci. 40, 2367–2369 (2005).

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Thermo-Calc
 l File name: T_11_Surface_tension_in_Cu-Zr.tcu

The same example is also provided in Console Mode as tcex56.

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.
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Figure 13: Surface tension of liquid metallic at 1373 K for Cu-Zr and compared to experimental data from 
[2005Kra].

More Information

The thermophysical properties are progressively being added to the Thermo-Calc databases starting 
with Thermo-Calc software version 2020a. 

You can learn more about the models by searching the help (press F1 when in 
Thermo-Calc). 

You can find information on our website about the properties that can be calculated with 
Thermo-Calc and the Add-on Modules. 
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T_12: Viscosity in Cr-Ni
This is an example of including viscosity in the calculations. 

Using the FEDEMO database, which is the free demonstration version of the TCS Steel and Fe-alloys 
Database (TCFE), the viscosity of metallic liquids is plotted at 1873 K for Cu-Ni and compared to 
experimental data from [2005Sat].

Reference

[2005Sat] Y. Sato, K. Sugisawa, D. Aoki, T. Yamamura, "Viscosities of Fe–Ni, Fe–Co and Ni–Co binary 
melts," Meas. Sci. Technol. 16, 363–371 (2005).

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Thermo-Calc
 l File name: T_12_Viscosity_in_Cr-Ni.tcu

The same example is also provided in Console Mode as tcex55.

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.
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Figure 14: The viscosity of metallic liquids  at 1873 K for Cu-Ni and compared to experimental data from 
[2005Sat].

More Information

The thermophysical properties are progressively being added to the Thermo-Calc databases starting 
with Thermo-Calc software version 2020a. 

You can learn more about the models by searching the help (press F1 when in 
Thermo-Calc). 

You can find information on our website about the properties that can be calculated with 
Thermo-Calc and the Add-on Modules. 
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T_13: Scheil Solidification with Solute Trapping
In Graphical Mode, you use the Scheil Calculator to set up the various Scheil solidification simulations.

This example shows the use of the Scheil with solute trapping option with an Al-7.5Si-0.2Cu alloy as 
compared to a Classic Scheil calculation. The thermodynamic ALDEMO (Aluminum demo) database, 
available to all users, is selected for this calculation to simulate the effect of solute trapping in the 
primary phase. This type of simulation is useful for additive manufacturing applications.

This example shows how the alloy starts to solidify at a lower temperature compared to a classic Scheil 
simulation, an effect which increases with increasing solidification speed. The solidification speed is 
calculated from user supplied scanning speed and angle between the solid/liquid interface and the 
scanning direction.

This example is included as a tutorial on  our website and as part of the Scheil Solidification 
Simulations playlist on our YouTube channel. 

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File  Information
 l Folder: Thermo-Calc
 l File name: T_13_Scheil_with_Solute_Trapping.tcu
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Figure 15: The effect of Scheil solidification with solute trapping of a Al-7.5Si-0.2Cu alloy compared to 
equilibrium and a Classic Scheil calculation.
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T_14: Fe-Cr-Ni Transition Comparison Using the Material to 
Material Calculator
In Graphical Mode, you use the Material to Material Calculator to perform calculations and examine 
how two materials transition from one into the other. The calculations in this example search for 
potential deleterious phases during heat treatment of alloys joined together. In this example, the 
calculation steps between a model martensitic stainless steel (Fe-17Cr-2Ni) and a model Alloy 800 
composition (Fe-35Ni-19Cr). Neither alloy is predicted to form the deleterious sigma phase at 600 °C. 
However sigma is predicted to form at a wide range of mixtures of these two materials, which could 
have an impact on mechanical properties if it forms.

The example, as defined when you open it, uses a One axiscalculation (also known as a property 
diagram), a temperature of 650 °C, to compare the volume fraction of all phases to the mass fraction of 
Alloy 800. The Fraction of the second material (Alloy 800) is set to 50% (0.5), which for a One axis 
calculation is used as the start value. 

As with all the examples, you can adjust the settings to plot a variety of combinations of 
output to see how the Material to Material Calculator works before defining your own 
project. 

The plot for this calculation compares the volume fraction of all phases of Material 1 (martensitic 
stainless steel) to the mass fraction of Material 2 (Alloy 800). In the plots you can see where each phase  
(FCC_A1, SIGMA_D8B, and BCC_A2) evolves. As you step from Material 1 to Material 2, the FCC_A1 
phase starts forming at about 5% (0.05), SIGMA-D8B phase starts to evolve at about 19% (0.19), and the 
BCC_A2 transitions from Material 1 to Material 2 where it stops forming at approximately 24% (0.24). 
The purpose of the calculation is to determine at what fraction of Alloy 800 the deleterious sigma phase 
forms and this is shown for these compositions.

This example is included as a tutorial on our website and as part of the Graphical Mode 
Examples playlist on our YouTube channel.

Project File Information
 l Folder: Thermo-Calc
 l File name: T_14_Fe-Cr-Ni_Material_to_Material.tcu

The default plot shows the volume fraction of all phases as a function of the mass fraction of the second 
material, which in this case, is Alloy 800. You can see that the martensitic stainless composition is BCC at 
this temperature, and the highly alloyed stainless is FCC. Neither material is expected to form any 
deleterious phase on its own at 650 °C.
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However, mixtures of these two materials, which could arise from a graded transition joint, weld, or 
potentially a diffusion couple, show some stability for the deleterious sigma phase at this temperature. 
You can try to make small adjustments to the initial chemistry to reduce the potential for sigma phase to 
form.

Figure 16: This plot shows the volume fraction of phases when changing composition from the Martensitic 
Steel (First material) to the Alloy 800 (Second material). This calculation uses the Material to Material 
Calculator to examine the transition of phases for two compositions of Fe-Cr-Ni. The purpose  is to determine 
at what fraction of Alloy 800 does the deleterious sigma phase start to form. See the text for details. 
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Figure 17: The composition varies linearly when the composition is changed from the Martensitic steel to the 
Alloy 800 using the Material to Material Calculator. See the text for details. 
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T_15: Molar Volume and Thermal Expansion Coefficients for 
L12-type Al3Sc and Al3Zr Compounds
This example calculates volumetric thermal expansion coefficients of the L12-type Al3Sc and the L12-
type Al3Zr, respectively. Both Al3Zr and Al3Sc are modeled as the same phase (named as AL3SC, since 
Al3Sc is stable while Al3Zr is metastable).

The example set up uses two System Definers and Equilibrium Calculators to plot and compare the 
molar volume and thermal expansion coefficients of the Al3Sc and Al3Zr binary compounds. It uses the 
ALDEMO database, which is the free demonstration version of the TCS Al-based Alloy Database (TCAL) 
and an Experimental File Reader node to read the data from [2015Sah].

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Thermo-Calc
 l File name: T_15_Molar_Volume_and_Thermal_Expansion_Coefficient.tcu

The example includes an experimental data (*.exp) file called Al3X.exp.

The same example is also provided in Console Mode as two separate examples: tcex58 and 
tcex59.

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.
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Figure 18: Compares the molar volume of both Al3Zr and Al3Sc, which are modeled as the same phase (named 
as AL3SC, since Al3Sc is stable while Al3Zr is metastable).

Figure 19: Compares volumetric thermal expansion coefficients of the L12-type Al3Sc and the L12-type Al3Zr 
using theoretical data with quasiharmonic approximation from [2015Sah].
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More Information

The thermophysical properties are progressively being added to the Thermo-Calc databases starting 
with Thermo-Calc software version 2020a. 

You can learn more about the models by searching the help (press F1 when in 
Thermo-Calc). 

You can find information on our website about the properties that can be calculated with 
Thermo-Calc and the Add-on Modules. 
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T_16: Electrical Resistivity and Thermal Conductivity for 
Pure Copper
This example calculates the electrical resistivity (ELRS) and thermal conductivity (THCD) of pure Cu. It 
makes a One axis (step) calculation over a wide temperature range, covering both the FCC_A1 state and 
the liquid state. It plots thermal conductivity of the system (both FCC_A1 and liquid) and that of a single 
phase (taking FCC_A1 as an example), respectively. Also it plots electrical resistivity of the system and 
that of FCC_A1.

The example set up uses an Equilibrium Calculator combined with four Experimental File Reader nodes 
that take data from the included 1972Ho_cu_thcd.exp and 1981Ho_cu_elrs.exp files.

The example is available to all users as it uses the ALDEMO database, which is the free demonstration 
version of the TCS Al-based Alloy Database (TCAL).

For more advanced examples using the TCAL database, see PM_G_10: Freeze-in Thermal 
Conductivity and PM_G_11: Freeze-in Electrical Resistivity.

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Thermo-Calc
 l File name: T_16_Electrical_Resistivity_Thermal_Conductivity_Cu.tcu
 l Experimental data files included 1972Ho_cu_thcd.exp and 1981Ho_cu_elrs.exp

The same example is also provided in Console Mode as tcex60.

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.
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Figure 20: The electrical resistivity (ELRS) of pure Cu over a wide temperature range, covering both the FCC_A1 
state and the liquid state. The data was recommended by [1981Ho].

Figure 21: The electrical resistivity (ELRS) of a single phase (FCC_A1) vs. temperature. The data was 
recommended by [1981Ho].

Thermo-Calc Graphical Mode Examples Collection ǀ 36 of 206

www.thermocalc.com

https://www.thermocalc.com/


Figure 22: The thermal conductivity of pure Cu over a wide temperature range, covering both the FCC_A1 
state and the liquid state. The data was recommended by [1972Ho].

Figure 23: The thermal conductivity (THCD) of a single phase (FCC_A1) vs. temperature. The data was 
recommended by [1972Ho].
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More Information

The thermophysical properties are progressively being added to the Thermo-Calc databases starting 
with Thermo-Calc software version 2020a. 

You can learn more about the models by searching the help (press F1 when in 
Thermo-Calc). 

You can find information on our website about the properties that can be calculated with 
Thermo-Calc and the Add-on Modules. 
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Thermo-Calc General Property Model Examples Collection
The General Models  are available to all users. 

To run calculations with  the Steel Models (as part of the Steel Model Library) requires a 
valid maintenance license plus licenses for both the TCFE (version 9 and newer) and MOBFE 
(version 4 and newer) databases. To run calculations with the Nickel Models (as part of the 
Nickel Model Library) requires a valid maintenance license plus licenses for both the TCNI 
(version 11 and newer) and MOBNI (version 5 and newer) databases. 

These examples use the Property Model Calculator, an activity available with Thermo-Calc. 

In this section:

PM_G_01: Phase Transition 40

PM_G_02: Coarsening and Interfacial Energy 42

PM_G_03: Driving Force and Interfacial Energy 45

PM_G_04: Yield Strength 47

PM_G_05: Yield Strength NiAlCr 50

PM_G_06: Yield Strength HEA 52

PM_G_07: Hot Crack Susceptibility 54

PM_G_08: Spinodal 56

PM_G_09: T-Zero Temperature 57

PM_G_10: Freeze-in Thermal Conductivity 59

PM_G_11: Freeze-in Electrical Resistivity 61

PM_G_12: Solidus and Liquidus Batch Calculation 63

PM_G_13: Ti Alloy Design for Additive Manufacturing 65
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PM_G_01: Phase Transition
The example uses the Property Model Calculator to predict the transition temperature to the unwanted 
brittle sigma phase. The example shows how the temperature is influenced by changes to a steel alloy’s 
composition  using the uncertainty calculation type and how to create either a histogram (frequency 
diagram) or probability plot.

This example is included as a Property Model tutorial on our website and as part of the 
Property Model Calculator playlist on our YouTube channel. 

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Property Models>General
 l File name: PM_G_01_Phase_Transition.tcu

Figure 24: A property diagram as a result of using the Equilibrium Calculator with a One-axis calculation to 
determine a good starting temperature of the SIGMA phase. 

Once you set up the Property Model Calculator, but before running a Grid calculation, it is 
recommended you run a Single calculation to make sure the calculation is valid. If the subprocess 
completed normally displays in the Event Log, it means it worked correctly. You will also see in the Log, 
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the result "Relaxed Condition", which refers to the variable, in this case, temperature. If the calculation 
did not work, you will see NAN (not a number) display instead. Check your configurations and run it again 
before moving on to the more complicated calculation.

Figure 25: Using the Property Model Calculator with the Phase Transition Model to plot a histogram showing 
how the transition temperature of sigma varies when you vary the composition. The plot changes each time 
you run the calculation because it is taking a random sampling from the composition range set.

Note that the X-axis is labeled the Relaxed Condition, which you can see on the Configuration window it 
is Temperature for the Condition to Vary setting. The Y-axis shows the Frequency, which is the number 
of samples out of 40 where the composition transitions at each temperature. You can see that the 
transitions occur more frequently near the 600 degree starting point and less frequently at the edges.  
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PM_G_02: Coarsening and Interfacial Energy
The example uses the Property Model Calculator and both thermodynamic (FEDEMO) and kinetic 
(MFEDEMO) demonstration steel databases. Using a Grid calculation type it produces these plots: a heat 
map, a contour plot and a cross plot with contour (where both the interfacial energy and coarsening rate 
is shown). It also creates a diagram to show the phase fractions vs time and a 3D plot comparing the 
coarsening rate coefficient.

This example is included as a Property Model tutorial on our website and as part of the 
Property Model Calculator playlist on our YouTube channel. 

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Property Models>General
 l File name: PM_G_02_Coarsening_and_Interfacial_energy.tcu

Figure 26: Coarsening rate coefficient (heat map plot).
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Figure 27: Coarsening rate coefficient (3D plot).

Figure 28: Coarsening rate coefficient (contour plot).
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Figure 29: The coarsening rate coefficient and interfacial energy in overlaid plots. 

Figure 30: Phase fractions vs T (one axis).
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PM_G_03: Driving Force and Interfacial Energy
The example uses the Property Model Calculator and a thermodynamic demonstration steel database 
(FEDEMO). Using a grid calculation type it produces a contour plot comparing the driving force and 
interfacial energy.

This example is included as a Property Model tutorial on our website and as part of the 
Property Model Calculator playlist on our YouTube channel. 

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Property Models>General
 l File name: PM_G_03_Driving_force_and_Interfacial_energy.tcu

Figure 31: A contour plot.
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Figure 32: Phase fraction.
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PM_G_04: Yield Strength
The example uses the Property Model Calculator and the Yield strength Property Model with a 
thermodynamic demonstration aluminum database (ALDEMO).

Using setting options for the precipitation strengthening models, this example compares the Simplified 
model (general) and Seidman model (Al-base) yield strength versus precipitate radius to experimental 
data for an Al-0.3wt%Sc alloy homogenized at 648 °C for 24 hours and subsequently aged at 350 °C.

The Seidman model [2002Sei] considers a combination of a shearing mechanism and Orowan 
dislocation bypass mechanism. For the shearing mechanism, the increase in yield strength results from 
the contributions of ordering strengthening, coherency strengthening, and modulus mismatch 
strengthening.

When Seidman model (Al-base) is selected as the Precipitation strengthening model, the setting for 
alpha is a constant related to the coherency strengthening of precipitates, which usually varies from 2 to 
3. In this example, the default alpha is 2.6 [1985Ard]. The m setting is the parameter that relates to the 
modulus mismatch strengthening and the default is set as 0.85 [1985Ard]. This model is applied in the 
study of precipitation hardening in dilute Al(Sc) alloys containing coherent Al3Sc precipitates. The model 
parameters described above may be adjusted by the user to also suite calculations for hardenable 
aluminum alloys from the 2000 (Al–Cu and Al–Cu–Mg), 6000 (Al–Mg–Si), and 7000 (Al–Zn–Mg) series.

As a comparison, the Simplified model [2008Zan] only considers the general mechanisms of cutting and 
looping (Orowan mechanism) without regard to any detailed dislocation mechanisms.

When Simplified model (general) is selected as the Precipitation strengthening model, the default 
critical size  r_c (the Critical radius setting)  is optimized  against experimental results for dilute Al-Sc. If 
the precipitates are smaller than a critical size (approximately 5–10 nm) the dislocations cut the 
precipitates. The strength of the obstacle is then proportional to the square root of the average radius. 
If the particles are larger than the critical size, r_c, it is easier for the dislocations to bow round the 
particles and now is inversely proportional to r. Since the Simplified model (general) only depends on 
generic material constants (kp and rc) it may be applied to any precipitation strengthened material.

Project File Information
 l Folder: Property Models>General
 l File name: PM_G_04_Yield_Strength.tcu

Open the example project file and click Perform Tree to generate the plots associated with it. 

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.
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Figure 33: Strength vs Radius - Simplified compared to experimental data from [2002Sei].

Figure 34: Strength vs Radius - Seidman compared to experimental data from [2002Sei].
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PM_G_05: Yield Strength NiAlCr
The example uses the Property Model Calculator and the Yield strength Property Model with a 
thermodynamic demonstration nickel database (NIDEMO).

The Reppich model is developed for calculation of precipitation strengthening in Ni-based super alloys 
consisting mainly of gamma prime (γ') precipitates in a gamma matrix. The example shows a calculation 
of the precipitation strengthening vs precipitate radius in a Ni-10at%Al-10at%Cr alloy.

This example uses the Reppich model [1982Rep] which is developed and rests on existing hardening 
models estimating the increase of the yield stress due to pairwise particle cutting and antiphase domain 
boundary (APB) formation. The effect of the anisotropy on the dislocation line tension of two-phase 
material and on the Orowan stress is taken into account. Compared to conventional APB hardening 
theories, this model can be applied to large volume fraction of precipitates in the anisotropic systems.

For the settings input of the Reppich model (Ni-base):

 l A is a numerical factor depending on the morphology of the precipitates. For spherical particles, 
A equals to 0.72.

 l w represents the elastic repulsion between the strongly paired dislocations, which can be 
determined by the experimental data [1979Hüt].

In this example, A and w are set by default to 0.7639 and 0.2919, respectively.

Project File Information
 l Folder: Property Models>General
 l File name: PM_G_05_Yield_Strength_NiAlCr.tcu

Open the example project file and click Perform Tree to generate the plots associated with it. 

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.
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Figure 35: Reppich model plotted with results and experimental data for PE16, all data is normalized with the 
square root of the volume fraction of precipitate.

References
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PM_G_06: Yield Strength HEA
The example uses the Property Model Calculator and the Yield strength Property Model with the 
thermodynamic TCS High Entropy Alloys Database (TCHEA). It is an example of solid solution 
strengthening, which is the contribution to total strength due to the elastic strains in the crystal lattice 
caused by alloying elements of a lattice parameter differing from the main constituent. The example 
shows the solid solution strengthening at 293 K over the full solubility range for the Mo-Ta system as 
compared to experimental data [2017Wal].

This example requires the use of the TCS High Entropy Alloys Database (TCHEA). A license is 
required to run the example.

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Property Models>General
 l File name: PM_G_06_Yield_Strength_HEA.tcu

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.
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Figure 36: The solid solution strengthening over the full solubility range for the Mo-Ta system as compared to 
experimental data [2017Wal].

Reference
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PM_G_07: Hot Crack Susceptibility
The example uses the Property Model Calculator and the Crack Susceptibility Coefficient Property 
Model to calculate the hot tearing tendency during solidification for an Al-Si alloy. The ALDEMO: 
Aluminum Demo Database  is used and this example is available to all users. 

Hot tearing is one of the most common and serious defects encountered during the casting of, for 
example, aluminum alloys. In general, it is defined by the formation of a macroscopic fissure in a casting 
as a result of stress and the associated strain, generated during cooling, at a temperature above the 
non-equilibrium solidus.

The Model is based on the publication by Yan and Lin [2006Yan] and uses experimental data [1955Pum; 
1976Feu; 2004Bar] from this paper. 

The experimental hot cracking susceptibility of an alloy is defined as the ratio between the cracking 
length for that alloy and the maximum cracking length in the alloy system studied. Considering the 
uncertainties and difficulties in hot tearing measurements, the calculated hot tearing tendencies are in 
excellent agreement with the experimental data. The typical L-shaped curve is well reproduced in the 
current prediction. It rapidly increases at a low solute content and has a maximum at a composition of 
around 0.5 wt pct Si.

This example is included as a Property Model tutorial on our website and as part of the 
Property Model Calculator playlist on our YouTube channel. 

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Property Models>General
 l File name: PM_G_07_Hot_Crack_Susceptibility.tcu
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Figure 37: The plot compares the predicted cracking susceptibility/composition curve for the Al-Si system with 
the experimental hot tearing tendencies [1955Pum; 1976Feu; 2004Bar].
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PM_G_08: Spinodal
The example uses the Property Model Calculator and the Spinodal Property Model to  calculate the so-
called spinodal curve for the BCC_A2 miscibility gap in the system Fe-Cr. The FEDEMO: Iron Demo 
Database  is used and this example is available to all users. 

Two Property Model Calculators are used in this example. The spinodal curve (a One axis calculation), is 
overlaid on top of a the Fe-Cr Phase diagram calculation. As can be seen in the plot, the spinodal curve 
for BCC goes through the one-phase region for Sigma. This is because the spinodal curve for a phase is 
calculated when all other phases are suspended.

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Property Models>General
 l File name: PM_G_08_Spinodal.tcu

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.

Figure 38: An Fe-Cr spinodal curve for BCC goes through the one-phase region for Sigma. 
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PM_G_09: T-Zero Temperature
The example uses the Property Model Calculator and the T-Zero Temperature Property Model to  
calculate the so-called T0 line for the two-phase field FCC_A1 and BCC_A2 in the Fe-Ni system.  The line 
is plotted together with the phase diagram for the same Fe-Ni system. The FEDEMO: Iron Demo 
Database  is used and this example is available to all users. 

The T0 temperature is defined as the temperature where two phases of identical chemical composition 
have the same molar Gibbs free energy. This temperature is an important quantity in the field of 
diffusionless phase transformations, e.g. martensitic transformation, since it is the upper limit where 
diffusionless phase transformations can occur.

Two Property Model Calculators are used in this example. The T0 line (a One axis calculation) for the 
two-phase field FCC_A1 and BCC_A2 is overlaid on top of a the Fe-Ni Phase diagram calculation. 

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Property Models>General
 l File name: PM_G_09_T-Zero_temperature.tcu

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.
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Figure 39: In this plot for the Fe-Ni system, the T0 line for the FCC_A1 and BCC_A2 phases is located in the 
middle of the two-phase region. No solution for the T0 temperature exists above about 30 mass% Ni.
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PM_G_10: Freeze-in Thermal Conductivity
The example uses the Property Model Calculator and the Equilibrium with Freeze-in Temperature 
Property Model to compare the use of the model with thermal conductivity with and without grain 
boundary (GB) phase scattering being included in the calculation. 

The TCS Al-based Alloy Database (TCAL) is used to evaluate a 7075_T6 alloy (Al-1.6Cu-2.5Mg-5.6Zn-
0.25Fe-0.15Mn-0.23Cr-0.2Ti-0.2Si) mass%. The "T6" in the alloy name means that the alloy has been 
artificially peak-aged, i.e. the matrix is almost depleted. The heating is assumed to be at a typical 
artificial aging temperature of 150 °C. The temperature has then been increased for measuring of the 
reported values thermal conductivity at 400, 500, and 532 °C.

The thermal conductivity  due to grain boundary phase scattering is approximated as a scattering 
constant times the total volume fraction of the grain boundary phases. The contribution to thermal 
conductivity is assumed to be related to that to electrical resistivity, following the Wiedemann-Franz 
law.

The calculation set up assumes that the alloy reaches equilibrium at the peak-age temperature, i.e. that 
the amounts of phases and their composition freeze-in at 150 °C and that these do not change for the 
evaluation of thermal conductivity at the temperatures 400, 500, and 532 °C. Calculations are compared 
between accounting and ignoring contributions from grain boundary (GB) phase scattering. 

As can be seen in Figure 40, the calculation including the approximate effect of grain boundary phase 
scattering is close to the experimentally measured values. Excluding the effect of grain boundary phase 
scattering slightly overestimates the thermal conductivity. Experimental data is from [2008ASM].

The  TCS Al-based Alloy Database (TCAL) is used in this example. A valid license for  version 7 
(TCAL7) or newer is required to run the example.  

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File  Information
 l Folder: Property Models>General
 l File name: PM_G_10_Freeze_In_Thermal_Conductivity.tcu
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Figure 40: Comparing the freeze-in temperature for the 7075_T6 alloy with and without grain boundary (GB) 
scattering included in the calculations.  

Reference
[2008ASM] ASM Handbook Committee, ASM Handbook Volume 15: Casting. ASM International, p. 468-
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PM_G_11: Freeze-in Electrical Resistivity
The example uses the Property Model Calculator and the Equilibrium with Freeze-in Temperature 
Property Model to compare the use of the model for electrical resistivity with and without grain 
boundary (GB) scattering being included in the calculation. 

The TCS Al-based Alloy Database (TCAL) is used to evaluate a 4032-O alloy (Al-0.9Cu-1.0Mg-0.9Ni-12.2Si) 
mass%. The "O" in the alloy name means that the Al alloy has been heat-treated at a typical 
temperature of 350 °C. The measurement of electric resistivity is usually performed at room 
temperature.

The electrical resistivity due to grain boundary phase scattering is approximated as a scattering constant 
times the total volume fraction of the grain boundary phases.

The calculation set up assumes that the alloy reaches equilibrium at the "O" heat-treated temperature, 
i.e. that the amounts of phases and their composition freeze-in at 350 °C and that these do not change 
for the evaluation of electrical resistivity at the room temperature. Calculations are compared between 
accounting and ignoring contributions from grain boundary (GB) scattering. 

As can be seen from Figure 41, the calculated electrical resistivity at room  temperature, including grain 
boundary phase scattering, is very close to the experimentally measured value (4.3E-8) for the alloy. 
Excluding the grain boundary phase scattering somewhat underestimates the electrical resistivity for the 
alloy. Experimental data is from [1993Dav]. 

The  TCS Al-based Alloy Database (TCAL) is used in this example. A valid license for  version 7 
(TCAL7) or newer is required to run the example.  

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Property Models>General
 l File name: PM_G_11_Freeze_In_Electric_Conductivity.tcu
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Figure 41: Comparing the freeze-in temperature for the 4032-O alloy with and without grain boundary (GB) 
scattering included in the calculations.  

Reference
[1993Dav] J.R. Davis, ASM Specialty Handbook: Aluminum and Aluminum Alloys, 1993, ASM 

International. Pages: 784. ISBN: 978-0-87170-496-2.
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PM_G_12: Solidus and Liquidus Batch Calculation
The example uses the Property Model Calculator and the Liquidus and Solidus Temperature Property 
Model to demonstrate the use of the Batch calculation type. 

The   thermodynamic demonstration steel database (FEDEMO) is used along with a randomized set of 
experimental data points that are shown on the Configuration window in a table. The data showing in 
this example is imported from a data file prepared with specific data entry requirements. 

A variety of compositions for an Fe-Cr-Mn-Ni-C alloy is used for the calculations; these compositions are 
also taken from the same data file. When the heading includes Exp, then these columns are considered 
experimental data by Thermo-Calc, where in this example it is the columns titled Exp Liq temp C and 
Exp Sol temp C. This experimental data can then be plotted  as a function of the calculated 
solidus/liquidus temperature and compared on the plot using a Cross plot mode, which is selected on 
the Plot Renderer. The limits are shown using the setting RMS (root mean square). 

The experimental data entered into the batch data file is unitless even though the actual 
experimental data unit is Celsius (as written in the header text). In order for the plot and 
calculations to match, Celsius is chosen as the temperature unit when defining the 
Solidus/Liquidus Property Model and all the axes manually scaled to the same limits (1360 
→ 1520).  

This example is included as a Property Model tutorial on our website and as part of the 
Property Model Calculator playlist on our YouTube channel. 

Open the example project file and click Perform Tree to generate the plots associated with it. 
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Project File  Information
 l Folder: Property Models>General
 l File name: PM_G_12_Solidus_and_Liquidus_Batch_Calculation.tcu
 l There is also a .csv file with the same name available in this folder that is used with this 

example. You can navigate to use it as a template for other data files or just to see its format.

Figure 42: A comparison of experimental liquidus and solidus data using the Cross plot mode with a Batch 
calculation. A root mean square (RMS) setting shows the distribution of the data points. 

Thermo-Calc General Property Model Examples Collection ǀ 64 of 206

www.thermocalc.com

https://www.thermocalc.com/


PM_G_13: Ti Alloy Design for Additive Manufacturing
This in-depth example, which is showcased on our website, uses the Property Model Calculator to find 
the optimal composition for a titanium-based alloy to be used for additive manufacturing applications.

Additive manufacturing provides new opportunities to fabricate complex parts. However, traditional 
alloys may not be readily printable using techniques such as laser powder bed fusion. As such, the 
development of new alloys may be necessary to fully realize the benefits of additive manufacturing 
technologies.

In this example, inspired by the work of Ackers et al. [2021Ack], batch calculations within the Property 
Model Calculator are used to identify candidate titanium alloy chemistries for biomedical implant 
applications using the thermodynamic TCS Ti/TiAl-based Alloys Database (TCTI). To optimize printability 
and material weight, the liquidus temperature, solidus temperature, and density of 2000 randomized 
titanium alloy chemistries from the Ti-Nb-Zr-Sn-Ta-Fe-Mo system are calculated. An estimate of alloy 
cost is also made for each alloy. Taken together, this methodology can be used to identify compositions 
of interest and accelerate material development activities.

Figure 43: Cost estimate histogram for 2000 randomized chemistries from the Ti-Nb-Zr-Sn-Ta-Fe-Mo system.  
The cost estimate was calculated using a user-defined function in the Property Model Calculator.

Project File Information
 l Folder: Property Models>General
 l File name: PM_G_13_Ti_Alloy_Design_for_AM.tcu
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The   TCS Ti/TiAl-based Alloys Database (TCTI) is used in this example. A valid license for  
version 4 (TCTI4) or newer is required to run the example.  

The resulting plots and details related to setting up this example are available  either via the 
dedicated web page, or you can read the more in depth step-by-step documentation as a 
PDF, also available via our website. 

Reference
[2021Ack] M. A. Ackers, O. M. D. M. Messé, U. Hecht, Novel approach of alloy design and selection for 

additive manufacturing towards targeted applications. J. Alloys Compd. 866, 158965 (2021). 
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Steel Model Library Examples Collection

The General Models  are available to all users. To run calculations with  the Steel Models (as 
part of the Steel Model Library) requires a valid maintenance license plus licenses for both 
the TCFE (version 9 and newer) and MOBFE (version 4 and newer) databases. 

These examples use the Property Model Calculator, an activity available with Thermo-Calc plus 
Property Models in the Steel Model Library. 

In this section:

PM_Fe_01: Fe-Cr-C Martensite with Intercritical Annealing 68

PM_Fe_02: Fe-Mn Martensite Morphologies 71

PM_Fe_03: Fe-C-Mn Pearlite 72

PM_Fe_04: Critical Temperatures 75

PM_Fe_05: Fe-C-Mn-Si-Ni-Cr-Mo Bainite 77

PM_Fe_06: TTT Diagram for Fe-C-Mn-Si-Cr-V 79

PM_Fe_07: Hardenability Design of Steel 81

PM_Fe_08: CCT Diagram for Fe-C-Mn-Si-Cr-V 82

PM_Fe_09: Fe-C-Ni Ferrite 84
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PM_Fe_01: Fe-Cr-C Martensite with Intercritical Annealing
The example uses the Property Model Calculator with the Martensite Fractions and Martensite 
Temperatures Models to  calculate martensite fractions and martensite temperatures [martensite start 
(Ms) and 90% transformation temperature (M90)]. 

The alloy is first intercritically annealed and then quenched. Austenite composition is determined by an 
equilibrium calculation at the annealing temperature. Martensite fraction is calculated as a function of 
temperature which the alloy is quenched to. The example also shows how Cr content in the alloy 
influences Ms and M90 after intercritical annealing.

This example is included as a Property Model tutorial on our website and as part of the 
Property Model Calculator playlist on our YouTube channel. 

Open the example project file and click Perform Tree to generate the plots associated with it. 

To run calculations with the Steel Models requires a valid maintenance license plus licenses 
for both the TCFE (version 9 and newer) and MOBFE (version 4 and newer) databases. Also 
see our website to learn more about the Steel Model Library and other related examples.

Project File  Information
 l Folder: Property Models>Steel
 l File name: PM_Fe_01_Fe-Cr-C_martensite_intercritical_annealing.tcu
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Figure 44: The transformation curves plot showing Fe-Cr-C martensite with intercritical annealing.

Figure 45: Comparing Martensite start (Ms) to Martensite finish (Mf).
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Reference
[1949Har] Harris, William J, and Morris Cohen. 1949. “Stabilization Of The Austenite-Martensite 

Transformation.” Trans. AIME 180: 447–70. 
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PM_Fe_02: Fe-Mn Martensite Morphologies
The example uses the Property Model Calculator with the Martensite Temperatures Property Model to 
calculate the Ms temperatures of different types of martensites: lath, plate, and ε (HCP), compared with 
experimental ε Ms values taken from several sources.

Open the example project file and click Perform Tree to generate the plots associated with it. 

To run calculations with the Steel Models requires a valid maintenance license plus licenses 
for both the TCFE (version 9 and newer) and MOBFE (version 4 and newer) databases. Also 
see our website to learn more about the Steel Model Library and other related examples.

Project File Information
 l Folder: Property Models>Steel
 l File name: PM_Fe_02_Fe-Mn_martensite_morphologies.tcu

Figure 46: A diagram showing all the Ms temperatures of different types of martensite morphologies (lath, 
plate and epsilon (HCP) compared with experimental epsilon Ms values.
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PM_Fe_03: Fe-C-Mn Pearlite
The example uses the Property Model Calculator and with the Pearlite Property Model and shows how 
to calculate pearlite growth rate, lamellar spacing, and times of start (2% transformation) and finish 
(98% transformation) as functions of isothermal heat treating temperature in an Fe-0.69C-1.80Mn alloy 
(mass %). With maximize growth rate set as the criterion, the model gives maximal growth rate and 
minimal lamellar spacing. With optimal pearlite as the pearlite mode, the model optimizes partitioning 
of substitutional alloying element(s) (Mn in this example) according to the criterion, which realizes a 
smooth transition between ortho-pearlite at high temperature and para-pearlite at low temperature.

Open the example project file and click Perform Tree to generate the plots associated with it. 

To run calculations with the Steel Models requires a valid maintenance license plus licenses 
for both the TCFE (version 9 and newer) and MOBFE (version 4 and newer) databases. Also 
see our website to learn more about the Steel Model Library and other related examples.

Project File  Information
 l Folder: Property Models>Steel
 l File name: PM_Fe_03_Fe-C-Mn_Pearlite.tcu

Figure 47: Growth rate as a function of temperature.
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Figure 48: Lamellar spacing as a function of temperature.

Figure 49: The TTT (time-temperature-transformation) diagram showing times of start (2% transformation) 
and finish (98% transformation) as functions of isothermal heat treating temperature in an Fe-0.69C-1.80Mn 
alloy (mass %).
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Reference
[1974Raz] Razik, N.A, G.W. Lorimer, and N Ridley. 1974. “An Investigation of Manganese Partitioning 

during the Austenite-Pearlite Transformation Using Analytical Electron Microscopy.” Acta 
Metallurgica 22 (10): 1249–58.
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PM_Fe_04: Critical Temperatures
The example uses the Property Model Calculator and the Critical Transformation Temperatures Model 
to calculate the distribution of the typical phase transition temperatures for a low alloy steel (Fe-0.3Cr-
1.0Mn-0.3Mn-0.18C) when the composition is varied within the specification for the alloy. 

In the set up of the example, the Critical Transformation Temperatures model is used with a Property 
Model Calculator Uncertainty calculation to plot a histogram showing the distribution of A1- and A3-
temperatures (Figure 50). As a comparison,  an Equilibrium Calculator, One axis calculation results in a 
property diagram showing the phase transitions for the nominal composition (Figure 51). 

The phase transition temperatures are defined as:

 l Liquidus: First austenite or ferrite transformation from the liquid
 l Solidus: Liquid fully transformed to solid
 l A0: Magnetic transition temperature (Curie temperature) of cementite. The cementite is 

paramagnetic above A0 and ferromagnetic below
 l A1: Austenite (FCC_A1) transforms to ferrite (BCC_A2) + carbide (cementite or graphite or 

M23C6)
 l A2: Magnetic transition temperature (Curie temperature) of ferrite (BCC_A2). Paramagnetic 

above A2 and ferromagnetic below
 l A3: Austenite (FCC_A1) transforms to ferrite (BCC_A2)

Open the example project file and click Perform Tree to generate the plots associated with it. 

The FEDEMO: Iron Demo Database  is used and this example is available to all 
users. However, in general a license is required to run the Steel Models.

Project File  Information
 l Folder: Property Models>Steel
 l File name: PM_Fe_04_Critical_Temperatures.tcu
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Figure 50: The distribution of the A1 and A3 phase transition temperatures for a low alloyed steel (Fe-0.3Cr-
1.0Mn-0.3Mn-0.18C) when the composition is varied within the specification. This plot uses the Critical 
Transformation Temperatures model with the Property Model Calculator.

Figure 51: This plot uses an Equilibrium Calculator to show an alternate visualization of the phase transitions 
in a property diagram for the nominal composition. 
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PM_Fe_05: Fe-C-Mn-Si-Ni-Cr-Mo Bainite
The example uses the Property Model Calculator and the Bainite Steel Model to calculate a Time-
Temperature-Transformation (TTT) diagram for an Fe-0.97C-0.72Mn-0.32Si-1.54Ni-0.8Cr-0.26Mo alloy. 
The result is compared to experimental results from [1948Jaf]. Other elements with low amount in the 
experimental alloy are omitted for the calculation.

Considered elements: Fe, C, Mn, Si, Cr, Ni, and Mo. Other elements in the system are 
neglected for bainite by mass percent.

A Property Model Calculator is used with a One axis calculation and the TTT mode selected on the Plot 
Renderer to plot the TTT diagram.

Open the example project file and click Perform Tree to generate the plots associated with it. 

To run calculations with the Steel Models requires a valid maintenance license plus licenses 
for both the TCFE (version 9 and newer) and MOBFE (version 4 and newer) databases. Also 
see our website to learn more about the Steel Model Library and other related examples.

When you run (Perform) this example, it takes a few minutes for the calculations to 
complete.

Project File Information
 l Folder: Property Models>Steel
 l File name: PM_Fe_05_Fe-C-Mn-Si-Ni-Cr-Mo_Bainite.tcu
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Figure 52: The bainite TTT diagram for an  Fe-0.97C-0.72Mn-0.32Si-1.54Ni-0.8Cr-0.26Mo alloy.

Reference
[1948Jaf]  L. D. Jaffe, Anisothermal formation of bainite and proeutectoid constituents in steels, Trans. 

AIME, vol. 176, pp. 343–383 (1948).
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PM_Fe_06: TTT Diagram for Fe-C-Mn-Si-Cr-V
The example uses the Property Model Calculator and the TTT Diagram Property Model to calculate a  
Time-Temperature-Transformation (TTT) diagram for an Fe-C-Mn-Si-Cr-V alloy (Steel 42CrV6). The 
calculation is compared to an experimental TTT diagram for the same steel (with some other impurities) 
from data in [1958Wev].  

A One axis calculation is selected on the Property Model Calculator and then the TTT mode selected on 
the Plot Renderer in order to plot the final TTT diagram shown in the figure below.

Open the example project file and click Perform Tree to generate the plots associated with it. 

To run calculations with the Steel Models requires a valid maintenance license plus licenses 
for both the TCFE (version 9 and newer) and MOBFE (version 4 and newer) databases. Also 
see our website to learn more about the Steel Model Library and other related examples.

When you run (Perform) this example, it can take over two hours to complete the 
calculations. 

Project File Information
 l Folder: Property Models>Steel
 l File name: PM_Fe_06_Fe-C-Mn-Si-Cr-V_TTT.tcu

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.

Steel Model Library Examples Collection ǀ 79 of 206

www.thermocalc.com

https://thermocalc.com/products/add-on-modules/steel-model-library/
https://www.thermocalc.com/training/video-tutorials/
https://www.youtube.com/channel/UCLTh3apGItuaVK69mrwcpJg/featured
https://www.thermocalc.com/


Figure 53: The TTT diagram for an  Fe-C-Mn-Si-Cr-V alloy comparing the calculation with experimental data 
from [1958Wev].

Reference
[1958Wev] F. Wever, A. Rose, Atlas zur Wärmebehandlung der Stähle: 1954/56/58 (Verlag Stahleisen, 

Düsseldorf, 1958), p. II-112.
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PM_Fe_07: Hardenability Design of Steel
This application example, which is showcased on our website, shows how the Steel Model Library in 
Thermo-Calc can be used to find the optimal compositions for an Fe–Mn–C steel to achieve high 
hardenability for the purpose of strength.

This example focuses on the hardenability design of steel using the Steel Model Library in Thermo-Calc. 
It shows how to find the optimal compositions for Fe-Mn-C steel to achieve high hardenability for the 
purpose of strength. Hardenability refers to the ability of steel to form martensite on quenching. It is a 
measure of the capacity of a steel to be hardened in depth when quenched from its austenitizing 
temperature. Among various factors, composition is one of the most important factors which has great 
influence on the hardenability of the steel. In this example, we use the Steel Model Library to 
investigate the possible composition ranges of Fe–C–Mn alloys to reach a fully martensitic 
microstructure.

To fulfil the requirement, room temperature martensite fraction should be large and the amount of 
retained austenite should be small. Meanwhile, other products of austenite decomposition should be 
avoided during continuous cooling. Such transformation products can be suppressed by fast quenching, 
yet the cooling rate is usually limited by the capacity of facilities or other problems such as cracking. 
Therefore, for hardenability purposes, it is desirable to achieve a fully martensitic structure with a 
relatively low cooling rate. This is done by promoting martensite formation while retarding other 
transformations through adjusting the steel composition.

Open the example project file and click Perform Tree to generate the plots associated with it. 

Although this example uses the FEDEMO and MFEDEMO databases, running the calculation 
requires a license for Thermo-Calc 2022b or newer and for the Steel Model Library.

Project File Information
 l Folder: Property Models>Steel
 l File name: PM_Fe_07_Hardenability_Design_of_Steel.tcu

The resulting plots and details related to setting up this example are available  either via the 
dedicated web page, or you can read the more in depth step-by-step documentation as a 
PDF, also available via our website. 
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PM_Fe_08: CCT Diagram for Fe-C-Mn-Si-Cr-V
The example uses the Property Model Calculator and the CCT Diagram Property Model to calculate a 
Continuous-Cooling-Transformation (CCT) diagram for an Fe-C-Mn-Si-Cr-V alloy (Steel 42CrV6). The 
calculation is compared to an experimental CCT diagram for the same steel (with some other impurities) 
from data in [1958Wev]. 

A One axis calculation is selected on the Property Model Calculator and then the CCT mode selected on 
the Plot Renderer in order to plot the final CCT diagram shown in the figure below.

Open the example project file and click Perform Tree to generate the plots associated with it. 

To run calculations with the Steel Models requires a valid maintenance license plus licenses 
for both the TCFE (version 9 and newer) and MOBFE (version 4 and newer) databases. Also 
see our website to learn more about the Steel Model Library and other related examples.

When you run (Perform) this example, it takes several hours to complete the calculations. 

Project File Information
 l Folder: Property Models>Steel
 l File name: PM_Fe_08_Fe-C-Mn-Si-Cr-V_CCT.tcu
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Figure 54: The CCT diagram for an  Fe-C-Mn-Si-Cr-V alloy comparing the calculation with experimental data 
from [1958Wev].

Reference
[1958Wev] F. Wever, A. Rose, Atlas zur Wärmebehandlung der Stähle: 1954/56/58 (Verlag Stahleisen, 

Düsseldorf, 1958), p. II-112.
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PM_Fe_09: Fe-C-Ni Ferrite
The example uses the Property Model Calculator and the Ferrite Property Model to calculate the ferrite 
fraction parabolic rate constant and ferrite start time for an Fe-0.12C-3.28Ni alloy.

Two growth modes—Orthoequilibrum (OE) and Paraequilibrium (PE)—are used with a One axis 
calculation type to compare the ferrite molar fraction and to determine the ferrite start time for each 
growth mode.

The experimental data for the ferrite start is taken from [1966Aar]. For the parabolic rate constant 
experimental data is from [1981Bra].

To run calculations with the Steel Models requires a valid maintenance license plus licenses 
for both the TCFE (version 9 and newer) and MOBFE (version 4 and newer) databases. Also 
see our website to learn more about the Steel Model Library and other related examples.

Open the example project file and click Perform Tree to generate the plots associated with it. 

When you run (Perform) this example, it takes a few minutes for the calculations to 
complete.

Project File Information
 l Folder: Property Models>Steel
 l File name: PM_Fe_09_Fe-C-Ni_Ferrite.tcu
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Figure 55: Ferrite fraction at the end of the transformation, under orthoequilibrium (OE) or paraequilibrium 
(PE).

Figure 56: Parabolic rate constant. Experimental data is from [1981Bra].
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Figure 57: Ferrite start time. This plot also uses the TTT mode. Experimental data from [1966Aar].

References
[1966Aar] H. I. Aaronson, H. A. Domian, Partition of alloying elements between austenite and 

proeutectoid ferrite or bainite. AIME MET SOC TRANS. 236, 781–796 (1966).

[1981Bra] J. R. Bradley, H. I. Aaronson, Growth kinetics of grain boundary ferrite allotriomorphs in Fe-C-
X alloys. Metall. Trans. A. 12, 1729–1741 (1981).
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Nickel Model Library Examples Collection

The General Models  are available to all users. To run calculations with the Nickel Models 
(as part of the Nickel Model Library) requires a valid maintenance license plus licenses for 
both the TCNI (version 11 and newer) and MOBNI (version 5 and newer) databases. 

These examples use the Property Model Calculator, an activity available with Thermo-Calc plus the 
available Property Models in the Nickel Model Library. 

In this section:

PM_Ni_01: Lattice Parameter of γ/γ' 88

PM_Ni_02: Antiphase Boundary Energy of γ' 90
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PM_Ni_01: Lattice Parameter of γ/γ'
The example uses the Property Model Calculator with the Equilibrium with Freeze-in Temperature - Ni 
Model.

Open the example project file and click Perform Tree to generate the plots associated with it. 

To run calculations with the Nickel Models requires a valid maintenance license plus 
licenses for both the TCNI (version 11 and newer) and MOBNI (version 5 and newer) 
databases. Also see our website to learn more about the Nickel Model Library.

Project File Information
 l Folder: Property Models>Nickel
 l File name: PM_Ni_01_Lattice_Parameter_of_Gamma_Gamma_Prime.tcu

The lattice parameters are measured experimentally for γ/γ' in a 
Ni0.6Mo0.92Ta12.5Al1.83Ti10.5Cr3.3W alloy.

The thermodynamically stable equilibrium will not be reached for this alloy during the experimental 
heat treatment; only the phases γ and γ' are noticed in the experiment. The γ/γ' microstructure is in this 
calculation example assumed to freeze-in at 1000 °C where the phase compositions do not change 
during cooling to room temperature.

Some of the key settings to note in this example: 

 l The Subset of phases is selected as Gamma and gamma-prime only to match the experimental 
observations. 

 l The Freeze-in temperature is set to 1000 °C. 
 l A One axis calculation is used where the evaluation temperatures are within a range of 20 °C to 

1000 °C.

Nickel Model Library Examples Collection ǀ 88 of 206

www.thermocalc.com

https://thermocalc.com/products/add-on-modules/nickel-model-library/
https://www.thermocalc.com/


Figure 58: The lattice parameters for γ and γ' are plotted against experimental data from [1985Nat].

Reference
[1985Nat] M. V. Nathal, R. A. Mackay, R. G. Garlick, Temperature dependence of γ-γ’ lattice mismatch in 

Nickel-base superalloys. Mater. Sci. Eng. 75, 195–205 (1985).
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PM_Ni_02: Antiphase Boundary Energy of γ'
The example uses the Property Model Calculator with the Antiphase Boundary Energy - Ni Model.

Open the example project file and click Perform Tree to generate the plots associated with it. 

To run calculations with the Nickel Models requires a valid maintenance license plus 
licenses for both the TCNI (version 11 and newer) and MOBNI (version 5 and newer) 
databases. Also see our website to learn more about the Nickel Model Library.

Project File Information
 l Folder: Property Models>Nickel
 l File name: PM_Ni_02_Antiphase_Boundary_Energy_of_Gamma_Prime.tcu

This example shows a calculation of the antiphase boundary energy for an Al75Ni alloy at room 
temperature with increasing amounts of Ti. The plot shows the (111) APB energy in Ni3Al1−xTix over the 
whole compositional range together with first-principle calculations from Chandran and Sondhi 
[2011Cha] and Vamsi and Karthikeyani [2012Vam] evaluated at 0 K. The trend with increasing 111 APBE 
with an increasing amount of Ti is predicted by all calculations but the absolute values between the first 
principle calculations are quite different.

Some of the key settings to note in this example: 

 l γ' is the only stable phase for these compositions. FCC_L12 is therefore selected as the only 
phase  in the System Definer.

 l The Freeze-in temperature and evaluation temperature are both set at 20 °C with the Subset of 
phases for All phases. 

 l A One axis calculation is used with Mole percent Ti between 0 and 25 in 20 steps.
 l The plotting quantity APBE for 111 plane (1/2) is then compared with the first principle 

calculations.
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Figure 59: Composition of Ti (mole %) compared to antiphase boundary surface energy for 111 plane and 
experimental data from [2011Cha; 2012Vam].

References
[2011Cha] M. Chandran, S. K. Sondhi, First-principle calculation of APB energy in Ni-based binary and 

ternary alloys. Model. Simul. Mater. Sci. Eng. 19, 025008 (2011).

[2012Vam] K. V. Vamsi, S. Karthikeyan, Effect of Off-Stoichiometry and Ternary Additions on Planar Fault 
Energies in Ni3Al, in Superalloys 2012 (John Wiley & Sons, Inc., Hoboken, NJ, USA, 2012; pp. 521–
530.
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Process Metallurgy Module Examples Collection

The Process Metallurgy Module requires both a valid Maintenance and Support 
Subscription (M&SS) and a license for the TCS Metal Oxide Solutions Database (TCOX8 or 
newer). 

All users can test the Process Metallurgy Module with the included OXDEMO database, 
which is limited to these elements: Al, C, Ca, Fe, O, S, and Si. For more information about 
this and other products visit our website.

In this section:

PMET_01: Basic Oxygen Furnace (BOF) 93

PMET_02: Desulphurization in a Ladle Furnace (LF) 94
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PMET_01: Basic Oxygen Furnace (BOF)
The example uses the Process Metallurgy Calculator to demonstrate a simplified steelmaking process in 
a Basic Oxygen Furnace (BOF). 

This application example in its various forms is showcased on our website. There are two application 
examples (one equilibrium, one kinetic) showing how the Process Metallurgy Module can be used to 
calculate the BOF process. 

This basic example uses equilibrium calculations to gain a general understanding of your BOF process 
and help you determine optimal operation conditions and predict and optimize costs of raw materials 
and recycling. The other set of examples gives detailed instructions on how to simulate the kinetics of 
the BOF process using the kinetic process simulation (see PMET_04: Basic Oxygen Furnace 
(BOF) Kinetics).

Project File Information

Open the example project file(s) from Thermo-Calc Help  → Example Files  → Process Metallurgy → 
PMET_01_Basic_Oxygen_Furnace.tcu. 

Choose a, b, or c versions of the example based on your license.

 l PMET_01a_Basic_Oxygen_Furnace is included in a regular Thermo-Calc installation as well as 
the free Educational version of Thermo-Calc. This is a highly simplified example and uses the 
OXDEMO database, and only considers the elements Fe, C, and O.

 l PMET_01b_Basic_Oxygen_Furnace is also a simplified calculation but uses the OXDEMO 
database. It requires a full license of Thermo-Calc 2021b and newer.

 l PMET_01c_Basic_Oxygen_Furnace requires the TCOX11 database and newer and a full license 
of Thermo-Calc 2021b and newer. 

The resulting plots and details related to setting up this example are available  either via the 
dedicated web page, or you can read the more in depth step-by-step documentation as a 
PDF, also available via our website. 
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PMET_02: Desulphurization in a Ladle Furnace (LF)
The example, which is also showcased on our website, uses the Process Metallurgy Calculator to 
demonstrate the use of a Ladle Furnace (LF) with the Process Metallurgy Module. 

The ladle furnace fulfils many purposes in the steelmaking process. Desulphurization, which we will 
focus on in this example, is merely one of them.

Desulphurization is usually performed by transferring S that is dissolved in the liquid metal to a CaO-rich 
slag phase. For this process to be successful, two conditions need to be fulfilled:

 1. The slag must be fully liquid (liquid fraction > 0.9). This is required for kinetic reasons. The slag 
phase must be fluid so that it can emulsify with the liquid steel and form a large surface area 
where the reaction between steel and slag can take place.

 2. The slag must take up a large amount of S from the liquid steel (have a “high sulphur capacity”) 
so that a significant amount of sulphur will move from the liquid steel to the slag phase.

It is difficult to decrease the S content in the liquid steel during steelmaking in a basic oxygen converter 
(BOF) or an electric arc furnace (EAF) because conditions are predominantly very oxidizing. 
Desulphurization is therefore usually performed in a subsequent step, during steel refining in a ladle 
furnace or a vacuum degasser after the steel has been fully killed by a suitable deoxidizing agent and the 
oxygen activity is low.

The following example explores these two conditions for an equilibrium between liquid steel and slag in 
a ladle furnace, trying to find good slag compositions.

Project Files

Open the example project  files from Thermo-Calc Help  → Example Files  → Process Metallurgy  → 
PMET_02a_Ladle_Furnace.tcu or PMET_02b_Desulphurization_in_Ladle_Furnace.tcu. 

Choose a or b versions of the example  based on your license

 l PMET_02a_Ladle_Furnace.tcu can be run with OXDEMO database but requires the full license 
for Thermo-Calc 2021b and newer.

 l PMET_02b_Desulphurization_in_Ladle_Furnace.tcu requires the TCOX11 database and a full 
license for Thermo-Calc 2021b and newer.
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The resulting plots and details related to setting up this example are available  either via the 
dedicated web page, or you can read the more in depth step-by-step documentation as a 
PDF, also available via our website. 
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PMET_03: Argon Oxygen Decarburization (AOD)
The Argon Oxygen Decarburization (AOD) process is a converter process applied in stainless steel 
making. In this process the oxidation of chromium in the steel melt needs to be prevented while carbon 
is oxidized. This is achieved by reducing the oxygen partial pressure by having a high Ar-content in the 
blowing gas. It is a highly exothermic process that requires adiabatic modeling. In this example the 
conversion of carbon-rich steel scrap is modeled together with additions of Ferronickel and 
Ferrochrome to a stainless steel. The example uses the Process Metallurgy Calculator. 

Visit the website Application Examples→Process Metallurgy page for more background 
information as well as more in depth analyses of this and other examples. Also visit the 
Process Metallurgy Module page to access resources such as training videos, presentations, 
publications, webinars, and much more. 

Open the example project file and click Perform Tree to generate the plots associated with it. 

When you run (Perform) this example, it takes a few minutes for the calculations to 
complete.

Project File Information

Open the example project  file from Thermo-Calc Help  → Example Files  → Process Metallurgy  → 
PMET_03_Argon_Oxygen_Decarburization.tcu.

This example does NOT require a license to run the simulation. It works with both the TCS 
Metal Oxide Solutions Database (TCOX versions 8 and newer) as well as the free OXDEMO 
database. 

Background Description
The AOD-process is characterized by an initially high O2-content of the blowing gas, which is gradually 
replaced by Ar. The maximum temperature of the process is typically around 1720 °C. A grid plot of an 
adiabatic calculation is well suited to model the required simultaneous change of amount of gas and its 
composition during this process. The black line in the plot above indicates a possible process control 
path that finally leads to suitable alloy composition close to a X5CrNi 18-10 stainless steel.
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In principle, this plot could be used to control the blowing gas flow in a plant process. However, note 
that the simulation only considers a global gas phase, i.e. additional gas is added but never removed. 
This means that the given gas phase composition is an average one and not identical to the composition 
of the gas flowing in at each point in time. Additionally there is a certain impact on the resulting 
equilibria from the fact that all gas remains in the system and is not removed. 
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Slag Basicity

Figure 60: The Slag Basicity plot shows the basicity of the slag (which is a measure for the sulphur capacity of 
the slag). The process achieves a final basicity of 1.74 which is typical for an AOD-process. The black line in the 
plot indicates a possible process control path that finally leads to suitable alloy composition close to a X5CrNi 
18-10 stainless steel.
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S Content in Steel

Figure 61: In the S Content in Steel plot, the sulphur content in the steel melt is slightly reduced during the 
process from 0.056% in the initial steel scrap to finally ca. 0.035%. The black line in the plot indicates a 
possible process control path that finally leads to suitable alloy composition close to a X5CrNi 18-10 stainless 
steel.
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Cr Content in Slag

Figure 62: In the Cr Content in Slag plot, the Cr2O3-content in the slag reaches at the end of the process ca. 26 
wt-%. This is typical for the AOD-process and requires an additional Cr-recovery step after the conversion to 
reduce the loss of chromium.  The black line in the plot indicates a possible process control path that finally 
leads to suitable alloy composition close to a X5CrNi 18-10 stainless steel.
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Amount of Slag

Figure 63: In the Amount of Slag plot, you can see that the process generates about 15 tons of slag in the 
total. The black line in the plot indicates a possible process control path that finally leads to suitable alloy 
composition close to a X5CrNi 18-10 stainless steel.
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Liquid Slag Fraction

Figure 64: In the Liquid Slag Fraction plot, you can see that towards the end of the process the slag is 
calculated to be mostly liquid. The black line in the plot indicates a possible process control path that finally 
leads to suitable alloy composition close to a X5CrNi 18-10 stainless steel.
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PMET_04: Basic Oxygen Furnace (BOF) Kinetics
The example uses the Process Metallurgy Calculator to demonstrate the steelmaking process in a Basic 
Oxygen Furnace (BOF). 

This application example in its various forms is showcased on our website. There are two application 
examples (one equilibrium, one kinetic) showing how the Process Metallurgy Module can be used to 
calculate the BOF process. 

This example simulates the kinetics of the BOF process, whereas the other only considers equilibrium. 
For information about the equilibrium examples, see PMET_01: Basic Oxygen Furnace (BOF).

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information

Open the example project file(s) from Thermo-Calc Help  → Example Files  → Process Metallurgy →. 

Choose a, b, or c versions of the example based on your license. 

 l PMET_04a_Basic_Oxygen_Furnace_Kinetics is included in a regular Thermo-Calc installation as 
well as the free Educational version of Thermo-Calc.  This  only considers the elements Fe, C, and 
O.

 l PMET_04b_Basic_Oxygen_Furnace_Kinetics needs a full license of Thermo-Calc 2021b or newer, 
but uses the free OXDEMO database. It considers the elements Fe, C, O, Ca, Al, Si, and S.

 l PMET_04c_Basic_Oxygen_Furnace_Kinetics requires both a full license of Thermo-Calc 2021b or 
newer and a license for the TCOX11 database and newer. This simulation corresponds pretty 
much to a real BOF process with the elements Fe, Mn, C, O, Ca, Al, Mg, Si, S, and P considered.  

The resulting plots and details related to setting up this example are available  either via the 
dedicated web page, or you can read the more in depth step-by-step documentation as a 
PDF, also available via our website. 
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PMET_05: Lab Scale Ladle Furnace (LF) Kinetics
Using the Process Metallurgy Calculator and the Process simulation branch, this example is based on 
the publication by Piva et al [2017Piv] where a lab scale sample of pure iron is first deoxidized with Si-
Mn and then a synthetic top slag is added to the steel. Generally, by using the project file and the 
information below, you can get an idea about how to set up a ladle furnace simulation using the Process 
Metallurgy Module.

Visit the website Application Examples→Process Metallurgy page for more background 
information as well as more in depth analyses of this and other examples. Also visit the 
Process Metallurgy Module page to access resources such as training videos, presentations, 
publications, webinars, and much more. 

Open the example project file and click Perform Tree to generate the plots associated with it. 

When you run (Perform) this example, it takes a few minutes for the calculations to 
complete.

Project File Information

To open this project file, from the Thermo-Calc menu, go to Help  → Example Files  → Process 
Metallurgy  →  PMET_05_Lab_Scale_Ladle_Furnace_Kinetics.tcu. 

This example requires a license to run the simulation. It works with TCS Metal Oxide 
Solutions Database (TCOX) versions 8 and newer. 

About the Plot Results
Many different aspects of the reactions taking place in the LF can be plotted and analyzed. After you run 
the project file and obtain the plots, you can experiment by adjusting the settings on each Plot Renderer 
to see what happens in each case. There is more analysis about this and other examples available at the 
links to our website.

For an example of a more realistic industry scale, see PMET_06: Ladle Furnace (LF) Kinetics.
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Setting Up the LF Process Simulation
In the paper by Piva et al. [2017], it is experimentally investigated how the steel and inclusion 
composition changes in function of time as the Si-Mn killed steel reacts with the slag. This experiment 
can serve as a model for the production of SiMn killed steel with subsequent top-slag deoxidation.

Figure 65: Diagram of the experiment performed by Piva et al. [2017]. The sequence as described in the text is: 
(1) liquid Fe with dissolved oxygen; (2) FeMn and SiMn added to deoxidize Fe; (3) top slag added after 360s; 
and (4) gradual reaction between steel, slag and inclusions.

According to the publication the following reaction sequence is expected as shown in the diagram:

 1. The deoxidizing agents dissolve and react with the oxygen in the steel forming oxide inclusions, 
thereby reducing the amount of dissolved oxygen (“killing” the steel). The kinetics are fast, and it 
can be assumed that the reaction proceeds to thermodynamic equilibrium.

 2. The inclusions formed in (1) slowly start to float upwards and are removed out of the liquid steel.

 3. After adding the slag (360 s after killing the steel in (1) the liquid steel starts reacting with the 
slag. 

 4. The inclusions continue to float up out of the liquid steel and combine with the slag. 

According to the authors the most important reaction that takes place is the dissolution of Al out 
of the slag and its transferal into the liquid steel, where it reacts with the inclusions and changes 
the chemistry.

In this example only the last reaction is simulated after adding the slag. The kinetic 
parameters, compositions of all materials and process schedule are all taken from the 
publication.
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Results and Experimental Analysis
The plots below compare the Al content in the liquid steel with the experimentally determined amount. 
The bottom plot shows how the Al2O3 from the slag phase is gradually reduced to metallic Al that 
dissolves in the liquid steel. 

In this example, only part of the Al in the liquid steel is dissolved as metallic Al. With the 
Process Metallurgy Module, it is possible to plot both dissolved Al and also total Al.  

In the steel industry this fraction of Al in the liquid steel is often termed dissolved Al. The rest of the Al 
reacts with the oxygen in the liquid steel and forms oxide inclusions. The amount of dissolved Al plus the 
Al  bound up in oxide inclusions is often termed total Al. The difference between total Al minus dissolved 
Al is an important measure for the steel cleanness. 

Total Al is what was measured by Piva et al. [2017] and their experimental data are compared to the 
calculated values below.
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Figure 66: Total Al in the steel compared with experimental data (blue/top curve). If only the fraction of 
dissolved Al is to be plotted (red/bottom curve), this is done by selecting “Composition of phase group” and 
“Liquid metal”. The bottom figure is available with the example. 

Immediately after killing the steel with SiMn and FeMn, the liquid steel contains liquid Si-Mn-oxide 
inclusions only. As the liquid steel picks up Al from the slag phase in function of time, the inclusions get 
richer and richer in Al. This experimentally verified change in inclusion chemistry is well reproduced by 
this simulation.
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Figure 67: Calculated composition of non-metallic inclusions in function of processing time compared to 
experimental data [2017Piv].

It is also possible to calculate the amount and type of inclusions present in the liquid steel. At the 
beginning of the process all the inclusions are liquid oxides. After about 20 minutes processing time, the 
first solid corundum (Al2O3) inclusions start appearing. After 25 minutes almost no liquid inclusions 
remain. The total amount of inclusions decreases in function of time as they float up out of the liquid 
steel and combine with the slag floating on top of the steel.
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Figure 68: Amount of inclusions in the liquid steel in function of processing time. The total amount of 
inclusions (red line) and liquid oxide inclusions (blue line) are plotted. Up to about 20 min all inclusions are 
liquid oxide type, then they are replaced by solid corundum (Al2O3) inclusions. Experimental data from 
[2017Piv].

Reference
[2017Piv] Piva, S. P. T., Kumar, D. & Pistorius, P. C. "Modeling Manganese Silicate Inclusion Composition 

Changes during Ladle Treatment Using FactSage Macros," Metall. Mater. Trans. B 48, 37–45 (2017).
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PMET_06: Ladle Furnace (LF) Kinetics
This in-depth example, which is also showcased on our website, uses the Process Metallurgy Calculator 
to show how to set up a full kinetic simulation of steel refining in a ladle furnace using the Process 
Metallurgy Module in Thermo-Calc. The Process Metallurgy Module uses the Effective Equilibrium 
Reaction Zone model (EERZ) to simulate the kinetics of the process. In this example, a full kinetic 
simulation of the LF refining process  is set up using the Process Metallurgy Module. 

For a simpler process  that describes a lab-scale ladle furnace process, see PMET_05: Lab 
Scale Ladle Furnace (LF) Kinetics.

The nodes in the Project window for this example. The Process Metallurgy Calculator is renamed to EERZ 
model. If you click this node the Configuration window opens, which is where all the settings for the process 
simulation are located. This advanced example also uses three Experimental Data Reader nodes to read the 
experimental data that is included in the simulation results. After setting up the system and accessing the 
experimental data, you then add Plot Renderers to the calculator to generate the output in the Results 
window. 

 Project File Information

To open this project file, from the Thermo-Calc menu, go to Help  → Example Files  → Process 
Metallurgy  →  PMET_06_Ladle_Furnace_Kinetics.tcu. 

This example requires the database TCOX10 or newer, a full license of Thermo-Calc 2020b 
or newer, plus a license for the Process Metallurgy Module.

Process Metallurgy Module Examples Collection ǀ 110 of 206

www.thermocalc.com

https://thermocalc.com/showcase/application-examples/kinetics-of-steel-refining-in-a-ladle-furnace/
https://www.thermocalc.com/


The resulting plots and details related to setting up this example are available  either via the 
dedicated web page, or you can read the more in depth step-by-step documentation as a 
PDF, also available via our website. 

Background Overview
After steelmaking, which is mostly performed in a basic oxygen furnace (BOF) or electric arc furnace 
(EAF), the steel is usually tapped into a ladle where certain additions are made (deoxidation agents, slag 
formers, certain alloying elements) and then transferred to the ladle furnace (LF). The LF fulfils many 
purposes in the steel refining process, the most important being:

 l Temperature control / heating by an electrical arc.
 l Mixing by Ar or N2 bubbling through porous plugs in the bottom of the ladle to achieve 

homogeneous temperature and composition throughout the ladle.
 l Removal of unwanted non-metallic phases / inclusions such as corundum (Al2O3), liquid oxide 

inclusions, spinel, on so on, by flotation, aided by Ar or N2 bubbling.
 l Modification / engineering of non-metallic inclusions so that they are not detrimental for the 

downstream processing and/or the final product.
 l Removal of unwanted volatile elements such as Pb, Zn, Sn, and so on. Due to their high vapor 

pressure, these elements are enriched in the rising Ar or N2 bubbles. After the gas escapes out of 
the ladle and cools, they condense, forming copious amounts of dust.

 l Removal of unwanted elements such as sulphur by liquid steel / slag reactions.
 l Lowering of the dissolved gas content. In the LF this is mainly achieved through chemical 

reactions. For direct removal of dissolved gas, vacuum degassing (VD) is usually required.
 l Alloying and trimming of the steel to achieve the exact alloy composition required by the 

specification of the steel that is to be produced.

The reactions taking place in a LF are a complex interplay between equilibrium thermodynamics that 
define the direction of chemical reactions, and kinetics that define how fast the equilibrium state is 
approached.
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PMET_07: Vacuum Oxygen Decarburization Kinetics
This application example, which is showcased on our website  and uses the Process Metallurgy 
Calculator, shows how the Process Metallurgy Module in Thermo-Calc can be used to simulate the 
Vacuum Oxygen Decarburization (VOD) process for a stainless steel.

This example, based on data of a real VOD process published by Ding et al. [2000Din], shows how to set 
up the VOD process in Thermo-Calc’s Process Metallurgy Module. Use of the following features in the 
Process Metallurgy Module are highlighted in this example:

 l Change of pressure as a function of time during the process
 l Change of reaction kinetics as a function of time during the process
 l Selection of zone where degassing is allowed

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information

Open this project file, from the Thermo-Calc menu, go to Help  → Example Files  → Process Metallurgy  
→  PMET_07_Vacuum_Oxygen_Decarburization_Kinetics.tcu. 

This example requires a license for Thermo-Calc 2021a or newer, the database TCOX10 or 
newer, and a license for the Process Metallurgy Module.

The resulting plots and details related to setting up this example are available  either via the 
dedicated web page, or you can read the more in depth step-by-step documentation as a 
PDF, also available via our website. 

Reference
[2000Din] R. Ding, B. Blanpain, P. T. Jones, P. Wollants, Modeling of the vacuum oxygen decarburization 

refining process. Metall. Mater. Trans. B. 31, 197–206 (2000).

Process Metallurgy Module Examples Collection ǀ 112 of 206

www.thermocalc.com

https://thermocalc.com/showcase/application-examples/vacuum_oxygen_decarburization_vod/
https://thermocalc.com/showcase/application-examples/vacuum_oxygen_decarburization_vod/
https://thermocalc.com/content/uploads/Application_Examples/VOD_Vacuum_Oxygen_Decarburization/simulating-vacuum-oxygen-decarburization-kinetics-using-the-process-metallurgy-module.pdf
https://thermocalc.com/content/uploads/Application_Examples/VOD_Vacuum_Oxygen_Decarburization/simulating-vacuum-oxygen-decarburization-kinetics-using-the-process-metallurgy-module.pdf
https://www.thermocalc.com/


PMET_08: Steel Deoxidation on Tapping
This application example, which is showcased on our website and uses the Process Metallurgy 
Calculator, shows a few of the ways the Process Metallurgy Module in Thermo-Calc can be used to 
investigate steel deoxidation (killing) on tapping.

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information

Open the project files, from the Thermo-Calc menu, go to Help  → Example Files  → Process Metallurgy 
 →  PMET_08_Steel_Deoxidation_on_Tapping.tcu. 

Choose a or b versions of the example based  on your license.

 l PMET_08a_Steel_Deoxidation_on_Tapping.tcu is included in a regular Thermo-Calc installation 
as well as the free Educational version of Thermo-Calc. It is a simplified version that uses the 
OXDEMO database.

 l PMET_08b_Steel_Deoxidation_on_Tapping.tcu requires a full license of Thermo-Calc version 
2021b or newer and database TCOX11 or newer.

The resulting plots and details related to setting up this example are available  either via the 
dedicated web page, or you can read the more in depth step-by-step documentation as a 
PDF, also available via our website. 

About Deoxidation or “Killing” of Steel
Deoxidation of steel, also known as killing of steel, occurs toward the end of the steelmaking process, 
but before desulphurization. After primary steelmaking, for example in a basic oxygen furnace (BOF) or 
electric arc furnace (EAF), the liquid steel contains a large amount of dissolved oxygen [O] (400 to over 
1000 ppm, see PMET_04: Basic Oxygen Furnace (BOF) Kinetics). This oxygen must be removed from the 
liquid steel for several reasons, including:

 l Desulphurization is not effective with high oxygen content in the steel (see example on 
desulphurization)

 l Continuous casting of un-killed steel is not possible and will result in “boiling” of the steel in the 
mould and massive porosity, as shown in the figure.
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The two most widely applied methods of deoxidizing or killing the steel are adding Al (Al-killed steel) to 
the steel and adding Si (Si-killed steel) to the steel. These elements readily react with oxygen to form 
oxides that precipitate within the liquid steel. This does not reduce the total amount of oxygen in the 
liquid steel; it simply transforms the dissolved oxygen into an oxide precipitate. This oxide precipitate 
then needs to be removed from the steel by flotation during secondary metallurgy in the ladle furnace 
(LF).

In this example we look at how the Process Metallurgy Module can be used to investigate these two 
widely applied methods of deoxidizing or killing the steel: adding Al (Al-killed steel) or adding Si (Si-killed 
steel). This, however, can result in the formation of damaging inclusions that cause problems during 
further processing, so we go on to look at two simple and very common processes that are used to 
transform the solid SiO2 and Al2O3 inclusions into liquid oxides so that they are less damaging.
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Diffusion Module (DICTRA) Graphical Mode Examples

Examples using up to three elements are available to all users. The other examples require 
a Diffusion Module (DICTRA) license to calculate and plot results. 

The Role of Diffusion in Materials: A Tutorial is available for download on our website. It is 
intended for engineers interested in using the Diffusion Module (DICTRA), as well as 
students learning about the role of diffusion in materials. It is designed to be useful at 
many levels, from undergraduate studies to someone with a PhD and experience in a 
related field.

These examples use the Diffusion Calculator. All examples use demonstration database packages 
included with your installation no matter what licenses you have.

In this section:

D_01: Homogenization of a Binary Fe-Ni Alloy 116

D_02: Ferrite(bcc)/Austenite(fcc) Transformation in a Binary Fe-C Alloy 117

D_03: Evolution of an Fe-Cr-Ni Diffusion Couple 119

D_04: Fe-C Moving Boundary: Austenite to Ferrite 121

D_05: γ/α/γ Diffusion Couple of Fe-Ni-Cr alloys 123

D_06: Diffusion Through a Tube Wall 128

D_07: Multiphase Carburization of an Alloy 131

D_08: Microsegregation During Solidification 134
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D_01: Homogenization of a Binary Fe-Ni Alloy
The single phase example simulates the diffusion of Fe and Ni at a temperature of 1400 K in a planar 
domain. At this temperature the material is fully austenitic, i.e. the only phase present is the so-called 
fcc (face centered cubic) phase. Initially, there is a linear variation in Ni going from 10 mass-% on the 
left-hand side to 50 mass-% on the right-hand side. 

This example is included as a Diffusion Module (DICTRA) tutorial on our website and as part 
of the  playlist on our YouTube channel. 

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Diffusion Module - DICTRA
 l File name: D_01_Diffusion_Single_Phase.tcu

This example is part of the Diffusion Module (DICTRA) Quick Start Guide available to all 
users. A version of the example is also available for Console Mode.

Figure 69: Composition of Ni vs Distance.
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D_02: Ferrite(bcc)/Austenite(fcc) Transformation in a 
Binary Fe-C Alloy 
The moving phase boundary example  simulates the growth of ferrite (bcc) into austenite (fcc). The 
austenite is assumed to be initially homogeneous with the composition Fe-0.15 mass-% C. The 
transformation temperature is 1050 K. The initial thickness of the austenite is 2 mm and an initially very 
thin ferrite (1 nm) is also present at the start of the simulation. 

This example is included as a Diffusion Module (DICTRA) tutorial on our website and as part 
of the  playlist on our YouTube channel. 

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Diffusion Module - DICTRA
 l File name: D_02_Diffusion_Moving_Boundary.tcu

This example is part of the Diffusion Module (DICTRA) Quick Start Guide available to all 
users. A version of the example is also available for Console Mode.

Figure 70: Position of interface vs time.
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Figure 71: Composition profile C.
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D_03: Evolution of an Fe-Cr-Ni Diffusion Couple
The multiphase example simulates the evolution of an Fe-Cr-Ni diffusion couple during a 100 hour heat 
treatment at  1100° C (1373.15 K). Both end members of the diffusion couple are duplex ferrite plus 
austenite, but the majority phase is ferrite on the left-hand side and austenite on the right. 

With this type of simulation it is assumed that the material is fully equilibrated at each grid point, i.e. 
the local phase fractions, phase compositions and so forth are obtained from an equilibrium calculation 
with the local overall composition as a condition. 

More details about the homogenization model for multiphase simulations can be found in Larsson and 
Engström [2006Lar]   and Larsson and Höglund [2009Lar]. Experimental data is from Engström [1995Eng]. 

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Diffusion Module - DICTRA
 l File name: D_03_Diffusion_Multiphase.tcu

This example is part of the Diffusion Module (DICTRA) Quick Start Guide available to all 
users. A version of the example is also available for Console Mode.

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.
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Figure 72: Phase fraction of FCC.
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D_04: Fe-C Moving Boundary: Austenite to Ferrite
This example simulates the austenite to ferrite transformation in a Fe-0.01 mass% C steel during 
continuous cooling. The simulation starts at a temperature where only austenite is stable, ferrite 
nucleates and grows into the austenite during cooling in the two phase region. Plots of thermal and 
carbon composition profiles are generated.

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Diffusion Module - DICTRA
 l File name: D_04_Diffusion_Fe-C_Moving_Boundary_Austenite_to_Ferrite.tcu

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.

Figure 73: Thermal profile.

Diffusion Module (DICTRA) Graphical Mode Examples ǀ 121 of 206

www.thermocalc.com

https://www.thermocalc.com/training/video-tutorials/
https://www.youtube.com/channel/UCLTh3apGItuaVK69mrwcpJg/featured
https://www.thermocalc.com/


Figure 74: Carbon composition profile.
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D_05: γ/α/γ Diffusion Couple of Fe-Ni-Cr alloys
This example demonstrates the evolution of a ternary Fe-Cr-Ni diffusion couple. A thin slice of ferrite (α 
phase) (38%Cr,0%Ni) is clamped between two thicker slices of austenite (γ phase) (27%Cr, 20%Ni). The 
assembly is subsequently heat treated at 1373 K. 

This set up corresponds to diffusion couple in Kajihara et al. [1993aKaj] and Kajihara and Kikuchi 
[1993bKaj].

Open the example project file and click Perform Tree to generate the plots associated with it. 

When you run (Perform) this example, it takes a few minutes for the calculations to 
complete.

Project File Information
 l Folder: Diffusion Module - DICTRA
 l File name: D_05_Diffusion_Fe_Ni_Cr_Moving_Boundary_Diffusion_Couple.tcu

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.
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Figure 75: Interface position.

Figure 76: Concentration profiles at 3600 s.
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Figure 77: Concentration profiles at 36 000 s.

Figure 78: Concentration profiles at 360 000 s.
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Figure 79: Concentration profiles at 3 600 000 s.

Figure 80: Diffusion paths.
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D_06: Diffusion Through a Tube Wall
This is a simple example of diffusion through a tube wall. The tube material is an Fe-0.06Mn-0.05C alloy. 
Two plots comparing distance to the U-fraction of manganese and composition of carbon are generated 
to visualize the austenite region. A cylindrical geometry is used with mixed zero flux and activity 
boundary conditions. 

On the inside wall a carbon activity of 0.9 is maintained whereas on the outside the carbon activity is 
very low. This example demonstrates the use of boundary conditions, advanced plotting and tables. 

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Diffusion Module - DICTRA
 l File name: D_06_Diffusion_Carburization_Tube.tcu

This example is based on Console Mode exab6. When in Console Mode, you can open the 
example from Thermo-Calc  (File → Examples Files → Diffusion Module). 

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.
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Figure 81: Composition of C vs Distance.

Figure 82: U-fraction of Mn vs Distance.
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Figure 83: Table: Composition C vs Distance.
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D_07: Multiphase Carburization of an Alloy
This example is based on Engström et al. [1994Eng] and is about carburization of a Ni-25Cr-0.0001C 
alloy. In this case the M7C3 and M3C2 carbides are entered as spheroid phases in an FCC_A1 matrix. It is 
similar to Graphical Mode example D_06 except the default simulation condition is automatically set to 
use the homogenization model. 

The isothermal calculation is run for 1000 hours at a temperature of 1123 K using the mixed zero flux 
and activity left boundary condition. Results are plotted using two Plot Renderers and a Table Renderer.

This example is included as a Diffusion Module (DICTRA) tutorial on our website and as part 
of the  playlist on our YouTube channel. 

Open the example project file and click Perform Tree to generate the plots associated with it. 

When you run (Perform) this example, it takes a few minutes for the calculations to 
complete.

Project File Information
 l Folder: Diffusion Module - DICTRA
 l File name: D_07_Diffusion_Carburization_Multiphase.tcu

This example is based on Console Mode exd1b. When in Console Mode, you can open the 
example from Thermo-Calc  (File → Examples Files → Diffusion Module). 
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Figure 84: Phase fraction vs distance.

Figure 85: Table of Composition profiles.
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Figure 86: Composition of C vs distance.
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D_08: Microsegregation During Solidification
This application example, which is showcased on our website, shows how Thermo-Calc together with 
the Diffusion Module (DICTRA) can be used to investigate and predict microsegregation during 
solidification, also known as solute redistribution during solidification. The example uses a steel with 
composition Fe – 0.8% Mn – 0.7%Si – 0.03%P – 0.4%C.

The example is based on a real case where the elemental distribution of a continuously cast steel was 
measured revealing the concentration of the elements Si, Mn, and P. The profile results from the well-
known segregation across secondary dendrite arms. The interesting point is that the elements Si and Mn 
show the expected positive segregation (higher concentrations) in the interdendritic regions. The peak 
of the P content, on the other hand, is shifted compared to Si and Mn, and, in fact, shows negative 
segregation in the interdendritic region. This is unexpected and counterintuitive.

The example also touches on some very basic concepts for metallurgy and using Thermo-Calc, such as 
stable and meta-stable phase diagrams, Scheil and para- or partial-equilibrium Scheil solidification 
simulations.

Open the example project file and click Perform Tree to generate the plots associated with it. 

When you run (Perform) this example, it takes a few minutes for the calculations to 
complete.

Project File Information
 l Folder: Diffusion Module - DICTRA
 l File name: D_08_Diffusion_Microsegregation_During_Solidification.tcu

Running this calculation requires licenses for the Add-on Diffusion Module (DICTRA) plus 
the steels thermodynamic database (TCFE9 or newer) and mobility database (MOBFE4 or 
newer).

The resulting plots and details related to setting up this example are available via the 
dedicated web page, or you can read the more in depth step-by-step documentation as a 
PDF, also available via our website. 
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Precipitation Module (TC-PRISMA) Graphical Mode 
Examples

Examples that use up to three elements are available to all users. The other examples 
require a Precipitation Module (TC-PRISMA) license to calculate and plot results. 

All examples use demonstration database packages included with your installation. You can 
open the examples from the main menu: File → or Help → Examples Files.

Unless specified in tables for each example, all the numerical parameters are assumed 
default values.

In this section:

P_01: Isothermal Precipitation of Al3Sc 137

Tutorial-P_01-Isothermal 140

P_02:  Stable and Metastable Carbides - Isothermal 149

P_03: Stable and Metastable Carbides - TTT Diagram 152

P_04: Precipitation of Iron Carbon Cementite 155

P_05: Precipitation of γ’ in Ni Superalloys - Isothermal 157

P_06: Precipitation of γ’ in Ni Superalloys - Non-isothermal 161

P_07: Continuous Cooling Transformation (CCT) Diagram of Ni-Al-Cr γ-γ’ 166

Tutorial-P_07-CCT 169

P_08: Precipitation of Cu-Ti CU4TI with Assumptions of Sphere and Needle Morphologies 174

P_09: Precipitation of Al-Sc AL3SC with Assumption of Sphere and Cuboid Morphologies 179

Tutorial-P_09-Al-Sc-Sphere_Cuboid 184

P_10: Initial Particle Size Distribution of Fe-Cr-C 193
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P_11: Interfacial Energy Function 196

P_12: Comparing Growth Rate Models for an Al-Zr System 198

P_13: Paraequilibrium Precipitation of Cementite Fe-C-Cr 201

P_14: Grain Growth and the Zener Pinning Effect 203
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P_01: Isothermal Precipitation of Al3Sc
This example simulates the kinetics of precipitation of Al3Sc from an FCC_A1 solution phase. The 
simulation results can be compared with experimental data collected from Marquis and Seidman 
[2001Mar] and Novotny and Ardell [2001Nov].

This example also includes a plot using the Yield strength Property Model. This demonstrates how you 
can use the results from a Precipitation Module (TC-PRISMA) simulation as input to the Yield Strength 
Model, i.e. the calculated precipitate radius/radii for each time step is used to calculate the precipitation 
strengthening, and similarly, the matrix composition for each time step is used to calculate the solid 
solution strengthening when this is selected in the Configuration on the Plot Renderer. The 
experimental data for the Yield Strength Model is from Seidman et al. [2002Sei]. In this example, the 
Precipitation strengthening model used is Seidman model (Al-base). This is selected on the Plot 
Renderer configuration panel that is connected to the Property Model.

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File, Step-By Step Instructions, and Video Tutorial Information
 l Folder: Precipitation Module - TC-PRISMA
 l File name: P_01_Precipitation_Al-Sc_AL3SC.tcu

This example is included as a Precipitation Module (TC-PRISMA) tutorial on our website and 
as part of the  playlist on our YouTube channel. 

You can also use the step-by-step instructions included in a PDF to follow the video or 
compare to the project file in Thermo-Calc.

Example Settings

System (System Definer)

Database package Demo: Aluminum-based alloys 
(ALDEMO, MALDEMO)

Elements Al, Sc

Conditions (Precipitation Calculator)

Composition Al-0.18Sc Mole percent

Matrix phase FCC_A1

Precipitation Module (TC-PRISMA) Graphical Mode Examples ǀ 137 of 206

www.thermocalc.com

https://thermocalc.com/support/video-tutorials/precipitation-module-tc-prisma-examples/
https://www.youtube.com/playlist?list=PLfv6McToaTGSpqvuLoY3b_UV-8xpgLUkJ
Tutorial-P_01-Isothermal.pdf
https://www.thermocalc.com/


Precipitate phase AL3SC

Precipitate Phase Data Parameters (Precipitation Calculator)

Nucleation sites Bulk

Interfacial energy Calculated

Calculation Type (Precipitation Calculator)

Calculation type Isothermal

Temperature 350° C

Simulation time 1.0E7 seconds

Experimental File Reader 1 and 2  

There are two Experimental File Reader nodes used. One for the mean radius plot 
and one to demonstrate the Yield Strength Property Model.  

Results

Figure 87: The mean radius of the AL3SC precipitate as a function of time.

Precipitation Module (TC-PRISMA) Graphical Mode Examples ǀ 138 of 206

www.thermocalc.com

https://www.thermocalc.com/


Figure 88: The total yield strength of the AL3SC precipitate as a function of time compared to experimental 
data from Siedmen et al. [2002Sei].
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Isothermal Precipitation Calculation: Example P_01 – 
Precipitation Al-Sc AL3SC 

This example shows you how to set up an isothermal precipitation calculation for the formation of 
AL3SC in an aluminium-scandium alloy at 350° using the Precipitation Module (TC-PRISMA).  

The end of the example also shows how to use the results of the calculation to model Yield Strength.  

This is one of the most basic calculations using the Precipitation Module (TC-PRISMA), so it is a good 
place to start if you are new to this simulation type.  

HELPFUL INFORMATION 

• All users can run this calculation, even those who do not have a license for the Precipitation 
Module (TC-PRISMA).  

• A companion video is available for this example , which can be watched here:  
https://www.youtube.com/playlist?list=PLfv6McToaTGSpqvuLoY3b_UV-8xpgLUkJ 

This calculation is based on Precipitation Module example P_01 – Precipitation Al-Sc AL3SC, which is 
included in your installation.  

1. To run the example file, open Thermo-Calc and select Help > Examples Files or click Example 
Files on the My Project Configuration window.  

2. Open the Precipitation Module (TC-PRISMA) folder. Double-click the example file to open it. 
3. In Thermo-Calc at the bottom center of the Configuration window click Perform Tree.  

 

 

https://www.youtube.com/playlist?list=PLfv6McToaTGSpqvuLoY3b_UV-8xpgLUkJ
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ABOUT THE EXAMPLE  

This example simulates the kinetics of precipitation of Al3Sc from an FCC_A1 solution phase. The 
results of the simulation are also used to model yield strength.  

SETTING UP THE SYSTEM 

1. Open Thermo-Calc in Graphical Mode.  
2. On the My Project Configuration window under Non-Equilibrium, click Precipitation. 
3. All the nodes for a precipitation calculation are added to the Project window:  

 

4. In the Project window, click the System Definer 1 node.  
5. On the Configuration window from the Package list, select Demo: Aluminium-based alloys 

(ALDEMO, MALDEMO). This loads both thermodynamic and kinetic demonstration 
aluminium databases.  

6. In the Periodic Table, select the elements in the following order.  
Select Al first so that it is the dependant element: 

a. Al (aluminium)  
b. Sc (scandium).  

7. From the Amount list (to the right of the Periodic Table), select Mole percent. 
8. Enter 0.18 for Sc. This automatically sets Al to 99.82.  
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The system is now defined. However, before starting the precipitation calculation, it is recommended 
to run a one axis calculation to find the phases present around 350° C.  

ONE AXIS CALCULATION 

Why We Do This 

In order to set up an isothermal precipitation calculation, you need to know which phases are 
present at 350 °C. A one axis calculation provides this information. Note that this step is not included 
with the P_01 example. This is an additional exercise. 

Setting up a One Axis Calculation 

1. In the Project window, right-click the System Definer 1 node, and select Create New 
Successor > Equilibrium Calculator.  

2. In the Configuration window, set Temperature to Celsius and enter 300. 
3. Under Calculation Type, click One axis.  

You now want to find the phases present around 350 °C. 
4. Under Axis Definitions, enter the Temperature range from Min 300 to Max 700.  

Keep the default values for everything else. The system is now defined. 
5. Right-click the Equilibrium Calculator node and select Create New Successor > Plot 

Renderer.  
6. In the Project window, click the Plot Renderer 2 node you just created. In the Configuration 

window, set the X-axis variable for Temperature to Celsius. Then right-click the Plot 
Renderer 2 node select Perform Now. Or click Perform at the bottom of the Configuration 
window. 
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Interpreting the Results of the One Axis Calculation 

Once the calculation is complete, a plot is displayed in the Results window. This plot shows you 
which phases are present at each temperature between 300° and 700° and the amount of that phase 
at each temperature. 

If you hover your cursor over any of the lines on the plot, a label gives you the name of the phase, 
the temperature and the amount of the phase at that temperature.   

We can see that there are two phases present at 350°. FCC_A1 is at the very top of the plot and 
makes up more than 99% of the system. The remainder of the system is made up of Al3SC, which is 
near the very bottom of the plot and is the precipitate phase in the alloy we are considering.  

Remember these two phases because these are used in the precipitation calculation.  
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PRECIPITATION CALCULATION 

Setting up the Precipitation Calculation 

1. In the Project window, click the Precipitation Calculator 1 node.  
2. Notice that the Composition set in the System Definer auto-populated here.  
3. Under Matrix Phase, the Phase defaults to FCC_A1, which is the primary phase present in the 

one axis calculation.  

NOTE: If you do not see any phases listed here it is probably because you do not have a kinetic 
database selected. If so, go back to the System Definer and add a kinetic (mobility) database. In this 
example it should be the MALDEMO database. 

4. Under Precipitate Phase, select AL3SC from the Phase list because that is the other phase 
present around 350 °C, as shown in the one axis calculation.  

5. Accept the rest of the default settings in the Precipitate Phase section. You could choose to 
define your own interfacial energy settings if you have them.  

6. Under Calculation Type, make sure Isothermal is selected.  
7. Enter: 

a. 350 as the Temperature and select Celsius.  
b. 1.0E7 as the Simulation time and select Seconds, which is ten million seconds.  

 

8. In the Project window, click the Plot Renderer 1 node. 
9. Under Y-axes, from the Axis type menu select Logarithmic 10 for a better view of the plot. 
10. Click Perform at the bottom, center of the Configuration window.  



Isothermal Precipitation Calculation 
Example P_01 – Precipitation Al-Sc AL3SC 

 

Page 6 of 9 
Version 4 (May 2022) 

 

 

Interpreting the Results of the Precipitation Calculation 

Once the calculation is complete, your plot is shown in the Results window. 

   

At the beginning, which is the left-most side of the plot, the mean radius is quite small and then 
grows rapidly over time, which is represented by moving rightward on the plot.  

Setting Other Variables in the Precipitation Module (TC-PRISMA) 

The Precipitation Module (TC-PRISMA) offers many variables that you can plot for the same 
calculation.  

1. Click the Plot Renderer 1 node. 
2.  Under Y-axes, click the Axis variable menu to see the other available options in the list.  

This plot shows the 
Mean radius of the 
AL3SC precipitate as a 
function of time.  



Isothermal Precipitation Calculation 
Example P_01 – Precipitation Al-Sc AL3SC 

 

Page 7 of 9 
Version 4 (May 2022) 

 

3. Once you have made your selection, click Perform at the bottom, center of the Configuration 
window to create a new plot.   

 

Model Yield Strength 

Beginning with Thermo-Calc 2020b, results of a precipitation simulation can be used as input to 
model yield strength using the Yield Strength Property Model. The following simulation requires a 
license for Thermo-Calc 2020b or newer.  

1. Right click the Precipitation Calculator 1 node and select Create New Successor > Plot 
Renderer.  

2. Under Y-axes, from the Axis variable menu, select Yield strength (as in the figure above but 
for Plot Renderer 3). 

3. Click the Configuration panel button.  
4. If required, expand the Plot Renderer Configuration window. Then from the Precipitation 

strengthening model menu select Seidman model (Al-base).  
5. Under Y-axes, from the Axis type menu, select Logarithmic 10. 
6. Click Perform at the bottom, center of the program.  

The program uses the results from the precipitation simulation as the input for the Yield Strength 
model. 
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Interpreting the Results of the Yield Strength Model 

Once the calculation is complete, your plot is shown in the Results window. 
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This plot shows the 
yield strength of the 
AL3SC precipitate as a 
function of time.  



P_02:  Stable and Metastable Carbides - Isothermal
This example simulates the kinetics of precipitation of both stable and metastable carbides from ferrite 
phase. It demonstrates that metastable carbides (cementite, M7C3) may first emerge and then 
disappear and the stable phase (M23C6) prevails. 

This example uses the Equilibrium Calculator  and a one axis calculation to determine how the phases 
change with temperature. We are interested in the carbide precipitation at 1053 K where only the 
carbide M23C6 is stable according to the equilibrium calculation. The Precipitation Calculator is used to 
do an isothermal calculation of the three phases (cementite, M23C6, and M7C3) where cementite and 
M7C3 are metastable phases. 

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Precipitation Module - TC-PRISMA
 l File name: P_02_Precipitation_Fe-C-Cr_Cementite-M7C3-M23C6.tcu

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.

Example Settings

System (System Definer)

Database package Demo: Steels and Fe-alloys (FEDEMO,MFEDEMO)

Elements Fe, C, Cr

Conditions (Precipitation Calculator)

Composition Fe-0.1C-12Cr Mass percent

Matrix phase BCC_A2

Precipitate phases Cementite, M23C6 and M7C3

Matrix Phase Data Parameters (Precipitation Calculator)

Grain size (click Show details to display this setting) 1.0E-4 m

Precipitate Phase Data Parameters (Precipitation Calculator)

Nucleation sites Grain boundaries
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Interfacial energy Cementite 0.167 J/m2, M23C6 0.252 J/m2, M7C3 0.282 J/m2

Calculation Type (Precipitation Calculator)

Calculation type Isothermal

Temperature 1053 K

Simulation time 400 000 seconds

Results

Figure 89: The Equilibrium Calculator  and a one axis calculation is used to determine how the phases change 
with temperature. 
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Figure 90: The Precipitation Calculator is used to do an isothermal calculation of the three phases (cementite, 
M23C6, and M7C3) where cementite and M7C3 are metastable phases. 
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P_03: Stable and Metastable Carbides - TTT Diagram
In this example, the kinetics of precipitation of both stable and metastable carbides is calculated from 
the ferrite phase. It demonstrates that metastable carbides may first emerge and then disappear and 
the stable phase prevails.

This example uses the Equilibrium Calculator  and a one axis calculation type to determine how the 
phases change with temperature. Using this result,  the Precipitation Calculator is used to do a TTT 
(Time-Temperature-Transformation) diagram calculation of the three phases (cementite, M23C6 and 
M7C3) at the grain boundaries.

For a TTT diagram calculation, select TTT diagram in Calculation Type, then enter Min, Max, and Step of 
Tempeature, as well as Max annealing time. In Stop criterion, choose Volume fraction of phase and 
enter the value. 

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Precipitation Module - TC-PRISMA
 l File name: P_03_Precipitation_Fe-C-Cr_TTT_Cementite-M7C3-M23C6.tcu

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.

Example Settings

System (System Definer)

Database package Demo: Steels and Fe-alloys (FEDEMO and MFEDEMO)

Elements Fe, C, Cr

Conditions (Precipitation Calculator)

Composition Fe-0.1C-12Cr Mass percent

Matrix phase BCC_A2
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Precipitate phases Cementite, M23C6 and M7C3

Matrix Phase Data Parameters (Precipitation Calculator)

Grain size  (click Show details to display this setting) 1.0E-4 m

Precipitate Phase Data Parameters

Nucleation sites Grain boundaries

Interfacial energy Cementite 0.167 J/m2, M23C6 0.252 J/m2, M7C3 0.282 
J/m2

Calculation Type (Precipitation Calculator)

Calculation type TTT diagram

Temperature 500° to 800° C with 25° C steps

Max. annealing time 1.0E8 seconds

Stop criteria Volume fraction of phase is set to 0.0001

Options > Numerical Parameters

No. of grid points over one order of magnitude in radius 150

Max no. of grid points over one order of magnitude in 
radius 200

Min no. of grid points over one order of magnitude in 
radius 100
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Results

Figure 91: The Equilibrium Calculator is used to show how the phases change with temperature.

Figure 92: The Precipitation Calculator is used to do a TTT (Time-Temperature-Transformation) diagram 
calculation of the three phases (cementite, M23C6 and M7C3) at the grain boundaries.
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P_04: Precipitation of Iron Carbon Cementite
This example is based on  [1949Wer] and simulates the kinetics of precipitation of carbides from a 
BCC Fe solution phase. This isothermal calculation example uses the Precipitation Calculator plus two 
Experimental File Reader activities to plot the volume fraction  of the  cementite phase.

Open the example project file and click Perform Tree to generate the plots associated with it. 

When you run (Perform) this example, it takes a few minutes for the calculations to 
complete.

Project File  Information
 l Folder: Precipitation Module - TC-PRISMA
 l File name: P_04_Precipitation_Fe-C_Cemetite.tcu

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.

Example Settings

System (System Definer)

Database package Demo: Steels and Fe-alloys (FEDEMO and MFEDEMO) 

Elements Fe, C

Conditions (Precipitation Calculator)

Composition Fe-0.016C mass percent

Matrix phase BCC_A2

Precipitate phase Cementite

Matrix Phase Data Parameters (Precipitation Calculator)

Grain aspect ratio   (click Show details to display this setting) 1.0
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Dislocation density    (click Show details to display this setting) 1.5e11m-3

Precipitate Phase Parameters (Precipitation Calculator)

Nucleation sites Dislocations

Interfacial energy 0.24 J/m2

Growth rate model (click Show details) Advanced 

Calculation Type (Precipitation Calculator)

Calculation type Isothermal

Temperature 102° C

Simulation time 600 000 seconds

Results

Figure 93: Volume fraction of the    cementite phase.

Reference
[1949Wer] C. A. Wert, Precipitation from Solid Solutions of C and N in α-Iron. J. Appl. Phys. 20, 943 

(1949).
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P_05: Precipitation of γ’ in Ni Superalloys - Isothermal
This example simulates the kinetics of precipitation of gamma primate (γ’) phase from gamma (γ) phase. 
The simulation results can be compared with experimental data collected from Sudbrack et al. 
[2008Sud]. 

This example uses three Experimental File Reader activities with the Precipitation Calculator. It does an 
isothermal calculation to plot the volume fraction, mean radius, and number density of the  cementite 
phase.

DIS_FCC_A1 needs to be selected on the System Definer. 

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Precipitation Module - TC-PRISMA
 l File name: P_05_Precipitation_Ni-Al-Cr_Isothermal_Gamma-Gamma_prime.tcu

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.

Example Settings

System (System Definer)

Database package Demo: Nickel-based Super Alloys (NIDEMO and MNIDEMO)

Elements Ni, Al Cr

Conditions (Precipitation Calculator)

Composition Ni-9.8Al-8.3Cr Mole percent

Matrix phase DIS-FCC_A1 

Precipitate phase FCC_L12#2

Precipitate Phase Data Parameters (Precipitation Calculator)

Nucleation sites Bulk
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Interfacial energy 0.012 J/m2

Calculation Type (Precipitation Calculator)

Calculation type Isothermal

Temperature 800° C

Simulation time 1 000 000 seconds

Results

Figure 94: The results of an isothermal calculation to plot the volume fraction of the cementite phase.
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Figure 95: The results of an isothermal calculation to plot the number density of the  cementite phase.

Figure 96: The results of an isothermal calculation to plot the mean radius of the  cementite phase.
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Reference
[2008Sud] C. K. Sudbrack, T. D. Ziebell, R. D. Noebe, D. N. Seidman, Effects of a tungsten addition on the 

morphological evolution, spatial correlations and temporal evolution of a model Ni–Al–Cr superalloy. 
Acta Mater. 56, 448–463 (2008).
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P_06: Precipitation of γ’ in Ni Superalloys - Non-isothermal
This example simulates the kinetics of precipitation of gamma prime (γ’) phase from gamma (γ) phase in 
Ni-8Al-8Cr and Ni-10Al-10Cr at.% alloys during continuous cooling. The simulation results can be 
compared with experimental results from Rojhirunsakool et al. [2013Roj]. 

DIS_FCC_A1 needs to be selected on the System Definer. 

Open the example project file and click Perform Tree to generate the plots associated with it. 

When you run (Perform) this example, it takes a few minutes for the calculations to 
complete.

Project File Information
 l Folder: Precipitation Module - TC-PRISMA
 l File name: P_06_Precipitation_Ni-Al-Cr_Non-isothermal_Gamma-Gamma_prime.tcu

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.

Example Settings

System (System Definer)

Database package Demo: Nickel-based Super Alloys (NIDEMO and MNIDEMO)

Elements Ni, Al, Cr

Conditions (Precipitation Calculator)

Composition (Ni-8Al-8Cr) Ni-8Al-8Cr Mole percent

Composition (Ni-10Al-10Cr) Ni-10Al-10Cr Mole percent

Matrix phase DIS_FCC_A1 
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Precipitate phase FCC_L12#2

Matrix Phase Data Parameters (Precipitation Calculator)

Mobility enhancement prefactor 
(click Show details to display this 
setting)

5.0

Precipitate Phase Data Parameters (Precipitation Calculator)

Nucleation sites Bulk

Interfacial energy 0.023 J/m2

Calculation Type (Precipitation Calculator)

Calculation type Non-isothermal

Temperature unit Celsius

Time unit Seconds

Temperature

1150 - 380 °C 

Simulation time (Ni-8Al-8Cr) 3300 s

Simulation time (Ni-10Al-10Cr) 3300 s

Multimodal PSD (Plot Renderer)

Separate multimodal PSD  for 8Al-8Cr The Valley depth ratio is set to 0.05 for both plots (mean radius and PSD) for 
this alloy. The number of Points is increased  to 200 for an average radius plot. 

Separate multimodal PSD  for 10Al-
10Cr

The Valley depth ratio is set to 0.18 for both plots (mean radius and PSD) for 
this alloy.
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Results

Figure 97: Mean radius Ni-8Al-8Cr.

Figure 98: Mean radius Ni-10Al-10CR.
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Figure 99: Preexisting Size Distribution (PSD) Ni-8Al-8Cr.

Figure 100: Preexisting Size Distribution (PSD) Ni-10Al-10Cr.
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Reference
[2013Roj] T. Rojhirunsakool, S. Meher, J. Y. Hwang, S. Nag, J. Tiley, R. Banerjee, Influence of composition 

on monomodal versus multimodal γ′ precipitation in Ni–Al–Cr alloys. J. Mater. Sci. 48, 825–831 
(2013).
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P_07: Continuous Cooling Transformation (CCT) Diagram of 
Ni-Al-Cr γ-γ’
This example shows you how to simulate a CCT (Continuous Cooling Transformation) diagram for 
gamma prime (γ’) precipitation in a Ni-Cr-Al alloy using the Precipitation Calculator. A CCT calculation 
maintains the same cooling rate the entire time.

The system is a Ni-10Al-10Cr γ - γ’ alloy and it is calculated and plotted with superimposition of the 
cooling rate values.

Open the example project file and click Perform Tree to generate the plots associated with it. 

When you run (Perform) this example, it takes a few minutes for the calculations to 
complete.

Project File, Step-By Step Instructions, and Video Tutorial Information
 l Folder: Precipitation Module - TC-PRISMA
 l File name: P_07_Precipitation_Ni-Al-Cr_CCT_Gamma-Gamma_prime.tcu

This example is included as a Precipitation Module (TC-PRISMA) tutorial on our website and 
as part of the  playlist on our YouTube channel. 

You can also use the step-by-step instructions included in a PDF to follow the video or 
compare to the project file in Thermo-Calc.

Example Settings

System (System Definer)

Database package Demo: Nickel-based Super Alloys (NIDEMO and MNIDEMO)

Elements Ni, Al, Cr

Conditions (Precipitation Calculator)

Composition Ni-10Al-10Cr Mole percent 

Matrix phase DIS_FCC_A1
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Precipitate phase FCC_L12#2

Precipitate Phase Data Parameters (Precipitation Calculator)

Nucleation sites Bulk

Interfacial energy 0.023 J/m2

Calculation Type (Precipitation Calculator)

Calculation type CCT Diagram

Temperature Min to Max 500 to 1200 Kelvin

Cooling rate(s) .01 .1 1 10 100 K/s

Stop criteria Volume fraction of phase 1.0E-4
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Results

Figure 101: In this plot, the blue horizontal line shows the time it takes for γ’ to transform at each of the 
cooling rates according to the stop criteria, which is set as 1e-4 volume fraction. The cooling rates are 
represented by the multicoloured curved lines.

If you hover your mouse over the intersection of the blue line and any of the vertical lines, a yellow box 
shows the approximate time it takes for γ’ to transform according to the stop criteria, which is a volume 
fraction of 1e-4, followed by the approximate temperature. 

Figure 102: An example of the table shown in the Results window, which shows the same information as in the 
plot - for each cooling rate the temperature and the time it takes for γ’ to transform according to the stop 
criteria, which is a volume fraction of 1e-4.
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Continuous Cooling Transformation (CCT) Diagram of 
Ni-Al-Cr γ-γ’: Precipitation Example P_07 

HELPFUL INFORMATION 

• All users can run this calculation, even those who do not have a license for the Precipitation 
Module (TC-PRISMA).  

• A companion video is available for this example , which can be watched here:  
https://www.youtube.com/playlist?list=PLfv6McToaTGSpqvuLoY3b_UV-8xpgLUkJ 

• This calculation is based on Precipitation Module example P_07 – Precipitation NI-Al-
Cr_CCT_Gamma-Gamma_prime, which is included in your installation.  

1. To run the example file, open Thermo-Calc and select Help > Examples Files or click Example 
Files on the My Project Configuration window.  

2. Open the Precipitation Module (TC-PRISMA) folder. Double-click the example file to open it. 
3. In Thermo-Calc at the bottom center of the Configuration window click Perform Tree.  

 

 

ABOUT THE EXAMPLE  

This example shows you how to simulate a CCT diagram for gamma prime (γ’) precipitation in a Ni-Cr-
Al alloy using the Precipitation Module known as TC-PRISMA.  

CCT stands for Continuous Cooling Transformation and is a calculation that maintains the same 
cooling rate the entire time.  

The system is a Ni-10Al-10Cr γ - γ’ alloy and it is calculated and plotted with superimposition of the 
cooling rate values using the Precipitation Module (TC-PRISMA).  

https://www.youtube.com/playlist?list=PLfv6McToaTGSpqvuLoY3b_UV-8xpgLUkJ
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SETTING UP THE SYSTEM 

1. Open Thermo-Calc in Graphical Mode.  
2. On the My Project Configuration window under Non-Equilibrium, click Precipitation. 
3. All the nodes for a precipitation calculation are added to the Project window:  

 

4. In the Project window, click the System Definer 1 node.  
5. On the Configuration window from the Package list, select Demo: Nickel-based alloys 

(NIDEMO, MNIDEMO). This loads both thermodynamic and kinetic demonstration nickel 
databases.  

6. From the Periodic Table, select the elements in the following order.  
Select Ni first so that it is the dependant element. 

a. Ni (nickel) 
b. Al (aluminium) then 
c. Cr (chromium).  

7. From the Amount list (to the right of the Periodic Table), select Mole percent. 
8. Enter 10 for Al and 10 for Cr, which automatically sets Ni to 80 mole percent. 
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9. Click the Phases and Phase Constitution tab.  
10. Under Phases click to select both check boxes next 

to the disordered FCC phase, DIS_FCC_A1. 

 

 

 

 

The system is now defined. The next step is to set up the precipitation calculations.  

SETTING UP THE PRECIPITATION CALCULATION 

1. In the Project window, click the Precipitation Calculator 1 node.  
2. Notice that the composition set in the System Definer auto-populated here.  
3. Under Matrix Phase, from the Phase list select Dis_FCC_A1, which is the disordered FCC 

phase.  
4. Under Precipitate Phase from the Phase list scroll to select FCC_L12#2.  
5. Change the Interfacial energy to User-defined then enter 0.023 in the field.  
6. Under Calculation Type, click CCT Diagram, which stands for Continuous-Cooling-

Transformation and means that the same cooling rate is maintained throughout the 
calculation.  

7. In the fields set: 
a. Min (minimum) Temperature to 500. 
b. Max (maximum) Temperature to 1200. 
c. Keep the default Kelvin as the temperature unit. 
d. Enter several cooling rates for the calculation. The rates are separated by a space. 

Enter these values as shown: .01 .1 1 10 100.  
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e. Keep the default Stop criteria of 1E-4 volume fraction of the γ’ phase. 
8. The calculation is now set. At the bottom, center of the Configuration window click Perform 

CCT Diagram Simulation.  

 

INTERPRETING THE RESULTS OF THE PRECIPITATION CALCULATION 

 

In this plot, the blue line shows the time it takes for γ’ to transform at each of the cooling rates 
according to the stop criteria, which is set as 1e-4 volume fraction. The cooling rates are represented 
by the multi-coloured curved lines. 

In this plot, the blue, 
horizontal line shows the 
time it takes for gamma 
prime (γ’) to transform at 
each of the cooling rates 
according to the stop 
criteria, which we set as 
1e-4 volume fraction.   
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If you hover your mouse over the intersection of the blue line and any of the vertical lines, a yellow 
box shows the approximate time it takes for γ’ to transform according to the stop criteria, which is a 
volume fraction of 1e-4, followed by the approximate temperature. In the image above, you can see 
a time of 0.531268 seconds and a temperature of 1147.49 Kelvin for the cooling rate of 100.0 K/s, 
which is represented by the yellow line.  

SHOWING THE RESULTS AS A TABLE 

You can also view these results in the form of a table, which gives you more precise results.  

1. In the Project window, right-click the Precipitation Calculator 1 node and select Create New 
Successor>Table Renderer.  

2. Right-click the Table Renderer 1 node and select Perform Now.  

The table is shown in the Results window and shows the same 
information as in the plot - for each cooling rate the temperature and 
the time it takes for γ’ to transform according to the stop criteria, 
which is a volume fraction of 1e-4.  

 

 

Tip! You can also convert the plot data into a table format that 
includes all the points.  

1. On the Project window, click Plot Renderer 1. 
2. On the Configuration window, click the Table View button  
3. After clicking the button, click Perform at the bottom of the window or right-click the Plot 

Renderer 1 node and select Perform Now. 
4. View the converted data on the Results window. 

 



P_08: Precipitation of Cu-Ti CU4TI with Assumptions of 
Sphere and Needle Morphologies
In this isothermal calculation example, the precipitation of Cu4Ti phase in a Cu-Ti binary alloy is 
calculated. To make a comparison, two separate simulations are performed, one assuming spherical 
morphology without elastic strain energy, and the other assuming needle morphology whose shape, 
determined by competition between interfacial energy and elastic strain energy, is changed during the 
simulation. The transformation strain is obtained from Borchers [1999Bor]. The results are compared 
with experiment results from Kampmann et al. [1987Kam]. 

Open the example project file and click Perform Tree to generate the plots associated with it. 

When you run (Perform) this example, it takes a few minutes for the calculations to 
complete.

Project File Information
 l Folder: Precipitation Module - TC-PRISMA
 l File name: P_08_Precipitation_Cu-Ti_CU4TI1_Sphere_Needle.tcu

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.

Example Settings

To ensure that the settings are done on the correct Precipitation Calculators, the Sphere 
and Needle nodes are renamed from Precipitation Calculator to match their morphology. 
The morphology is set in the Precipitate Phase section when you click Show details.
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System (System Definer)

Database package Demo: Copper-based alloys (CUDEMO and MCUDEMO)

Elements Cu, Ti

Sphere and Needle Conditions (Precipitation Calculator)

Composition Cu-1.9Ti Mole percent

Matrix phase FCC_L12

Precipitate phase CU4TI1

Matrix Phase Data Parameters (Precipitation Calculator)

Mobility enhancement prefactor 
(click Show details to display this 
setting)

100

Precipitate Phase Data Parameters (Precipitation Calculator)

Nucleation sites Bulk

Interfacial energy The default 

Morphology  (click Show details to 
display this setting)

For the Sphere node (renamed from Precipitation Calculator), keep the default. 

For the Needle node (renamed from Precipitation Calculator), Needle is selected. 

Transformation strain (click Show 
details to display this setting)

For the Sphere node (renamed from Precipitation Calculator), keep the default. 

For the Needlenode (renamed from Precipitation Calculator), User defined is 
selected. In this example, the following settings are defined:

 l ε11 and ε22 are set to 0.022
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 l ε33 is set to 0.003 

Calculation Type  (Precipitation Calculator)

Calculation type Isothermal

Temperature 350° C

Simulation time 10,000 seconds

Datasets (Experimental File Reader)

Borchers Mean radius vs Time and 
Borchers Number density vs Time

Data sets included with this example and imported to two Experimental File 
Readers. These data sets are used for the Mean Radius and Number Density plots, 
respectively.

Results

Figure 103: Mean Aspect Ratio.
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Figure 104: Number Density.

Figure 105: PSD and ASD.
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Figure 106: Mean Radius.
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P_09: Precipitation of Al-Sc AL3SC with Assumption of 
Sphere and Cuboid Morphologies
In this isothermal calculation example, the precipitation of Al3Sc phase from FCC_A1 matrix phase in an 
Al-Sc binary alloy is simulated. To make a comparison, two separate calculations are performed, one 
assuming spherical morphology without elastic strain energy, and the other assuming cuboid 
morphology whose shape is determined by competition between interfacial energy and elastic strain 
energy. The simulation results are compared with experimental data collected from Marquis and 
Seidman [2001Mar] and Novotny and Ardell  [2001Nov]. In addition, mean cubic factor and cubic factor 
distribution are also plotted for cuboid shape to illustrate the spherical-cuboidal transition during 
precipitation. 

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File, Step-By Step Instructions, and Video tutorial Information
 l Folder: Precipitation Module - TC-PRISMA
 l File name: P_09_Precipitation_Al-Sc_AL3SC_Sphere_Cuboid.tcu

This example is included as a Precipitation Module (TC-PRISMA) tutorial on our website and 
as part of the  playlist on our YouTube channel. 

You can also use the step-by-step instructions included in a PDF to follow the video or 
compare to the project file in Thermo-Calc.

Example Settings

To ensure that the settings are done on the correct Precipitation Calculators, the Sphere 
and Cuboid nodes are renamed from Precipitation Calculator to match their morphology. 
The morphology is set in the Precipitate Phase section when you click Show details. See P_
08 for an example of this.

System (System Definer)

Database package Demo: Aluminum-based alloys (ALDEMO, MALDEMO)
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Elements Al, Sc

Sphere and Cuboid Conditions (Precipitation Calculator)

Composition Al-0.18Sc Mole percent

Matrix phase FCC_A1

Precipitate phase AL3SC

Matrix Phase Data Parameters (Precipitation Calculator)

Elastic properties   (click 
Show details to display 
this setting)

For the Sphere node (renamed from Precipitation Calculator), the default, Disregard is kept.

For the Cuboid node (renamed from Precipitation Calculator), choose Cubic. Then enter the 
elastic constants accordingly. Default elastic constants are given based on the major 
element of the alloy system. In this example that is 

 l c11 is 108.2 GPa

 l c12 is 61.3 GPa

 l c44 is 28.5 GPa

Precipitate Phase Data Parameters (Precipitation Calculator)

Nucleation sites Bulk

Interfacial energy The default 

Morphology  (click Show 
details to display this 
setting)

For the Sphere node (renamed from Precipitation Calculator), keep the default. 

For the Cuboid node (renamed from Precipitation Calculator), Cuboid is selected. 

Transformation strain 
(click Show details to 
display this setting)

For the Sphere node (renamed from Precipitation Calculator), keep the default. 

For the Cuboid node (renamed from Precipitation Calculator), Calculate from molar volume 
is selected  to obtain a purely dilatational strain. 

Calculation Type  (Precipitation Calculator)

Calculation type Isothermal

Temperature 350° C

Simulation time 1.0E9 seconds

Datasets (Experimental File Reader)

Dataset 1 and Dataset 2 Data sets included with this example and imported to one Experimental File Reader. It is 
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used for the Mean Radius plot.

Results

Figure 107: Mean Radius
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Figure 108: Particle size distribution (PSD).

Figure 109: Mean Radius and Cubic Factor
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Figure 110: Particle size distribution (PSD) and cubic factor.
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Precipitation of Al-Sc AL3SC with Assumption of 
Sphere and Cuboid Morphologies: Precipitation 
Example P_09 
HELPFUL INFORMATION 

• All users can run this calculation, even those who do not have a license for the Precipitation 
Module (TC-PRISMA).  

• A companion video is available for this example , which can be watched here: 
https://www.youtube.com/playlist?list=PLfv6McToaTGSpqvuLoY3b_UV-8xpgLUkJ 

• This calculation is based on Precipitation Module example P_09 – Precipitation_Al-
Sc_AL3SC_Sphere_Cuboid, which is included in your installation. 

1. To run the example file, open Thermo-Calc and select Help > Examples Files or click Example 
Files on the My Project Configuration window.  

2. Open the Precipitation Module (TC-PRISMA) folder. Double-click the example file to open it. 
3. In Thermo-Calc at the bottom center of the Configuration window click Perform Tree.  

 

ABOUT THE EXAMPLE  

This example shows you how to calculate the precipitation of Al3Sc phase from FCC_A1 matrix phase 
in an Al-Sc binary alloy using the Precipitation Module (TC-PRISMA).  

Two separate calculations are performed so you can make a comparison of the results, one assuming 
spherical morphology without elastic strain energy, and the other assuming cuboid morphology 
whose shape is determined by competition between interfacial energy and elastic strain energy.  

In addition, mean cubic factor and cubic factor distribution are plotted for cuboid shape to illustrate 
the spherical-cuboidal transition during precipitation.  

https://www.youtube.com/playlist?list=PLfv6McToaTGSpqvuLoY3b_UV-8xpgLUkJ
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If you run the example file included in your software, the simulation results are compared with 
experimental data collected from Marquis and Seidman (2001) and Novotny and Ardell (2001). 

SETTING UP THE SYSTEM 

1. Open Thermo-Calc in Graphical Mode.  
2. On the My Project Configuration window under Non-Equilibrium, click Precipitation. 
3. All the nodes for a precipitation calculation are added to the Project window:  

 

4. In the Project window, click the System Definer 1 node.  
5. Set the database Package to Demo: Aluminium-based alloys (ALDEMO, MALDEMO), which 

loads both thermodynamic and kinetic demonstration aluminium databases.  
6. From the Periodic Table, select the elements in the following order.  

Select Al first so that it is the dependant element: 
a. Al (aluminium)  
b.  Sc (scandium).  

7. From the Amount list (to the right of the Periodic Table), select Mole percent. 
8. Enter 0.18 for Sc. This automatically sets Al to 99.82.  
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Our system is now defined. Now set up the precipitation calculations.  

SETTING UP THE PRECIPITATION CALCULATIONS 

There are two precipitation calculations in this example, one assuming spherical morphology without 
elastic strain energy, and the other assuming cuboid morphology whose shape is determined by 
competition between interfacial energy and elastic strain energy. The results are then compared for 
both calculations.  

Setting up the Precipitation Calculation with Spherical Morphology 

1. In the Project window, right-click the Precipitation Calculator 1 node and select Rename. 
Enter Sphere, then press enter or click OK.  

 
2. Notice that the composition set in the System Definer auto-populated on the Precipitation 

Calculator.  
3. Under Matrix Phase from the Phase list it defaults to FCC_A1.  
4. Under Precipitate Phase from the Phase list select AL3SC. 
5. Under Calculation Type, make sure Isothermal is selected, which means that the same 

temperature is maintained throughout the calculation.  
6. Enter  

a. 350 as the Temperature and select Celsius.  
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b. 1.0E9 as the Simulation time and select Seconds. 

 

Our first calculation is set, so next configure the plot.  

Configuring the Plot 

1. In the Project window, right-click Plot Renderer 1 and select Rename. Name the plot Mean 
radius then press enter or click OK. 

2. Under Y-axes change the units to Nanometer (nm). 
3. From the Axis type list select Logarithmic 10.  

 

The plot is now set, but before running the simulation you set up another calculation and link it to 
the same Plot Renderer.  

Setting up the Precipitation Calculation with Cuboid Morphology 

1. In the Project window, right-click the Sphere node and select Clone.  
a. Right-click the Sphere 1 node and select Rename.  
b. Name the node Cuboid and press enter or click OK.  

2. On the Configuration window to the right of Matrix Phase click Show Details.  
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3. From the Elastic Properties list select Cubic. Keep the suggested default values. Click Hide 
details. 

 

4. To the right of Precipitate Phase, click Show details.  
5. From the Morphology list select Cuboid.  
6. From the Transformation strain list select Calculate from molar volume. 

  

The second calculation is now set up, so now link it to the Plot Renderer node.  

Linking the Plot to the Calculation with Cuboid Morphology 

1. In the Project window, right-click the Mean radius node and select Add Predecessor 
>Cuboid.  

2. Notice that in the Configuration window there are two tabs associated with this plot, one for 
Sphere and one for Cuboid. The Sphere settings are already configured, so you just need to 
set up the Cuboid tab.  

 
3. Click the Cuboid tab. 
4. Under Y-axes change the units to Nanometer (nm). 
5. From the Axis type list select Logarithmic 10.  
6. The calculation is now ready to run. Right-click the Mean radius node and select Perform 

Now or click Perform on the Configuration window. 
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INTERPRETING THE RESULTS OF THE PRECIPITATION CALCULATIONS 

  

In this plot, the blue line represents the sphere calculation and the red line represents the cuboid 
calculation. You can see that, in this instance, these are almost identical.  

By ‘radius for non-spherical particles’ it means the radius of equivalent spheres with the same 
volume. 

If you run the example file that is included in your software, the plot also contains an experimental 
file, which you can see closely matches the calculations. 

PLOTTING ADDITIONAL VARIABLES 

Now you use the same calculation to set up additional plots using the many available variables. The 
examples below include two Y-axes each.  

Plotting Mean Radius and Cuboid Factor 

This plot has two Y-axes: Mean radius and Cuboid factor.  

1. Right-click the Cuboid node and add a Plot Renderer.  
2. Right-click the new node and rename it Mean radius and Cuboid factor.  
3. Under Y-axes click the plus sign to add another axis.  
4. Keep Mean radius as the first axis variable but change the units to Nanometer (nm) and set 

the axis type to Logarithmic 10.  
5. Set the second Axis variable to Mean cubic factor.  
6. Click to clear the Automatic scaling check box. In the fields, enter the Limits from 1 to 1.41 

and the step to 0.1.  
7. The plot is now set. Click Perform.  

In this plot, the blue 
line represents the 
sphere calculation 
and the red line 
represents the cuboid 
calculation. You can 
see that, in this 
instance, they are 
almost identical.  
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Interpreting the Results of Mean Radius and Cuboid Factor 

  

The blue line represents the evolution of the average radius of the cubic particles as a function of 
time. Again, for non-spherical precipitates this means the radius of equivalent spheres with the same 
volume.  

The red line shows the average cubic factor as a function of time. A value of one represents a 
spherical shape. A square root of two represents a cubic shape.  

In this plot, the blue line 
represents the evolution 
of the average radius of 
the cubic particles as a 
function of time. The red 
line shows the average 
cubic factor as a function 
of time. 
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The evolution of the shape when the particles grows is determined by competition between 
interfacial energy and elastic strain energy. In general, the shape is close to spherical at small particle 
sizes because the interfacial energy term dominates.  

At large sizes the elastic energy dominates and it is therefore more favourable with a non-spherical 
shape.  You can see that the particles get a more cubic form at later times when they grow to larger 
sizes.  

Plotting Particle Size and Cubic Factor Distribution 

This final plot shows the particle size distribution (PSD) and cubic factor distribution at the end of the 
simulation.  

This plot also has two Y-axes, so you can clone the previous plot. 
1. Right-click the Mean radius and Cuboid factor node and select Clone. 
2. Right-click the new node and rename it PSD and Cuboid factor.  
3. Under the Y-axes 

a. Select Size distribution as the first Axis variable.  
b. Change the Axis type to Linear.  

4. Set the second Y-axis to Cubic factor distribution and enter a Time of 1e9 Seconds.  
5. Keep the Automatic Scaling check box cleared. Enter the Limits from 1 to 1.45 and the step 

to 0.1.  
6. Under Size X-axis, change the unit to Nanometer (nm).  
7. Click Perform at the bottom center of the Configuration window. 
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Interpreting the Results of Particle Size Distribution and Cuboid Factor 

  

The blue curve, which shows the particle size distribution, is close to the regular LSW size distribution 
that is expected for spherical particles.  

The cubic factor distribution shows that the smallest particles are closer to spherical and that the 
larger ones get more and more cubic. 

References 

1. Marquis, E.A, and D.N Seidman. 2001. “Nanoscale Structural Evolution of Al3Sc Precipitates 
in Al(Sc) Alloys.” Acta Materialia 49 (11): 1909–19. 
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In this plot, the blue 
curve shows the 
particle size 
distribution and the 
red line shows the 
cubic factor 
distribution. 
 



P_10: Initial Particle Size Distribution of Fe-Cr-C
This example demonstrates the effect of initial particle size distribution (PSD) of the precipitate phases 
on the overall precipitation kinetics. It  uses two Precipitation Calculators to simulate and compare 
carbide precipitations from a ferritic BCC_A2 matrix in a Fe-0.1C-12Cr alloy. Three carbides, CEMENTITE, 
M23C6, and M7C3, are included in the calculations for competitive precipitations, and the precipitation 
kinetics are compared with or without initial particle size distribution.

Open the example project file and click Perform Tree to generate the plots associated with it. 

Project File Information
 l Folder: Precipitation Module - TC-PRISMA
 l File name: P_10_Precipitation_Initial_PSD_FeCrC.tcu

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.

Example Settings
The example illustrates the use of the PSD setting. You can import data from a spreadsheet or text file 
(.xls, .xlsx, .csv or .txt formats are acceptable). The Preexisting Particle Size Distribution window shown 
below, provides a graphical representation of the radius versus corresponding frequencies.

Figure 111: The Preexisting Particle Size Distribution (PSD) settings window for example P_10.

System (System Definer)

Database package Demo: Steels and Fe-alloys (FEDEMO and MFEDEMO)
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Elements Fe, C, Cr

Conditions (Precipitation Calculator)

Composition Fe-0.1C-12Cr Mass percent

Matrix phase
BCC_A2

All other defaults are kept.

Precipitate phases CEMENTITE, M23C6 and M7C3

Precipitate Phase Data Parameters (Precipitation Calculator)

Nucleation sites Grain boundaries (all calculations): Calculated from the matrix settings with a wetting 
angle of 90°

Interfacial energy

User-defined function f(r,T) (all calculations):

 l CEMENTITE: 0.167 J/m2

 l M23C6 0.252 J/m2

 l M7C3 0.282 J/m2

Preexisting size distribution 
(click Show details to 
display this setting)

For the Precipitation Calculator including particle size distribution, and for all precipitate 
phases, this check box is selected.

For each precipitate phase (CEMENTITE, M23C6 and M7C3), click Edit particle size 
distribution to make changes to the parameters. A window opens with a graphical 
representation of the radius vs number density. 

Calculation Type  (Precipitation Calculator)

Calculation type Isothermal

Temperature 1053 K

Simulation time 400 000 seconds

Precipitation Module (TC-PRISMA) Graphical Mode Examples ǀ 194 of 206

www.thermocalc.com

https://www.thermocalc.com/


Results

Figure 112: Volume fraction with initial particle size distribution (PSD).

Figure 113: Volume fraction with no initial particle size distribution (PSD).
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P_11: Interfacial Energy Function
In some cases, interfacial energy may be a function of temperature and/or particle radius. This example 
uses four Precipitation Calculators at four temperature points in 30 K increments: 673 K, 703 K, 733 K, 
and 763 K. It is an isothermal calculation to examine the mean radius of an Al-0.12Sc system. It uses an 
FCC_A1 matrix phase and AL3SC precipitate phase with bulk nucleation sites and user-defined interfacial 
energy function. The user defined interfacial energy function uses an error function to set a smooth 
transition of the interfacial energy from 0.065  J/m2 to 0.085   J/m2 for particle radii below and above 1e-
8m and 5e-8m, respectively.

A dataset based on Iwamura and Miura [2004Iwa]  data is compared with the calculated results.

Open the example project file and click Perform Tree to generate the plots associated with it. 

When you run (Perform) this example, it takes a few minutes for the calculations to 
complete.

Project File Information
 l Folder: Precipitation Module - TC-PRISMA
 l File name: P_11_Interfacial_energy_function.tcu

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.

Example Settings

System (System Definer)

Database package Demo: Aluminum-based Alloys (ALDEMO, MALDEMO)

Elements Al, Sc

Conditions (Precipitation Calculator)

Composition Al-0.12Sc Mole percent

Matrix phase
FCC_A1

All other defaults are kept.

Precipitate phase AL3SC
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Nucleation sites (all calculations): Bulk (6.025E28 m-3)

Interfacial energy (all calculations): User-defined function f(r,T): 0.075+0.011*erf((r-3e-8)/1e-
8 J/m2)

Calculation Type  (Precipitation Calculator)

Calculation type Isothermal (all calculations)

Temperature Four temperature points in 30 K increments: 673 K, 703 K, 733 K, and 763 K.

Simulation time 1 000 000 seconds (all calculations)

Datasets (Experimental File Reader)

Wamura 2004 (Dataset 
1) Data set included with this example and imported to one Experimental File Reader. 

Results

Figure 114: The results of an isothermal calculation to examine the mean radius of an Al-0.12Sc system with 
experimental data from [2004Iwa]. 

Reference
[2004Iwa] Iwamura, S, and Y Miura. 2004. “Loss in Coherency and Coarsening Behavior of Al3Sc 

Precipitates.” Acta Materialia 52 (3): 591–600.
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P_12: Comparing Growth Rate Models for an Al-Zr System
This example compares the Simplified, General and Advanced growth rate models for an Al-Zr system. 
The resulting plot compares the mean radius of the spheres for each AL3ZR_D023 precipitate phase 
calculated for each type of growth rate model. 

All models treat a spherical particle (precipitate) of stoichiometric composition or with negligible atomic 
diffusivity. Local equilibrium at the precipitate-matrix interface is assumed. 

When you use the Advanced model,  the velocity of a moving phase interface and the operating tie-line 
are solved together from flux-balance equations. This model can treat both high supersaturation and 
cross diffusion rigorously. It can also capture the transition between NPLE (non-partitioning local 
equilibrium) and PLE (partitioning local equilibrium) without any ad hoc treatment.

The Simplified model is based on the quasi-steady state diffusion approximation, and estimates solute 
partitioning  with matrix composition and nuclei composition instead of time-consuming stepwise tie-
line calculations. It also neglects cross diffusion for simplicity. 

The General model  can be considered the same theoretical approximation as, but an improvement over,  
the Simplified model, with cross-diffusion terms taken into account, as well as adjustment of Gibbs-
Thomson effect and effective diffusivity implemented. A dataset based on Knipling et al. [2008Kni]   data 
is compared with the calculated results.

Open the example project file and click Perform Tree to generate the plots associated with it. 

When you run (Perform) this example, it takes a few minutes for the calculations to 
complete.

Project File Information
 l Folder: Precipitation Module - TC-PRISMA
 l File name: P_12_Precipitation_Al-Zr_GrowthRateModel_comparison.tcu

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.

Example Settings

System (System Definer)

Database package Demo: Aluminum-based Alloys (ALDEMO, MALDEMO)
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Elements Al, Zr

Conditions (Precipitation Calculator)

Composition Al-0.2Zr Mole percent

Matrix phase
FCC_A1

All other defaults are kept.

Precipitate phase
AL3ZR_D023

Click Show details to select the Growth rate model (Simplified, Advanced and General). All other 
defaults are kept.

Calculation Type  (Precipitation Calculator)

Calculation type Isothermal

Temperature 425 Celsius

Simulation time 400 hours

Datasets (Experimental File Reader)

2008 Knipling Data set included with this example and imported to one Experimental File Reader.
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Results

Figure 115: Result comparing the mean radius of the spheres for each AL3ZR_D023 precipitate phase 
calculated for each type of growth rate model. 

Reference
[2008Kni] K. E. Knipling, D. C. Dunand, D. N. Seidman, Precipitation evolution in Al–Zr and Al–Zr–Ti alloys 

during isothermal aging at 375–425°C. Acta Mater. 56, 114–127 (2008).
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P_13: Paraequilibrium Precipitation of Cementite Fe-C-Cr
In this example, the precipitation of cementite during tempering of a Fe-Cr-C steel is simulated 
considering two interface conditions: one is the usual ortho-equilibrium condition; the other is the para-
equilibrium condition. The simulation results are compared with the experimental data from Sakuma et 
al. [1980Sak]. 

This example demonstrates that the early stage of the cementite precipitation can only be accounted 
for by a simulation applying the para-equilibrium condition, under which the precipitation kinetics are 
controlled by the diffusion of C. The comparison also shows a later stage gradual transition from the 
para-equilibrium condition to the ortho-equilibrium condition, and if the tempering time is long enough 
the diffusion of Cr has a dominating effect on the coarsening of cementite. 

Open the example project file and click Perform Tree to generate the plots associated with it. 

When you run (Perform) this example, it can take over two hours to complete the 
calculations. 

Project File Information
 l Folder: Precipitation Module - TC-PRISMA
 l File name: P_13_Precipitation_Fe-C-Cr_Paraequilibrium_Precipitation_of_Cementite.tcu

Many of our Graphical Mode examples have video tutorials, which you can access in a 
variety of ways. When in Thermo-Calc, from the menu select Help → Video Tutorials, or 
you can go to the website or our YouTube channel.

Example Settings

System (System Definer)

Database package Demo: Steels and Fe-alloys (FEDEMO, MFEDEMO)

Elements Fe, Cr, C

Conditions (Precipitation Calculator)

Composition Fe-0.95Cr-1.065C Mass percent

Matrix phase
BCC_A2

All other defaults are kept.

Precipitation Module (TC-PRISMA) Graphical Mode Examples ǀ 201 of 206

www.thermocalc.com

https://www.thermocalc.com/training/video-tutorials/
https://www.youtube.com/channel/UCLTh3apGItuaVK69mrwcpJg/featured
https://www.thermocalc.com/


Precipitate phase
CEMENTITE

Click Show details to select the Growth rate model (Simplified and Para-eq). All other defaults 
are kept.

Calculation Type  (Precipitation Calculator)

Calculation type Isothermal

Temperature 773 Kelvin

Simulation time 20 hours for the paraequilibrium model and 600 hours for the simplified model.

Datasets (Experimental File Reader)

1980 Sakuma Data set included with this example and imported to one Experimental File Reader.

Results

Figure 116: Comparing results from Para-eq (PE) and Simplified (OE) growth models.

Reference
[1980Sak] T. Sakuma, N. Watanabe, T. Nishizawa, The Effect of Alloying Element on the Coarsening 

Behavior of Cementite Particles in Ferrite. Trans. Japan Inst. Met. 21, 159–168 (1980).
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P_14: Grain Growth and the Zener Pinning Effect
This example demonstrates the simulation of normal grain growth and the pinning effect [1948Smi; 
1998Man] of precipitated second-phase particles on the grain boundary motion.

To investigate the grain growth and Zener pinning effect, an Fe-0.2C (wt.%) binary alloy, with a BCC_A2 
matrix phase and CEMENTITE precipitate phase, is simulated and uses the demonstration steel 
databases, FEDEMO and MFEDEMO. These databases are available to all users (i.e. you do not need a 
license for the Precipitation Module (TC-PRISMA)) and contain the necessary thermodynamic and kinetic 
data needed for the calculation.

Open and run this example in Thermo-Calc to follow along with the description and to 
experiment with the available settings.

When you run (Perform) this example, it takes a few minutes for the calculations to 
complete.

Project File Information
 l Folder: Precipitation Module - TC-PRISMA
 l File name: P_14_Precipitation_Fe-C-Ferrite-Grain_Growth_with_Zener_Pinning.tcu

This example is included as a Precipitation Module (TC-PRISMA) tutorial on our website and 
as part of the  playlist on our YouTube channel. 

Results Discussion
The calculated equilibrium volume fraction of CEMENTITE at 722 °C (0.02786), using FEDEMO, matches 
that (0.02787) of a Fe-0.2C-0.004S-0.0004O-0.001N-0.001Al (wt.%) multicomponent commercial alloy, 
calculated using the latest version of the TCS Steel and Fe-alloys Database (TCFE), an alloy that was 
studied by Hellman and Hillert [1975Hel]. The adjusted interfacial energy assures the precipitation 
kinetics of CEMENTITE phase in Fe-C system matches that of experimental data [1975Hel] of the 
commercial counterpart (and shown in Figure 117).
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Figure 117: Result comparing the cementite mean radius to experimental data from [1975Hel].

The grain boundary energy was chosen to be a reasonable value of 0.5 J/m2. There is a large 
discrepancy, in several orders of magnitude, among experimental data regarding the grain boundary 
mobility. The experimental grain growth data from Hellman and Hillert [1975Hel] indicates that for this 
commercial alloy, the grain boundary mobility should be in the magnitude of 10-16 m4/Js. The closet 
match was from Malow and Koch [1997Mal], though their data, obtained from nanocrystalline 
structures, which reduce the grain boundary mobility, are underestimated for the micron scale grains. 
Therefore, the activation energy of 242 000 J/mol is adopted from their work, while increased the grain 
boundary mobility prefactor to 4 x 10-3 m4/Js, which gives a grain boundary mobility of 7.9432 x 10-16 
m4/Js at 722 °C.
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Figure 118: Result comparing the ferrite mean grain radius with and without pinning for the BCC-A2 phase and 
compared to experimental data [1975Hel].

Example Settings

System (System Definer)

Database package Demo: Steels and Fe-alloys (FEDEMO and MFEDEMO)

Elements Fe, C

Conditions (Precipitation Calculator)

Composition Fe-0.2C Mass percent

Matrix phase

BCC_A2

 l Grain boundary energy (J/m2): 0.5
 l Grain boundary mobility: Prefactor (m4/Js): 0.004
 l Grain boundary mobility: Activation energy (J/mol): 242000

 l Initial grain size distribution: Lognormal distribution with average radius 2.0 
x 10-6 m

Precipitate phase
CEMENTITE

Interfacial energy: Calculated with Prefactor 0.15

Calculation Type  (Precipitation Calculator)

Calculation type Isothermal
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Temperature 722 °C

Simulation time 35 hours

Datasets (Experimental File Reader)

[1975Hel] Data sets included with this example and imported to two Experimental File Readers.

References
[1948Smi] C. S. Smith, Grains, Phases, and Interfaces - an Interpretation of Microstructure. Trans. AIME. 

175, 15–51 (1948).

[1975Hel] P. Hellman, M. Hillert, On the Effect of Second-Phase Particles on Grain Growth. Scand. J. 
Metall. 4, 211–219 (1975).

[1997Mal] T. R. Malow, C. C. Koch, Grain growth in nanocrystalline iron prepared by mechanical 
attrition. Acta Mater. 45, 2177–2186 (1997).

[1998Man] P. A. Manohar, M. Ferry, T. Chandra, Five Decades of the Zener Equation. ISIJ Int. 38, 913–
924 (1998).
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