About the TC-Python Help and PDFs

💡 The TC-Python help is available on the Thermo-Calc website where you can also access additional resources. You can alternatively access the installed documentation from the Help menu in Thermo-Calc.

Opening the TC-Python Locally Installed Documentation

1. In Thermo-Calc from the menu, select Help → Manuals Folder.

You can also navigate to the Manuals folder outside of Thermo-Calc and based on your operating system installation location.
2. In the window that opens, double-click to open the **TC-Python** folder.

   > This PC > Documents > Thermo-Calc > <version> > Manuals

   ![Folder structure]

   3. Double-click the **Index** HTML file (or any of the HTML files).

   ![Index file]

   4. The TC-Python API reference documentation opens as a searchable HTML file in your local browser. From here you can read about the **High level architecture** and search the **API reference** for information about the classes and methods.
Which TC-Python Installation Should I Choose?

A license is required to run TC-Python. Also remember to review the System Requirements page on our website.

There are these options to install TC-Python.

See the Videos about TC-Python page additional learning resources.

Install with the Bundled Python-interpreter

This is a straightforward installation where TC-Python is preinstalled together with some popular Python packages.

This is the recommended option for new users to TC-Python who may only want to run the examples. The available preinstalled packages (e.g. numpy, scipy, scikit-learn, and matplotlib) can also be sufficient for many advanced users.

"Installing TC-Python with a Bundled Python-interpreter" on the next page.

Install with a Python-interpreter of Your Choice

This installation requires additional steps and is the recommended option for more advanced use and has full flexibility.

"Installing TC-Python Into a Python-interpreter of Your Choice" on page 8.
Installing TC-Python with a Bundled Python-interpreter

TC-Python can be installed using a Python-interpreter that is bundled to Thermo-Calc. This interpreter has TC-Python preinstalled together with some popular Python packages. This is the recommended option for new users to TC-Python who may only want to run the examples. The available preinstalled packages (e.g. numpy, scipy, scikit-learn, and matplotlib) can also be sufficient for many advanced users.

The bundled interpreter package is also used to run the Property Models in Thermo-Calc. Do not make changes to interpreter packages or this can stop Thermo-Calc from working correctly. To fix issues caused by changes to an interpreter, completely uninstall Thermo-Calc and start over, either with the bundled interpreter package or using interpreters of your choice.

If you are planning to do more advanced calculations, that require other external packages you may want to follow these instructions instead: "Installing TC-Python Into a Python-interpreter of Your Choice" on page 8

Limitations

The following examples cannot be run with the bundled Python-interpreter as additional packages are required: pyex_M_01_Input_from_file.py (pandas) and pyex_M_02_Output_to_file.py (pandas, lxml, h5py).

The bundled Python 3.7.2 interpreter contains the following major packages.

If you have recommendations for additional packages to include (see below), send an email to Thermo-Calc Support.

<table>
<thead>
<tr>
<th>Package</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>matplotlib</td>
<td>3.3.2</td>
</tr>
<tr>
<td>numpy</td>
<td>1.19.2</td>
</tr>
</tbody>
</table>
### Step 1. Install an IDE (Integrated Development Environment)

Any editor can be used to write the Python code, but an IDE is recommended, e.g. PyCharm. These instructions are based on the use of PyCharm.

Use of an IDE will give you access to code completion, which is of great help when you use the API as it will give you the available methods on the objects you are working with.

2. Click to choose your OS and then click **Download**. You can use the **Community** version of PyCharm.
3. Follow the instructions. It is recommended you keep all the defaults.

For Mac installations, you also need to set some environment variables as described below in "macOS: Setting Environment Variables" on page 13.

### Step 2. Configure PyCharm to use the bundled Python-interpreter

Open PyCharm and configure the interpreter:

1. Go the menu **File → Settings**.
2. Navigate in the tree to **Project: YourProjectName** and choose **Project Interpreter**.
3. Click on the settings symbol close to the **Project Interpreter** dropdown menu and choose **Add**.
4. Select **System Interpreter** and add the bundled Thermo-Calc Python 3 interpreter,
which is located in a folder based on the operating system:

<table>
<thead>
<tr>
<th>Operating system</th>
<th>Path to the bundled Python-interpreter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows</td>
<td>C:\Program Files\Thermo-Calc\2021a\python\python.exe</td>
</tr>
<tr>
<td>Linux</td>
<td>/home/UserName/Thermo-Calc/2021a/python/bin/python3</td>
</tr>
<tr>
<td>macOS</td>
<td>/Applications/Thermo-Calc-2021a.app/Contents/Resources/python/bin/python3</td>
</tr>
</tbody>
</table>

5. Select the interpreter and confirm.

*Step 3. Run a TC-Python Example*

It is recommended that you open one or more of the included examples to both check that the installation has worked and to start familiarizing yourself with the code.

*Open the TC-Python Project in PyCharm*

When you first open the TC-Python project and examples, it can take a few moments for the Pycharm IDE to index before some of the options are available.

1. Open PyCharm and then choose **File → Open**. The first time you open the project you will need to navigate to the path of the TC-Python installation based on your operating system.
2. Click the **Examples** folder and then click **OK**.
3. From any subfolder:
   - Double-click to open an example file to examine the code.
   - Right-click an example and choose **Run**.

If you are not following the recommended approach and create a new project (**File → New Project...**), you need to consider that by default the options to choose the interpreter are hidden within the **Create Project** window. For this, click **Project Interpreter: New Virtual Environment** and in most cases choose your **System Interpreter** containing the Python bundled to Thermo-Calc instead of the default **New Virtual Environment**.
Installing TC-Python Into a Python-interpreter of Your Choice

TC-Python can be installed using a Python-interpreter of your choice. This is the recommended option for any more advanced usage and provides full flexibility.

If you are new to TC-Python and perhaps mainly want run the examples then it is recommended you install the bundled Python-interpreter. The available preinstalled packages (e.g. numpy, scipy, scikit-learn, and matplotlib) can also be sufficient for many advanced users. See "Installing TC-Python with a Bundled Python-interpreter" on page 5.

Step 1. Install a Python Distribution

If you already have a Python distribution installation, version 3.5 or higher, skip this step.

These instructions are based on using the Anaconda platform for the Python distribution. Install version 3.5 or higher to be able to work with TC-Python, although it is recommended that you use the most recent version.

Install Anaconda

2. Click to choose your OS (operating system) and then click Download. Follow the instructions. It is recommended you keep all the defaults.

Step 2. Install Thermo-Calc and the TC-Python SDK

TC-Python is available starting with Thermo-Calc version 2018a.

1. Install Thermo-Calc.
2. When the installation is complete, open the TC-Python folder that includes the *.whl file needed for the next step. There is also an Examples folder with Python files you can use in the IDE to understand and work with TC-Python.
### Installing TC-Python Into a Python-interpreter of Your Choice

<table>
<thead>
<tr>
<th>Operating system</th>
<th>Path to the TC-Python folder</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows</td>
<td>C:\Users\UserName\Documents\Thermo-Calc\2021a\SDK\TC-Python</td>
</tr>
<tr>
<td>Linux</td>
<td>/home/UserName/Thermo-Calc/2021a/SDK/TC-Python</td>
</tr>
<tr>
<td>macOS</td>
<td>/Users/Shared/Thermo-Calc/2021a/SDK/TC-Python</td>
</tr>
</tbody>
</table>

**Step 3. Install TC-Python**

#### Updating to a Newer Version

On Windows, it is recommended you use the Anaconda distribution prompt (i.e. Anaconda), especially if you have other Python installations.

> Do not use Virtual Environments unless you have a good reason to do so. Also see "Fixing Potential Issues with the Environment" on page 14.

1. Open the command line. For example, in Anaconda on a Windows OS, go to **Start → Anaconda → Anaconda Prompt**.

   ![Anaconda Prompt](image)

   ```cmd
   (base) C:\Users\amanda> ...
   ```

2. At the command line, enter the following. Make sure there are no spaces at the end of the string or in the folder name or it will not run:

   ```bash
   pip install <path to the TC-Python folder>/TC_Python-<version>-py3-none-any.whl
   ```
On Linux, and depending on the interpreter, typically `pip3` is used.

3. Press <Enter>. When the process is completed, there is a confirmation that TC-Python is installed.

If your computer is located behind a proxy-server, the default `pip` command will fail with a network connection error. In that case you need to install the dependency `py4j` in a special configuration:

```
pip install -proxy user:password@proxy_ip:port py4j
```

Go to the TC-Python Help Troubleshooting section for detailed information. This can be found on our website or from the installed documentation where you can search for "pip install fails".

**Step 4. Install an IDE (Integrated Development Environment)**

Any editor can be used to write the Python code, but an IDE is recommended, e.g. PyCharm. These instructions are based on the use of PyCharm.

Use of an IDE will give you access to code completion, which is of great help when you use the API as it will give you the available methods on the objects you are working with.

2. Click to choose your OS and then click Download. You can use the Community version of PyCharm.
3. Follow the instructions. It is recommended you keep all the defaults.

For Mac installations, you also need to set some environment variables as described below in "macOS: Setting Environment Variables" on page 13.

**Step 5. Open the IDE and Run a TC-Python Example**

After you complete all the software installations and set up the pip install path, you are ready to open the IDE to start working with TC-Python.

It is recommended that you open one or more of the included examples to both check that the installation has worked and to start familiarizing yourself with the code.
Open the TC-Python Project in PyCharm

When you first open the TC-Python project and examples, it can take a few moments for the Pycharm IDE to index before some of the options are available.

1. Open PyCharm and then choose File → Open. The first time you open the project you will need to navigate to the path of the TC-Python installation based on your operating system.
2. Click the Examples folder and then click OK.
3. From any subfolder:
   - Double-click to open an example file to examine the code.
   - Right-click an example and choose Run.
Updating to a Newer Version

If you are using the bundled Python-interpreter automatically installed with Thermo-Calc, these steps are not required.

These steps are required if you have previously followed the instructions in "Installing TC-Python Into a Python-interpreter of Your Choice" on page 8.

When updating to a newer version of Thermo-Calc, you always need to also install the latest version of TC-Python. It is not sufficient to run the installer of Thermo-Calc (except for bundled versions of the Python interpreter).

```
pip install <path to the TC-Python folder>/TC_Python-<version>-py3-none-any.whl
```

In case of problems you may wish to uninstall the previous version of TC-Python in advance:

```
pip uninstall TC-Python

pip install <path to the TC-Python folder>/TC_Python-<version>-py3-none-any.whl
```

However, this should not normally be required.

On Linux typically `pip3` is used.

You can check the currently installed version of TC-Python by running:

```
pip show TC-Python
```
In order to use TC-Python on Mac you need to set some environment variables.

```
TC21A_HOME=/Applications/Thermo-Calc-2021a.app/Contents/Resources
```

If you use a license server:

```
LSHOST=<name-of-the-license-server>
```

If you have a node-locked license:

```
LSHOST= NO-NET
LSERVRC=/Users/Shared/Thermo-Calc/lservrc
```

In PyCharm, you can add environment variables in the configurations.

Select **Run → Edit Configurations** to open the **Run/Debug Configurations** window. Enter the environment variable(s) by clicking the button to the right of the **Environment Variables** text field. Now the environment variables(s) will be set for each new configuration by default. The same way for configuring the environment variables can be used on other operating systems as if necessary.
Fixing Potential Issues with the Environment

In most cases you should run TC-Python within your global Python 3 interpreter and not use Virtual Environments unless you have a good reason to do so. If there are problems with the interpreter settings, you can resolve them in the Settings window:

1. Go the menu File → Settings.
2. Navigate in the tree to <Project.YourProjectName> and choose Project Interpreter.
3. Click on the settings symbol close to the Project Interpreter drop-down menu and choose Add.
4. Now choose System Interpreter and add your existing Python 3 interpreter.
5. Select your added interpreter and confirm.

If you are not following the recommended approach and create a new project (File→New Project...), you need to consider that by default the options to choose the interpreter are hidden within the Create Project window. For this, click Project Interpreter: New Virtual Environment and in most cases choose your System Interpreter containing the Python bundled to Thermo-Calc instead of the default New Virtual Environment.

If you really need to use a Virtual Environment, it is recommended you review the hints provided in the Best Practices section in the full TC-Python HTML help or PDF.
TC-Python Diagnostic Script

A diagnostic script is available as a Miscellaneous example (diagnostics.py) as well as in the Troubleshooting section of the TC-Python guide. Information about the script is also available on our website. The script automatically prints useful suggestions that, in many cases, will help you to fix the problem yourself. If you are unable to solve the problem, contact us for support.

It is important to run the diagnostic script EXACTLY the same way as you run your TC-Python script (in the same IDE, same project, same Python environment, same Jupyter notebook, etc).

The script automatically prints useful suggestions that, in many cases, will help you to fix the problem yourself. If you are unable to solve the problem, contact us for support.