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Installing Thermo-Calc
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Key to Using this Guide

4
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About the Thermo-Calc Components To Be Installed

7

System Requirements and Platforms Tested

8
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Key to Using this Guide
This installation guide is for all Thermo-Calc installations running on Windows, macOS or Linux
operating systems. It is also applicable to demo (trial) installations as well as previously
installed versions of Thermo-Calc (the new version is installed alongside the old version).
This guide includes information about:
The types of licenses and installations available.

l

Installing the Thermo-Calc software and its components on stand-alone computers,
servers and client computers.

l

l

Installing the license management software for network installations.

l

Retrieving and installing license files.

l

Troubleshooting to solve common installation problems.

ICONS IN THIS GUIDE
Name

Description

Information

Provides important information and indicates that more detail is
located in the linked or named topic.

Note

The information can be of use to you. It is recommended that you
read the text or follow the link.

Operating system

License file

Thermo-Calc

The operating system is indicated when the information is specific to a Windows,
macOS or Linux operating system.
The license file, which contains the license keys and is installed on either a
standalone computer or a network server.
The Thermo-Calc software and its components (including databases) to be installed.

TYPOGRAPHICAL CONVENTIONS
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Convention

Definition

Forward
arrow →

The forward arrow symbol → instructs you to select a series of menu items in a specific
order. For example, Tools → Options is equivalent to: From the Tools menu, select Options.

Boldface font

A boldface font indicates that the given word(s) are shown that way in on a toolbar button
or as a menu selection. For example, if you are told to select a menu item in a particular
order, such as Tools → Options, or to click Save.

Italic font

An italic font indicates the introduction of important terminology. Expect to find an
explanation in the same paragraph or elsewhere in the guide.

code
bold

and code

A code font indicates you are to make a keyboard entry. It also shows a programming code
or code examples. The code bold font highlights the entry.

Installation Terminology
Term

Definition

client

A computer without a license file of its own but connected through the network to a
computer with the license information. The client receives a license token from the
computer where the license management software is installed.

consolidated
network

A type of network installation where the Thermo-Calc software and a Thermo-Calc licensing
software are installed on a single server computer. This allows all computers in the network
to access both the software and a license on the server via a client installation.

distributed
network

A type of network installation where the Thermo-Calc software is installed on one server
computer in a network and the Thermo-Calc licensing software is installed on a different
computer. After a thin client installation, all computers in the network can access both the
software and the network license key via the server.

host ID

The MAC address on the computer that a license is locked to.

license file

The file (called lservrc) that contains all the purchased license keys. It is issued by Thermo-Calc
Software, usually by email.

license key

The information contained in the license file that represents the products purchased and
which is then authorised for installation.
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Term

Definition

License
Manager
(Windows)

The Windows program used for license management: it distributes license tokens as specified
in the network license file issued by Thermo-Calc Software.

License
Server
(Linux)

The Linux program used for license management: it distributes license tokens as specified in
the network license file issued by Thermo-Calc Software.

license
server

The use of the term license server (lower case letters) is reserved for use for scripts and
option files (for example, in an Unattended Network Client Installations). For the purposes of
the step-by-step instructions it is not used to refer to the type of network installation that runs
the license management program. Also see License Manager (Windows) and License Server
(Linux).

licensing
software

The Thermo-Calc license management software. When working in Windows it is called
License Manager (full name is Sentinel RMS License Manager by SafeNet) and on Linux it is
called License Server (full name is Sentinel License Sever by Safenet).

Network
License
(NWL)

The license type used with the licensing software. The NWL can only be used on one specific
computer that hosts the licensing software. This restricts license usage to a certain subnet or
subnets.
The software may be used on the number of sites you have paid for and by the number of
persons you have paid for on any number of network connected computers

standalone
computer

A computer which uses a SUNLL license type.

Single-UserNode
LockedLicense
(SUNLL)

A unique license file for one designated computer at one designated site. It cannot be copied
or moved outside the site. If the software is installed on a portable computer, it can be
temporarily used off-site. The license can be used without network access (to the License
Server).

thin client

An installation where the software is installed on a file server but is run from a client
computer. The licensing software may be installed on the file server (consolidated network
installation) or on a different computer (distributed network installation).

XQuartz

An open-source X Windows System, which is required to run Thermo-Calc on a Mac.
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About the Thermo-Calc Components To Be Installed
What is installed with a Full Standalone or Full Network Client Option?
At the start of the installation process, the following components are installed when you choose
either the Full Standalone or Full Network Client options. If you want to exclude a component
(perhaps one of the SDKs), then you would use the Custom option.

A full installation means that all listed feature components are installed but the availability of
the individual components is based on the license you have. This is also applicable to the
databases and software development kits (SDKs).
Thermo-Calc
The Thermo-Calc software includes several add-on features and capabilities that are packaged
with the software and included with a full standalone or network client installation. For
example, there are the specialized add-on products Diffusion Module (DICTRA), Precipitation
Module (TC-PRISMA), and Process Metallurgy Module as well as the Steel Model Library. For
most of these specialized features, demonstration (demo) versions and examples area available
for all users but advanced features are only available with a license.
Databases
All the latest databases are installed. As with the software features, availability of a specific
database in the software itself is based on license. However, several demonstration
(demo) databases are included and available to all users.
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Software Development Kits (SDKs)
When the Full Standalone or Full Network Client option is chosen, it installs the TC-Python,
TC-API and TQ-Interface SDKs. It does not install TC-Toolbox for MATLAB® (available only for
Windows) unless the program finds a MATLAB® installation on your computer during this
installation process, at which point you are asked if this component should be also be installed.
The TC-Python program is installed when the Full Standalone or Full Network Client option is
chosen, but there are additional steps required to complete the installation as described
separately in the TC-Python Quick Installation Guide.

What does the Custom option allow me to do during an installation?
During the installation process, there is some flexibility to choose what to include or exclude
with the installation by choosing the Custom option. This is primarily to the level of being able
to choose the SDKs or to exclude all databases or Thermo-Calc itself. That is, you cannot choose
specific Thermo-Calc features or databases as these are controlled by the license and not the
installation procedure.

System Requirements and Platforms Tested
About the Thermo-Calc Components To Be Installed
A full list of system requirements and program availability are found on the Thermo-Calc
website. You can also see our roadmap for platform support to use for planning purposes. The
software development kits (SDKs) are available as follows for the indicated platforms:
SDK

Windows

Mac

Linux

TC-Python

x

x

x

TQ-Interface

x

not available

x
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SDK

Windows

Mac

Linux

TC-API

x

not available

x

TC-Toolbox for MATLAB®

x

not available

not available

Thermo-Calc and its components are tested on these platforms for Thermo-Calc 2020a:
Platforms Tested by Operating System
Windows

Mac

Windows 10 64-bit

macOS X Catalina
10.15.1

Linux1, 2
l

Ubuntu 19.04 (Disco)

l

CentOS 7.6

l

OpenSUSE 15.0

1 Thermo-Calc Software cannot guarantee full functionality if the software is installed on other Linux distributions.
2 If you are installing on CentOS 7, it is recommended you install gtk2 before you run the installation script.
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License and Installation Types
In this section:
License and Installation Types

11

About License Keys and Files

11

Standalone Installations (SUNLL)

12

Multi-User Network Installations (NWL)

12
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License and Installation Types
Installation procedures are based on the license type, the installation type and the operating
system.
Demo (trial) installations: Only a standalone installation is available and a license
file is automatically installed.
License
type
SUNLL

NWL

1

Installation Type

Windows

macOS

Linux

Standalone

Yes

Yes

Yes

Consolidated network

Yes

No

Yes

Distributed network

Yes

No

Yes

License installations on a server
network

Yes

Yes1

Yes

For macOS, the licensing software is installed on a Windows or Linux computer server.
www.thermocalc.com/purchase/licensing-options/

About License Keys and Files
Demo (trial) installations: A license file is automatically installed with the
software. You do not need to request it.
To run Thermo-Calc and its components you need a valid license key for each product. The
license keys are included in the license file emailed to you by Thermo-Calc Software.
You can copy the license file to the applicable computer(s) before or after installing the
software––the license file itself is not required during the installation process. However, it is
required to make calculations in Thermo-Calc.
Request a License File from Thermo-Calc Software
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Standalone Installations (SUNLL)
The standalone installation is used with the Single-User Node-Locked License (SUNLL). The
Thermo-Calc software
and a Thermo-Calc license file
are installed on a standalone
computer. You can do a full (all operating systems) or a custom installation (Windows and Linux
only).

To get started, go to First Steps of Installation and then Standalone Installations.

Multi-User Network Installations (NWL)
There are different types of multi-user network installations: consolidated, distributed and
where the licensing software is installed on a computer network. There is also a subtype of
installation called thin client, which is a step done with the consolidated and distributed
network installations.
Thin client installations: A thin client installation is where the Thermo-Calc
software is installed on a computer server but is run from a client computer. The
licensing software can be installed on the computer server (a consolidated
network) or on a different computer (a distributed network). This type of
installation is available for Windows and Linux operating systems. The client
computer must have the Thermo-Calc software installed. This type of installation
mainly sets environmental variables and paths on the client computer.

Consolidated Network Installations
The consolidated network installation is used with a Network License (NWL) and it is available
for Windows and Linux operating systems.
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The Thermo-Calc software

and the license management program are installed on the same

server where the license file
is also copied. A thin client installation allows all computers
(the clients) in the server network to access both the software and the licensing on the same
computer server.
To get started, go to First Steps of Installation and then Network Client Installations.

Distributed Network Installations
The distributed network installation is used with a Network License (NWL) and is available for
Windows and Linux operating systems.
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The Thermo-Calc software

is installed on one computer server in a network and the

licensing software is installed on a different computer server where the license file
is also
copied. A thin client installation allows all computers (the clients) in the server network to
access both the software and the licensing on the two computer servers.
To get started, go to First Steps of Installation and then Network Client Installations.

License Installations on a Server Network
When a license file is installed on a server network, it is used with a Network License (NWL). It
is available for all platforms. However, for macOS the server containing the licensing software
must be set up on Windows or Linux.

The licensing software is installed on a computer server where the license file
copied. The Thermo-Calc software
it.

is also

is installed on every computer in the network that needs

To get started, go to First Steps of Installation and then Network Client Installations.
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Preparing for Installation
In this section:
First Steps of Installation

16

Default Directory Installation Locations

16

Subnet Information for Network Licenses

22

macOS Installation Notes

22

Linux Installation Notes

23
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First Steps of Installation
This section reviews some of the things you need to do before installing the Thermo-Calc
software.
l

Learn about the default directories where the software and license files are installed.

l

For network installations, collect subnet information.

l

For Mac, install XQuartz and make sure the security preferences are set correctly.

l

For a Linux Cent OS 7 installation, also install gtk2 before you run the installation script.
yum install gtk2

Should I get my license file before or after software installation? The license file
itself is not required during the installation process (and not at all for demo
installations). However, it is required to make calculations in Thermo-Calc. The
license file has details about your computer(s) that in some cases cannot be
determined accurately until after installation (especially for a network installation).
For most users it is recommended you request the file before you start installing.

Default Directory Installation Locations
The default directories where the software and its components are installed, including where
the license file is stored, vary by platform and user type.
If you want to select specific components to install or if you want to install the software in a
non-default installation directory, then do a custom installation (Windows and Linux only). In
the table, <user> stands for the user name and <version> for the version of Thermo-Calc, for
example 2020a.

Thermo-Calc Default Directory Locations

LICENSE FILE - ALL OPERATING SYSTEMS
The license file is installed outside of the installation program folder. If you have more than one
version of Thermo-Calc installed then there will be additional folders here and one license file.
On a Mac the license file is put in /Users/Shared/Thermo-Calc. The example below is for a
Standalone Windows installation.
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WINDOWS
Windows user type

Default directory
The Thermo-Calc program is installed here:
Program Files\Thermo-Calc\<version>

The documents, materials, examples and other folders that sometimes require
additional licenses are installed here:
C:\Users\Public\Public Documents\Thermo-Calc\<version>

Administrator

A copy of the documents, materials, examples and more are then placed here:
C:\Users\<user>\Documents\Thermo-Calc\<version>

It is recommended that you work with the files that are copied
to the user folder.

License software
installations on a server
network (the License
Manager software)

C:\Program Files (x86)\Common Files\SafeNet Sentinel\Sentinel RMS
License Manager\WinNT\
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MAC
Mac user type

Default directory
The Thermo-Calc program is installed here in the Applications folder:
Thermo-Calc-<version>.app, Thermo-Calc-<version>-Demo.app, and,
uninstall-Thermo-Calc-<version>.app

Administrator (user name and
password required)

The documents, materials, examples and other folders that sometimes
require additional licenses are installed here:
/Users/Shared/Thermo-Calc/<version>

To go to this folder, in Finder, from the Go main menu select Go to folder.
Enter the above file path and click Go.

LINUX
Linux user type

Non root user

Default directory
The Thermo-Calc program including the documents, materials, examples
and other folders that sometimes require additional licenses are installed
here:
/home/<user>/Thermo-Calc/<version>

Root user

The Thermo-Calc program including the documents, materials, examples
and other folders that sometimes require additional licenses are installed
here:
/opt/Thermo-Calc/<version>

License software installations
on a server network (the
License Server software)

If you are doing a network installation then these files are available as a tarfile from the Thermo-Calc Software web site.
In the downloaded tar-file, there is a restart_lserv script file, which can be
used as a template for creating a script that starts up the License Server.

DATABASES
The standard Thermo-Calc databases and the database initialization file tc_initd.tdb are
located in a subfolder to the Thermo-Calc installation. For example, in a Windows Standalone
installation, you can find these in a folder called data where the file path is C:\Program
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Files\Thermo-Calc\<version>\data.

TC-TOOLBOX FOR MATLAB
Examples for the TC-Toolbox are placed under MATLAB® in the same documents folder as the
Thermo-Calc files (Documents folder):
..\Documents\MATLAB\Thermo-Calc-Toolbox-X\Examples

Where X is the installed version number of the toolbox.
For most installations the examples are available in the MATLAB window when the software is
opened.

DATABASE CHECKER PROGRAM
The Thermo-Calc software package includes a program to check that the syntax of unencrypted
database files is correct. The program applies the syntax rules set out in the Database Manager
User Guide and reports errors and issues warnings. This program is intended for advanced users
who develop and manage databases.
Thermo-Calc accepts deviations from these syntax rules. This means that a
database can work even if the Database Checker reports errors and warnings. For
example, an error is reported if an abbreviated phase name is found, but phase
name abbreviations are accepted by Thermo-Calc and its add-on modules.
The executable DatabaseChecker file is found in the Thermo-Calc home directory. The
program can also be launched by selecting Tools→ Database Checker from the main menu.

MATERIALS
When you are working with the System Definer you can open the default Materials folder
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included with your installation.
At the bottom of the window under Material, click Load material to navigate to a material file.
There is a separate folder for materials saved using the Process Metallurgy
Calculator. See Process Metallurgy Materials.

The default directory where these files are stored is based on operating system:
Operating
system
Windows

Linux

Materials installation directory
C:\Users\<user>\Documents\Thermo-Calc\2020a\Materials

On Linux all user files are installed where the program is installed. If installed as root
the default is:
/opt/Thermo-Calc/2020a/Materials

Mac

/Users/Shared/Thermo-Calc/2020a/Materials

CUSTOM PROPERTY MODELS
All property models (whether these are predefined or custom models) must be
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located in a subdirectory of the property model directory. You can go to Tools →
Options and the Model directory field displays the default directory.

Predefined models included with the Property Model Calculator are installed in the locations
below based on your operating system. If you create your own models, this is the default
directory where these are saved. You can also use one of these as a template to create your
own property model.
Operating
system
Windows

Linux

Property model installation directory
C:\Users\<user>\Documents\Thermo-Calc\2020a\PropertyModels

On Linux all user files are installed where the program is installed. If installed as root
the default is:
/opt/Thermo-Calc/2020a/PropertyModels

Mac

/Users/Shared/Thermo-Calc/2020a/PropertyModels

PROCESS METALLURGY MATERIALS
With the Process Metallurgy Calculator you can save materials to work with again. This is the
default folder where these are stored based on your operating system:
Operating
system
Windows

Linux

Process Metallurgy Materials installation directory
C:\Users\<user>\Documents\Thermo-Calc\2020a\ProcessMetallurgyMaterials

On Linux all user files are installed where the program is installed. If installed as root
the default is:
/opt/Thermo-Calc/2020a/ProcessMetallurgyMaterials

Mac

/Users/Shared/Thermo-Calc/2020a/ProcessMetallurgyMaterials
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Subnet Information for Network Licenses
For network licenses, the subnet information is also required. Ask your network administrator
for the network address for the subnet. Additional requirements are included elsewhere for
network installations.
l

l

Subnets should be in the format aaa.bbb.ccc*** (for example: 192.168.29.0/24 or
192.168.29.*
A maximum of six subnets are permitted.

An alternative way to get this information is to run the command:
l

Windows:ipconfig

l

Mac/ Linux: ip

/all

a

macOS Installation Notes
RESTARTING AFTER AN INSTALLATION
In some types of installations (e.g. a network installation), you may have to restart your Mac to
use Thermo-Calc for the first time.

INSTALLING XQUARTZ
The XQuartz open-source X Windows system is required to run Thermo-Calc on macOS X but it
is not required to install Thermo-Calc. Before installing Thermo-Calc, you may also need to
ensure that the computer security permissions are set.
1. In a web browser go to https://www.macupdate.com or to download it directly from
XQuartz, http://xquartz.macosforge.org/landing/.
2. In the Search Mac Apps field, enter XQuartz.
3. Click the XQuartz search result. For example, based on the recent version, the name is
XQuartz-2.7.7.dmg.
4. Click Download.
5. Double-click the XQuartz.pkg file. Follow the instructions.
6. Click OK when the message about logging out displays and click Close when the
installation is successful.

ENABLING THE SECURITY SETTINGS
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1. From the Apple main menu, select System Preferences.
2. Click Security and Privacy.
3. Click General. At the bottom of the Security & Privacy window, click the lock icon to make
changes. Enter the administrator password as required.
4. If you have already tried to launch the Thermo-Calc installer, you can click Open Anyway
to proceed. Otherwise, under Allow apps downloaded from: click Anywhere and then
Allow from Anywhere.
5. Continue with the applicable installation type (standalone or network).
Remember to reset your security after installing Thermo-Calc.

Linux Installation Notes
The following are details you need to know regarding your Linux installation as well as how to
open Thermo-Calc.

openSUSE Administration (sudo) Users
Note the following if you are a sudo user (administrator) in openSUSE installing Thermo-Calc
using this command:
sudo ./linux-installation-x64-6.0.0.17347.run

When this command is used, you will do a text-based installation instead of having a graphical
interface to guide you. The information is the same, just without the user interface.

Opening Thermo-Calc in Linux
To open Thermo-Calc double-click the Thermo-Calc-2020a application or from the Thermo-Calc
installation directory enter $ ./Thermo-Calc-2020a.sh in the terminal.

Linux Installation Notes ǀ 23 of 80

Thermo-Calc Installation Documentation Set

Standalone Installations
You can either do a full or a custom standalone installation. The license type is called a SingleUser Node-Locked License (SUNLL).
In this section:
Full Standalone Installations

25

Custom Standalone Installations

28

Add New Components to an Existing Installation

31
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Full Standalone Installations
The following describes a full standalone installation. These steps assume you have completed
the section First Steps of Installation.
Request your license file from Thermo-Calc Software
Demo (trial) installations: Skip this step. A license file is automatically installed
with the software. You do not need to request it.

Updates to Thermo-Calc: Customers who subscribe to the annual maintenance
plan can skip this step if you have received your license file in an email from
Thermo-Calc Software AB. Save the license file to your computer to use during
software installation. The license file name must be the same as the existing file
name to ensure there are no errors during the update.
Follow the instructions for your operating system in the section Request a License File from
Thermo-Calc Software.
Download your Thermo-Calc installation software
l

l

Web downloads: For web links sent in an email from Thermo-Calc Software, go to the
URL and log in with the information provided to download the software.
DVD installations: Insert the DVD and follow the instructions.

Run the applicable installation file for your operating system
1. Navigate to the folder for your operating system and click the link to download the
software package, then go to the folder where you downloaded it.

Administrative rights are required for Windows and Mac installations.

WINDOWS
Right-click the .exe file and choose Run as administrator to launch the Setup program.
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MACOS
Double-click the downloaded file then follow the instructions.

For macOS and when you first run the installer, you may see a message that
Thermo-Calc-osx-<version> can't be opened because Apple cannot check it for
malicious software. If this happens, select Show in Finder. Then, in the opened
Finder window right-click the downloaded file Thermo-Calc-osx-<version> and
select Open.

LINUX
To start the Setup Wizard in a Terminal window, enter these commands in the directory where
the installation file is saved:
> chmod +x linux-installation-x64-2020a.run
> ./linux-installation-x64-2020a.run

If you are an openSUSE root user, see Linux Installation Notes for some information
about your installation.
2. On the Setup window click Next.
3. On the License Agreement window click the button to accept the license agreement
then click Next.
Demo (trial) installations: Your installation starts and is done when the
Completing the Thermo-Calc Demo Setup Wizard opens. Click Finish and start
using Thermo-Calc.
Select the installation type and upload the license file
About the Thermo-Calc Components To Be Installed
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1. In the Select Installation Mode window click Full Standalone: Install all features.

If you want to exclude a component (perhaps one of the SDKs), then you
would use the Custom option. See Custom Standalone Installations.

When the Full Standalone or Full Network Client option is chosen, it
installs everything except the TC-Toolbox for MATLAB® (available for
Windows only). However, if the program finds a MATLAB® installation on
your computer during this installation process, you are prompted if this
component should be also be installed.

The TC-Python program is installed when the Full Standalone or Full
Network Client option is chosen, but there are additional steps required as
described separately for this SDK.
2. For a Full Standalone installation, in the Choose a license file field either enter the file
path or click the file button
to navigate to where you saved the license file emailed
to you from Thermo-Calc Software. The license file is called lservrc. Click Next.

To prevent errors, leave this field blank if you did not get a license file yet.
3. TC-Python is installed for all users even if you do not have a license. The Install TCPython window is a reminder that additional installation procedures are required after
Thermo-Calc is installed. Click Next.
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Install the software and start using Thermo-Calc
1. In the Ready to Install window click Next.
2. Click Finish and start using Thermo-Calc. For Linux users, log out and log back in
to finish the installation and start using Thermo-Calc.
macOS installations and if you have previous Thermo-Calc installations:
When you launch Thermo-Calc with the new or updated version, the splash
screen hides the Import User Settings dialog box. In order to proceed you
need to click the splash screen and then click Yes or No in the dialog box.

If you did not get your license file see Request a License File from Thermo-Calc
Software.

Custom Standalone Installations
About the Thermo-Calc Components To Be Installed
Use the Custom option if you want more control over what component features to include or
exclude, for example use it to exclude an SDK.
This topic describes how to do a custom installation on a standalone computer for either a
Windows or Linux operating system. These steps assume you have completed these sections:
l

l

First Steps of Installation
Steps 1 to 3 of a Full Standalone Installations where you request your license file,
download the software and then have started to set up the program up to the Select
Installation Mode window.

Select the installation mode and what components to include or exclude
About the Thermo-Calc Components To Be Installed
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1. In the Select installation mode window click Custom (the option appears greyed out,
but it is available to select). Click Next.

2. On the Specify Configuration window the Create Shortcuts on Desktop check box is
selected by default. Click Next.
3. In the Select Components window, click to deselect the check boxes as needed. Click
Next.

Set the installation directory and choose the license file
1. In the Installation Directory window, either accept the default path or enter a path to
where you want to install the software (see Default Directory Installation Locations).
Click the file button to Browse for Folder and navigate to another directory. Click
Next.
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To prevent errors, leave this field blank if you do not have a license file yet.

For the Windows TC-Toolbox for MATLAB® component, and if you get a
MATLAB not found message, enter the MATLAB® installation directory and
click Next.
2. In the Choose Setup Type window, click Standalone.

3. In the Choose a license file field enter the path to your license file (called lservrc) or
click the file button to navigate to a location on the computer and open the file. Click
Next.
4. If TC-Python is selected to be installed, the Install TC-Pythonwindow is a reminder that
additional installation procedures are required after Thermo-Calc is installed. Click
Next.
Install the software and start using Thermo-Calc
1. In the Ready to Install window click Next.
2. Click Finish and start using Thermo-Calc. For Linux users, log out and log back in to
finish the installation and start using Thermo-Calc.
macOS installations and if you have previous Thermo-Calc installations: When you
launch Thermo-Calc with the new or updated version, the splash screen hides the
Import User Settings dialog box. In order to proceed you need to click the splash
screen and then click Yes or No in the dialog box.
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If you did not get your license file see Request a License File from Thermo-Calc Software.

Add New Components to an Existing Installation
If you want to add new components to an existing Thermo-Calc installation (for example, you
purchased a license for TC-Python), run the installation file again as in Step 3 of Full Standalone
Installations.
1. For all OS you need to have administrative level rights. For example in Windows, rightclick the executable Thermo-Calc installation .exe file and choose Run as administrator
to launch the Setup program.

2. Click Next. Click to accept the license agreement. Click Next.
3. Select the additional component(s) to install. Click Next.
4. Click Next to start the installation, which adds the new component(s).
Use the Uninstall program to remove components.
Uninstalling Thermo-Calc
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Network Client Installations
This installation type is available for all operating systems, however for macOS the License
Server must be run on a Windows or Linux computer. It is applicable to the consolidated and
distributed network types of installations as well as for the licensing installation on a server
network.
About the Thermo-Calc Components To Be Installed
In this section:
Full Network Client Installations

33

Set Up the License Manager on Windows

34

Set Up the License Server on Linux

36

Thin Client Installations

39

Custom Network Client Installations

40

Unattended Network Client Installations

43
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Full Network Client Installations
The following outlines how you do a full network client installation.
Install the licensing software
Follow the instructions for your operating system:
l

Set Up the License Manager on Windows, or

l

Set Up the License Server on Linux

Complete Steps 1 to 3 of a full standalone installation
These steps assume you have completed the instructions for Full Standalone Installations to
download and run the software up to the Select Installation Mode window. It is up to you
whether you get the computer information for the license files before or after installing the
software.
Choose the installation type and enter the computer server details
About the Thermo-Calc Components To Be Installed
1. In the Select Installation Mode window click Full Network Client to Install all features
(the option appears greyed out, but it is available to select).

If you want to exclude a component (perhaps one of the SDKs), then use the
Custom option and see Custom Network Client Installations.

2. In the field, enter the name or IP number of the computer where the licensing software
is installed. Click Next.

3. TC-Python is installed for all users even if you do not have a license. The Install TCPython window is a reminder that additional installation procedures are required after
Thermo-Calc is installed. Click Next.
4. In the Ready to Install window click Next.
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5. When the Completing the Thermo-Calc Setup Wizard window opens, click Finish.For
Linux users, log out and log back in to start using Thermo-Calc.
macOS installations and if you have previous Thermo-Calc installations:
When you launch Thermo-Calc with the new or updated version, the splash
screen hides the Import User Settings dialog box. In order to proceed you
need to click the splash screen and then click Yes or No in the dialog box.

If you did not get your license file see Request a License File from Thermo-Calc Software.

Set Up the License Manager on Windows
License Manager vs License Server: Both terms refer to the licensing software
program installed on a network computer. License Manger is for Windows and
License Server is for Linux. See Installation Terminology for more information.

Installation Requirements
This procedure explains how to install the License Manager on a computer that acts as a license
server in your network. It is a Sentinel RMS License Manager Windows service and it supplies
the client computers in your network with license tokens when it runs the Thermo-Calc
software. A network license can only be used on one specific computer that hosts the License
Manager. The network license determines which client computers receive license tokens using
their IP addresses and IP ranges.
l

l

l

For Mac installations, the server containing the license file must be set up on a Windows
or Linux computer.
For testing purposes, and in order to confirm the installation is working correctly, install
the Thermo-Calc software on the same computer as the Sentinel RMS License Manager.
Thermo-Calc can always be uninstalled after testing if required.
Administrator rights are required.
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Installing the License Manager on Windows
Install the Sentinel RMS License Manager software
1. Follow the instructions to download your Thermo-Calc installation software.
2. Open the directory for Windows and right-click the file Sentinel RMS License Manager
8.5.1.msi.
3. Select Save target as and choose a suitable directory so that you can easily find the file
later.
4. Right-click the downloaded file and choose Install. Click Next.
Choose the installation directory
1. Click to accept the license agreement. Click Next.
2. Enter your User Name and Organization and select to install the License Manager for
All users. Click Next.
3. In the Destination Folder window click Next to accept the suggested destination
directory or Change to select another directory. Click Next.
Choose the setup type and install the software
1. In the Setup Type window, select Complete. Click Next.
2. Select the Unblock the system firewall for the Sentinel RMS License Manager check
box.

Selecting the check box is required to run Thermo-Calc.

3. Click Next and then Install.
4. Click Finish to exit the InstallShield Wizard.
Copy the license files to the destination directory
1. Copy the network license file to the destination directory. By default, it is installed in the
following directory with the name lservrc.
C:\Program Files (x86)\Common Files\SafeNet Sentinel\Sentinel
RMS License Manager\WinNT\
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The name of the license file must be in lower case letters (lservrc). This is
especially important if both Windows and Linux operating systems are part
of your network; Linux commands and operations are case-sensitive.

If the default file path does not work, you can set the environmental variable
LSERVOPTS to select the license file:
a. In the Windows Control Panel, go to System → Advanced system settings.
b. In System Properties select Advanced → Environment Variables → New.
c. Enter the Variable name LSERVOPTS to specify the parameters with which the
License Manager is started.
d. To specify the path to the license file in the Variable value field enter the
following and include the complete license file path and name.
-s <license file path and name>

Reboot or restart the license manager

Set Up the License Server on Linux
License Manager vs License Server: Both terms refer to the licensing software
program installed on a network computer. License Manger is for Windows and
License Server is for Linux. See Installation Terminology for more information.

Installation Requirements
There are a variety of things needed to prepare for a Linux License Server installation. The
following points are described in this section.
l

l

l

You need to stop older versions of the License Server before running the new one. To
stop the license server you run lsrvdown .
Root access to your computer is required or you need to be on the sudoers list.
To run the License Server on a Linux 64-bit computer, you need to install 32-bit library
support. For example, on CentOS this can be done by running the command:
>yum install glib2.i686

l

You need a valid lservrc network license file supplied by Thermo-Calc Software and the
actual License Server—a file(program) called lserv.
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l

The name of the license file must be in lower case letters (lservrc) because
Linux commands and operations are case-sensitive.

l

l

The license file need to be read and writable by the license server(license manager)
If you have a license server; Upgrade your license server if the new one is a higher
version than the present one. Clients work with newer license servers(managers) but not
necessarily with ones older than client.

OPENSUSE

ADMINISTRATION (SUDO) USERS

Note the following if you are a sudo user (administrator) in openSUSE installing Thermo-Calc
using this command:
sudo ./linux-installation-x64-6.0.0.17347.run

When this command is used, you will do a text-based installation instead of having a graphical
interface to guide you. The information is the same, just without the user interface.
Installing the License Server on Linux
Stop any older versions of the License Server
Skip this step if this is a new installation.
1. To stop an old version of the License Server that is already running, go to the directory
where the old file is found, and enter the commands:
>chmod +x <lsrvdown>
>./lsrvdown <host_name>

2. Edit existing scripts that start the older version of the License Server so that they start
the newer version instead.
For more information about the lservdown utility, go to
http://sentinelrms.safenetinc.com/RMSDocumentation/SysAdmin/Content/lsrvdown.htm
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Write a script to start the License Server
The following is an excerpt from the template script for starting the License Server found in the
restart_lserv file.
Replace the paths for LICENSE_SERVER_DIR, LICENSE_FILE_DIR and LOG_DIR to match your
system. Save it as a script:
# set the directory where the executables are located
LICENSE_SERVER_DIR=/usr/local/Thermo-Calc/2020a/Licensing-files
# set the directory of the license file lservrc
LICENSE_FILE_DIR=/usr/local/Thermo-Calc/2020a/Licensing-files
# set the directory where you wish to save the log-files
LOG_DIR=/tmp
# stop the running server
# (omit this line if calling this script at startup)
$LICENSE_SERVER_DIR/lsrvdown $HOSTNAME
# start the license server
$LICENSE_SERVER_DIR/lserv -s $LICENSE_FILE_DIR/lservrc -l $LOG_DIR/lserv_use.log -f
$LOG_DIR/lserv_err.log

Confirm the HOSTNAME variable and open the UDP port
The hostname should always correspond to the DNS record verify this by doing the following.
1. Before starting the License Server make sure that the value of the $HOSTNAME variable
is correct. This value can be shown by typing the > nslookup $HOSTNAME command in
the terminal window:
The value should be the same IP address that is shown when you use the ifconfig
command.
2. Open the UDP port 5093 in your firewall. In case you have installed SELinux you might
also need to disable it by setting SELINUX=permissive in the /etc/selinux/config
file.
Start the License Server
1. To start the License Server, run the script created as root. Enter these commands in the
console:
> chmod +x <name_of_script_file>
> ./<name_of_script_file>
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2. If you want the License Server to start when you boot the system, put a copy of the start
script under /etc/rc.d/init.d and start the script from the file /etc/rc.d/rc.local.

Thin Client Installations
This topic describes how you install a thin Thermo-Calc client to run Thermo-Calc from a file
server. It is applicable to consolidated and distributed network installations for either a
Windows or Linux operating system.

INSTALLATION REQUIREMENTS
l

You need access to the directory where Thermo-Calc is installed on the file server.

l

You need the IP number or name of the computer where the license file is installed.

l

For Linux you may have to disable your firewall. If SELinux is installed, try disabling it by
setting SELINUX=permissive in /etc/selinux/config.

INSTALLING A THIN CLIENT ON WINDOWS
1. Map the file server share as a network drive so that it gets an assigned drive letter (e.g.
E:).
2. Open the \Thermo-Calc\<version>\ directory on the file server, where version is the
current version of the software.
3. Open the directory Thin-client. Double-click the Thermo-Calc-client-windows<version>.exe file.
4. Click to accept the terms of the license agreement. Click Next.
5. Enter the name or IP number of where the license file and the License Manager
software is installed. Click Next.
6. By default the Create Shortcuts on Desktop check box is selected. Click Next.
7. In the Ready to Install window, click Next.
8. Click Finish. To start Thermo-Calc find the program on the server and start it from
there.

INSTALLING A THIN CLIENT ON LINUX
1. Add the following to the smb.conf file, where <user> is your user name:
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[public]
path=/home/<user>/Thermo_Calc/2020a
public=yes
writable=yes
comment=smb share
guest OK=yes
force user=<user>

2. From the client, mount the directory on the server computer that contains the ThermoCalc server installation (by default, this directory is called /Thermo-Calc/2020a). How
the directory is mounted depends on the Linux distribution being used as well as how the
Thermo-Calc directory on the server computer is shared. Use the Linux command
mount. For example:
> mkdir public
> sudo mount -t cifs //ip_number_server_computer/public ./public -o
user=<user>

3. Open the mounted directory on your computer, and run client-install-linuxx64.run or client-install-linux-x86.run in the /Thin-client directory.
4. If you do this from the terminal window, use the following to start the installation
(assuming that the file server is a 64-bit computer):
> ./client-install-linux-x64.run
5. Click Forward and click to select the license agreement. Click Forward.
6. Enter the name or IP number of the License Server. Click Forward.
7. If you are installing as a non-root user, by default, the Create Shortcuts on Desktop
check box is selected. Click Forward.
8. In the Ready to Install window click Forward.
9. Click Finish. Log out and log back in to start using Thermo-Calc.

Custom Network Client Installations
This installation type is available for all operating systems, however for macOS the License
Server must be run on a Windows or Linux computer.The requirements are the same as for a
full client installation.
Install the licensing software
Follow the instructions for your operating system:
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l

Set Up the License Manager on Windows, or

l

Set Up the License Server on Linux

Complete Steps 1 to 4 of a full standalone installation
Follow the instructions for Full Standalone Installations to download and run the software. It is
up to you whether you get the computer information for the license files before or after
installing the software.
Select the installation mode and what components to include or exclude
About the Thermo-Calc Components To Be Installed
1. In the Select installation mode window click Custom (the option appears greyed out,
but it is available to select). Click Next.

2. On the Specify Configuration window the Create Shortcuts on Desktop check box is
selected by default. Click Next.
3. In the Select Components window, click to deselect the check boxes as needed. Click
Next.

Set the installation directory and the file path to the license
1. In the Installation Directory window, either accept the default path or enter a path to
where you want to install the software (see Default Directory Installation Locations).
Click the file button to Browse for Folder and navigate to another directory. Click
Next.
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To prevent errors, leave this field blank if you do not have a license file yet.

For the Windows TC-Toolbox for MATLAB component and if you get a
MATLAB not found message, enter the MATLAB® installation directory and
click Next.
2. In the Choose Setup Type window, click Network Client and enter the name or IP
number of the computer where the licensing software is installed. Click Next.

If you have selected to install TC-Python there is a reminder window that
additional installation procedures are required after Thermo-Calc is
installed. Click Next.
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Install the software and start using Thermo-Calc
1. In the Ready to Install window click Next.
2. Click Finish and start using Thermo-Calc. For Linux users, log out and log back in to
finish the installation and start using Thermo-Calc.
macOS installations and if you have previous Thermo-Calc installations: When you
launch Thermo-Calc with the new or updated version, the splash screen hides the
Import User Settings dialog box. In order to proceed you need to click the splash
screen and then click Yes or No in the dialog box.

If you did not get your license file see Request a License File from Thermo-Calc Software.

Unattended Network Client Installations
Terminology note: The use of the term license server (lower case letters) is
applicable to the option files as described in this section. For the purposes of the
step-by-step instructions it is not used to refer to the type of network installation
that runs the licensing software.
Sometimes it is convenient to install Thermo-Calc network clients without providing user input
after the installation is initiated (an unattended network client installation). This is available for
Windows and Linux operating systems.
Make sure you know the name or IP number of the computer where the licensing
software and the license file are to be installed.
Create an option file in a text editor to enter the options
The following is an example of an option file for a custom network client installation, where
<name/IP number> is the name or IP number of the computer where the license file is installed:
installation_mode=custom
setup_type=client
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enable-components=thermo,databases,tq,tcapi,toolbox,tcpython
icons=1
license_server=<name/IP number>

Below is a shorter example, specifying that a full Thermo-Calc network client should be
installed:
installation_mode=full_client
license_server=<name/IP number>

Go to the directory where the installation file is stored
Thermo-Calc can only be installed in unattended mode from the command line
prompt.
Start the installation in unattended mode using the option file created with this command:
l

For Windows: <installationfile>.exe

--mode unattended --optionfile

<path\optionfile>
l

For Linux: <installationfile>.run

--mode unattended --optionfile

<path/optionfile>

To see other options when you start the Thermo-Calc installation program from the command
line prompt, run this command:
l

For Windows: <installationfile>.exe

l

For Linux: <installationfile>.run

–-help

–-help
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Request License Files
In this section:
Request a License File from Thermo-Calc Software

46

Getting License Information Using Thermo-Calc

46

Requesting the License File for Windows or Linux

47

Requesting the License File for macOS

49
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Request a License File from Thermo-Calc Software
The following explains how to retrieve the necessary diagnostic and network adaptor
information about your computer and then send an email to Thermo-Calc Software to get your
license file(s) containing the license key(s).
To set up the correct licensing (excluding demo installations where a license file is not
required):
1. Make a note of your company or organization’s site number. You can find the site
number on an invoice or any correspondence from Thermo-Calc Software.
2. Retrieve your computer diagnostic and network adapter information.
3. Email Thermo-Calc Software with this information.
4. A Thermo-Calc Software representative emails you the license file. Save the license file
lservrc (there is no file suffix) to a location where you can easily access it later.
https://www.thermocalc.com/support/request-support/

Getting License Information Using Thermo-Calc
If you have already installed Thermo-Calc, you can view the license information in the GUI.
Select Help → Show License Info.
In Console Mode you can run the SYS module command DISPLAY_LICENSE_INFO.
1. Open Thermo-Calc.
2. Click Switch to Console Mode.

3. At the SYS: prompt, enter DISPLAY_LICENSE_INFO (all caps).
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4. You can output the information to a FILE or to the SCREEN.

5. For both options, the information is displayed on screen. Copy the section containing the
Ethernet and IP address. You can save it to a text file or paste it directly into an email.
If you choose FILE as the output, then you can attach the file to an email.

Requesting the License File for Windows or Linux
Demo (trial) installations: Skip this section. A license file is automatically installed
with the software. You do not need to request it.

Upgrades to a new version of Thermo-Calc: Skip this section if you are upgrading
to a new version of Thermo-Calc and (and you have a maintenance plan). Your
license is sent to you in an email from Thermo-Calc Software AB. Save it to your
computer to use during software installation.
1. To access the computer information you need to provide to get a license, start ThermoCalc and select Help → Show License Info.
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2. Copy the information from the License Information window. A lot of information may
be shown below the initial screen, so make sure you scroll down to the end when you
select and copy the window's contents. (Alternatively, you can copy the same
information from the console by using the SYS module command DISPLAY_LICENSE_
INFO.)
3. Send an email to support@thermocalc.com. Make sure to include the following in the
subject line:
License diagnostic information from <Name> where Name is replaced with your name,
the organisation name and the Site Number. You can find the five-digit site number on
an invoice or any correspondence from Thermo-Calc Software.

4. A representative from Thermo-Calc Software replies to the email and attaches your
license file(s).
5. Save the license file(s) to your computer or network.
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Requesting the License File for macOS
Demo (trial) installations: Skip this section. A license file is automatically installed
with the software. You do not need to request it.

Upgrades to a new version of Thermo-Calc: Skip this section if you are upgrading
to a new version of Thermo-Calc and (and you have a maintenance plan). Your
license is sent to you in an email from Thermo-Calc Software AB. Save it to your
computer to use during software installation.
1. From the Apple main menu, select System Preferences.
2. Click Network.
3. In the left column select Ethernet or Built-in Ethernet (do not select a WiFi connection
as a local static MAC address is required).
4. Click Advanced → Hardware.
The Network window shows you the MAC Address. For example, the MAC address (the
host ID) might be 3c:07:54:28:5f:72.

5. Send an email to support@thermocalc.com and copy and paste the MAC address into
the body of the email. Make sure to include the following in the subject line:
License diagnostic information from <Name> where Name is replaced with your name,
the organisation name and the Site Number. You can find the five-digit site number on
an invoice or any correspondence from Thermo-Calc Software.
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6. A representative from Thermo-Calc Software replies to the email address provided and
attaches your license file or files.
7. Save your license file to your computer or network.
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License Errors
Issue

Platform

Installation
type

Action or link to more information

How do I add or update a
standalone (SUNLL) license
on a Windows computer
where Thermo-Calc is
already installed?

Windows

Standalone

Determining the Current License File
Directory Path

How do I add or update a
standalone (SUNLL) license
on a Linux computer where
Thermo-Calc is already
installed?

Linux

Standalone

Determining the Current License File
Directory Path

How do I add or update a
network license on
Windows?

Windows

Network

Determining the Current License File
Directory Path

How do I add or update a
network license on Linux?

Linux

Network

Determining the Current License File
Directory Path

No license file found. Copy a
valid license file to the
installation directory after
completing the installation.

All

All

You get this message if the wrong path or
no license file is found at a path entered
during the installation process. See Default
Directory Installation Locations and
Determining the Current License File
Directory Path

MATLAB® not found (for the
TC-Toolbox for MATLAB
component)

Windows

All

MATLAB® Installation Directory

Warning Environment
variable “LSHOST” is not set.
Software will not function
properly.

All

Network

Specifying a New Server Name or IP
Number

Problem running post-install
step. Installation may not
complete correctly.

Linux and
Mac

Standalone

macOS Installations: Running the License
Initialization Script or Linux Installations:
Running the License Initialization Script
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Platform

Installation
type

Action or link to more information

Firewall warnings related to
license management
software (License Manager
and License Server)

Windows
and Linux

Network

Firewalls

Client / Server naming
mismatches

Windows
and Linux

Network

Client/Server Mismatch

Network

You are not notified if the InstallScript
scripting engine is not installed. Install the
ISScript.msi file and then run the
downloaded file from Thermo-Calc again as
described in Set Up the License Manager
on Windows

Issue
Unable to run postinstallation script, run the
license initialization script as
root after the installation.

InstallScript engine missing

Windows

Determining the Current License File Directory Path
This topic explains how to find out where your license file is installed, either by default or if a
different directory was chosen for previously installed versions. For new installations, where
you may not have had a license file when you installed Thermo-Calc (for example, you had a
demo version), you can also use these instructions to determine the correct file path.
From Thermo-Calc
If you have already installed Thermo-Calc, you can view the path to the license file in the GUI.
Select Help → Show License Info.
In Console Mode you can run the SYS module command DISPLAY_LICENSE_INFO.

WINDOWS STANDALONE INSTALLATIONS
How do I add or update a standalone (SUNLL) license on a Windows computer where ThermoCalc is already installed?
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1. Unpack the .zip file that contains your standalone license and save the LSERVRC file on
your computer. Find out where to place the new license file by opening a Command
Prompt Window (cmd.exe) and type in the command line:
>set LSERVRC

2. Press Enter. The output from the command is the path to the license file (including the
name of the license file). For example: if the output is
LSERVRC=C:\Users\<user>\Documents\Thermo-Calc\lservrc

then the new license file should be placed in C:\Program

Files\Thermo-

Calc\2020a\

LINUX STANDALONE INSTALLATIONS
How do I add or update a standalone (SUNLL) license on a Linux computer where Thermo-Calc is
already installed?
Find out where to place the new license file by opening a Terminal window and type in the
command line:
echo $LSERVRC

WINDOWS NETWORK INSTALLATIONS
How do I add or update a network license on Windows?
1. You need administrator rights to do the following.
l

l

On Windows 7, click the Start button and in the search field type Services.
Double-click the Services result.
On Windows 8, move the mouse over the right edge of the screen to access
Search, click Settings and then enter and select View Local Services.

2. In the list of installed services, right-click Sentinel RMS License Manager and select
Properties from the pop-up menu.
3. On the General tab under Path to executable, click the line containing the path to see
where the file lservnt.exe is located. The license file (lservrc) is in the same directory.
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The default path for the license file is
C:\Program Files (x86)\Common Files\SafeNet Sentinel\Sentinel RMS
License Manager\WinNT\LSERVRC

4. Move your copy of the license file (lservrc) to this directory.
5. Restart the Sentinel RMS License Manager by:
l

l

Restarting the computer, or
Right-clicking Sentinel RMS License Manager and selecting Restart from the list
of installed services.

LINUX NETWORK INSTALLATIONS
How do I add or update a network license on Linux?

Determining the Current License File Directory Path ǀ 55 of 80

Thermo-Calc Installation Documentation Set

Replace your current license file with the new license file. The license file is located in the
same directory as the license server.

Specifying a New Server Name or IP Number
The Thermo-Calc Setup wizard does not warn you if the name or IP number entered to the
server (with the license management software) is incorrect.
If the name or IP number is not set at all, or if it is set to an empty string, then when you start
Thermo-Calc the following message displays: Warning Environment variable “LSHOST” is not
set. Software will not function properly.

WINDOWS
This section explains how to specify or change the name or IP number of the server where the
License Manager is installed and for a consolidated network client installation.
To install a license for an existing Thermo-Calc program, follow these steps:
1. Close all running Thermo-Calc programs.
2. Open a command line window.
3. Specify the name or IP number of the licensing software server. Type:
set LSHOST=<name/IP number>

To display the current name or IP number, type:
set LSHOST

MAC
Permanently set the environmental variable LSHOST to specify a new licensing server name or
IP number. Refer to the file /Applications/Thermo-Calc-2020a.app/Contents/plist.info.
In this file, you can manually set the TC20A_HOME variable, which specifies the home directory
of the Thermo-Calc program. See the plist.info file for an example.

LINUX
You can set or change the name or IP number of the license server at a later time by setting the
environmental variable “LSHOST” to this name or number.
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MATLAB® Installation Directory
For Windows installations of the TC-Toolbox for MATLAB® component, you may get an error
message or window asking for the MATLAB installation directory path. If it is during the
installation Setup process, enter the path in the field.

DETERMINING THE LICENSING SOFTWARE VERSION
Sometimes you may need to know the version of License Manager (Windows) or License Server
(Linux) software being used. This can be useful while troubleshooting network installations.
l

On Windows open a command prompt and go to the directory where lservnt.exe is
found. For example:
>C:\Program Files (x86)\Common Files\SafeNet Sentinel\Sentinel RMS
License Manager\WinNT

Type the command >lservnt.exe
l

–help

and the version is displayed.

On Linux open a Terminal window and go to the directory where the lserv
saved. For example:

script

is

>cd opt/Thermo-Calc/<version>/Licensing-files

Type the command >./lserv

–help

and the version is displayed.

Firewalls
WINDOWS
For a Windows License Manager installation you may have to change the system firewall
settings to allow the License Manager to communicate with the computers running the client
applications. Go to the Windows Firewall settings window to see if there are any problems. If
prompted, select Unblock the system firewall for the Sentinel RMS License Manager and click
Next.

LINUX
For a Linux License Server installation you need to open the UDP port 5093 in your firewall. In
case you have installed SELinux you might also need to disable it by setting SELINUX=permissive
in the /etc/selinux/config file.
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Client/Server Mismatch
For some network installations there can be a naming mismatch that causes errors. The server
(where the license management software is installed) gets information from its DNS servers
that an IP address (aaa.bbb.ccc) belongs to a computer (Computer A). But the client computer
identifies itself as having a different IP address (aaa.bbb.ccc.eee) for the same computer
(Computer A).
Even if the IP address of the client computer belongs to a subnet range listed in the license file,
there is a problem with accessing the license file because the computer name does not match
the information.
You may need your organisation’s network administrator to assist with this issue.

HOW TO CHECK
Compare computer names on the client computer and server
1. On the client computer, start a command prompt cmd.exe and type ipconfig
Press Enter. A variety of data is displayed on screen. Write down the following
information for later comparison:
l

Hostname

l

DNS Suffix

l

Current IPv 4 Address

/all.

2. In the command window, type nslookup <client_computer_name>, where client_
computer_name is the actual name of the client. Press Enter.
This shows what information is saved on the DNS Servers used by the client computer.
This information should match what is shown in the output from the first step.
3. On the server that holds the license management software, open a command prompt
and run the command line: nslookup client_computer_name. The output lists the
information for this server.
Does it match the information given by the command ipconfig /all on the client
computer? If not try the following:
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Try these options to correct the issue
1. If the client computer has a dynamic (DHCP) IP address, either change it to a static one
or make a reservation on the DHCP Server so that the computer always get the same IP
address.
2. Update the records on the DNS Servers used by both the client computer and the server
computer.
You can also configure the computer names and IP addresses in the local Hostfile of the client
and server:
1. On the client computer, make a backup copy of the file
C:\Windows\System32\drivers\etc\hosts.
2. Open the original in a simple text editor.
3. Add a new line which contains the IP and name of the server, for example:
192.168.29.27 license_server.thermocalc.se.
4. Save the changes.
5. On the server, make a backup copy of the file /etc/hosts.
6. Open the original in a simple text editor.
7. Add a new line which contains the IP and name of the client, for example: 192.168.29.47
Computer_A.thermocalc.se.
8. Save the changes.
9. In the host file, there is an example of how the operating system (Windows or Linux)
wants the line in the hosts file to look like.

macOS Installations: Running the License Initialization Script
As part of the Standalone installation of Thermo-Calc, the Setup runs a license initialization
script. If this part of the installation process did not complete properly for a standalone
installation, you must manually run the license initialization script. You need the administrator
username and password for these steps.

HOW TO RUN THE SCRIPT
For this script to successfully initialize the license, the license file must be called lservrc and be
located in the folder:
/Users/Shared/Thermo-Calc
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Default Directory Installation Locations
1. Open a terminal window. The Terminal application is in the /Applications/Utilities
folder.
2. At the prompt, enter this command:
$ sudo /Applications/Thermo-Calc2020a.app/Contents/Resources/license-initialization-macOS-x86_
64.sh

For demo installations, the path should be /Applications/Thermo-Calc-2020aDemo.app/Contents/Resources/ license-initialization-macOS-x86_64.sh.

If you are not already logged in as an administrator, you probably cannot run the sudo
command. If this is the case, then you can use the su command in the terminal window
to login as an administrator. Contact your local system administrator for help.
3. Enter the administrator password and press Enter.
4. When you restart your computer and run the license initialization script, you are ready
to start using Thermo-Calc.
If you did not install a license file during this procedure, you can still start
Thermo-Calc although you will get the No license file found message.

Linux Installations: Running the License Initialization Script
As part of a Standalone installation of Thermo-Calc, the Setup runs a license initialization script.
If you get a warning message during the standalone installation Unable to run post-installation
script, run the license initialization script as root after the installation, then you need to
manually run the script as root.
OPENSUSE

ADMINISTRATION (SUDO) USERS

Note the following if you are a sudo user (administrator) in openSUSE installing Thermo-Calc
using this command:
sudo ./linux-installation-x64-6.0.0.17347.run

When this command is used, you will do a text-based installation instead of having a graphical
interface to guide you. The information is the same, just without the user interface.

HOW TO RUN THE SCRIPT
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For this script to successfully initialize the license, the license file must be called
lservrc and be located in the directory where you have installed Thermo-Calc.
Default Directory Installation Locations
1. In the console, go to the Thermo-Calc installation directory.
l The license file is put in /home/<user>/Thermo-Calc if you are installing as a
non-root user, where <user> is your user name.
l

If you are installing as root, then this directory is opt/Thermo-Calc/.

2. Enter this command:
$ sudo sh license-initialization-linux.sh

If you are not able to execute the sudo command because you are not on the sudoers
list, you must log in as a root user with the command su, and then use sh to run the
license initialization script. For example, on a 64-bit computer, enter the following:
$ sh license-initialization-linux.sh

3. Log out of Thermo-Calc and then log back in to save these changes.
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Uninstalling Thermo-Calc
In this section:
Uninstalling Thermo-Calc

63

Uninstalling Standalone Versions of TC-PRISMA

64
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Uninstalling Thermo-Calc
WINDOWS 10
1. From the Control Panel Desktop app, go to Programs → Programs and Features →
Uninstall or change a program.
2. In the list of programs, locate the version of Thermo-Calc you want to uninstall. Click to
highlight that row.
3. Click Uninstall/Change.
4. In the Setup window, Uninstallation Mode dialog box, choose to uninstall the Entire
application or Individual components. Follow the instructions to finish.

MAC
Deleting the program from the Applications folder does not remove the program from your
operating system. Run the Thermo-Calc-<version>-uninstaller program located in the
Applications folder. This is also applicable to the Demo version of the software.
1. Go to the Applications folder and double click the file that starts with Thermo-Calc<version>-uninstaller. Enter the administrator’s user name and password.
2. Click Yes to choose Entire application or select individual components. Otherwise click
No to quit.
3. The Uninstalling Thermo-Calc window shows the progress. Click OK when prompted.

LINUX
1. To start the uninstallation procedure, in the Thermo-Calc installation directory use the
command
./Thermo-Calc-2020a-uninstaller.run

For Thin Client installations, use the command
./Thermo-Calc-client-2020a-uninstaller.run

2. To remove the whole application, including all its components, select Entire application
and click Forward, or to remove specific components, select Individual components
and click Forward.
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If you intend to reinstall Thermo-Calc 2020a it is important to (1) Restart the
computer before you reinstall the software and (2) remove the environmental
variable TC20A_HOME.

Uninstalling Standalone Versions of TC-PRISMA
As of Thermo-Calc version 2016a, TC-PRISMA is no longer a standalone program. It
is integrated into the Thermo-Calc Graphical Mode and considered an add-on
module called the Precipitation Module. It is also available for all platforms
(Windows, Mac and Linux). If you have older versions of the TC-PRISMA software
that you want to uninstall, follow these instructions.
1. Go to the Thermo-Calc uninstaller. For example, in Windows 7, go to Start → All
Programs → Thermo-Calc or in Windows 10 go to Start → All Apps → Thermo-Calc.
2. Click uninstall-Thermo-Calc-2015b (or the version of TC-PRISMA you have).

3. In the Setup window, click Individual components. Click Next.

4. Select the TC-PRISMA check box.
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5. Click Next and then OK when the software component is uninstalled.
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Quick Installation Guides
In this section:
Windows® Standalone Quick Install Guide

67

macOS® Standalone Quick Install Guide

70

TC-Python Quick Install Guide

74
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Windows® Standalone Quick Install Guide
This quick guide helps you do a full or demo standalone installation. A standalone installation is
used with the Single-User Node-Locked License (SUNLL), where the software and the license file
are together on one computer.
This guide is applicable to:
l

Windows operating systems

l

Full Standalone installation (SUNLL)

l

Demo installations – during the installation you only need to do steps 2 and 3.

l

Upgrading to a new standalone version of Thermo-Calc (maintenance plan only)
Also see the Thermo-Calc Installation Guide for detailed instructions for other
operating systems and network installations.

Request a License File
Demo (trial) installations: Skip this section. A license file is automatically installed
with the software. You do not need to request it.

Upgrades to a new version of Thermo-Calc: Skip this section if you are upgrading
to a new version of Thermo-Calc and (and you have a maintenance plan). Your
license is sent to you in an email from Thermo-Calc Software AB. Save it to your
computer to use during software installation.
1. To access the computer information you need to provide to get a license, start ThermoCalc and select Help → Show License Info.
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2. Copy the information from the License Information window. A lot of information may
be shown below the initial screen, so make sure you scroll down to the end when you
select and copy the window's contents. (Alternatively, you can copy the same
information from the console by using the SYS module command DISPLAY_LICENSE_
INFO.)
3. Send an email to support@thermocalc.com. Make sure to include the following in the
subject line:
License diagnostic information from <Name> where Name is replaced with your name,
the organisation name and the Site Number. You can find the five-digit site number on
an invoice or any correspondence from Thermo-Calc Software.

4. A representative from Thermo-Calc Software replies to the email and attaches your
license file(s).
5. Save the license file(s) to your computer or network.
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Install the Software
Download and run your Thermo-Calc installation software

Administrative rights are required to complete this installation.

1. For web links sent in an email from Thermo-Calc Software, go to the URL and log in with
the information provided. Then navigate to the Windows folder and click the link to
download the software.
2. Go to the folder where you downloaded the software. Right-click the .exe file and
choose Run as administrator to launch the Setup program.

3. On the Setup-Thermo-Calc window click Next.
4. On the License Agreement window click to accept the license agreement. Click Next.
Demo (trial) installations: Your installation starts and is done when the
Completing the Thermo-Calc Demo Setup Wizard opens. Click Finish and
start using Thermo-Calc.
Select the installation mode
1. In the Select Installation Mode window click Full Standalone: Install all features.
The TC-Python program is installed when the Full Standalone or Full
Network Client option is chosen, but there are additional steps required as
described separately for this SDK.
2. For a Full Standalone installation, in the Choose a license file field either enter the file
path or click the file button
to navigate to where you saved the license file emailed
to you from Thermo-Calc Software.
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The license file is called lservrc. Click Next. To prevent errors, leave this
field blank if you did not get a license file yet.
3. TC-Python is installed for all users even if you do not have a license. The Install TCPythonwindow is a reminder that additional installation procedures are required after
Thermo-Calc is installed. Click Next.
4. In the Ready to Install window click Next. Click Finish and start using Thermo-Calc.

macOS® Standalone Quick Install Guide
This quick guide helps you do a full or demo standalone installation. A standalone installation is
used with the Single-User Node-Locked License (SUNLL), where the software and the license file
are together on one computer.
This guide is applicable to:
l

Mac operating systems

l

Full Standalone installation (SUNLL)

l

Demo installations – during the installation process you only need to do steps 1 and 2.

l

Upgrading to a new standalone version of Thermo-Calc (maintenance plan only)
Also see the Thermo-Calc Installation Guide for detailed instructions for other
operating systems and network installations.

Request a License File
Demo (trial) installations: Skip this section. A license file is automatically installed
with the software. You do not need to request it.
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Upgrades to a new version of Thermo-Calc: Skip this section if you are upgrading
to a new version of Thermo-Calc and (and you have a maintenance plan). Your
license is sent to you in an email from Thermo-Calc Software AB. Save it to your
computer to use during software installation.
1. From the Apple main menu, select System Preferences.
2. Click Network.
3. In the left column select Ethernet or Built-in Ethernet (do not select a WiFi connection
as a local static MAC address is required).
4. Click Advanced → Hardware.
The Network window shows you the MAC Address. For example, the MAC address (the
host ID) might be 3c:07:54:28:5f:72.

5. Send an email to support@thermocalc.com and copy and paste the MAC address into
the body of the email. Make sure to include the following in the subject line:
License diagnostic information from <Name> where Name is replaced with your name,
the organisation name and the Site Number. You can find the five-digit site number on
an invoice or any correspondence from Thermo-Calc Software.
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6. A representative from Thermo-Calc Software replies to the email address provided and
attaches your license file or files.
7. Save your license file to your computer or network.

Install the Software
Download and install XQuartz
The XQuartz open-source X Windows system is required to run Thermo-Calc on macOS X.
1. In a web browser go to https://www.macupdate.com or to download it directly from
XQuartz, http://xquartz.macosforge.org/landing/.
2. In the Search Mac Apps field, enter XQuartz.
3. Click the XQuartz search result. For example, based on the recent version, the name is
XQuartz-2.7.7.dmg.
4. Click Download.
5. Double-click the XQuartz.pkg file. Follow the instructions.
6. Click OK when the message about logging out displays and click Close when the
installation is successful.
Download and run your Thermo-Calc installation software

Administrative rights are required to complete this installation.

1. For web links sent in an email from Thermo-Calc Software, go to the URL and log in with
the information provided. Then navigate to the Mac folder and click the link to
download the software.
2. Double-click the downloaded file to launch the installation.
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For macOS and when you first run the installer, you may see a message
that Thermo-Calc-osx-<version> can't be opened because Apple cannot
check it for malicious software. If this happens, select Show in Finder.
Then, in the opened Finder window right-click the downloaded file ThermoCalc-osx-<version> and select Open.

3. On the Setup-Thermo-Calc window click Next.
4. On the License Agreement window click to accept the license agreement. Click Next.
Demo (trial) installations: Your installation starts and is done when the
Completing the Thermo-Calc Demo Setup Wizard opens. Click Finish and reboot
your computer to start using Thermo-Calc.
Select the installation mode
1. In the Select Installation Mode window click Full Standalone: Install all features.
The TC-Python program is installed when the Full Standalone or Full
Network Client option is chosen, but there are additional steps required as
described separately for this SDK.
2. For a Full Standalone installation, in the Choose a license file field either enter the file
path or click the file button
to navigate to where you saved the license file emailed
to you from Thermo-Calc Software.
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The license file is called lservrc. Click Next. To prevent errors, leave this
field blank if you did not get a license file yet.
3. TC-Python is installed for all users even if you do not have a license. The Install TCPythonwindow is a reminder that additional installation procedures are required after
Thermo-Calc is installed. Click Next.
4. In the Ready to Install window click Next. Click Finish and start using Thermo-Calc.
macOS installations and if you have previous Thermo-Calc installations: When you
launch Thermo-Calc with the new or updated version, the splash screen hides the
Import User Settings dialog box. In order to proceed you need to click the splash
screen and then click Yes or No in the dialog box.

TC-Python Quick Install Guide
This quick guide helps you do a TC-Python API installation.

The TC-Python API Reference Guide is available on the Thermo-Calc website. You
can alternatively open a local copy of the help in your browser, or use the PDF
guide included with your Thermo-Calc installation.

Once you have installed TC-Python, go to Thermo-Calc and from the menu select Help →
Manuals Folder and go to:
l

TC-Python, then double-click index.html (or any .html file).

l

Software Development Kits (SDKs) for the PDF.
Go to Thermo-Calc and search the online help (Help>Online Help).
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For an installation video plus more information, go to
https://www.thermocalc.com/products-services/software/tc-python/
This quick guide helps you to get a working TC-Python API installation.

A license is required to run TC-Python. Also remember to review the System
Requirements page on our website.

Install a Python Distribution
If you already have a Python distribution installation, version 3.5 or higher, skip this
step.
These instructions are based on using the Anaconda platform for the Python distribution. Install
version 3.5 or higher to be able to work with TC-Python, although it is recommended that you
use the most recent version.
Install Anaconda

1. Navigate to the Anaconda website: https://www.anaconda.com/download/.
2. Click to choose your OS (operating system) and then click Download. Follow the
instructions. It is recommended you keep all the defaults.
Install Thermo-Calc and the TC-Python SDK

TC-Python is available starting with Thermo-Calc version 2018a.

1. Install Thermo-Calc.
2. When the installation is complete, open the TC-Python folder that includes the *.whl file
needed for the next step. There is also an Examples folder with Python files you can use
in the IDE to understand and work with TC-Python.
The installation location for this API is the same as for other SDKs and based
on the OS. For details, see "Default Directory Locations" in the Thermo-Calc
Installation Guide.
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Install TC-Python
Updating to a Newer Version
On Windows, it is recommended you use the Anaconda distribution prompt (i.e. Anaconda),
especially if you have other Python installations.

Do not use Virtual Environments unless you have a good reason to do so. Also see
Fixing Potential Issues with the Environment.

1. Open the command line. For example, in Anaconda on a Windows OS, go to Start →
Anaconda → Anaconda Prompt.

2. At the command line, enter the following. Make sure there are no spaces at the end of
the string or in the folder name or it will not run:
pip install <path to the TC-Python folder>/TC_Python-<version>py3-none-any.whl

For example, on a Windows OS Standalone custom installation the path to
the TC-Python folder is C:\Users\Public\Documents\ThermoCalc\2020a\SDK\TC-Python\

Details for Mac and Linux installations are described in "Default Directory
Locations" in the Thermo-Calc Installation Guide. On Linux typically pip3 is
used.
3. Press <Enter>. When the process is completed, there is a confirmation that TC-Python is
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installed.
If your computer is located behind a proxy-server, the default pip-command
will fail with a network connection error. In that case you need to install the
dependency py4j in a special configuration:
pip install -proxy user:password@proxy_ip:port py4j

Go to the TC-Python Help Troubleshooting section for detailed information. This
can be found on our website or from the installed documentation where you can
search for "pip install fails".
Install an IDE (Integrated Development Environment)
Any editor can be used to write the Python code, but an IDE is recommended, e.g. PyCharm.
These instructions are based on the use of PyCharm.
Use of an IDE will give you access to code completion, which is of great help when you use the
API as it will give you the available methods on the objects you are working with.
1. Navigate to the PyCharm website: https://www.jetbrains.com/pycharm/download.
2. Click to choose your OS and then click Download. You can use the Community version
of Pycharm.
3. Follow the instructions. It is recommended you keep all the defaults.

For Mac installations, you also need to set some environment variables as
described below in macOS: Setting Environment Variables .

Open the IDE and Run a TC-Python Example
After you complete all the software installations and set up the pip install path, you are ready to
open the IDE to start working with TC-Python.
It is recommended that you open one or more of the included examples to both check that the
installation has worked and to start familiarizing yourself with the code.
Open the TC-Python Project in PyCharm

When you first open the TC-Python project and examples, it can take a few
moments for the Pycharm IDE to index before some of the options are available.
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1. Open PyCharm and then choose File → Open. The first time you open the project you
will need to navigate to the path of the TC-Python installation as done in Step 4.
For example, on a Windows OS Standalone custom installation the path to
the TC-Python folder is C:\Users\Public\Documents\ThermoCalc\2020a\SDK\TC-Python\

Details for Mac and Linux installations are described in "Default Directory
Locations" in the Thermo-Calc Installation Guide.
2. Click the Examples folder and then click OK.
3. From any subfolder:
l Double-click to open an example file to examine the code.
l

Right-click an example and choose Run .

Fixing Potential Issues with the Environment
In most cases you should run TC-Python within your global Python 3 interpreter and not use
Virtual Environments unless you have a good reason to do so. If there are problems with the
interpreter settings, you can resolve them in the Settings window:
1. Go the menu File → Settings.
2. Navigate in the tree to <Project.YourProjectName> and choose Project Interpreter.
3. Click on the settings symbol close to the Project Interpreter drop-down menu and
choose Add.
4. Now choose System Interpreter and add your existing Python 3 interpreter.
5. Select your added interpreter and confirm.
If you are not following the recommended approach and create a new project (File
→ New Project), you need to consider that by default the options to choose the
interpreter are hidden within the Create Project window. Therefore, click Project
Interpreter: New Virtual Environment and in most cases choose your System
Interpreter instead of the default New Virtual Environment.
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If you really need to use a Virtual Environment, it is recommended you review the
hints provided in the Best Practices section in the full TC-Python HTML help or
PDF.

Updating to a Newer Version
When updating to a newer version of Thermo-Calc, you always need to also install the latest
version of TC-Python. It is not sufficient to run the installer of Thermo-Calc. The procedure is
generally identical to Step 3:
pip install <path to the TC-Python folder>/TC_Python-<version>-py3none-any.whl

In case of problems you may wish to uninstall the previous version of TC-Python in advance:
pip uninstall TC-Python
pip install <path to the TC-Python folder>/TC_Python-<version>-py3none-any.whl

However, that should normally not be required. Note that on Linux usually pip3 is used.
You can check the currently installed version of TC-Python by running:
pip show TC-Python

macOS: Setting Environment Variables
In order to use TC-Python on Mac you need to set some environment variables.
TC20A_HOME=/Applications/Thermo-Calc-2020a.app/Contents/Resources

If you use a license server:
LSHOST=<name-of-the-license-server>

If you have a node-locked license:
LSHOST= NO-NET
LSERVRC=/Users/Shared/Thermo-Calc/lservrc

In PyCharm, you can add environment variables in the configurations.
Select Run → Edit Configurations to open the Run/Debug Configurations window. Enter the
environment variable(s) by clicking the button to the right of the Environment Variables text
field. Now the environment variables(s) will be set for each new configuration by default. The
same way for configuring the environment variables can be used on other operating systems as
if necessary.
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Diagnostic Script
A diagnostic script is available as a Miscellaneous example (diagnostics.py) as well as in the
Troubleshooting section of the TC-Python guide. Information about the script is also available
on our website. The script automatically prints useful suggestions that, in many cases, will help
you to fix the problem yourself. If you are unable to solve the problem, contact us for support.
It is important to run the diagnostic script EXACTLY the same way as you run your TC-Python
script (in the same IDE, same project, same Python environment, same Jupyter notebook, etc).
The script automatically prints useful suggestions that, in many cases, will help you to fix the
problem yourself. If you are unable to solve the problem, contact us for support.
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