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1. Introduction 
This guide is for new users of Thermo-Calc who want to work in Graphical Mode. This guide 
includes an overview of the software and its underlying structure, describes the GUI, how to 
define a system of components, set up and run calculations, and visualise the results. A basic 
understanding of thermodynamics is required.  

1.1 The Thermo-Calc software program 

Thermo-Calc is a sophisticated software, database and programming-interface package for 
performing thermodynamic calculations. It allows you to calculate complex homogeneous and 
heterogeneous phase equilibria and plot the results as property diagrams, property grids and 
phase diagrams. A property grid shows how a property—such as the amount of a certain phase 
for example—varies along two dimensions—the compositions of two components for example. 

The program supports stoichiometric and non-ideal solution models and databases. These 
models and databases are used to make calculations on a variety of materials such as steels, 
alloys, slags, salts, ceramics, solders, polymers, subcritical aqueous solutions, supercritical 
electrolyte solutions, non-ideal gases and hydrothermal fluids or organic substances. The 
calculations take into account a wide ranges of temperature, pressure and composition 
conditions—the temperature can be set up to 6000 K and pressure up to 1 Mbar. 

There are two interfaces available with the Thermo-Calc program, the Console Mode, which 
uses a command line interface, and the Graphical Mode, which is the graphical user interface 
(GUI) version described in this guide.  

1.2 Learning Resources 

 
Additional documentation is available on Thermo-Calc Software’s website 
http://www.thermocalc.com/support/documentation/. 

There is also online help available that contains general information about the Graphical Mode, 
information about most Configuration window settings, as well as descriptions of two step-by-
step examples. 

You can access online help information in several ways: 

• Select Help > Help Contents to open a list of online help contents in your default web 
browser. Click Graphical Mode to get access to all the help pages that are available in 
the GUI. 

• In one of the main windows of the Graphical Mode GUI, the Configuration window, you 
can click the help button  to view help information regarding the tab that is currently 
shown in this window. The help information is shown in the default web browser.  

Example Collections 
To learn more about how to use Thermo-Calc, you can open and run the example projects in 
the Thermo-Calc Graphical Examples Collection. These are in the format of Thermo-Calc project 
files (*.TCU). 

The examples are the following: 

• Calculating a single-point equilibrium 
• Stepping in temperature in the Fe-C system 
• The Fe-C phase diagram 

http://www.thermocalc.com/support/documentation/
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• Ternary phase diagram in the Fe-Cr-C system at 1000 K 
• The stable and the metastable Fe-C phase diagrams 
• Serially coupled equilibrium calculators 
• User defined functions 
• Scheil and equilibrium solidification 

1.3 Typographical Conventions 

The following conventions are used: 

Convention Definition 

Forward arrow symbol > The forward arrow symbol > instructs you to select a series of menu items in 
a specific order. For example, Tools>Options is equivalent to: From the Tools 
menu, select Options. 

Boldface font A boldface font indicates that the given word(s) are shown that way in on a 
toolbar button or as a menu selection. For example, if you are told to select a 
menu item in a particular order, such as Tools>Options, or to click Save. 

Italic font An italic font indicates the introduction of important terminology. Expect to 
find an explanation in the same paragraph or elsewhere in the guide.  

code and code 
bold 

A code font indicates you are to make a keyboard entry. It also shows a 
programming code or code examples. The code bold font highlights the 
entry. 

1.4 Software program overview 

The Thermo-Calc software architecture consists of modules that handle, for example, database 
retrieval and management, calculation, visualisation and diagram plotting. See the Thermo-Calc 
Console Mode User Guide for more information about the modular architecture of the 
software. 

Most of the calculation types done in the Console Mode can also be performed in Graphical 
Mode. However, you can only do data optimisation and thermodynamic or kinetic assessments 
in the Console Mode. 

The two modes can be run simultaneously, but there is no communication between them. 
What you do in the Graphical Mode does not affect the state of the Console Mode session and 
vice versa. There is one exception to this. The options you set for plotting in the Results window 
or the Console Results window are applied to how diagrams are plotted in both modes.  

In the Thermo-Calc Graphical Mode, calculations are always set up, carried out, and visualised 
as part of a project. These different steps in your project is performed by different types of 
activities.  

2. The Graphical Mode interface 
This section introduces you to the concepts and terminology of the Graphical Mode and 
describes the basic workflow. 

2.1 The layout 

Figure 1 is an example of the default layout of the windows in Graphical Mode. You can easily 
reorganize the windows yourself. See Moving windows. 

http://www.thermocalc.com/media/23639/thermo-calc-console-mode-user-guide.pdf
http://www.thermocalc.com/media/23639/thermo-calc-console-mode-user-guide.pdf
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Figure 1 The Graphical Mode default window layout. 

The windows in Figure 1 are: 

1. Project: Create, manipulate and navigate between the activities that make up a project.  
2. Configuration: Shows the settings that can be configured for the currently selected activity. 
3. Scheduler: Displays information about jobs, such as calculations, that are being performed 

or that are scheduled to be performed. You can cancel scheduled jobs and if a job has 
failed, then you can view information about the error. 

4. Event Log: By default this window is closed, but it opens when a calculation is run to show 
detailed progress information. 

5. Results: Shows the results of a calculation, either plotted as a diagram or displayed in table 
format. 

2.2 Project activities and the tree structure 

2.2.1 The tree structure 
In a project, a set of linked activities (see Project activity nodes) is called a tree. A result 
calculated within a tree is fed as input into the next activity in the tree. Consequently, if you 
have an Equilibrium Calculator with another Equilibrium Calculator as its successor, the 
successor takes the calculation results of the predecessor as the starting values for its 
calculation. See Successor and predecessor nodes for more information. 

1 2 

3 

4 

5 
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The Project window in Figure 2 shows a project with two trees. Within each tree, settings and 
calculation results are propagated downward until the calculation and the visualisation of the 
results are completed. However, the system definitions, settings and calculation results of the 
two trees are independent of each other. 

 
Figure 2 An example of a project with two trees with successor and predecessor activity nodes. 

2.2.2 Project activity nodes 
Table 1 is a brief description of the project activity types. When working with activities in the 
Project window these are also referred to as nodes in the tree structure. 

Table 1 Project activity types. 

Activity type Description 

System Definer The System Definer activity is used to define a certain thermodynamic 
system and to read it from file into memory. Also see System definer. 

(Appended System) To read data from multiple databases, multiple System Definer activities 
must be created and linked serially. The successor System Definer 
activities defined is by default called Appended System. 

Equilibrium Calculator The Equilibrium Calculator activity is used to set thermodynamic 
conditions and to define axis variables when a series of equilibrium 
calculations are to be performed in one or more dimensions. Also see 
Equilibrium calculator. 

Plot Renderer The Plot Renderer activity is used to determine the layout of non-text 
based output. Also see Plot renderer. 

Table Renderer A table renderer activity is used for text based output. Also see Table 
renderer. 

Binary Calculator The Binary Calculator activity can be used for some calculations involving 
two components only. It can be thought of as a combination of a System 
Definer activity and an Equilibrium Calculator activity with certain 
adaptations to simplify the configuration of calculations on binary 
systems. Note that, to perform this activity successfully, you need a 
database that was designed for the Binary Calculator, such as the TCBIN 
database for example. Also see Binary calculator. 

Ternary Calculator The Ternary Calculator activity can be used for some calculations 
involving three components. It can be thought of as a combination of a 
System Definer activity and an Equilibrium Calculator activity with certain 
adaptations to simplify the configuration of calculations on ternary 
systems. Note that, to get a reliable result from performing this activity, 
you need a database that contains fully assessed binary and ternary 
systems. Also see Ternary calculator. 
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Activity type Description 

Scheil Calculator The Scheil Calculator activity is used to perform Scheil-Gulliver 
calculations (also known as Scheil calculations). A default Scheil 
calculation is used to estimate the solidification range of an alloy 
assuming that i) the liquid phase is homogeneous at all times and ii) the 
diffusivity is zero in the solid. However, it is possible to disregard the 
second assumption for selected components. Also see Scheil Calculator. 

Experimental File 
Reader 

The Experimental File Reader activity can only be created from the top 
My Project node. This activity allows you to read an experimental data 
file (*.EXP). Such a file contains information specifying a plotted diagram, 
written in the DATAPLOT graphical language. See Experimental file 
reader. 

2.2.3 Successor and predecessor nodes 
An activity node located below another activity node in a tree is referred to as that activity’s 
successor. An activity located above another activity is referred to as that activity’s predecessor. 
A predecessor is performed before the predecessor’s successors and its result is fed forward to 
any successor activities. 

For example, to calculate and display a phase diagram, create a branch with three linked 
activities: A System Definer activity linked to an Equilibrium Calculator activity, which in turn is 
connected to a Plot Renderer activity.  

Figure 3 is an example of a Project window where Equilibrium Calculator 1 is the successor to 
System Definer 1 and the predecessor to Table Renderer 1 and Equilibrium Calculator 2. 

 
Figure 3 An example of successors and predecessors. 

2.3 Workflow 

You can set up a whole tree in the Project window and then perform all the activities at once, or 
create and perform one activity at a time. 

The typical workflow is the following: 

• Define your system: Create a System Definer activity, which allows you to select a 
database and select which elements to have as components in your system. The 
database and elements are selected in the Configuration window. 
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• Set up and run your calculation: Create an Equilibrium Calculator activity, which allows 
you to set the conditions for your calculation (temperature, pressure, etc.) and set axis 
variables if you want to make a property or phase diagram. The settings of activities are 
specified in the Configuration window. 

• Visualise the results: Create either a Plot Renderer or a Table Renderer activity that 
present the results of your calculation in diagram or table format. The results are 
shown in a Plot Renderer or a Table Renderer tab in the Results window. Note that if 
you do not visualise the results by performing a Plot Renderer or a Table Renderer, then 
you do not see any calculation results, even if you have performed an Equilibrium 
Calculator. 

See Working with Thermo-Calc projects to get started. 

2.4 The Graphical Mode buttons and menus 

2.4.1 Main menu and toolbar 
Along the top of the GUI is a toolbar and menus as described in this section. 

 
Table 2 Main menu and toolbar options. 

Option Description Action (s) 

New  Create a new project. Click New on the toolbar.  
Select File>New Project. 
Press Ctrl+N on the keyboard. 

Open Open an existing project. Click Open on the toolbar.  
Select File>Open Project. 
Press Ctrl+O on the keyboard. 

Save Save a project. See Saving and 
opening Thermo-Calc project 
files. 

Click Save on the toolbar.  
Select File>Save Project. 
Press Ctrl+S on the keyboard. 

Switch to 
Console Mode 

Open Console Mode. Click the button to exit Graphical Mode and 
open the Console Mode. 

Append 
Project 

Combine two projects into one 
project file. 

Select File>Append Project. 

Save Project 
As… 

Save an existing project with a 
new name. 

Select File>Save Project As…. 

Exit Exit the program. In the upper right-corner of the program, click 
the red X. 
Select File>Exit. 
Press Ctrl+Q on the keyboard. 

Options Change the global defaults for a 
variety of settings. See Editing 
global defaults. 

Select Tools>Options. 
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Option Description Action (s) 

Database 
Checker 

Open the Database Checker, a 
program to check that the 
syntax of Thermo-Calc database 
files is correct. This is for 
advanced users who develop 
and manage databases. 

Select Tools>Database Checker. 

Window menu Highlight a specific window on 
the GUI  

From the Window menu, select an option to 
refocus on that specific window.  

Show License 
Info 

Open the License Information 
window. See License 
information and the Thermo-
Calc Installation Guide for more 
information. 

Select Help>Show License Info 

Check for 
update 

Check the Thermo-Calc Software 
website for updates to the 
software. 

Select Help>Check for update 

2.4.2 Project and activity menus 
When working in the Project window you can right-click nodes to access menus with the 
available actions. For example, click the My Project node to open the menus shown in Figure 4. 
Most nodes in the tree have a common menu as shown in Figure 5, with differences based on 
the placement in the tree and the activity type. 

 
Figure 4 Menu options available for the My Project node. 

 
Figure 5 An example of the common menu for other activities. 
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Table 3 Menu options for activities. 

Option Description Action (s) 

Create New 
Activity 

Add System Definer, Binary Calculator, 
Ternary Calculator, and Experimental File 
Reader nodes.  
See Creating activities and successors. 

Right-click My Project and from the 
Create New Activity menu choose an 
option. 

Create New 
Activity > Use 
Template 

Choose from the available templates to 
use the Wizard or add predefined nodes.  
See Using templates. 

Right-click My Project and from the 
Create New Activity>Use Templates 
menu choose an option. 
The templates are also available on the 
Configuration window, which you can 
access by clicking the My Project node, 
or from the Window menu. 

Create New 
Successor 

Add a successor to the selected node. 
Options are System Definer, Equilibrium 
Calculator or Scheil Calculator. 
See Working with Thermo-Calc projects 
and Creating activities and successors. 

Right-click one of these nodes System 
Definer, Equilibrium Calculator, Binary 
Calculator, Ternary Calculator or 
Experimental File Reader, and from the 
Create New Successor menu choose an 
option. 

Add a 
Predecessor 

Add a predecessor to the selected node.  Right-click a node to add a predecessor 
to it (when available). 

Perform Now 
or Perform 
Later 

Perform a calculation or create a plot or 
table immediately, or schedule it for a 
time in the future. See Performing 
projects, trees and activities. 

Right-click any node. 

Rename Change the name of the node. Right-click any node. 
Remove Delete the selected node from the tree. Right-click any node except My Project. 
Clone Duplicate the selected node and add it to 

the same tree. See Cloning activities and 
trees. 

Right-click any node except My Project. 

Clone tree Duplicate a tree and add it to My project. Right-click any node except My Project. 
Apply Auto 
Layout 

Apply an automatic layout to the nodes in 
the tree. 

Right-click any node. 

Snap to Grid Snap a node to align it with the grid. See 
Moving nodes in the tree and using the 
grid. 

Right-click any node. 

Show Grid Turn the grid on or off in the Project 
window. 

Right-click any node. 

Zoom In, 
Zoom Out, 
Reset Zoom 

Zoom in and out of the Project window or 
reset the zoom to the default. 

Right-click any node. 

2.4.3 Moving windows 
The windows in Thermo-Calc can be fixed or free-floating. When fixed, it can also be set to 
auto-hide, where the window is minimised if you select another window. The minimised 
window is then shown either along the bottom or side of the Thermo-Calc window. A free-
floating window is shown on top of the other windows and can be moved outside the frame of 
Thermo-Calc window. 

By default, the windows are fixed and open, except the Event Log window, which is set to auto-
hide by default. 
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You can always go back to the standard window layout. From the main menu, select 
Windows>Reset Windows. 

For each window you can rearrange, resize, minimize and close it. At the top right corner are 
the following buttons. 

Button(s) Description 

    Click to toggle on/off free-floating 

   Click to toggle on/off auto-hide. 

 Click to minimize an open window that has auto-hide turned on. 
Note that the window automatically minimizes if you select 
another window.  

 Click to close the window. You can open the window again from 
the Window main menu. 

2.4.4 Moving nodes in the tree and using the grid 
You can organise a project in the Project window in various ways. 

• Selecting activities: Click an activity node to select it. To select several activities, hold 
down Ctrl while clicking on the activities you want to select. Alternatively, click and hold 
the mouse button while you trace a square around the activities that you want to select. 
Both the name and the icon that represents an activity must be within the square for it 
to get selected in this way. 

• Moving activities: Click and hold the activity node, then move the cursor. 
• Zoom: Use the scroll wheel to zoom in and out or in the Project window right-click and 

select Zoom In or Zoom Out. To go back to the default zoom, select Reset Zoom. 
• Turn on/off grid: To show a grid of light-grey cross-hairs overlaid on a project (see Figure 

6), click Show Grid in the toolbar. Click the button again to turn the grid off. Or right-click 
in the Project window and select Show Grid. 

• Snap to grid: If you turn on Snap to Grid, each activity in the Project window is 
automatically positioned at a cross-hairs point in the grid. Click Snap to Grid in the 
toolbar or right-click in the Project window and select Snap to Grid. 

 
Figure 6 The project window with the grid turned on and activity nodes moved from the default location. 

2.4.5 Node status markers 
Whether an activity is ready to be performed, is being performed, or has been performed is 
indicated by status markers overlaid on the activity icons in the Project window. The different 
status markers are shown on a System Definer icon. 
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Table 4 Node status markers for the Project and Scheduler windows. 

Status 
marker 

Location Description 

 Project window No status marker means that the activity is ready to be performed and 
that it has not yet been performed.  

 Scheduler 
window 

No status marker means that the activity is scheduled to be performed 
but that Thermo-Calc has not yet begun to perform it. 

 
Project window A yellow triangle indicates that the activity cannot be run. The reason is 

that the necessary configurations for the activity have not been set or 
that other pre-requisites have not been met. 

 Scheduler 
window 

A yellow triangle indicates that there was an error during the 
performance of the activity.  

 Project window A green disc indicates that the activity has been performed. 

 Scheduler 
window 

A green disc indicates that the activity has already been performed 
successfully. 

 Scheduler 
window 

A green right-facing arrow indicates that the activity is being 
performed. 

 Project window A red circle with a dial (a clock face) indicates that the activity is 
currently being performed. 

3. Working with Thermo-Calc projects 
This section describes how you create and perform activities for your project, as well as how 
you manipulate and link various activities. 

You work with Thermo-Calc in the Graphical Mode by creating, configuring and performing 
activities within a project. The activities in your project and how they are linked are represented 
as a tree-structure in the Project window, where you can also add new activities.  

3.1 Using the Quick Start wizard 

The Quick Start wizard gets you started using the Graphical Mode, even before you have any 
knowledge about how to work with Thermo-Calc projects. You can easily set up, calculate and 
visualise any of the following: 

• Single point equilibrium 
• Property diagram 
• Phase diagram 
• Scheil solidification simulation 

To set up, perform and visualise a calculation using the Quick Start wizard: 

1. In the Configuration window click Quick Start. If you cannot see the Quick Start button, 
first click My Project in the Project window. 

2. In the Select Project Type window click to select the type of calculation to perform. 
Single point equilibrium, Property diagram, Phase diagram or Scheil solidification 
simulation. Click Next. 

3. In the Define System window, select a Database from the menu. TCFE7 is the default. 
4. In the Elements section, click the check boxes of the elements to include as 

components in the system. Or click Material file to enter the file path to a material file 
or click the Open button to navigate to a file on the computer. 

5. Click Next. 
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6. In the Select Conditions window, choose a Composition unit–Mass percent, Mole 
percent, Mass fraction or Mole fraction. 

7. Under Condition Definitions specify the values of the state variables in the system. 
8. For a Property diagram or Phase diagram, specify the Axis Definitions of the stepping 

or mapping operation. Choose minimum and maximum values for the variable(s) (select 
Linear – min no. of steps, Linear – max step size or Logarithmic –scale factors) and 
whether it is Normal or Separate phases. 

9. For a Scheil solidification simulation, and where applicable, select Fast diffuser to 
account for back-diffusion of any fast-diffusing elements.  

10. Click Finish. 
11. The Event Log window opens and shows information about the progress of the 

calculation. 
12. The diagram is plotted in a Plot Renderer tab in the Results window. If you have 

calculated a single-point equilibrium, then a Table Renderer tab shows information 
about the equilibrium. 

13. To save the project, click Save on the main toolbar. To save a diagram or table, right-
click the diagram or table and select Save As. 

3.2 Using templates 

Use a Template to create all the activities necessary for a certain type of calculation. In the 
Project window click the My Project node to display the templates in the Configuration window 
as in Figure 7. 

 
Figure 7 The templates available in the Configuration window. 

When you click a template, an activity tree is added to the Project window. You can then 
configure and perform the activities or the project.  

For example, if you click Property Diagram, a tree is added to the My Project node with System 
Definer, Equilibrium Calculator and Plot Renderer nodes. 

 
You can also select templates from the Project window by right-clicking the topmost My Project 
node, choosing Create New Activity, and opening the Use Template submenu. 
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3.3 Saving and opening Thermo-Calc project files 

Thermo-Calc makes use of project files with the file name suffix .TCU. To save your project and 
all its settings and results, on the toolbar click Save. Select to Include calculated results in the 
project file (the default) or not. To open a Thermo-Calc project file, on the toolbar click Open 
and select the project file in the Open file window.  

You can only have one project file open at a time. However, you can attach the trees from 
additional project files to the topmost My Project node. To append an additional project file in 
this way, from the main menu select File>Append Project and open a project file. 

3.4 Creating activities and successors 

You can create a new activity in the following ways: 

• In the Project window, right-click an activity and choose Create New Activity (My 
Project node only) or Create New Successor (all other nodes). Select the activity you 
want to create from the submenu. 
At the bottom of the Configuration window, click Create New Activity or Create New 
Successor and select the activity to create. 

3.4.1 Cloning activities and trees 
You can clone a single selected activity or the selected activity and all the activities that succeed 
it. The predecessor of the selected activity also is the predecessor of the clone. Cloned activities 
are configured exactly like the activities that they were cloned from, and any results of 
calculations or plots are also cloned. To clone a selected activity, right-click the activity and 
select Clone. 

For example, if you clone the Equilibrium Calculator in this project: 

 
Figure 8 Cloning an Equilibrium Calculator activity node. 

The result is that Equilibrium Calculator 2 is created as a successor to System Definer 1. The 
new Equilibrium Calculator has exactly the same settings for conditions, functions and options 
as Equilibrium Calculator 1 from which it was cloned. If the Equilibrium Calculator is done 
already, then the calculation results are also cloned. If the activity is a Plot Renderer or a Table 
Renderer, then the plot or table is cloned. If you also want to clone all the successor activities 
that follow a selected activity, then right-click and select Clone Tree instead. See Equilibrium 
Calculator clones and successors for more information. 
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3.4.2 Equilibrium Calculator clones and successors 
If you create an Equilibrium Calculator as a successor to another Equilibrium Calculator, then 
the successor inherits all the settings for conditions, functions and options from its predecessor. 
In this respect, it is similar to a clone. However, the successor is different from a clone in that it 
does not inherit any calculated results and it is a successor to the Equilibrium Calculator instead 
of a successor to its predecessor. The calculated result from an Equilibrium Calculator that is the 
predecessor to another Equilibrium Calculator is the starting value for the latter’s calculation. 
The clone of an Equilibrium Calculator on the other hand, does not receive any data as input 
from the Equilibrium Calculator that it was cloned from. 

For an example of how serially coupled Equilibrium Calculators can be used, see example 6 in 
the Thermo-Calc Graphical Examples Collection. 

3.5 Performing projects, trees and activities 

You can trigger the performance of an activity and all the activities below it in the same tree in 
either the Project window or in the Configuration window. In the Project window you can also 
perform a single activity without performing its successors or perform the whole project (all the 
activity trees).  

In the Configuration window, click Perform Tree to perform the currently selected activity and 
all the activities below it in the tree. If there are no activities below the currently selected 
activity, then the button says Perform in the Configuration window. 

 Whenever you perform an activity, all activities that must be performed as a prerequisite 
to the performance of that activity are automatically performed first. Consequently, if you 
perform a Plot Renderer with an Equilibrium Calculator and a System Definer above it in the 
activity tree, then the System Definer and the Equilibrium Calculator are automatically 
performed first. 

In the Project window, you can do any of the following: 

• Perform an activity: Right-click the activity and select Perform Now, or Perform Later 
and schedule a time when the activity is performed.  

 
• Perform an activity and all activities below it in the tree: Right-click any activity in the 

tree that you want to perform and select Perform Tree Now. Or select Perform Tree 
Later and schedule a time when all the activities in the tree are performed. 

• Perform a project: Right-click the My Project node and select Perform Now or Perform 
Later and schedule a time for all the activity trees in your project to be performed. 
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If there is an error during the performance of an activity, icons display status markers, which 
are described in Node status markers. 

3.5.1 Using the Scheduler 
The Scheduler window shows information about activities that Thermo-Calc is currently 
performing or are scheduled to be done. It also indicates if there is an error during performance 
and an activity is aborted. If you have set an activity, tree or project to be performed at a later 
time (with the Perform Later or Perform Tree Later options) then this scheduled performance 
is listed as well.  

Whenever you trigger the performance of a whole project, tree or individual activity, all the 
activities to be performed are presented under a Job heading. If all the activities belonging to a 
job are successfully completed the job and its activities disappear from the Scheduler window.  

If there is an error during the performance of an activity, icons for that job and activity remain 
in the Scheduler window until removed. See Node status markers for these indicators. 

 
Figure 9 An example of a list of scheduled jobs. 

3.5.2 Managing the schedule 
In the Scheduler window, you can cancel scheduled jobs, remove errors and show information 
about errors. 

• Cancel All Jobs: To cancel all jobs, right-click the Scheduled Jobs label or the cogwheel 
icon, and select Cancel All Jobs. 

• Clear All Errors: To remove all failed activities and jobs, right-click the Scheduled Jobs 
label or the cogwheel icon, and select Clear All Errors. 

• Cancel Job: To cancel a specific job, right-click the job label (for example, Job no 1) and 
select Cancel Job. 

• Clear Error: To remove a specific failed job, right-click the job label (for example, Job no 
1) and select Cancel Job. 

• Show Error Log: To open a window with information about an error, right-click the label 
for the failed job (for example, Job no 1), and select Show Error Log. 

3.5.3 The Event Log 
The Event Log window is closed by default, but is opened when an activity, tree or project is 
performed. 

Information about what Thermo-Calc is currently doing is shown in blue, and error and warning 
messages are shown in red. 

You can specify how detailed the information in the Event Log window by opening the Options 
window, and from the main menu selecting Tools>Options>General tab and setting the Log 
level slide bar to anything between Debug (most detailed) and Error (least detailed).  
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Figure 10 An example of an Event Log. 

4. Activities 
In this section is a description of each type of activity, brief descriptions of the Configuration 
window settings, and descriptions of some procedures that are tied to specific activities. 

4.1 System definer 

In a System Definer activity, you select which database to use for retrieving thermodynamic 
data, and define which elements your system has as components. You can also select which 
species to include as well as change the reference temperature and pressure for your 
components. 

4.1.1 Predecessors and successors 
• Possible predecessors:  My Project System Definer 
• Possible successors:  System Definer, Equilibrium Calculator, Scheil Calculator 

A System Definer that is a successor to another System Definer by default gets the name 
Appended System. 

4.1.2 Selecting a database and defining elements 
This procedure describes how to define a system, namely select a database and defining the 
elements that are in the system. You must have created and selected a System Definer activity 
in the Project window. 

1. In the Configuration window, from the top menu, select the database to use from the 
Select database menu. 
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2. In the Elements tab, click the elements in the periodic table (or on the alphabetic list) that 

you want to include in your system. 
3. If required, you can change species, phases or components in the other tabs. 
4. Click Perform to start the System Definer activity immediately and retrieve thermodynamic 

data about your system.  

4.1.3 Appending data from an additional database 
If you want to use thermodynamic data from several databases, you can create extra System 
Definers as successors to your first System Definer. You must already have created a System 
Definer. 

1. In the Project window, right-click the System Definer to which you want to append 
thermodynamic data. Choose Create New Successor>System Definer. 

2. Or select the System Definer in the Project window, and at the bottom of the Configuration 
window click Create New Successor> System Definer. This creates an Appended System 
activity, which is linked to a System Definer predecessor. 

3. In the Configuration window for the Appended System, select which database you want to 
append thermodynamic data from, regarding which components, phases, etc. 

4.2 Equilibrium Calculator 

An Equilibrium Calculator allows you to set the conditions for, and perform, a calculation. The 
Configuration window for an Equilibrium Calculator has these tabs: 

• Conditions: Set the conditions for your calculation that define the stepping or mapping 
axis variables. This tab can be viewed in a simplified mode and in an advanced mode. 

• Functions:  Define your own quantities and functions, which you then can calculate and 
plot.  

• Options: Modify numerical settings that determine how equilibria are calculated, as well 
as how stepping and mapping calculations are performed. 
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4.2.1 Predecessors and successors 
Possible predecessors: System Definer, Equilibrium Calculator 

Possible successors: Plot Renderer, Table Renderer, Equilibrium Calculator 

An Equilibrium Calculator that is the successor of another Equilibrium Calculator inherits all the 
Configuration window settings of the predecessor. 

For an example of how serially coupled Equilibrium Calculators can be used, see example 6 in 
the Thermo-Calc Graphical Examples Collection. 

4.2.2 Setting conditions for different calculations 
Conditions and axis variables are set in the Conditions tab of the Configuration window. There 
you can specify the conditions and axis variables you want to use for your calculation. The tab 
can be viewed in two modes, the simplified mode (default) or the advanced mode. 

What conditions you have to set depends on the type of calculation you intend to perform. 

For examples of how various kinds of calculations can be set up using an Equilibrium Calculator, 
see the Thermo-Calc Graphical Examples Collection: example 1 is an example of a single-point 
equilibrium calculation; example 2 an example of a stepping calculation; and example 5 is an 
example of a mapping calculation. 

 
The following table briefly describes what you can set on the Conditions tab in simplified mode. 
More advanced options are available if you click Switch to advanced mode. 
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Setting or condition Description 

Composition unit Select whether to use mass percent, mole percent, mass 
fraction or mole fraction when defining the composition of your 
system. 

Condition definitions 
Temperature 
Pressure 
System size 
Composition 

Specify the values (and units) of the different state variables. 

Calculation type 
Single equilibrium 
Property diagram 
Property grid 
Phase diagram 

Select whether to calculate a single equilibrium (no axes), a 
property diagram, a property grid or a phase diagram. 

Axis definitions 
(X-axis) 
(Y-axis) 

To calculate a property diagram, a property grid or a phase 
diagram, define the axis variable (property diagram) or the two 
axis variables (property grid and phase diagram). 
When you define an axis, select which state variable you want 
the stepping/mapping to apply to and set the minimum and 
maximum values. 
Note that if the Equilibrium Calculator already has a Plot 
Renderer as a successor and you change the stepping/mapping 
quantities, then the quantities represented on the X- and Y-axis 
is automatically updated in the Plot Renderer. 

Step Division and Type 
(Property diagram/Phase 
diagram) 

If you set Type to Linear - min no. of steps, then the Step 
Division value specifies at minimum number of steps that is 
calculated between the minimum and maximum value during 
the stepping/mapping operation.  
If you set Type to Linear - max step size, then the Step Division 
sets the maximum size of each step. 
If you set Type to Logarithmic - scale factor, then Step Division 
specifies the scale factor of a logarithmic function that 
distributes the steps from the initial equilibrium to the 
minimum and maximum values you have defines. 

Normal / Separate phases / T-
Zero 

To do the stepping operation along an axis one phase at a time, 
select Separate phases.  
If you want to calculate the T0-line, where the Gibbs energy for 
each phase is the same, then select T-Zero. 

Number of steps 
(Property grid) 

When calculating a property grid, you set a fixed Number of 
steps instead of a Step Division value and Type for each axis. 
The number of steps along with the minimum and maximum 
values for the axes define a grid. For each grid point, Thermo-
Calc calculates an equilibrium. 
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4.2.3 Setting conditions – advanced mode 
In advanced mode, you can add and remove conditions as you see fit. Furthermore, you can 
define additional axis definitions beyond the two that you can set in simplified mode. However, 
the number and types of conditions that you set must still conform to the Gibbs’ phase rule (see 
Thermo-Calc Educational Material). The Number of missing conditions is field, at the top of the 
tab shows how many conditions that you have left to set. If the number is negative, then you 
need to remove that number of conditions.  

The next section demonstrates how to calculate and plot a diagram with a fixed phase in order 
to find out, for example, at what temperature a material starts to melt. 

4.2.4 How to calculate with a fixed phase 
This section describes how you use the advanced mode to set a certain phase to be fixed at a 
certain amount. This allows you to, for example, find out at what temperature you material 
starts to melt. If you set the phase to be fixed to liquid phase at zero amount, and leave the 
temperature state variable undefined, then you can calculate at what temperature the material 
enters a state where the liquid phase is no longer zero (that is when it starts to melt).  

When you perform an equilibrium calculation with a fixed phase, it is recommended to do it in 
an Equilibrium Calculator that is the successor to an Equilibrium Calculator that performs an 
ordinary equilibrium calculation for which you roughly estimate the value of the condition you 
are interested in. This provides your fixed phase calculation with better starting values. 

1. Create an Equilibrium Calculator and have this activity selected in the Project window.  
2. In the Configuration window, click Switch to advanced mode. Note, if you have set 

Default calculation mode to Advanced in the Calculation tab of the Options window, 
then the Configuration window is in advanced mode by default, see section 2.4.4. 

3. Click the green + button to add a condition. 
4. Select Fix phase from the first menu. 
5. Select the phase that you want to fix in the second menu, and set the amount of that 

phase you want to fix the phase to. For example, if you want to know when your 
material starts to melt, set the phase to LIQUID and the value to 0.0, as shown below: 

 
6. Above the condition definitions, the Number of missing conditions is field is probably -

1. This means that you must remove one condition.  
7. To remove a condition, either click the red (-) button, or unselect it by clicking in the 

tick-box. For example, if you want to know at what temperature your material starts to 
melt, then you cannot have a fixed temperature. For example, the temperature 
condition is not selected: 

 
8. Note that the Number of missing conditions is field displays 0. When you have set all 

your conditions, you can perform the Equilibrium Calculator (now or later). 
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4.2.5 Calculating and plotting functions 
The Functions tab allows you to define your own functions that you can then set to be plotted 
in a Plot Renderer.  

For an example of how you can use functions that you yourself define, see example 7 in the 
Thermo-Calc Graphical Examples Collection. 

You must have created an Equilibrium Calculator and you must have this activity selected in the 
Project window. 

1 Create an Equilibrium Calculator and have this activity selected in the Project window.  

2 In the Configuration window, click the Functions tab. 

3 Under Quantity Definitions, define any number of quantities. These quantities are 
referred to as Q1, Q2, Q3 and so on.  When you have defined a quantity, you can use 
it to define functions under Function definitions. 

 
In this screen shot, the quantity Q1 is defined as the amount of liquid phase. This 
quantity is then used to define a function called fraction_solid, which gives as its 
output the fraction of solid phase (that is 1-Q1).  

4 Under Function Definitions, define as many functions as you need. Enter the name of 
each function in the left field before the equal sign (=), and enter the function itself in 
the right field after the equal sign. Note that you can also use Console Mode syntax 
when entering the function. For example, the function above could have been entered 
as 1-NP(LIQUID).  

5 To set up a Plot Renderer so that it plots the defined function, create a Plot Renderer 
as a successor to the Equilibrium Calculator in which you have defined the function.  
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6 In the tab for the Equilibrium Calculator that contain the function, set one of the axis 
variables to Function, then select the name of the function you have defined from the 
menu. In the example below, the Y-axis is set to plot the value of the function 
fraction_solid. 

 
7 When run, the Plot Renderer plots the value of the function. 

4.3 Plot renderer 

The Plot Renderer allows you to set the plotting axis variables for property and phase diagrams. 
If you are plotting a property grid, then the X- and Y-axes always represent the quantities that 
define the stepping axes in the Equilibrium Calculator, but you need to set a variable for the Z-
axis (the axis perpendicular to the plane defined by the X- and Y-axes). 

Several Plot Renderer activities (as well as Table Renderer activities) can be shown in the 
Results window as different tabs, as the following screen shot shows: 
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If you have plotted a diagram and then modify something in the tree that the Plot Renderer is 
associated with, then a notification sign—an exclamation mark enclosed in a yellow triangle—is 
shown in the Plot Renderer’s tab. The following screenshot shows a property grid diagram that 
has not been updated in light of changes made to the activity tree that the Plot Renderer 
belongs to. 

 

4.3.1 Predecessors and successors 
Possible predecessors Equilibrium Calculator 
Binary Calculator 
Ternary Calculator 
Scheil Calculator 
Experimental File Reader 

Possible successors None 

The configurations that can be set in the Configuration window for a Plot Renderer vary 
depending on the kind of predecessor it is created from. 

A Plot Renderer can have several predecessors (if you want to plot several calculations in the 
same diagram), in which case there are several tabs in the Configuration window, one for each 
predecessor. 
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4.3.2 Configuration window settings 
The following screenshot shows the Configuration window for a Plot Renderer that is the 
successor to an Equilibrium Calculator. 

 
The following table briefly describes the configurations that can be set in the Configuration 
window. 

Setting/Button Description 

Save Diagram Save the plot diagram. 
Show Triangular Display the diagram in triangular form, with the X-axis along the base 

and the Y-axis along the left side. Such a diagram is often useful if you 
want to plot the fractions of two components in a ternary diagram. 

Show Grid Overlay a grid on the diagram. 
Switch Axes Show the plotting X axis variable on the diagram’s Y-axis, and the Y axis 

variable on the diagram’s X-axis. 
Retain Labels  Toggle the default to keep labels displaying on the plot. By default 

labels are retained. 
Tie lines Select how many tie lines to be plotted in the diagram. Every nth 

number of tie line is plotted, where n is the number set here. 
Consequently, the higher the number, the fewer the number of plotted 
tie lines in the diagram. 
Note that this setting is not present if the Plot Renderer is a successor 
to a Scheil Calculator or to an Equilibrium Calculator where only one 
axis has been defined and varied (that is, an Equilibrium Calculator that 
has performed a stepping calculation).  

Legend option Select whether the diagram’s legend should display the Stable phases 
or the Axis quantity. 
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Setting/Button Description 

Plot type This menu is only available if the Plot Renderer is a successor to an 
Equilibrium Calculator that has been set up to calculate a property grid. 
Choose either Heat map or Contour.  
On a heat map diagram, each equilibrium calculation in the grid is 
represented by a colour-coded pixel, where dark red represents the 
highest Z-axis variable value and dark blue represents the lowest Z-axis 
variable value. 
On a contour diagram, Z-axis variable values are traced with curves in 
different colours (in the same way that height values are traced with 
curves on a topographical map). 

Axis variable  Set which state variable that you want plotted along the X-axis and the 
Y-axis. 
Note that if the stepping/mapping variables are changed in the 
Equilibrium Calculator that precedes the Plot Renderer, then the 
variables to be plotted along the diagram’s X- and Y-axis are 
automatically updated to the appropriate quantities. 

Axis type Select what type of scale to use on the axis. Choose between Linear, 
Logarithmic, Logarithmic 10 and Inverse. 

Limits Specify the range along the axis that should be shown in the plot by 
setting the minimum and maximum values of the axis variable. You can 
also determine the step size between the tick marks along each axis.  
Alternatively, select Automatic scaling. 

4.3.3 Adding labels 
To add a label text at a certain point in the diagram, right click on that point, and select Add 
Label.  

You can enter the label as Plain text or LaTeX-formatted text. For Plain text, and when 
applicable, choose an option from the list.  

For LaTeX-formatted text the chosen point name is added by default. Use the LaTeX math text 
to enter or edit the text as required. For example, underscores (_) are added before the 2 and 4 
to make subscripts in the label.  

 

For a list of supported LaTeX commands, see: 
http://www2.ph.ed.ac.uk/snuggletex/documentation/math-
mode.htmlhttp://www.thermocalc.com/products-services/software/system-
requirements/. 

 

http://www2.ph.ed.ac.uk/snuggletex/documentation/math-mode.html
http://www2.ph.ed.ac.uk/snuggletex/documentation/math-mode.html
http://www.thermocalc.com/products-services/software/system-requirements/
http://www.thermocalc.com/products-services/software/system-requirements/
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In this example, you must also remove the underscore after the 4 in order to make it work 
correctly on the plot.  

 
The suggested label specifies the names of the stable phases at the coordinate where you 
clicked. Once a label is created, you can select it and move it around on top of the diagram. By 
default the Show anchor check box is selected: there is always an arrow from the label point to 
the coordinates. 

If you do not want the label to be oriented horizontally in the Plot Renderer tab, then you 
specify the number of degrees that it should be rotated in the Rotation angle field. 

4.3.4 Changing the plot properties 

 
For global changes to the default settings plots see Plotting: Change 
the default settings for any plotted diagrams. The settings are the 
same but applied to all new plots. 

To make local changes to the appearance of a specific plot, in the Results window right-click a 
plot and select Properties. In the Plot Properties window the settings in the table below can be 
made. 

You can also edit some properties for individual plot lines (the color, the line width and type, 
and whether data points are included). In the Results window, hover the mouse over a plot line. 
The crosshair cursor turns into a cursor resembling a pointing hand when it is over a line that 
can clicked. Alternatively, hold down Ctrl while you move the cursor around the plot to only 
display it as a crosshair and prevent unintended edits. 

4.3.5 Saving your diagram 
To save a diagram, at the top of the Configuration window click Save Diagram. Or right-click the 
diagram in the Results window and select Save As. 

4.3.6 Plotting several calculations in one diagram 
It is possible to plot several calculations in one and same diagram by adding extra predecessors 
to the Plot Renderer activity. 

For an example of a project in which several calculations are plotted in one diagram, see 
example 5 in the Thermo-Calc Graphical Examples Collection. 

To plot several calculations in one diagram, you must have, in addition to the Plot Renderer’s 
original predecessor, at least one extra possible Plot Renderer predecessor in your project. The 
extra predecessor can be an Equilibrium Calculator, a Binary Calculator, a Ternary Calculator, a 
Scheil Calculator or an Experimental File Reader. 
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1 Select the Plot Renderer activity in the Project window, and click Add Predecessor in 
the Configuration window. Or right-click the Plot Renderer and choose Add 
Predecessor then select which predecessor to add. 

 
2 When selected, the extra predecessor becomes linked to the Plot Renderer in the 

Project window. On the Plot Renderer’s Configuration window, the different 
predecessors are shown as two different tabs: 

 
3 Configure how you want each calculation plotted on the tabs in the Configuration 

window, then perform the Plot Renderer activity. 

4 The calculations are plotted in the same diagram in a tab in the Results window. If any 
of the axis variables of the plots differ, then the label and scale of all calculations are 
shown parallel to each other. The following screen shot shows a diagram in which two 
calculations with different plotting axes variables have been plotted. 
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4.4 Table renderer 

A Table Renderer visualises the result of calculation as a table. Several Table Renderer activities 
(as well as Plot Renderer activities) can be shown in the Results window as different tabs. 

You can only successfully tabulate the results of a single-equilibrium calculation or a stepping 
operation. The tabulated data from an equilibrium calculation is very different from the 
tabulated data from a stepping calculation. 

4.4.1 Predecessors and successors 
Possible predecessors Equilibrium Calculator 

Possible successors None 

4.4.2 Tabulated results from an equilibrium calculation 
The following tab shows the result of an equilibrium calculation. 
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For each stable phase that is listed, you can select in the menu displaying Composition and 
constitution in the screen shot how much information you want to view. In the preceding 
screen shot, the maximum amount of information is shown, that is, information about both 
composition and constitution. 

4.4.3 Tabulated results from a stepping operation 
The following tab shows the results of a stepping calculation. 



Thermo-Calc Graphical Mode 
User Guide Version 2015a 

32 | 

 

Defining columns 
In the Configuration window set the columns you want the table to contain: 

 

4.4.4 Setting number format and number of decimal digits 
The results can be presented in ordinary decimal number format or using normalized scientific 
notion. Set this in the Number format menu in the Configuration window. You can also select 
Auto and Thermo-Calc uses the most appropriate format given by the tabulated data. 

You can also increase or decrease the number of decimal digits that are used in the table: this is 
in the Decimal digits field in the Configuration window. 

4.4.5 Setting background colours 
By right-clicking a Table Renderer tab in the Results window, and selecting Properties from the 
pop-up menu, you can change the background colours of the table. 

4.4.6 Saving tabulated data 
To save all the data in a table as a plain text file, click Save table in the Configuration window or 
right-click in the table in the Results window and select Save As. 

To copy the data from a single cell of a table to the clipboard, right-click the cell and select 
Copy. To copy the whole table to the clipboard, select Copy all. 

 Saved data is the data shown in the Table Renderer tab. If you have calculated data but 
not displayed it, this is not saved. 
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4.5 Experimental file reader 

The Experimental File Reader activity can only be created from the top My Project node. This 
activity allows you to read an experimental data file (*.EXP). Such a file contains information 
specifying a plotted diagram, written in the DATAPLOT graphical language.  

4.5.1 Predecessors and successors 
Possible predecessors My project 

Possible successors Plot Renderer 

4.5.2 Plotting an experimental data file 
1. Right-click My Project and from the Create New Activity submenu choose Experimental 

File Reader. 
2. In the Configuration window in the EXP file field, enter the name of EXP-file that you want 

to plot. 
3. Click Create New Successor and select Plot Renderer. Or right-click the experimental file 

reader activity in the Project window and from the Create New Successor submenu choose 
Plot Renderer. 

4. Click Perform in the Configuration window or right-click the plot renderer activity that you 
created in the Project window. 

4.6 Binary calculator 

A Binary Calculator can be used for some calculations involving two components. You can think 
of this activity as a combination of a System Definer and an Equilibrium Calculator, but designed 
to simplify setting up and performing calculations on binary systems.  

The Binary Calculator relies on some specifications that are not supported by all databases. You 
therefore need a database that was designed for the Binary Calculator, such as the TCBIN 
database for example. 

For an example of how a Binary Calculator can be used in a project, see example 3 in the 
Thermo-Calc Graphical Examples Collection. 

4.6.1 Predecessors and successors 
Possible predecessors My Project 

Possible successors Plot Renderer 

4.6.2 Configuration window settings 
The following shows the Configuration window of a Binary Calculator activity: 
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The following table briefly describes the available settings that must be configured before 
performing the calculation. 

Setting Description 

Select database Select a database that contains specifications dedicated to the 
Binary Calculator. 

Elements 
(periodic table) 

In the periodic table, select the two elements that make up the 
components of the system. 

Phase diagram Select to perform a mapping calculation. 
Gibbs energy curves Select the temperature; the Gibbs energy curves are calculated at a 

constant temperature over the whole composition range. 
Activity curves Select the temperature; the activity curves are calculated at a 

constant temperature over the whole composition range. 
Phase fractions Select the composition; the phase fractions are calculated as a 

function of temperature at a constant composition. 

4.7 Ternary calculator 

A Ternary Calculator can be used for some calculations involving three components. You can 
think of this activity as a combination of a System Definer and an Equilibrium Calculator, but 
designed to simplify setting up and performing calculations on ternary systems.  
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For an example of how a Ternary Calculator can be used in a project, see example 4 in the 
Thermo-Calc Graphical Examples Collection. 

4.7.1 Predecessors and successors 
Possible predecessors My Project 

Possible successors Plot Renderer 

4.7.2 Configuration window settings 
The following screen shot shows the Configuration window of a Ternary Calculator activity: 

 
The following table briefly describes the available settings that must be configured before you 
perform the calculation. 

Setting Description 

Select database Select a database that contains specifications dedicated to the 
Ternary Calculator. 

Elements 
(periodic table) 

In the periodic table, select the three elements that make up 
the components of the system.  

Isothermal section Select the temperature at which the ternary system is 
calculated for the whole composition range. 

Monovariant lines The variation of the liquid compositions with temperature is 
calculated. 

Liquidus projection Select the desired temperature range and a temperature 
interval. The projection liquid surface and the monovariant 
lines are calculated over the given temperature range. 
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4.8 Scheil Calculator 

The Scheil Calculator activity is used to perform simulations of so-called Scheil (Scheil-Gulliver) 
solidification processes. By default, a Scheil calculation results in an estimation of the 
solidification range of an alloy. The calculation is based on the assumption that the liquid phase 
is homogeneous at all times and that the diffusivity is zero in the solid. However, it is possible to 
disregard the latter assumption for selected components. 

For an example of how a Scheil Calculator can be used in a project, see example 8 in the 
Thermo-Calc Graphical Examples Collection. 

4.8.1 Predecessors and successors 
Possible predecessors System Definer 

Possible successors Plot Renderer 

By default, a Plot Renderer successor has the default plot axes Mole fraction of solid (X-axis) 
and Temperature Celsius (Y-axis). When these default axes are used in the Plot Renderer, the 
results of normal equilibria calculations are automatically plotted in the same diagram as the 
Scheil calculations. 

4.8.2 Configuration window settings 
The following screen shot shows a part of the Configuration window of a Ternary Calculator 
activity: 

 
The following table briefly describes the settings that must be configured before you perform 
the calculation. 

Setting Description 

Start temperature Select a Start Temperature that is higher than the liquidus 
temperature of the alloy, in other words, the temperature at 
which the alloy is completely melted. 

Temperature step Select a Temperature Step. Decreasing the temperature step 
increases the accuracy, but the default value is usually 
adequate. 

Temperature unit Select the temperature unit. 
Allow BCC --> FCC Select to allow BCC -> FCC transformations in the solidified 

part of the alloy caused by each of the components specified 
to be Fast Diffuser. It is recommended that you only select 
this for steels. 

Composition unit Select the composition unit. 
Composition Specify the composition of the alloy. 
Fast diffuser Select if you want to allow redistribution of this component in 

both the solid and liquid parts of the alloy. 
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5. General administration 

5.1 Thermo-Calc license information 

You can start Thermo-Calc without a valid Thermo-Calc license, but you cannot do any 
calculations. To use Thermo-Calc, you need a valid standalone LSERVRC license file (if you have 
a standalone installation of Thermo-Calc) or access to license management software (the 
License Manager on Windows and the License Server on Linux) with a valid network LSERVRC 
license file (if you have a network client installation). 

 If you have a network client installation of Thermo-Calc, then you may not be able to do 
any calculations even if you have access to the licensing server with a valid network license file. 
This is because other clients who are part of your network installation may have checked out all 
instances of Thermo-Calc that the network license allows you to run simultaneously.  

Also see the Thermo-Calc Installation Guide on the website for more information. 

To show information about the licenses you have for using Thermo-Calc, from the main menu 
select Help>Show License Info. This opens the License Information window. 

If you are running a network client installation of Thermo-Calc, you can see how many instances 
of the client licenses are currently checked out and how many of them are left. You can also see 
which client computers it is that have checked out these licenses.  

Figure 11 is an example of the kind of information available for a network client installation. It 
shows the various license types that the license server makes available (in this case, the license 
server is pumbaa.thermocalc.se).  

 
Figure 11 License Information window. 

The number of licenses column shows how many instances of each license type that can be 
checked out simultaneously, and the in use column shows how many of those instances that 
are currently checked out. 

Under each license type with instances checked out, a list of who has checked out each is 
shown. An instance is checked out when an Equilibrium Calculator activity is created, and 
checked back in when that Equilibrium Calculator is removed. In Console Mode, an instance is 
checked when a user enters the POLY module and is checked back in when a user exits the POLY 
module.  

http://www.thermocalc.com/support/documentation/
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For example, you can see that a user johanj has checked out a TC_FULL license. 

5.2 Editing global defaults 

In the Options window (select Tools>Options) you can globally set general settings for 
Graphical Mode as well as default settings for any new activities for both the Graphical Mode 
and Console Mode. The relevant settings for Graphical Mode are briefly described in the 
following sections. 

5.2.1 General 

 
Setting Options 

Tooltips enabled Select whether to turn on tooltips information. By default the Tooltips 
enabled check box is selected. This displays a small text box when you 
hover the cursor above some buttons or other items.   

Localization To change the GUI language from the Localization list choose English (the 
default), Swedish, Spanish, German, Russian, Chinese or Japanese.  

Look and feel To change the Look and feel of the GUI layout, choose Windows (the 
default), Metal, Nimbus, CDE/Motif or Windows Classic. 

Database directory In the Database directory field, specify the path to the directory that 
contains the data directory. This is where the Thermo-Calc database 
directory called data is located. Do not specify the path to where the 
database files are found (that is, in the data directory). 

Log level Select the level and type of information to display in the Event Log 
window using the Log level slide bar. Choose from a Debug, Info, Warning 
or Error level of detail.  

Check update 
interval 

From the Check update interval list, choose not to check (Don’t check, the 
defaut) or On startup. You can also manually check for updates – choose 
Help>Check for update. 

5.2.2 Graphical Mode - Default Units 

 
Setting Options 

Temperature Kelvin (the default), Celsius or Fahrenheit 
Pressure Pascal (the default), Atmospheres or Bar 
Amount Mole (the default), Gram, Kilogram or Pound 
Composition Mass percent (the default), Mole percent, Mass faction or Mole 

fraction 
Energy Joule (the default), Calorie or Electron volt 
Volume Cubic meter (the default), Cubic decimeter or Cubic centimeter 
Density Kilogram per cubic meter (the default) or Gram per cubic meter 
Entropy Joules per Kelvin (the default), Calorie per Kelvin or Electron volt 

per Kelvin 
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5.2.3 Graphical Mode – Activities 

 
There are Calculation, Plotting and Tabulation settings windows. 

Calculation: Change the default settings for the Equilibrium Calculator  
When you create a new Equilibrium Calculator, its initial settings are taken from these defaults. 
The settings of each Equilibrium Calculator can then be configured individually. Once created, 
the specific (local) settings for an Equilibrium Calculator are not affected if you later make 
changes to the global defaults. 

 Also see Equilibrium Calculator. 

These settings can also be changed locally for a certain Equilibrium Calculator. 

Setting Options 

Default calculation mode Simplified (the default) or Advanced 
Default calculation type Single equilibrium (the default), Property diagram, Phase 

diagram or Property grid 
Single equilibrium and property grid 
Global minimization The check box is selected by default to ensure that the most 

stable minimum under the specified conditions is 
computed. 

Max no of iterations Default is 500 
Max grid points Coarse (2000 grid points, the default), Medium (20,000 grid 

points), Fine (200,000 grid points), or Custom (set your own 
number of grid points) 

Required accuracy The default is 1.0E-6 
Smallest fraction The default is 1.0E-12 
Approximate driving force for 
metastable phases 

The check box is selected by default 

Force positive definite phase 
Hessian 

The check box is selected by default 

Control stepsize The check box is selected by default 
Property diagram 
Global minimization The check box is selected by default to ensure that the most 

stable minimum under the specified conditions is 
computed. 

Global test interval Every 10th eq (the default), Always or Custom 
Phase diagram 
Global minimization The check box is selected by default to ensure that the most 

stable minimum under the specified conditions is 
computed. 
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Setting Options 

Global test interval At node points (the default), Every 10th eq, Always or 
Custom 

Generate starting points 
automatically 

The check box is selected by default 

Use inside meshing points Click to select the check box as required 
No of meshes along an axis The default is 3 

Plotting: Change the default settings for any plotted diagrams 
When you create a new Plot Renderer, its initial settings are taken from these default settings. 
The settings can then be configured individually. Once created, the settings of a Plot Renderer 
are not affected by changes to the default global settings. 

 The default settings are shared with the Console Mode. Any changes you make also apply 
to the default settings on the Console Mode>Plotting tab in the Options window (and vice 
versa). 

 
For individual (local) changes to plots see Changing the plot properties. The settings 
options are the same. 

To configure the settings of an individual Plot Renderer rather than the default settings, right-
click a plot in the Results window and select Properties from the menu. 

Setting Options 

Title Enter a title. Select Plain text (the default) or LaTeX formatted text.  
Click α button to add symbols. Click a symbol category (for example, Latin 
characters or Greek and math symbols).  Then click to choose the symbol 
located on the right-hand side.  
When you select LaTeX formatted text you can use the LaTeX math text to 
enter text. For a list of supported LaTeX commands, see 
http://www2.ph.ed.ac.uk/snuggletex/documentation/math-mode.html 

Title font, Legend 
font, Label font, 
Header font 

Click Modify to edit the Font Name, Style, Size and Color. 

Legend background 
color, Background 
color, Canvas color, 
Border color,  

Click Modify to choose a color or enter a specific color. 

Label format Select Plain text (the default) or LaTeX formatted text. 
Show anchor By default, an anchor between the label and the plot point is displayed. 
Retain labels 
(Graphical Mode 
only) 

By default the check box is selected. Plot labels are kept (retained) when 
plots are updated. It can be applied globally or locally to individual plots. 

Show header 
(Console Mode only) 

Click to select the Show header check box to display the basic details about 
the plot along the top. This includes the date and time the plot is generated, 
the database used and the properties. 

Border width Choose a plot border width between 1 (thin, the default) and 10 (thick). 
Color option For the plot line colors, choose from the options in the list: Legacy, Printer 

friendly, JFree chart, Pastel, Medium dark, Bright dark, Vivid or Earth. 

http://www2.ph.ed.ac.uk/snuggletex/documentation/math-mode.html
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Setting Options 

This option is also available for specific plot lines. To change the color of an 
individual plot line double-click it in the Results window and use the color 
palette to define it or enter a specific color. 

Line width For the plot line width, choose from the options in the list. These options 
are also available for specific plot lines. To change an individual plot line 
width double-click it in the Results window. 

Line type This option is only available for individual plot lines. To change an individual 
plot line type double-click it in the Results window and choose an option 
from the list. 

 
Show data points Click to select the check box to display the data points on the plot lines. This 

option is also available for specific plot lines. To show data points on an 
individual plot line double-click it in the Results window and select the 
check box. 

Data point marker 
size 

Choose the data point marker size between 1 (small) and 10 (large). The 
default is 3. 

Plot Area Size The Fit the plot area size to the enclosing window option is selected by 
default. Excluding triangular plots, click Define the plot area size to enter a 
Plot area height and Plot area width.  

Tabulation: Change the default setting for the Table Renderer activity 
When you create a new Table Renderer, its initial settings are taken from these default settings. 
The settings of each Table Renderer can then be configured individually. Once created, the 
settings of a Table Renderer are not affected by changes in the default settings. 

Setting Options 

Decimal digits The default is 5 
Number format Auto (the default), Decimal or Scientific 
Phase description detail Composition (the default), Condensed, Constitution, or 

Composition and constitution 
Primary display color Click Modify to change the default 
Secondary display color Click Modify to change the default 
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